Touchpad not recognized on Dell Inspiron 1420

Reported by Brian Pitts on 2007-07-31
18
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Nominated for Gutsy by Alan Swartz
linux-source-2.6.20 (Ubuntu)
Low
Unassigned
Nominated for Gutsy by Alan Swartz
linux-source-2.6.22 (Ubuntu)
Low
Unassigned
Nominated for Gutsy by Alan Swartz

Bug Description

Binary package hint: xserver-xorg-input-synaptics

From /var/log/Xorg.0.log:
(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Device: "/dev/input/mice"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "true"
(**) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(II) Synaptics touchpad driver version 0.14.6 (1406)
Synaptics Touchpad no synaptics event device found (checked 19 nodes)
(**) Option "Device" "/dev/psaux"
(**) Option "HorizScrollDelta" "0"
Query no Synaptics: 6003C8
(EE) Synaptics Touchpad no synaptics touchpad detected and no repeater device
(EE) Synaptics Touchpad Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "Synaptics Touchpad"
(II) UnloadModule: "synaptics"
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
(II) Configured Mouse: ps2EnableDataReporting: succeeded

From /proc/bus/input/devices:

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/class/input/input5
H: Handlers=mouse2 ts2 event5
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

http://ubuntuforums.org/showthread.php?t=510516

purplearcanist (ejg-dnd) wrote :

It also doesn't work on my Dell Inspiron either.

Bruce Tuloch (bruce-causal) wrote :

The same problem occurs on the new Dell Inspiron 1720.

The trackpad in this case is an ALPS GlidePoint (according to Windows).

Even with the most recent production kernel (2.6.22) this device is
not recognized and defaults to a generic PS/2 mouse:

cat /proc/bus/input/devices

   I: Bus=0011 Vendor=0002 Product=0001 Version=0000
   N: Name="PS/2 Generic Mouse"
   P: Phys=isa0060/serio1/input0
   S: Sysfs=/class/input/input1
   U: Uniq=
   H: Handlers=mouse0 event1 ts0
   B: EV=7
   B: KEY=70000 0 0 0 0 0 0 0 0
   B: REL=3

It appears that this device is returning something that the macro:

  SYN_ID_IS_SYNAPTICS

defined in the kernel source file:

  drivers/input/mouse/synaptics.h

does not recognize as being a synaptics compatible device, or if
it does then the subsequent trackpad model ID or capabilities tests
fails. In my case at least, I don't think this is a problem in

  xserver-xorg-input-synaptics (Ubuntu)

but rather an issue for the synaptics driver maintainers.

Changed in linux-source-2.6.22:
status: New → Confirmed
Changed in xserver-xorg-input-synaptics:
status: New → Confirmed
Alan Swartz (apswartz) wrote :

Yes, the synaptics device isn't being detected by a cat /proc/bus/input/devices
Is the driver even used to detect the touchpad? Or is it some other code?
That output (on my Inspiron 1420n) is

<blockquote>
I: Bus=0017 Vendor=0001 Product=0001 Version=0100
N: Name="Macintosh mouse button emulation"
P: Phys=
S: Sysfs=/class/input/input0
H: Handlers=mouse0 event0 ts0
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/class/input/input1
H: Handlers=kbd event1
B: EV=120013
B: KEY=1007 2002000 4380207a f840d001 feffffdf ffefffff ffffffff ffffffff
B: MSC=10
B: LED=7

I: Bus=0010 Vendor=001f Product=0001 Version=0100
N: Name="PC Speaker"
P: Phys=isa0061/input0
S: Sysfs=/class/input/input2
H: Handlers=kbd event2
B: EV=40001
B: SND=6

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/class/input/input3
H: Handlers=mouse1 event3 ts1
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/class/input/input4
H: Handlers=event4
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button (CM)"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/class/input/input5
H: Handlers=kbd event5
B: EV=3
B: KEY=100000 0 0 0

I: Bus=0019 Vendor=0000 Product=0003 Version=0000
N: Name="Sleep Button (CM)"
P: Phys=PNP0C0E/button/input0
S: Sysfs=/class/input/input6
H: Handlers=kbd event6
B: EV=3
B: KEY=4000 0 0 0 0

</blockquote>

Thanks for your bug report.
For this bug to be accepted by the kernel team it requires some extra information.
Please provide the information in seperate attachments described here: https://wiki.ubuntu.com/DebuggingHardwareDetection.

Changed in linux-source-2.6.22:
assignee: nobody → pascal-devuyst
status: Confirmed → Incomplete
Changed in xserver-xorg-input-synaptics:
status: Confirmed → New
Brian Pitts (bpitts) wrote :
Alan Swartz (apswartz) wrote :

Here is the information for my Dell Inspiron 1420 N
Purchased July 2007

Assigning to the ubuntu-kernel-team as described in https://wiki.ubuntu.com/KernelTeamBugPolicies.

Changed in linux-source-2.6.22:
assignee: pascal-devuyst → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Tim Gardner (timg-tpi) wrote :

I'm skeptical. I have a Dell 1420 for which the touchpad works just fine, for both Feisty and Gutsy. This is one of the Ubuntu certified Dell platforms. I find it hard to believe that no one else has reported a problem like this.

Is this a factory install (plus archive updates) ?
run 'sudo dmidecode' and look for 'BIOS Information'. It should be at least 'Release Date: 05/23/2007'

I'm more inclined to believe that you have a hardware problem. In the meantime I'm closing this bug report since I do not think it is software related.

Tim Gardner (timg-tpi) wrote :

Not a synaptics touchpad

Tim Gardner (timg-tpi) wrote :

Not reproducible.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → nobody
importance: Medium → Undecided
status: Triaged → Invalid
Alan Swartz (apswartz) wrote :

But has been reproduced on a number of systems. There are a number of people reporting the same program.

Byron Poland (wpoland) wrote :

I have a brand new 1420N I received on Wednesday 8/1.

While the touch pad works for pointing and double tapping, there is no scrolling.

So if this isn't a synaptics touch pad, how do we get the scrolling? The thing has indicators printed on the touch pad that scrolling is supported....

Tim:

To clarify, the issue is not with the touchpad itself, but rather with the *scrolling* feature on the touchpad. There are 2 drawn lines on the touchpad (on the bottom and on the right) that symbolize scrolling sideways and up/down. It is this scrolling feature that does not work. The touchpad itself is fine.

Matthew Garrett (mjg59) wrote :

This is an alps pad rather than a synaptics one - nevertheless, the issue is that the kernel doesn't recognise the latest generation alps pads. Relevant code is drivers/input/mouse/alps.c (which gets built into the psmouse module). Since it's not being recognised it's falling back to ps/2 emulation mode, which gives you relative motion but nothing else. It's likely to be a simple fix.

Matthew Garrett (mjg59) wrote :

Just to clarify - even though it's an alps pad, the kernel exposes the same information to userspace as it does with a synaptics pad. So xserver-xorg-input-synaptics is the correct driver for the userspace side. In this case it's clearly a kernel issue, though.

Isaac Kriegman (zackriegman) wrote :

I'm having exactly the same problem

The touchpad works fine for the most part.

However, the scroll features of the touchpad do not work at all.

Tim Gardner (timg-tpi) wrote :

Gents, I've consulted with my laptop expert. The device in the Dell 1420 is a new ALPS pad and is not recognized by the Feisty kernel, nor is it ever going to (perhaps when Gutsy is released). To whit:

<rtg> BenC or mjg59: Am I smoking crack on this one: https://bugs.launchpad.net/ubuntu/+bug/129477 ? What does a Synaptics touchpad do under windows that these guys expect?
<mjg59> rtg: It's a new-model ALPS pad. The kernel doesn't recognise it.
<rtg> mjg59: So PS/2 emulation is the best we can expect w/Feisty, right?
<mjg59> With Feisty, yes
<rtg> mjg59: Thanks.
<mjg59> rtg: In PS/2 emulation mode it only reports relative motion. In native mode it gives absolute coordinates which give the synaptics userspace driver the ability to implement additional functionality (like scrolling)
<rtg> I guess I've never used a touchpad like that.
<mjg59> Basically everything (other than very old stuff and bleeding-edge alps) works like that in Linux

So, if your touchpad acts like a standard mouse, then that is as good as it gets for Feisty. If it does not provide any 2D mouse motion, or is not detected at all (which is what I assumed by the report title), then its broken.

P.S. In future bug reports, please attach only uncompressed files.

Byron Poland (wpoland) wrote :

should a bug be filed so this gets fixed in Gutsy? I have lived with scrolling touch pads for the last 3+ years, and not having it is a huge disadvantage.

Alan Swartz (apswartz) wrote :
Tim Gardner (timg-tpi) wrote :

OK - this touchpad scroll-bars aren't working in the upstream kernel either. You can help me by periodically checking drivers/input/mouse/alps.c in the kernel source. The current upstream commit is 1e0c5b1275a0e59747349745da8778523a9dcd18. If it changes you can notify me directly.

git whatchanged drivers/input/mouse/alps.c

Since the changes to support the scroll bars in Feisty are A) unimplemented, and B) probably substantial, I'm going to change the bug status to Will Not Fix, and add a report against Gutsy. If upstream implements it in time, then I might be able to backport the changes to Gutsy.

Changed in linux-source-2.6.20:
status: Invalid → Won't Fix
Changed in xserver-xorg-input-synaptics:
assignee: nobody → timg-tpi
importance: Undecided → Low
status: New → Confirmed
Matthew Garrett (mjg59) wrote :

Trivial patch in http://lkml.org/lkml/2007/8/4/41 should work

Byron Poland (wpoland) wrote :

Here's a work around (works for feisty for me) until it gets incorporated into the packaged kernel:

http://ubuntuforums.org/showthread.php?p=3132270#post3132270

Alan Swartz (apswartz) wrote :

Yes, I just tried it out and it works for me. I involves adding 1 line to alps.c -- can't that be implemented rather quickly?

Tim Gardner (timg-tpi) wrote :

Please try this test kernel:

wget http://people.ubuntu.com/~rtg/inspiron-1420/linux-image-2.6.20-16-generic_2.6.20-16.30_i386.deb
sudo dpkg -i linux-image-2.6.20-16-generic_2.6.20-16.30_i386.deb
sudo reboot

Changed in linux-source-2.6.20:
assignee: nobody → timg-tpi
status: Won't Fix → Fix Committed
Tim Gardner (timg-tpi) on 2007-08-06
Changed in linux-source-2.6.22:
status: Confirmed → Fix Committed
Changed in linux-source-2.6.20:
importance: Undecided → Low
Alan Swartz (apswartz) wrote :

Yes, kernel works for me. Thanks!

solongoblong (solongoblong) wrote :

Kernel worked for me as well!! Thank you so much :)

Isaac Kriegman (zackriegman) wrote :

This worked for me, however, now double tapping to drag doesn't work anymore. Has anyone else noticed this? Is there a way to fix this?

Bruce Tuloch (bruce-causal) wrote :

After applying the patch referred to above and reloading the psmouse
module running a vanilla 2.6.22 kernel on a Dell Inspiron 1720 I can
confirm the problem is resolved (the ALPS trackpad is identified and
the X server can now be configured to use it; scrolling, double tap
and drag etc). The Gnome configuration tool (gsynaptics) also updates
the trackpad parameters correctly.

Using Gutsy Tribe-4 on Inspiron 1420, scrolling still does not work.

Tim Gardner (timg-tpi) wrote :

Scrolling works with 2.6.22-10

Changed in linux-source-2.6.22:
status: Fix Committed → Fix Released

Scrolling working with tribe-5.

Changed in dell:
status: New → Fix Released
Tim Gardner (timg-tpi) on 2007-09-17
Changed in linux-source-2.6.20:
assignee: timg-tpi → nobody
status: Fix Committed → Fix Released
Changed in linux-source-2.6.22:
assignee: timg-tpi → nobody

Touchpad scrolling again not working with latest updates (as of 9/19/07). Need to open a new bug?

Byron Poland (wpoland) wrote :

I'm using gutsy, and am up to date (as of 9/19/07 2pm eastern) and I've lost my scrolling as well. It has been gone for at least a day or so, I didn't notice until I left home and unplugged my mouse last night.

synclient -l says it's enabled:

 VertScrollDelta = 22

my xorg log seems okay with synaptics:

(II) Synaptics touchpad driver version 0.14.6 (1406)
(--) Synaptics Touchpad auto-dev sets device to /dev/input/event7
(**) Option "Device" "/dev/input/event7"
(**) Option "SHMConfig" "true"
(**) Option "HorizScrollDelta" "0"
(--) Synaptics Touchpad touchpad found
(**) Option "SendCoreEvents" "true"
(**) Synaptics Touchpad: always reports core events
.....
Synaptics DeviceInit called
SynapticsCtrl called.
(II) Configured Mouse: ps2EnableDataReporting: succeeded
Synaptics DeviceOn called
(--) Synaptics Touchpad auto-dev sets device to /dev/input/event7
(**) Option "Device" "/dev/input/event7"
(--) Synaptics Touchpad touchpad found

Tim Gardner (timg-tpi) wrote :

In the System/Preferences/Mouse menu select the Touchpad tab to enable/disable scrolling.

That worked for me. This seems to be new functionality. Anyway to have it enabled by default for all users?

Byron Poland (wpoland) wrote :

Indeed that does the trick.. But has Jose says, this should be clicked by default or mentioned in release notes at least. I had gsynaptics installed and was using that, with lots of nothing happening.

riahmatic (riahmatic) wrote :

Hmm, my "Touchpad" tab is not there, is there a config file for this?

My touchpad is not detected. I tried with the patch given here but didn't work :(
I am including the bug-info as per the Ubuntu Hardware Detection.
My laptop is connoi laptop. Older connoi laptops running ubuntu fiesty fawn detected touchpad and working fine.

i just purchased a lenovo r61 (intel duocore) that has an alps touchpad (checked hw manager in xp to confirm this) that gets recognized as a generic mouse and thus, none of the synaptics work and synaptics module gets unloaded by xorg. (no synaptics event device etc.). hwinfo --mouse shows generic mouse only same with dmesg. using gutsy 32bit downloaded late last week.

Ugo Riboni (uriboni) wrote :

Related to the comment from user "buddycat" above: my Thinkpad R61 has the same issue on Gutsy.
However I opened a bug specific for the R61 and Gutsy to track this: Bug #163141

Flemming Bjerke (flem) wrote :

It looks like several problems are mixed in this thread. It is decisive whether a synaptics touchpad is detected or not (I don't know about alps). If your Gutsy finds a synaptics touchpad, I have made a small howto:
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/163141/comments/8

Gutsy (kernel-2.6.22) finds my synaptics touchpad. Here is two excerpts from cat /proc/bus/input/devices. The first shows that the synaptics touchpad is recognised as such:

I: Bus=0011 Vendor=0002 Product=0007 Version=8fb1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio4/input0
S: Sysfs=/class/input/input108
U: Uniq=
H: Handlers=mouse1 event2
B: EV=b
B: KEY=6420 0 70003 0 0 0 0 0 0 0 0
B: ABS=11000003

The second excerpt shows that the touchpad is ALSO recognised as a generic mouse, and therefore it will work as a touchpad with the generic mousedriver. But, there will be no scroll and other advanced touchpad functions.

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=synaptics-pt/serio0/input0
S: Sysfs=/class/input/input112
U: Uniq=
H: Handlers=mouse2 event6
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

Ketil Malde (ketil-ii) wrote :

I seem to have the same problem on my HP dm-1. The touchpad is just recognized as:

I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name="ImPS/2 Generic Wheel Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input11
U: Uniq=
H: Handlers=mouse1 event 11
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=103

It basically works, but is so horribly sensitive that it is impossible to type on the keyboard without getting random mouse clicks/scrolling all the time.

Ketil Malde (ketil-ii) wrote :

I'll just add a small confirmation that for me, this is fixed in the latest Lucid (kernel 2.6.32-19-generic). (I only noticed this because the scrollbar stopped working, but now I'll hopefully be able to fix this myself). In dmesg, I now get:

[ 16.205528] input: AlpsPS/2 ALPS GlidePoint as /devices/platform/i8042/serio1/input/input11

Thanks!

Changed in somerville:
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305601

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers