Ubuntu

No sound from Laptop speakers, but headphones. my solution

Reported by karavoia on 2008-09-11
82
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Matt Ginzton
Nominated for Jaunty by NicMagic
Nominated for Lucid by Bella's Bells

Bug Description

On my HP Compaq 6730b the laptop speakers had no sound, after the installation of Ubuntu 8.10 alpha5 2.6.27-2-generic. The only way I could hear sound was when I plugged in my headphones. After reading the Wiki on how to install Intel soundcards, it still didn't work, but now all works fine. Here is my solution (first steps are from Intel soundcard Wiki):
1. finding out what kind of soundcard i have in my laptop

cat /proc/asound/cards

0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0x98900000 irq 17
2.finding out the codec-type

head -n 1 /proc/asound/card0/codec*

==> /proc/asound/card0/codec#0 <==
Codec: Analog Devices AD1984A
==> /proc/asound/card0/codec#1 <==
Codec: LSI ID 1040
3.with the information above, searching for the soundchip

zless /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz

4. editing "/etc/modprobe.d/alsa-base" and adding in my case

options snd-hda-intel model=mobile

after that I still had no sound from my speakers, but the final step solved all that
5. editing "/etc/modprobe.d/options" and adding in my case

options snd-hda-intel model=mobile

6.reboot

Now not only do my laptop speakers have sound, but also mute if I plug in my headphones.

Matt Ginzton (matt-ginzton) wrote :

I have a brand new HP 6930 notebook, and installed Ubuntu 8.10 current beta with all packages up to date.

I see this same problem, and the same solution works. (I don't know if both "options" lines are necessary or not; I just added both and rebooted.)

Also, on the 6930 there's a hardware mute button next to the volume controls above the keyboard, and it affects the volume of the builtin speakers but not the headphones (i.e. the headphones ignore the mute status).

Matt Ginzton (matt-ginzton) wrote :

I now have just "options snd_hda_intel model=mobile" in /etc/modprobe.d/options, and that also suffices to let me play sound through headphones when plugged in and internal speakers otherwise.

It also has the side effect of removing most of the tracks from the volume control for device "HDA Intel (Alsa mixer)".

Frej (frecon) wrote :

Thank you! This solved the same problem on a LG P1 Express Dual. I my case I entered "lg" instead of "mobile" on point 4 and 5.

rajeshz (rajualways) wrote :

My Machine: Laptop HP 6730b
Platform: Ubuntu 8.10 (using AlSA for sound)
Problem: Sound comes only in headphones, but not through laptop speakers

I tried to repeat the above steps, but couldnt proceed after below step

To check the model of the sound card, I run the below cmd in the terminal
>head -n 1 /proc/asound/card0/codec*

Result:
==> /proc/asound/card0/codec#0 <==
Codec: Analog Devices ID 194a

==> /proc/asound/card0/codec#1 <==
Codec: Generic 11c1 ID 1040

Now can you tell me, how to identify the model?

Without knowing the model i tried to edit below files
>/etc/modprobe.d/alsa-base
>/etc/modprobe.d/options

by trying
>options snd-hda-intel model=mobile
>options snd-hda-intel model=laptop

Now how to proceed..
I am really stuck, will be great if somebody provide me a soltion

rajeshz (rajualways) wrote :

Hi Guys,

I solved the problem

Step 1:
Download this http://www.linuxant.com/alsa-driver/alsa-driver-linuxant_1.0.18.0_all.deb and install it.

Step 2:
Type <gedit /etc/modprobe.d/alsa-base> in terminal and add a line
options snd-hda-intel model=laptop
at theend of the file

Type <gedit /etc/modprobe.d/options> in terminal and add a line
options snd-hda-intel model=laptop
at the end of the file

Step 3:
Restart

Step 4:
Type <gnome-volume-control> in terminal
and make sure nothing is muted.

Step 5:
If sound works, send thanks to <email address hidden> else forgive me...

sirstrider (giuseppelobrutto) wrote :

to whom it may interest:

to solve the problem with my laptop I followed
rajeshz recipe downloading the drivers and installing them.
But instead of adding "options snd-hda-intel model=laptop"
I added options "snd-hda-intel model=mobile" in either file
(Step 2).
Afterwards I went through step 3 to 5 and everything worked
smoth ;-)

Bye

pascal hensel (hensel-p) wrote :

thanks all lot!!

i followed rajeshz procedure and my speakers work again!
it's wonderful after having a lot of problems with my speaker-sound after ubuntu 7.04
my machine: compaq presario 2700 (my old buddy)
platform: ubuntu 8.10

pascal

Ant (antauen) wrote :

Thank you for your solution.
It fits me perfectly :-)
Sincerly, JL.

Diederich (herman-vanrhijn) wrote :

Cheers to rajeshz !!
His fix works great on a HP Turion 6735b - all sounds work now!

Thanks again!!
Regards.

Herman
The Netherlands

mislaf (mislav-renic) wrote :

This worked for my HP 6735s with intrepid ! Thanks alot rajeshz!!

Chuck (venomheir) wrote :

Hey Team i had the same problem, no speaker sound, headphones worked.
I have HP 2230s KS057UT running ubuntu 8.10 everything works out of box except sound.
I followed RAJESHZ directions step by step and now sound is working.
YOU GUYS R GREAT and I LOVE UBUNTU Linux :}

Jordan Thoms (jords) wrote :

Tried both the original and rajeshz instructions, both worked but the rajeshz one gave me a lot more options to control my sound card in the mixer.

Thanks a lot for this... now if only ubuntu could include the line in the module load by default :D

Paul McClean (wutangpaul) wrote :

Hey, worked for me on my HP 6375s too. Took about 3 minutes or so to build on reboot. Laptop speakers work like a charm. Thanks again, folks.

Witan (jamespaprocki) wrote :

Tried the original instructions. I couldn't get past step 2, finding the codecs, because the terminal didn't recognize the command.

Tried rajeshz's instructions, but it didn't work. When I tried installing the "options" line in either document, it wouldn't let me save. "You do not have the permissions necessary to save the file. Please check that you typed the location correctly and try again."

Now my headphones don't work either. Rah. Murphy's Law, I guess.

Computer model: HP dv4-1220us

Any other suggestions?

Witan (jamespaprocki) wrote :

Witan again - strike that last about the headphones not working. I guess the sound go turned down a little. I have to have it on full blast before you can hear it. Don't know if that's normal, but it works.

Note: only my headphones are working. My laptop speakers still won't work, so the problem remains.

Jordan Thoms (jords) wrote :

Hi Witan
You need to edit the files in /etc as root. Not sure how your opening the files now, but in rajeshz's instructions where it says:
Type <gedit /etc/modprobe.d/alsa-base> in terminal you need to type gksudo gedit /etc/modprobe.d/alsa-base and same for the other file, gksudo gedit /etc/modprobe.d/options not just gedit. This will ask you for your password and then open the file with root permissions which will let you save.

Jordan

Witan (jamespaprocki) wrote :

I tried it with gksudo; didn't work.
I tried reinstalling the package, and it said it failed :-(

GregScott (gregscott) wrote :

I have an HP/Compaq 6735S laptop. I just tried the suggestion from rageshz and it didnt' work for me. This system is running 64 bit Ubuntu 8.10 with kernel 2.6.27-11.

- Greg Scott

GregScott (gregscott) wrote :

I should have been more specific. I have the same problem - sound from the headphones but not the builtin speakers. Editing the suggested files with both

options snd-hda-intel model=mobile
and
options snd-hda-intel model=laptop

made no difference.

Next I downloaded and installed the driver suggested by regeshz and the behavior is still the same. I can get sound from the headphones but not the speakers.

- Greg Scott

Jarl (jarl-dk) wrote :

I have a HP6735b and
cat /proc/asound/cards
head -n 1 /proc/asound/card0/codec*

gave same information.

So I also edited
/etc/modprobe.d/alsa-base /etc/modprobe.d/options as described in step 4 and 5 and then rebooted. That also made it work for me.

Thanks a lot.

Jarl

kkk (karthik-asvsrk) wrote :

Hi lads,

I use compaq CQ45 112AU laptop...I have the same problem.........I tried all the above solutions but they didn't work.I'm new to ubuntu....can u plz giv a detailed description of rageshz solution....bcoz I'm unable to save the edited file....it is saying "U have no permission to save".....and wen I restart nothing happened>>>can anyone plz give me a solution ASAP..............

Thanking you in advance.......

sirstrider (giuseppelobrutto) wrote :

U have to open the files to be modified as super user.
For example by terminal type: sudo gedit <filename>
Add all you need save it and restart

kkk (karthik-asvsrk) wrote :

Thanx a lot sirstrider........

NicMagic (nic-network-group) wrote :

HI the solution mentioned above worked perfectly for me too...

I have a HP Compaq 6730b and everything worked out the box except for the sound (Through Speakers)

Step by Step your solution worked.
Thank you very much!
Avatar

Thank you!
It works on a HP 6730b

cokekid (cokekid) wrote :

i have done all of this and now the sound is muted and i cant unmute it.it says( audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Failed to connect stream: Invalid argument)

help and yes im a newbie.

cokekid (cokekid) wrote :

i just updated this presario 2700 and restarted it again and the sound is stuck on mute. when i go to terminal and type in gnome-volume-control all i get is this... No volume control GStreamer plugins and/or devices found. so now what can i do.

Rick Keever (reviskeev) wrote :

Sounds like you got the same problem i did when i loaded the latest updates on 4/9. there seems to be something happening with the gnome applets. here is what i had to do to fix , though you might not like the first part. i tried everything first with no luck. Finally reinstalled ubuntu and ran all updates, then after reboot i got the gnome applets error. i did not select the "delete applet from your configuration?", and then reinstalled gnome-applets, gnome-applets-data, and GDM. i then applied the fix from rajeshz and got the ubuntu drum at start up. music to my ears! someone might be able to fix without reinstall, but i got annoyed. I had all my data copied to an external hd so it wasn't that big a deal, just time consuming. hint: reload ubuntu, load all updates and go to bed :-)

Emmet Hikory (persia) wrote :

I've looked at this bug, and to me it appears to be a collection of related issues, especially because people are having success with different solutions, depending on their devices. I've marked the bug invalid, as I don't believe there exists a solution that definitively closes the bug for all participants.

Could those experiencing the issue please retest against a current image (alpha, beta, daily, etc.), and if the problem recurs, open new (separate) bug reports following https://wiki.ubuntu.com/DebuggingSoundProblems ? The goal is to have one report per specific hardware device demonstrating the issue, as it is likely that each requires different quirks to reach a solution.

Changed in linux (Ubuntu):
status: New → Invalid
Matt Ginzton (matt-ginzton) wrote :

Ahem, this bug does reflect one real problem on one specific family of devices.

The snd-hda-intel driver does not correctly detect/configure the jacks on HP Elitebook 2530p/6930p (and probably 8530p, and apparently some other similar HP models). With the stock settings, you will get sound from headphones but never the internal speaksers. You need to load the snd-hda-intel driver with "model=mobile"; then it works.

(Apparently this is fixed in alsa from 2.6.30: http://mjg59.livejournal.com/110148.html. But that doesn't help with Intrepid or Jaunty, unless you backport the fix, or specifically configure snd-hda-intel.)

IMHO this specific problem is addressable by this bug report, and if other people have *other* problems they should file new bugs, but I don't see the point in closing this one as invalid only to refile the same issue this one originally tracked.

Changed in linux (Ubuntu):
status: Invalid → New
Jarl (jarl-dk) wrote :

I have retested this in Jaunty. The problem still exists on my HP 6735b.
My HP6735b gives
$cat /proc/asound/cards
 0 [SB ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xd6500000 irq 16
$head -n 1 /proc/asound/card0/codec*
==> /proc/asound/card0/codec#0 <==
Codec: Analog Devices AD1984A

==> /proc/asound/card0/codec#1 <==
Codec: LSI ID 1040

However I solved it by editing "/etc/modprobe.d/alsa-base" and adding
  options snd-hda-intel model=laptop

`options snd-hda-intel model=mobile' also works as suggested in description.

In Jaunty I did not need to edit/create "/etc/modprobe.d/options" as described in description.

Jarl

Jarl (jarl-dk) wrote :

Shouldn't this bug be marked as affecting the alsa-base ubuntu package, as the file /etc/modprobe.d/alsa-base.conf belongs to alsa-base. I am new to launchpad so I hesitate to do it myself lest I do more damage than good.

Jarl

J Nelson (jnmnus) wrote :

My HP Compaq nc6530b has the same audio codecs (AD1984A, LSI ID 1040) as the HP 6735b described in Jarl's comment (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/269027/comments/31). His solution works for me too.

lin398432 (stlinden087) wrote :

Hi i am running ubuntu 9.04 on my hp mini 1030 nr and these are my audio specs:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
 Subsystem: Hewlett-Packard Company Device 361a
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fe938000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: HDA Intel
 Kernel modules: snd-hda-intel

i tried both model=mobile and model=laptop to no success, but my problem is exactly the same as the problem described in the first and origional post. Does anyone know what im doing wrong.....im anlso using nano to edit my documents...does this matter...i also considered using wine to install a .exe sound driver update from hp's website...will this work...thank you for the help!!!!!!!!

PelletAR (pelletar) wrote :

I'm having an issue where the headphones don't work but the speakers do. I've had this problem on my Everex NC1503. But the weird thing is it's been like this for as long as I can remember. No matter which Linux version I've been using. I've tried everything I could find. Anyone have any ideas? The only problem is that not only am I new to Linux and have no idea what I'm doing, I'm not really computer friendly. So if anyone can help, I would need extremely detailed instructions...I tried installing the above program but it wouldn't even let me do that. I have no idea what to do...

Hi karavoia,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . Please then run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p alsa-base 269027

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kernel-sound
tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
jim0112 (james-leavers) wrote :

I can confirm the issue (headphones working, speakers not working) still exists in 9.04 with 2.6.28-14-generic - tested on a Compaq Mini 702EA using UNR.

Fix:

Install version of alsa-driver-linuxant that matches your kernel from http://www.linuxant.com/alsa-driver/downloads-ubuntu-x86.php
Add options snd-hda-intel model=laptop to /etc/modprobe.d/alsa-base.conf
Reboot

Jarl (jarl-dk) wrote :

@lin398432.
Using nano to edit the files should be OK.

"I also considered using wine to install a .exe sound driver update from hp's website...will this work?"
That will not work, it may make things worse and complicate fixing the problem.

@PelletAR
It seems like you have a completely different problem; The hardware is different and your experience "The headphones don't work but the speakers do" does not match this bugs description. I suggest you create a new bug describing your problem.

Jarl

BillyH (citro-cell) wrote :

Thanks so much - it worked without issue on my 6730b running Ubuntu 9.04 Jaunty.

Hilton Shumway (hillshum) wrote :

I installed the Linuxant driver (for the 2.6.28-15 kernel in my case) and the put the bits about model=mobile in the conf files, the only thing that doesn't work now is muting the speakers when headphones are plugged in

Changed in linux (Ubuntu):
status: Incomplete → New
status: New → Incomplete

I use Ubuntu 9.04 Jaunty Jackalope with Hp EliteBook 6030p.
To solve the sound problem i only edit
>gedit /etc/modprobe.d/alsa-base.conf
and add
options snd-hda-intel model=laptop
The problem disappear, and now i have sound.
Thanks for everyone to write here.

I use Ubuntu 9.04 Jaunty Jackalope with Hp EliteBook 6930p.
To solve the sound problem i only edit
>gedit /etc/modprobe.d/alsa-base.conf
and add
options snd-hda-intel model=laptop
The problem disappear, and now i have sound.
Thanks for everyone to write here.

Jarl (jarl-dk) wrote :

Leann Ogasawara, you have marked this bug "Incomplete", what information are you missing?

Jarl

Jarl, I think the reason is comment #29 where Emmet asks everyone affected to create new bug reports as this bug has been cluttered with different issues :).

mwendamseke (imwendamseke) wrote :

it is the same problem i face on my computer, let me try to follow up the procedures.

Hilton Shumway (hillshum) wrote :

This is fixed in Karmic for me on my 6735b, though I still have issues related to detecting the presence of something plugged in to the headphone jack (another bug possibly?)

mwendamseke (imwendamseke) wrote :

how can i start my front speakers as headphones do on my computer using ubuntu 9.04?

Jarl (jarl-dk) wrote :

@Leann Ogasawara: If Christian Funder Sommerlund is right in comment 44: that status=incomplete is caused by comment 29, then I suggest you mark this bug invalid, in stead of incomplete.

Jarl (jarl-dk) wrote :

This is fixed on my HP 6735b on Karmic.

Abelvn (vena8606) wrote :

HP Pavilion dv5 1135la here. Running Ubuntu 9.04
Same problem: laptop speakers dont work, sound works with headphones plugged.

Step 1:
 0 [SB ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xd2400000 irq 16
 1 [HDMI ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xd2310000 irq 19

Step 2:
==> /proc/asound/card0/codec#0 <==
Codec: IDT 92HD71B7X

==> /proc/asound/card0/codec#1 <==
Codec: LSI ID 1040

Step 3:
i open the fila, but dont really know what to look for. :S

step 4
Practically ignoring Step 3, i modified the file in this step (btw, i found it as "alsa-base.conf")

Step 5:
"/etc/modprobe.d/options" opens a blank file. that means that file is not there, or doesnt exist in that location

I dont know what to do now.

And the solution Rajesh provided didnt work. I downloaded the .deb file, but the instalation failed.
This is what i got:

ERROR: build failed. Please review the build log at /somelocation/file.log
dpkg: error processing alsa-driver-linuxant (--install):
   subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
alsa-driver-linuxant
(Reading database ... 113378 files and directories currently installed.)
Preparing to replace alsa-driver-linuxant 1.2.18.0 (using ../alsa-driver-linuxant_1.0.18.0_all.deb) ...
FATAL: Module snd_hda_intel not found.
FATAL: Module snd_seq_dummy not found.
FATAL: Module snd_pcm_oss not found.
FATAL: Module snd_seq_oss not found.
FATAL: Module snd_seq_midi not found.

Anyway, i modified the file at /etc/modprobe.d/alsa-base.conf and added the model=laptop at the end of the file, restarted (btw, it configures some kernel files and it takes A LONG TIME to even start. :S) and didnt work.

tl;dr: i cant make this work with the first solution or rajeshz's in my hp dv5 1135la, now my ubuntu 9.04 takes A LOT to start and the processor is working as hell (which heats up my laptop as hell) :(

Abelvn (vena8606) wrote :

Ok, I had that problem with my startup, but it's fixed now.
But I dont have sound in my computer at all! It doesnt work even with headphones plugged in. :(
All I hear in my headphones is static of some kind.

mezquitale (mezquitale) wrote :

I had the same problem with my Latitude D610 laptop after I removed pulseaudio the fix was to install gnome-alsamixer and I clicked on "External Amplifier" and sound on my laptop's speakers were working again.

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: efrat 1590 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x94500000 irq 22'
   Mixer name : 'Intel G45 DEVCTG'
   Components : 'HDA:111d7608,103c3069,00100202 HDA:80862802,80860101,00100000'
   Controls : 32
   Simple ctrls : 19
DistroRelease: Ubuntu 9.10
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=he_IL.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-20.57-generic
Uname: Linux 2.6.31-20-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:1819): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1819): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1965): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1928): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (firefox:2267): GLib-WARNING **: g_set_prgname() called multiple times

Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected
mord (mordechai-taitelman) wrote :

same problem on Compaq CQ61-120EJ on Ubuntu 9.10 (but I can confirm 9.04 has the same issue)
posted logs (sorry for spamming the forum with them - didn't know)

also tried to uninstall pulseaudio (as someone suggested) - didn't work.

I think in the past the only solution that did something (partially worked) was to recompile alsa package.

mord (mordechai-taitelman) wrote :

solved . now also my speakers works (not only the headphone jack):

modified my alsa-base.conf file:
Compaq CQ61-120EJ
added to also-base.conf end of file:
options snd-pcsp index=-2
options snd slots=snd-hda-intel
options snd-hda-intel model=hp-m4
alias snd-card-0 snd-hda-intel
options snd-hda-intel enable_msi=1

save and restart.

Bella's Bells (sandyd) wrote :

can we please get this released for lucid?
this has been dragging on fro several releases already and lucid is a nice time to fix it since its a LTS.

Changed in linux (Ubuntu):
status: New → Confirmed
Connor Carney (cscarney) wrote :

mord's solution in #64 got the speakers working on my HP dv4-2100us, but broke the headphones.

However, I got everything working by adding just this line to /etc/modprobe.d/alsa-base.conf:
options snd-hda-intel model=hp-m4

and unmuting everything in alsa-mixer

Abelvn (vena8606) wrote :

Hello.
Yesterday I reinstalled Ubuntu 9.04 on my HP (after trying OpenSolaris for some months) and guess what... The solution mord provided worked!
Just added those lines to my alsa-base.conf and my speakers work just fine! :D

options snd-pcsp index=-2
options snd slots=snd-hda-intel
options snd-hda-intel model=hp-m4
alias snd-card-0 snd-hda-intel
options snd-hda-intel enable_msi=1

The first line was already there.
Save and restart.
Thanks, man!

clockworkpc (clockworkpc) wrote :

The fix worked for my LG P1 Express Dual. Here is the output of my alsa-base.conf: (See the bottom for the fix)

/etc/modprobe.d/alsa-base.conf

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2

# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp-dv5
options snd-hda-intel enable_msi=1
options snd-hda-intel probe_mask=1 model=3stack

# THIS IS WHAT SOLVED IT FOR ME ON MY LG P1 DUAL EXPRESS
options snd-hda-intel model=lg

*************************************************************************************************

 /etc/modprobe.d/options:

# THIS RESTORED SPEAKER SOUND TO MY LG P1 DUAL EXPRESS
options snd-hda-intel model=lg

Utkarsh Kumar (utkarsh-kumar) wrote :

Tried the things above...still doesn't work !!
Running ubuntu-10.4 and the relevant elements of alsa.conf file are mentioned below :-

options snd-pcsp index=-2
options snd-intel8x0 ac97_quirk=1 buggy_irq=1 enable=1 index=0
options snd-hda-intel model=3stack enable=yes
options snd-hda-intel model=auto position_fix=1 enable=yes
options snd-hda-intel enable_msi=1
options snd slots=snd-hda-intel
options snd-hda-intel model=hp-m4
alias snd-card-0 snd-hda-intel

I hear only from earphones !! Please help

my laptop model is hp-G62

 cat /proc/asound/cards returns

0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xd4400000 irq 34

cat /proc/asound/card0/codec#* | grep

returns

Codec: Realtek ID 270
Codec: Intel G45 DEVIBX

My machine is 64 bit and i am running 32 bit ubuntu on it.
Did i miss something ??
Please help this is really bugging me...

sarath george (george-sarath) wrote :

mine is netbook edition..what to do

simran (smarwa) wrote :

hi Guys,
I am using an HP 620 with mandriva 2010. I have tried the above with no luck. what should i change in the commands?
Kindly help

Mantas Kriaučiūnas (mantas) wrote :

I've fixed the "no sound with internal speaker" problem on HP 620 (this laptop has only one mono speaker) by installing linux-backports-modules-alsa-lucid-generic package on Ubuntu 10.04.1
Now I have HP Mini 110-3010sy also with one mono speaker and original Ubuntu 10.04.1 also has the same problem - no sound on HP Mini 110-3010sy netbook :(
I will install linux-backports-modules-alsa-lucid-generic package on this netbook and write there if this will fix audio problem.

Neal Oram (neal-oram) wrote :

Hi everyone. I need some help. I tried the patch but it came up with an error in the install. Bugger that. Anyhow, long story short, my speakers aren't working either now. They were yesterday for about a month since I did the install of ubuntu, now nothing. Perhaps a virus of sorts?

Any help would be amazing. I can either be reached here or at <email address hidden>.

cheers

Neal Oram (neal-oram) wrote :

Great, now I have no sound from either one. I didn't change anything? What the hell!

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.