Bluetooth doesn't work (hci_cmd_task: hci0 command tx timeout)

Bug #268502 reported by _oOMOo_ on 2008-09-10
728
This bug affects 122 people
Affects Status Importance Assigned to Milestone
Genesi EfikaMX Support Project
Undecided
Unassigned
Linux
In Progress
Medium
bluez (Debian)
Fix Released
Unknown
bluez (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Eddy
Nominated for Karmic by Fernando D.
Nominated for Lucid by Fernando D.
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
bluez-utils (Debian)
New
Unknown
linux (Fedora)
Unknown
Unknown
linux (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Eddy
Nominated for Karmic by Fernando D.
Nominated for Lucid by Fernando D.
Intrepid
Medium
Unassigned
Jaunty
Medium
Brian Rogers

Bug Description

SRU justification:

Impact: A series of bluetooth dongles [1] do not work properly with the new
        btusb driver which replaced usb_hci. This has been fixed upstream
        (2.6.29-rc3). The required changes are all local to the btusb driver.

Fix: The following three patches are required to fix this (two as prerequisite
     and one for the actual fix). The fix deviates from upstream by the change
     of a version number and the missing resume part which does not exist for
     Intrepid nor Jaunty.

Test: Fix has been tested by bug reporters.

---

Bluetooth doesn't work for at least the following devices:
ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter
ID 1131:1004 Integrated System Solution Corp. Bluetooth Device
ID 2001:f111 D-Link Corp. [hex] DBT-122 Bluetooth adapter
ID 0a5c:200a Broadcom Corp. Bluetooth dongle

They don't work properly with the newer btusb driver, which replaced hci_usb by default in 2.6.27. This hasn't been fixed upstream as of v2.6.29-rc3.

Original message below:

Association with Bluetooth works using kernel 2.6.26, since the updates to 2.6.27 (both -1 and -2) association fails. I can scan and see bluetooth devices but not pair.

Using my phone, I start the association process, the phone asks for a passkey, and in 2.6.26 the popup window appears normally allowing me to enter the passkey. In 2.6.27 the dialog box never appears.

If I use hcitool:

:~$ sudo hcitool cc 00:1B:59:96:A6:DD
:~$ sudo hcitool auth 00:1B:59:96:A6:DD
HCI authentication request failed: Connection timed out

the dialog box appears very very briefly then vanishes.

dmesg shows a couple of problems:

[25791.306170] btusb_intr_complete: hci0 urb ffff88004dd0fb40 failed to resubmit (19)
[25791.315446] btusb_send_frame: hci0 urb ffff880048542840 submission failed

and the syslog shows that there was an attempt to associate:

Sep 23 08:16:59 charlie hcid[5903]: link_key_request (sba=00:11:67:9C:59:B5, dba=00:1B:59:96:A6:DD)
Sep 23 08:16:59 charlie hcid[5903]: pin_code_request (sba=00:11:67:9C:59:B5, dba=00:1B:59:96:A6:DD)

_oOMOo_ (hermann-blaxhall) wrote :

Output of lsusb

:~$ lsusb
Bus 002 Device 002: ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Luca Zorzi (lucazorzi91) wrote :

I had the same problem with Intrepid Alpha 5, then I tried to send a photo from my Nokia N70 to the PC (no problem with that), then tried to associate again my Bluetooth headset and it worked!
I use a D-Link DBT-120.

_oOMOo_ (hermann-blaxhall) wrote :

No change with 2.6.27-4

description: updated
_oOMOo_ (hermann-blaxhall) wrote :

Have clean installed Intrepid Beta, and updated now to 2.6.27-6, and the problem persists.

Danny Wood (danwood76) wrote :

I can confirm this bug with the same bluetooth controller.
I'm wondering if it is a specific bug with this controller?

danny@danny-laptop:~$ lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Alexander Butenko (avb) wrote :

seems #281949 is a duplicate of this one but assigned to a wrong package.

Alexander Butenko (avb) wrote :

i have the same issue. Mine usb adapter is dlink dbt-122.

Here is a snip of dmesg:
[138209.665630] Bluetooth: Generic Bluetooth USB driver ver 0.3
[138209.666632] usbcore: registered new interface driver btusb
[138214.844410] hci_cmd_task: hci0 command tx timeout
[138219.848340] hci_cmd_task: hci0 command tx timeout
[138224.853676] hci_cmd_task: hci0 command tx timeout
[138229.856417] hci_cmd_task: hci0 command tx timeout
[138234.860719] hci_cmd_task: hci0 command tx timeout
[138239.960585] hci_cmd_task: hci0 command tx timeout
[138240.464277] bluetoothd[5133]: segfault at 3 ip b7e39938 sp bfb8fcc8 error 4 in libc-2.8.90.so[b7dc8000+158000]

# lsusb
..
Bus 004 Device 007: ID 2001:f111 D-Link Corp. [hex] DBT-122 Bluetooth adapter
..

Carlo (gentuser) wrote :

Same Problem:
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 0a5c:200a Broadcom Corp. Bluetooth dongle
Dmesg :
[ 55.092421] hci_cmd_task: hci0 command tx timeout
[ 60.096506] hci_cmd_task: hci0 command tx timeout
[ 65.100369] hci_cmd_task: hci0 command tx timeout
[ 70.104358] hci_cmd_task: hci0 command tx timeout
[ 75.108196] hci_cmd_task: hci0 command tx timeout
[ 80.112996] hci_cmd_task: hci0 command tx timeout

It works with regression of these package :
'bluez-utils_3.26-0ubuntu6_i386.deb'
'bluez-hcidump_1.40-0ubuntu1_i386.deb'
'bluez-cups_3.26-0ubuntu6_i386.deb'
'bluez-audio_3.26-0ubuntu6_i386.deb'
'bluetooth_3.26-0ubuntu6_all.deb'
No other solution found.

tielie (mike-tielie) wrote :

I confirm this as a bug Bus 004 Device 003: ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter

does not work on mine system to :-/

Intrepid with Linux 2.6.27-7

If I boot with old linux 2.6.26-* it works. So its probadly kernel problem. or maybe bluez related...

_oOMOo_ (hermann-blaxhall) wrote :

I have been able to pair (intermittently) from phone to computer using a different phone, an LG rather than a Sony Ericsson. The LG allows me to enter the passcode much more quickly than the Sony (which normally thinks for about 25 seconds before asking me to choose a passcode). Is this a timeout issue?

Having said that, even when paired I am still unable to browse files on the LG.

tielie (mike-tielie) wrote :

its not a time only a timerissue in the bluz stack its seems to be an KY-BT100 driver issue or/and the ehci/uhci_hsd as far as I could understand it when reading some mailinglists.

My other bt adapter ( 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)) works nicely.

psernetz (patrick-sernetz-com) wrote :

Same problem on my site.

 ID 1131:1004 Integrated System Solution Corp. Bluetooth Device

It's a no name device which worked in hardy but not in intrepid.

It seems my problem is more severe...

I have 2 different bluetooth dongles (Kensington & Ambicom). They both used to work fine in Hardy, but all I'm showing is timeout errors since I upgraded to Ibex. I can't pair, I can't search devices, obex... Anything.

At first, the BT icon didn't even show, but after installing a few packages through Synaptic and rebooting, that problem went away.

Another weird thing is that the timeout errors occur within a second of attempting any kind of interaction with bluetoothd.

Let me know if you guys need any extra info, and I'll try to post it up ASAP.

Syl21 (sylvain-gargasson) wrote :

The same problem for me with the final 8.10 intrepid ibex and a D-Link DBT-122.

Blink green power and link and nothing more...

lsusb:
Bus 006 Device 003: ID 2001:f111 D-Link Corp. [hex] DBT-122 Bluetooth adapter

lsmod | grep bt:
btusb 21912 3
bluetooth 70820 15 btusb,rfcomm,sco,bnep,l2cap
usbcore 175376 8 btusb,snd_usb_audio,uvcvideo,snd_usb_lib,usbhid,ehci_hcd,uhci_hcd

If I plus and unplus my key I have a normal dmesg like:
[ 851.624013] usb 5-1: new full speed USB device using uhci_hcd and address 3
[ 851.857750] usb 5-1: configuration #1 chosen from 1 choice
[ 923.456037] usb 5-1: USB disconnect, address 3

but the first time I plus and unplug, I have it:
[ 359.864020] usb 6-1: new full speed USB device using uhci_hcd and address 3
[ 360.060177] usb 6-1: configuration #1 chosen from 1 choice
[ 365.196166] hci_cmd_task: hci0 command tx timeout
[ 370.200185] hci_cmd_task: hci0 command tx timeout
[ 375.204223] hci_cmd_task: hci0 command tx timeout
[ 380.208153] hci_cmd_task: hci0 command tx timeout
[ 385.212186] hci_cmd_task: hci0 command tx timeout
[ 390.216194] hci_cmd_task: hci0 command tx timeout
[ 437.128037] usb 6-1: USB disconnect, address 3
[ 437.129858] btusb_intr_complete: hci0 urb ffff88006289cd80 failed to resubmit (19)
[ 437.130126] btusb_send_frame: hci0 urb ffff880062522a80 submission failed
[ 437.130161] __ratelimit: 3 callbacks suppressed
[ 437.130164] bluetoothd[5470]: segfault at 100000007 ip 00007f165b228339 sp 00007fff64096490 error 4 in libc-2.8.90.so[7f165b1ae000+169000]

Thanks in advance...

Syl21 (sylvain-gargasson) wrote :

Suite of my post, I have forget my kernel "uname -a":
Linux syl21-desktop 2.6.27-7-generic #1 SMP Thu Oct 30 04:12:22 UTC 2008 x86_64 GNU/Linux

How as in other users my D-Link DBT-122 not work in 8.10 Untrepid Ibex Release.
--------------------
"uname -a":
Linux leolik-komp 2.6.27-7-generic #1 SMP Thu Oct 30 04:12:22 UTC 2008 x86_64 GNU/Linux

hara (harak-iitm) wrote :

I see this problem when I hibernate... It also vomits other errors as i have included a bug i opened
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/293115

olnabe (waspee) wrote :

I also have this problem with kernel 2.6.27.4.

hci_cmd_task: hci0 command tx timeout
btusb_intr_complete: hci0 urb failed to resubmit (19)

Things like that.

After replacing the bluetooth subsystem with the codes from 2.6.26.7
and recompiling the kernel, the problem is solved. My bluetooth mouse
works again on "2.6.27.4".

My adapter is a KY-BT100 one.

Stiff (stiff.ru) wrote :

I have the same problem. If i request authentification from my phone, it works. But i cant pair device from computer.
hcitool scan scans devices good, but i cant connect to phone via obex or rfcomm. sdptool outputs connetion timeout.
string from lsusb:

Bus 002 Device 002: ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter

Syl21 (sylvain-gargasson) wrote :

We are lot of people having loosing our Bluetooth connection... Thanks in Advance.

Changed in linux:
status: Triaged → Confirmed
Krugger (krugger-gmail) wrote :

Same problem with 2 bluetooth adapters, this one is from my usb dongle:

Bus 001 Device 006: ID 1131:1004 Integrated System Solution Corp. Bluetooth Device

And the error on dmesg:

[ 235.132015] hci_cmd_task: hci0 command tx timeout

I can see (and pair) the devices, but any other activity fails.

Same here, seems another kernel regression....

kylea (kylea) wrote :

I can pair nearly at will - but what happens to me is that the bluetooth connection will not "stick". I have been getting intermittent syncing and file file transferring to work for two days then it stops for a 3 or 4 and then it will work for 8 hours and then stop.

Here is a log from the last week

1/12/2008 21:45 | kyle Amadio
      Nope that does not seem to make any difference.
      Can send files between my phone and wifes.

01/12/2008 21:37 | kyle Amadio
      Monday morning 1/12/2008 - went to work, started PC - interestingly the Dell Bluetooth switch was not on.
      Noticed this well after the PC had booted. Turned on the switch and the sync process and other Bluetooth functions worked.
     Have now returned home and 5 hours after leaving work. Bluetooth has stopped working.
     Will see if the Dell bluetooth switch being off make during the boot process makes any difference.

30/11/2008 21:03 | kyle Amadio
     Ok its Sunday 30th still not syncing - have tried a variety of things, resetting phone, re-pairing, restarting PC bluetooth.
     I can send images and music files between my 6233 and my wifes successfully, both ways.

29/11/2008 08:07 | kyle Amadio
    Shutdown - went to bed - 8 hours later - it works.
    Changed nothing on the phone

28/11/2008 22:48 | kyle Amadio
    Ok - did a shutdown and reboot. Syncing / Bluetooth stopped working.

28/11/2008 22:36 | kyle Amadio
       Well- went home and syncing is all good again.

28/11/2008 12:15 | kyle Amadio
      Syncing worked fine for two days - failed this morning (Fri 28th).

n0PxN0p (n0pxn0p) wrote :

Same problem, i tried 2 different bt usb-dongles (based on different chipsets), but no luck.
Everything works for me, when i start up with 2.6.24-21 stable kernel from array.org ^_^
_________________
root@gazenwagen:~# rfcomm connect 0
Can't connect RFCOMM socket: Operation now in progress

root@gazenwagen:~# hciconfig dev
hci0: Type: USB
BD Address: 00:11:67:C6:F0:6B ACL MTU: 1021:4 SCO MTU: 48:10
UP RUNNING
RX bytes:2180 acl:0 sco:0 events:85 errors:0
TX bytes:890 acl:0 sco:0 commands:70 errors:0

root@gazenwagen:~# dmesg|tail
[ 2876.984143] hci_cmd_task: hci0 command tx timeout
[ 4710.928544] usb 1-2: USB disconnect, address 5
[ 4710.928742] btusb_intr_complete: hci0 urb e4f5d200 failed to resubmit (19)
[ 4710.928742] btusb_bulk_complete: hci0 urb e4c30780 failed to resubmit (19)
[ 4710.929414] btusb_bulk_complete: hci0 urb e4c30b80 failed to resubmit (19)
[ 4710.940056] btusb_send_frame: hci0 urb e4ee4980 submission failed
[ 4710.952039] __set_isoc_interface: hci0 setting interface failed (19)
[ 4727.752273] usb 1-2: new full speed USB device using uhci_hcd and address 6
[ 4737.927583] usb 1-2: configuration #1 chosen from 1 choice
[ 4990.780188] hci_cmd_task: hci0 command tx timeout
_________________

BrowneR (chris-scotland) wrote :

I just built 2.6.28-rc7-git2 from kernel.org and I have the same problems with bluetooth so this is obviously not something that has been addressed upstream.

Is it worth reporting this upstream?

BrowneR (chris-scotland) wrote :

Bug 288613 seems related (https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/288613) and interestingly the reporter claims bluetooth worked fine in beta but not when the first intrepid RC was released. What changed kernel wise?

kylea (kylea) wrote :

Ok : here is what I think is going: (I have a Dell E6500 laptop)

IF I have my Bluetooth radio switch turned OFF during the Boot Up process and only turn it ON AFTER Gnome is fully loaded and all processes are finished THEN Bluetooth processes work.

Have proven this with repeated tests:

IF the Bluetooth radio switch is ON during the boot up then Bluetooth will not work.

SO what is going on - surely this is enough for you guys to make a search now. Can we change the load sequence of the Bluetooth daemon to load last ?

Jamie Lokier (jamie-shareable) wrote :

kylea, I usually boot with the Bluetooth radio off. It's USB internally and disconnected when I boot, then I switch it on after logging in.

I still have this pairing problem every time with 2.6.27 kernels.
So changing the load sequence wouldn't fix it.

The information we need may be to bisect between the last kernel which works reliably and the one after, trying it on someone's machine until the change which breaks it is identified. Alas I don't have the time for it, so I just run old kernels with Intrepid.

Carlo (gentuser) wrote :

In the same pc on Ubuntu with 2.6.27-7 bluez doesn't pair with any device, with gentoo 2.6.27-r1 bluez-3.36 it does...
I don't know is a kernel problem or what else, but with regression of bluez association works well

Carlo (gentuser) wrote :

Update: ubuntu kernel 2.6.27-10 doesn't solve my problem

n0PxN0p (n0pxn0p) wrote :

it doesn't solve my problem too )

New kernel @ Jaunty, 2.6.28 series fixes my problem.
Now I got my bluetooth headset working on Skype....finally.

Intrepid remains "unpreant" release for me, it was still fine with Hardy.

I too have just tried the Jaunty kernel.
I added this line to my apt/sources.list

deb http://gb.archive.ubuntu.com/ubuntu/ jaunty main restricted multiverse universe

and first of all just upgraded the bluez related packages to 4.21-0ubuntu1.

Now when I try to pair with my phone it immediately fails and gives an error message rather than timing out like before. I then downgraded these packages back to the intrepid version and installed the Jaunty kernel packages (2.6.28). Rebooted the new kernel. Bluetooth still wont work.

I then upgrade the bluez packages again and try to pair with my phone. Success - I am given a 4 digit password and enter this on my phone and it pairs correctly. I am however unable to do any file transfers or use my phone as an HID remote control or modem. So progress at least but still not fixed.

It seems to be a combination of factors related to bluez and the kernel as each one on its own didn't fix the problem however when they were both upgraded i was able to pair at least...

Tiago Silva (tiagosilva) wrote :

I tested file receiving/sending on my laptop (Compal FT00 VBI) with two Nokia mobile phones: N70 and 6600.
Sending files to the phones was fine. Receiving files doesn't work.

pseudolegolas (pseudolegolas) wrote :

same problem with me..............
have tried everything exept different kernel virsion
will do that today

comp is able to detect devices but cant connect

is some developer listening
SOS

SOS

SOS

Mike (farlo144) wrote :

This seems like a pretty bad bug for no one to look into. Is there a workaround yet? 8.10 released ages ago, and bluetooth is a pretty standard technology. Is someone going to look into why this broke between 8.04 and 8.10? Seems like a lot of stuff broke in 64bit 8.10.

kylea (kylea) wrote :

I don't get - I have paid for support and still cannot get a sensible answer on this.

Just another reason why MS will keep its market share. How can we always be moving towards a new version when the basics don;t work on the majority of the hardware out there.

This behaviour is as bad - in fact worse than MS as the Linux community spends its time rightly bagging MS but then we do the same thing.

I just don't get it, can some of the zealots please explain what is going on here?

Vadim Peretokin (vperetokin) wrote :

No - please keep the bug report on topic. If you paid for Ubuntu commercial support, please contact them - however support implies solving user issues most likely. (at least, the contract that came with ubuntu on my laptop did).

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

What does the comment above actually mean then? Does this mean this major bug is not going to be looked at any further? Or assigned to another team? Who should it be assigned to? This is a major flaw and causes extreme disruption particularly to users who rely on services such as calendar/event syncing.

Changed in linux:
status: Unknown → In Progress
description: updated
Changed in linux:
assignee: nobody → brian-rogers
description: updated
Changed in linux:
status: Confirmed → In Progress
Stefan Bader (smb) on 2009-04-01
Changed in linux:
assignee: nobody → stefan-bader-canonical
importance: Undecided → Medium
status: New → Fix Committed
status: In Progress → Fix Committed
description: updated
Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in debian:
status: Unknown → New
Changed in linux (Ubuntu Intrepid):
status: Fix Committed → Confirmed
Changed in linux (Ubuntu Jaunty):
status: Fix Released → Confirmed
Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Changed in linux (Ubuntu Jaunty):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Intrepid):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in bluez (Ubuntu):
status: New → Invalid
Changed in bluez (Ubuntu Intrepid):
status: New → Invalid
Changed in bluez (Ubuntu Jaunty):
status: New → Invalid
maximi89 (maximi89) on 2009-05-22
affects: debian → bluez-utils (Debian)
Changed in bluez-utils (Debian):
status: New → Unknown
Changed in bluez (Debian):
status: Unknown → New
Changed in bluez-utils (Debian):
status: Unknown → New
Martin Pitt (pitti) on 2009-06-05
tags: added: verification-needed
Steve Beattie (sbeattie) on 2009-06-16
tags: added: hw-specific
Changed in bluez-utils (Debian):
status: New → Fix Committed
Changed in bluez (Debian):
status: New → Fix Committed
Philip (hallo9999) on 2009-08-16
Changed in linux (Ubuntu Jaunty):
status: Fix Released → Fix Committed
status: Fix Committed → New
Changed in linux (Ubuntu Jaunty):
status: New → Fix Released
Changed in linux (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Changed in bluez (Debian):
status: Fix Committed → New
Changed in bluez-utils (Debian):
status: Fix Committed → New
lively (doratheexplorer) on 2009-11-03
Changed in linux (Ubuntu Jaunty):
status: Fix Released → Confirmed
status: Confirmed → Fix Released
tags: added: iso-testing
Changed in bluez (Ubuntu Jaunty):
status: Invalid → Fix Committed
Steve Langasek (vorlon) on 2010-01-21
Changed in bluez (Ubuntu Jaunty):
status: Fix Committed → Invalid
Stefan Bader (smb) on 2010-02-11
Changed in linux (Ubuntu Intrepid):
assignee: Stefan Bader (stefan-bader-canonical) → nobody
KeithG (grider-4) on 2010-03-27
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Steve Langasek (vorlon) on 2010-03-27
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
228 comments hidden view all 308 comments
KeithG (grider-4) wrote :

Ok, I have read tons of these posts about defective bluetooth support in gnome/kernel. What is the fix? Can I try something? Do we have any idea as to when this may be pushed to the updater for 9.10? I have been patient for a couple of months and still nothing works. Dongle shows up, It can see nothing. If it does see a device, it cannot pair. This dongle works fine on the same computer under XP. It is a cambridge dongle which pairs with my serial port device on 2 laptops with XP I dearly want to run it on Karmic and would be willing to try a 'fix' if ti were clear as to what that 'fix' might be.

KeithG

On Sun, Mar 28, 2010 at 12:59:57AM -0000, KeithG wrote:
> Ok, I have read tons of these posts about defective bluetooth support in
> gnome/kernel. What is the fix? Can I try something? Do we have any idea
> as to when this may be pushed to the updater for 9.10?

The fix for this bug was present in Ubuntu 9.10 when it released. If you
are having issues with bluetooth in 9.10, you should file a separate bug
report.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Download full text (3.9 KiB)

This bug is present for at least 9.4, it is still present, no actual
bug fix was posted.
Never explained, the issue persist allways, execpt for a few persons
that i was able to see that posted that somehow, with some device
worked, never for me.

2010/3/27 Steve Langasek <email address hidden>:
> On Sun, Mar 28, 2010 at 12:59:57AM -0000, KeithG wrote:
>> Ok, I have read tons of these posts about defective bluetooth support in
>> gnome/kernel. What is the fix? Can I try something? Do we have any idea
>> as to when this may be pushed to the updater for 9.10?
>
> The fix for this bug was present in Ubuntu 9.10 when it released.  If you
> are having issues with bluetooth in 9.10, you should file a separate bug
> report.
>
> --
> Steve Langasek                   Give me a lever long enough and a Free OS
> Debian Developer                   to set it on, and I can move the world.
> Ubuntu Developer                                    http://www.debian.org/
> <email address hidden>                                     <email address hidden>
>
> --
> Bluetooth doesn't work (hci_cmd_task: hci0 command tx timeout)
> https://bugs.launchpad.net/bugs/268502
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: In Progress
> Status in “bluez” package in Ubuntu: Invalid
> Status in “linux” package in Ubuntu: Fix Released
> Status in “bluez” source package in Intrepid: Invalid
> Status in “linux” source package in Intrepid: Fix Released
> Status in “bluez” source package in Jaunty: Invalid
> Status in “linux” source package in Jaunty: Fix Released
> Status in “bluez” package in Debian: New
> Status in “bluez-utils” package in Debian: New
>
> Bug description:
> SRU justification:
>
> Impact: A series of bluetooth dongles [1] do not work properly with the new
>        btusb driver which replaced usb_hci. This has been fixed upstream
>        (2.6.29-rc3). The required changes are all local to the btusb driver.
>
> Fix: The following three patches are required to fix this (two as prerequisite
>     and one for the actual fix). The fix deviates from upstream by the change
>     of a version number and the missing resume part which does not exist for
>     Intrepid nor Jaunty.
>
> Test: Fix has been tested by bug reporters.
>
> ---
>
> Bluetooth doesn't work for at least the following devices:
> ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter
> ID 1131:1004 Integrated System Solution Corp. Bluetooth Device
> ID 2001:f111 D-Link Corp. [hex] DBT-122 Bluetooth adapter
> ID 0a5c:200a Broadcom Corp. Bluetooth dongle
>
> They don't work properly with the newer btusb driver, which replaced hci_usb by default in 2.6.27. This hasn't been fixed upstream as of v2.6.29-rc3.
>
> Original message below:
>
> Association with Bluetooth works using kernel 2.6.26, since the updates to 2.6.27 (both -1 and -2) association fails. I can scan and see bluetooth devices but not pair.
>
> Using my phone, I start the association process, the phone asks for a passkey, and in 2.6.26 the popup window appears normally allowing me to enter the passkey. In 2.6.27 the dialog box never appears.
>
> If I use hc...

Read more...

VladimirCZ (vlabla) wrote :

Steve Langasek wrote: "The fix for this bug was present in Ubuntu 9.10 when it released. If you are having issues with bluetooth in 9.10, you should file a separate bug report."

For me and probably most others effected by that "original general" bug the problem was solved. So it is time to focus on probably more hardware specific bugs.

Tom (tom6) wrote :

Hi Keith :)

I think you thought that by clicking on "Fix Commited" it would have an effect on your machine. I guess you know now that bug-report threads are a convenient way for people working on solving the bug to communicate with each other and keep track of progress and the "current state of play".

It helps when ordinary users like you & me are able to say when a bug also exists on some other hardware or with a different version of Ubuntu but we do sometimes need a bit of direction to make sure we post into the right thread as the distinctions between bugs can seem a bit hazy to us. Hopefully we might be able to help beta-test a bug patch or few but my skills are not that advanced yet.

Thanks for helping the Ubuntu community with this so far :)
Good luck and regards from
Tom :)

PS sorry for using this thread as a personal message board. I just thought a bit of clarification might help

KeithG (grider-4) wrote :

Tom ,

Thanks! I did not think that the 'fix committed' worked like that, but was looking through the thread for a fix that someone said "worked" and a response saying, "yes, worked for me, too".

On a whim, I added the repository "http://ppa.launchpad.net/blueman/ppa/ubuntu karmic main" and then ran an update. It updated the packages and now I have been able to pair 2 phones with Karmic. The one allows PANU network connection and the other file transfers. I verified both worked last night. Now, I can pair to my phone with the PANU network, but cannot actually connect to that network... I will try a reboot, but that is very XP :-(. The phone and the computer show 'connected' and I selected connect to network, but the network manager will not connect, thiough it shows up in the dropdown list in the gnome applet. When the other phone comes home, I will see if I can transfer files again today. I tried a number of times last night and was successful via all means of file transfer. The next test is to see if I can connect my BT-serial port.

IN summary, it still seems a bit iff-y. THe BTUSB dongle shows up as Accel-OB2 and it identifies as Cambridge ltd. The error in the syslog is:
NetworkManager: <WARN> nm_device_bt_connect_cb(): Error connecting with bluez: Connection refused (111)

If my serial port works, I'll post that here.

Keith

KeithG (grider-4) wrote :

Well, I just tried the serial port. I do not think this is part of this bug, though, as it will not allow me to select the 1234 paring number that my serial port needs. What I did was click on the device in the BT manager, then select the pin option and select 1234 then clicked connect. At that time, the BT manager gives me a 6 digit random pin to type in on the serial port (which is impossible). If there is a command line way to do this, I am fine with thaty as well. I just want to be able to connect to the serial port. Oh, and, when I type "hcitool scan" at the command line, the serial port does not show up in the list, though it does in the BT manager. If this belongs somewhere else, let me know.

Keith

KeithG (grider-4) wrote :

The latest I have tried is to uninstall "gnome-bluetooth" and install "bluez-gnome". This allowed me to actually connect to the serial port with the '1234' code. It now shows up in BT manager with a totally different dialog graphics and commands, but it seems to be more robust at least for this pair. I still struggle with my iPhone bt pairing regardless of which interface I use (bluez-gnome or gnome-bluetooth). It connects sometimes, but rarely. The Nokia uses OBEX to allow me to see files and is very robust. It appears that this is still not correct as the title says.

Changed in linux (Ubuntu):
assignee: Brian Rogers (brian-rogers) → nobody
Eugene San (eugenesan) wrote :

Bug is still in Lucid as 14May2010.
If fix released, where it is?

LP #460743 (https://bugs.edge.launchpad.net/fedora/+source/linux/+bug/460743)
Should be merged with this one.

Selmi (selmi) wrote :

i had no problem with karmic. since update to lucid it doesn't work. i will try clean install, bue i doubt it will solve something

opposite experience here: finally works in Lucid for the first time
ever, All seems to work, from file browsing and moving filesa across to
one-click internet connection via mobile phone

On 20/05/10 19:07, Selmi wrote:
> i had no problem with karmic. since update to lucid it doesn't work. i
> will try clean install, bue i doubt it will solve something
>

Brian Rogers (brian-rogers) wrote :

You don't have to reinstall to do a clean test. You can just boot the livecd session and test there.

alxQ (alxq) wrote :

I have same bug. Ubuntu 10.04, bluez 4.60-0ubuntu8.

ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

# hciconfig -a
hci0: Type: USB
 BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0
 DOWN
 RX bytes:0 acl:0 sco:0 events:0 errors:0
 TX bytes:0 acl:0 sco:0 commands:0 errors:0

dmesg:
hci_cmd_task: hci0 command tx timeout
btusb_intr_complete: hci0 urb e522e200 failed to resubmit (19)
btusb_bulk_complete: hci0 urb e522ed00 failed to resubmit (19)
btusb_bulk_complete: hci0 urb e522ea00 failed to resubmit (19)

akaars (ilyabr) wrote :

Can confirm this - Lucid 10.04, Version: 4.60-0ubuntu8 2.6.32-22-generic

Bus 005 Device 022: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

akaars (ilyabr) wrote :

Hmm... Same PC, another dongle (noname):
Integrated System Solution Corp. Bluetooth Device
 - works like a charm.

akaars (ilyabr) wrote :

No changes with last bluez version:

Package: bluez
State: installed
Automatically installed: no
Version: 4.65-0ubuntu1

I've also tried 4.66 - same problem.

David A. Cuadrado (krawek) wrote :

I have the same problem

distribution: Ubuntu 10.04 LTS
kernel: 2.6.32-23-generic
bluez 4.60-0ubuntu8
Bus 002 Device 004: ID 0a5c:2021 Broadcom Corp.

Mark Hobley (markhobley) wrote :

I am using Debian (squeeze/testing) and I am testing with kernel 2.6.32-5-486
. I am getting the timeout here, so I reckon this is still broken in Debian (squeeze) testing:

# hciconfig -a
hci0: Type: BR/EDR Bus: USB
        BD Address: 00:1F:81:00:01:1C ACL MTU: 1021:4 SCO MTU: 180:1
        UP RUNNING
        RX bytes:330 acl:0 sco:0 events:8 errors:0
        TX bytes:24 acl:0 sco:0 commands:16 errors:8
        Features: 0xff 0x3e 0x09 0x76 0x80 0x01 0x00 0x80
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
        Link policy:
        Link mode: SLAVE ACCEPT
Can't read local name on hci0: Connection timed out (110)

# dmesg
[127422.591465] hci_cmd_task: hci0 command tx timeout

# lsusb
Bus 003 Device 006: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

I tried updating to bluez-4.69, which I downloaded from an upstream source and compiled myself, but the problem still persists.

Mark.

David A. Cuadrado (krawek) wrote :

same issue on kernel 2.6.34. I've just tested.

xulio77 (juliojgd) wrote :

Same issue with usb BT dongle from Cambridge Silicon Radio (0a12:0001) and kernel 2.6.31 (x86_64 arch).

$ uname -a
Linux oem-desktop 2.6.31-22-generic #60-Ubuntu SMP Thu May 27 02:41:03 UTC 2010 x86_64 GNU/Linux

$ lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 05e3:0716 Genesys Logic, Inc.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 004 Device 002: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

$sudo dpkg -l |grep bluetooth
ii bluetooth 4.51-0ubuntu2 Bluetooth support
ii gnome-bluetooth 2.28.1-0ubuntu2 GNOME Bluetooth tools
ii libbluetooth3 4.51-0ubuntu2 Library to use the BlueZ Linux Bluetooth sta
ii libgnome-bluetooth7 2.28.1-0ubuntu2 GNOME Bluetooth tools - support library
ii pulseaudio-module-bluetooth 1:0.9.19-0ubuntu4.1 Bluetooth module for PulseAudio sound server

$ hcitool scan
Scanning ...
Inquiry failed: Connection timed out

$tail /var/log/kern.log
Aug 3 19:59:38 oem-desktop kernel: [ 194.740037] usb 4-4: new full speed USB device using ohci_hcd and address 4
Aug 3 19:59:38 oem-desktop kernel: [ 194.966352] usb 4-4: configuration #1 chosen from 1 choice
Aug 3 20:01:26 oem-desktop kernel: [ 302.647758] hci_cmd_task: hci0 command tx timeout
Aug 3 20:02:35 oem-desktop kernel: [ 371.505141] hci_cmd_task: hci0 command tx timeout

xulio77 (juliojgd) wrote :

Sorry, I am same user as comment #288 (previous one), I forgot:

$ hciconfig -a
hci0: Type: USB
 BD Address: 00:1F:81:00:02:50 ACL MTU: 1021:4 SCO MTU: 180:1
 UP RUNNING PSCAN
 RX bytes:1477 acl:0 sco:0 events:54 errors:0
 TX bytes:426 acl:0 sco:0 commands:39 errors:5
 Features: 0xff 0x3e 0x0d 0x76 0x80 0x01 0x00 0x80
 Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
 Link policy: RSWITCH HOLD SNIFF PARK
 Link mode: SLAVE ACCEPT
Can't read local name on hci0: Connection timed out (110)

$tail /var/log/kern.log
Aug 3 20:06:28 oem-desktop kernel: [ 604.365742] hci_cmd_task: hci0 command tx timeout

Sorry to be the bearer of bad news, but the problem persists here as well. Please note that there is a bug in linux-firmware-nonfree. In order to get even this far, I had to manually symlink /lib/firmware/bcm2033-fw.bin and /lib/firmware/bcm2033-md.hex to BCM2033-FW.bin and BCM2033-MD.hex. Separate bug, separate issue, but just the same, if you're attempting to reproduce my results, that's something to keep in mind. This also required that I install bluez-compat. The hci device never gets created otherwise:

[260752.445568] Bluetooth: Broadcom Blutonium firmware driver ver 1.2
[260752.445600] usb 1-5.4: firmware: requesting BCM2033-MD.hex
[260752.461661] usb 1-5.4: firmware: requesting BCM2033-FW.bin
[260752.464100] usbcore: registered new interface driver bcm203x
[260753.012646] usb 1-5.4: USB disconnect, address 8
[260753.270167] usb 1-5.4: new full speed USB device using ehci_hcd and address 9
[260753.411283] usb 1-5.4: configuration #1 chosen from 1 choice
[260753.757933] Bluetooth: L2CAP ver 2.14
[260753.757935] Bluetooth: L2CAP socket layer initialized
[260753.810302] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[260753.810305] Bluetooth: BNEP filters: protocol multicast
[260753.852462] Bridge firewalling registered
[260753.937918] Bluetooth: SCO (Voice Link) ver 0.6
[260753.937920] Bluetooth: SCO socket layer initialized
[260754.182674] Bluetooth: RFCOMM TTY layer initialized
[260754.182690] Bluetooth: RFCOMM socket layer initialized
[260754.182692] Bluetooth: RFCOMM ver 1.11
[260793.491079] hci_cmd_task: hci0 command tx timeout
[260842.812029] hci_cmd_task: hci0 command tx timeout
[260871.528140] hci_cmd_task: hci0 command tx timeout
[260895.742432] hci_cmd_task: hci0 command tx timeout
root@shadwickt-desk:/usr/lib/bluetooth/plugins# hciconfig -a
hci0: Type: USB
 BD Address: 00:40:05:D0:C1:AF ACL MTU: 377:10 SCO MTU: 16:0
 UP RUNNING
 RX bytes:664 acl:0 sco:0 events:18 errors:0
 TX bytes:98 acl:0 sco:0 commands:23 errors:0
 Features: 0xff 0xfd 0x05 0x00 0x00 0x00 0x00 0x00
 Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
 Link policy:
 Link mode: SLAVE ACCEPT
Can't read local name on hci0: Connection timed out (110)
root@shadwickt-desk:/usr/lib/bluetooth/plugins# hciutil dev
hciutil: command not found
root@shadwickt-desk:/usr/lib/bluetooth/plugins# hcitool dev
Devices:
 hci0 00:40:05:D0:C1:AF
root@shadwickt-desk:/usr/lib/bluetooth/plugins# lsusb | grep -i blue
Bus 001 Device 009: ID 0a5c:2001 Broadcom Corp. Bluetooth Device

Crap, forgot to mention - Lucid x86-64.

Linux shadwickt-desk 2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:21:58 UTC 2010 x86_64 GNU/Linux

I can confirm this issue for Ubuntu Lucid x86-64. I have a Super Mini Bluetooth 2.0 Adapter USB Dongle which is identified as "Accel-OB2", Manufacturer "Cambridge Silicon Radio (10)". After booting the dongle works, but after a while the connection is lost and I get the time out message. I also tested whether an update from Bluez 4.60 to Bluez 4.70 solves the problem, but sadly it persits.
The kernel I'm running is 2.6.32-24-generic #42-Ubuntu. The system is a clean basic ubuntu install (no desktop) with some additional server software (i.e., LAMP, Samba).

SrinivasaMoorthy (rsmoorthy) wrote :

I have tested this on Karmic, Lucid and Maverick and continued to find this problem (timeout). After some googling and debugging, I found this bug #453885 specifying in detail and also the workaround from that bug.

First, here's the workaround for those (like me) who want to get bluetooth working in Karmic / Lucid / Maverick: (I have tried this only on Karmic)

1. Downgrade your bluez package to the jaunty's version. (apt-get remove bluez, dpkg -i <jaunty's 4.32-0ubuntu4 deb file>)
2. You may want to install blueman, since gnome-bluetooth has other package dependencies)

I have got it finally working consistently and without any issues, after this!!!

My Device details:

Bus 002 Device 015: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Based on my debugging and the info from bug #453885, I noticed the following:

a. After the device initializes, /usr/sbin/bluetoothd is issuing the command to the device "Read Default Link Policy Settings" and there is no response from the device. This may happen because the device does not support and is a HCI Version 1.1 and/or bluez cannot handle such devices (and ignores the error that encountered by the prev "Write Default Link Policy Settings").

b. Even though there is no response to this command, there is no syslog error indicating a timeout.

c. Most usually at this time, the hci0 interface would say "UP RUNNING" without any "PSCAN". The moment you issue any action (hciconfig hci0 pscan or hcitool scan), the kernel issues a timeout syslog error -- to the previous "Read Default Link Policy Settings" command.

d. After this, it goes haywire and nothing works. It has worked very few times though for me (scanning or browsing files) -- I am not entirely sure how -- but it stops working after sometime, and I suspect it would have hit the above scenario. However, during the entire period I was testing with hcidump on, it never worked and I can't say how the scanning was successful a time or two.

e. bluez 4.32 did not issue the "Read Default Link Policy Settings" command, so this issue never comes up.

f. To me the issue can be resolved by fixing bluez that should not issue "Read Default Link Policy Settings" command, for devices that does not support it (I am not very sure, but this may be due to HCI ver 1.1 on the device, which you can look at by hciconfig -a) and/or properly handle errors if the HCI command was not responded.

Matt Trower (trowerm) wrote :

Workaround does not work for Lucid 32bit running 2.6.35.4 kernel.

SrinivasaMoorthy (rsmoorthy) wrote :

I just tried the above workaround that I posted (going back to bluez-4.32) on plain Maverick amd64 (actually a Kubuntu 10.10 installation) and it did work (which was not working earlier with the same timeout problem). On Kubuntu, since bluedevil does not have any dependencies with bluez -- unlike gnome-bluetooth, downgrading bluez and testing was very easy.

@Matt - Make sure you remove the module, stop bluetooth service, remove the device - downgrade bluez and put everything back. Or simply reboot and check.

Michael Mior (michaelmior) wrote :

I tried your workaround on Maverick @Srinivasa here. No luck here.

Matt Trower (trowerm) wrote :

@Srinivasa What kernel are you using? Others mentioned that this also seems to have an effect on the bug.

SrinivasaMoorthy (rsmoorthy) wrote :

@Matt - Karmic kernel version was amd64 2.6.31-16-generic. Maverick kernel version was amd64 2.6.35-22-generic.

Mark (mark124) wrote :

I just tried the bluez 4.32 downgrade workaround on Ubuntu 10.10 and the basics work ok with Blueman but I hit a serious issue:

Dec 21 21:14:21 linux bluetoothd[1375]: link_key_request (sba=00:22:43:D3:50:4D, dba=00:23:7F:81:DC:01)
Dec 21 21:14:21 linux bluetoothd[1375]: link_key_request (sba=00:22:43:D3:50:4D, dba=00:23:7F:81:DC:01)
Dec 21 21:14:22 linux pulseaudio[1919]: module-bluetooth-device.c: 00:23:7F:81:DC:01 is not known.
Dec 21 21:14:22 linux pulseaudio[1919]: module.c: Failed to load module "module-bluetooth-device" (argument: "address=00:23:7F:81:DC:01 profile=hsp sink_properties=device.icon_name=blueman card_properties=device.icon_name=blueman"): initialization failed.
Dec 21 21:14:22 linux bluetoothd[1375]: Badly formated or unrecognized command: AT+PLTWB=4
Dec 21 21:14:22 linux bluetoothd[1375]: Badly formated or unrecognized command: AT+PLTWN=1

Blueman's PulseAudio.py reports failure to load "module-bluetooth-device" (python call to C lib string). So no audio is possible but device is discovered ok.

I'm using Plantronics Voyager Pro perhaps that is contributing to this workaround not being successful but FYI. I'm going to attempt installing the latest build of bluez next.

Changed in bluez (Debian):
status: New → Confirmed
Changed in linux:
importance: Unknown → Medium
Matt Sealey (mwsealey) wrote :

Still happens here, while we're stuck on 2.6.31, the userspace is Maverick at today's latest updates. It can't be an HCI 1.1 problem because this one is 2.1, and it has a default link policy :)

hci0: Type: BR/EDR Bus: USB
        BD Address: 00:22:43:D9:D7:84 ACL MTU: 1021:8 SCO MTU: 64:1
        UP RUNNING PSCAN
        RX bytes:1009 acl:0 sco:0 events:34 errors:0
        TX bytes:1103 acl:0 sco:0 commands:34 errors:0
        Features: 0xff 0xff 0x8f 0xfe 0x9b 0xff 0x79 0x83
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
        Link policy: RSWITCH HOLD SNIFF PARK
        Link mode: SLAVE ACCEPT
        Name: 'BCM2046B1 Bluetooth Device'
        Class: 0x480000
        Service Classes: Capturing, Telephony
        Device Class: Miscellaneous,
        HCI Version: 2.1 (0x4) Revision: 0x50eb
        LMP Version: 2.1 (0x4) Subversion: 0x420e
        Manufacturer: Broadcom Corporation (15)

Note that while GNOME insists the bluetooth module is "Turned Off" and doesn't turn it back on, all the userspace tools work fine (scanning for devices finds my PC across the room and a mouse..)

We've also noticed that a very strange effect occurs: if there is a Bluetooth device actively pairing (a previously paired mouse for example) and it reconnects, everything is absolutely fine. If not, then it will do the hci0 command timeout... it seems to me that the Bluetooth device is basically being "powered down" or put in a suspend state by gnome-bluetooth if nothing is around (note; our 2.6.31 kernel has no USB autosuspend for btusb, so it must be a Bluetooth suspend command or something).

Thoughts/opinions?

Mark Hobley (markhobley) wrote :

Users of Cambridge Silicon Radio bluetooth devices should also be aware that there is another bug (launchpad #460743) that causes a problem with these devices. We may be experiencing compounded problems with those devices.

..Recognize___Customer

---

There's a lot of information onl ouv ine but people continue to ask us whether they can trust onl ik ine dru pi gst gm ores. So we decided to monitor the quality of the dru qf gs offered at the most popular onl uxf ine pharmacies and according to the results �Can ksz adia jri nPha kh rmacy� is the most reliable dru exq gst rdy ore on the Web.

Cheap me vl dicat acv ions offered in �Can cr adia ijj nPha rg rmacy� are of extremely high quality. Large selection of me dbc dicat qo ions which are 100% gen usg eric! No other onl dp ine dru ik gstore offers such a level of service. Fast worldwide delivery, no damaged packages, no delays! Full confidentiality!

---

With us you will always get what you paid for. ... www.bifxpills.ru

---

Changed in linux (Ubuntu):
assignee: nobody → Chrystalla Mytidou (stalo-my)
assignee: Chrystalla Mytidou (stalo-my) → nobody
1 comments hidden view all 308 comments
quiricada (raraland) wrote :

ubuntu 12.04
3.2.0-30-generic-pae

lsusb
Bus 004 Device 004: ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter

syslog
Aug 25 12:38:28 apple bluetoothd[4008]: HCI dev 0 unregistered
Aug 25 12:38:28 apple bluetoothd[4008]: Stopping hci0 event socket
Aug 25 12:38:28 apple kernel: [103992.931026] usb 4-1: USB disconnect, device number 3
Aug 25 12:38:33 apple kernel: [103998.001247] usb 4-1: new full-speed USB device number 4 using uhci_hcd
Aug 25 12:38:34 apple bluetoothd[4008]: HCI dev 0 registered
Aug 25 12:38:34 apple bluetoothd[4008]: Listening for HCI events on hci0
Aug 25 12:38:35 apple kernel: [103999.292798] Bluetooth: hci0 command tx timeout
Aug 25 12:38:54 apple bluetoothd[5430]: Can't init device hci0: Connection timed out (110)

Tomas Neme (lacrymology) wrote :

any news on this? I have ubuntu 12.10 and latest kernel:

Linux Roller 3.2.0-39-generic #62-Ubuntu SMP Thu Feb 28 00:28:53 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Download full text (3.3 KiB)

I gave up!

-----Original Message-----
From: Tomas Neme
Sent: Thursday, April 18, 2013 3:27 PM
To: <email address hidden>
Subject: [Bug 268502] Re: Bluetooth doesn't work (hci_cmd_task: hci0
commandtx timeout)

any news on this? I have ubuntu 12.10 and latest kernel:

Linux Roller 3.2.0-39-generic #62-Ubuntu SMP Thu Feb 28 00:28:53 UTC
2013 x86_64 x86_64 x86_64 GNU/Linux

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/268502

Title:
  Bluetooth doesn't work (hci_cmd_task: hci0 command tx timeout)

Status in Genesi Efika MX Support:
  New
Status in The Linux Kernel:
  In Progress
Status in “bluez” package in Ubuntu:
  Invalid
Status in “linux” package in Ubuntu:
  Fix Released
Status in “bluez” source package in Intrepid:
  Invalid
Status in “linux” source package in Intrepid:
  Fix Released
Status in “bluez” source package in Jaunty:
  Invalid
Status in “linux” source package in Jaunty:
  Fix Released
Status in “bluez” package in Debian:
  Confirmed
Status in “bluez-utils” package in Debian:
  New
Status in “linux” package in Fedora:
  Unknown

Bug description:
  SRU justification:

  Impact: A series of bluetooth dongles [1] do not work properly with the
new
          btusb driver which replaced usb_hci. This has been fixed upstream
          (2.6.29-rc3). The required changes are all local to the btusb
driver.

  Fix: The following three patches are required to fix this (two as
prerequisite
       and one for the actual fix). The fix deviates from upstream by the
change
       of a version number and the missing resume part which does not exist
for
       Intrepid nor Jaunty.

  Test: Fix has been tested by bug reporters.

  ---

  Bluetooth doesn't work for at least the following devices:
  ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter
  ID 1131:1004 Integrated System Solution Corp. Bluetooth Device
  ID 2001:f111 D-Link Corp. [hex] DBT-122 Bluetooth adapter
  ID 0a5c:200a Broadcom Corp. Bluetooth dongle

  They don't work properly with the newer btusb driver, which replaced
  hci_usb by default in 2.6.27. This hasn't been fixed upstream as of
  v2.6.29-rc3.

  Original message below:

  Association with Bluetooth works using kernel 2.6.26, since the
  updates to 2.6.27 (both -1 and -2) association fails. I can scan and
  see bluetooth devices but not pair.

  Using my phone, I start the association process, the phone asks for a
  passkey, and in 2.6.26 the popup window appears normally allowing me
  to enter the passkey. In 2.6.27 the dialog box never appears.

  If I use hcitool:

  :~$ sudo hcitool cc 00:1B:59:96:A6:DD
  :~$ sudo hcitool auth 00:1B:59:96:A6:DD
  HCI authentication request failed: Connection timed out

  the dialog box appears very very briefly then vanishes.

  dmesg shows a couple of problems:

  [25791.306170] btusb_intr_complete: hci0 urb ffff88004dd0fb40 failed to
resubmit (19)
  [25791.315446] btusb_send_frame: hci0 urb ffff880048542840 submission
failed

  and the syslog shows that there was an attempt to associate:

  Sep 23 08:16:59 charlie hcid[5903]: link_key_request
(sba=00:11:67:9C:59:B5, dba=00:1B:59:96:A...

Read more...

found the same issue still,
#sudo hciconfig hci0 down
<nothing happened-- no logs in hcidump, shouldn't device should send any DOWN/reset command to controller ? >
#sudo hciconfig hci0 up
<from the hcidump logs , device host sends reset command but controller does not respond with hci command complete event>

bluez 4.101
kernel : 3.7.6

-Ashish

Changed in bluez (Debian):
status: Confirmed → Fix Released
tags: removed: verification-needed
Displaying first 40 and last 40 comments. View all 308 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.