Ubuntu

ubuntu 8.10 beta boot failure - patch attached

Reported by chanjar on 2008-09-01
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
High
linux (Ubuntu)
Medium
Tim Gardner
Intrepid
Medium
Tim Gardner

Bug Description

i've upgraded from ubuntu 8.04 to ubuntu 8.10 alpha4. But i find that i can't boot with the new kernel.
Here is the error message:

BUG Int 14 : CR2 ffb41000
             EDI ffb40710 ESI 000008f0 EBP c04c3f08 ESP c04c3ee0
             EBX ffb40fff EDX 00000000 ECX ffb40ffb EAX ffb41000
             err 00000000 EIP c02ddfa1 cs 00000000 flg 00010046
STACK etc.

i have the same problem when i used to install linux 2.6.26 kernel, but i think this problem will
be solved if i install ubuntu 8.10 alpha4. But that problem appears again.:-(

BTW, the old kernel works well.

i have an ASUS P5QL-PRO motherboard with a onboard ethernet card Atheros AR8121/AR8113/AR8114,
a ATI HD3850 video card, a SATA 250G harddisk, an Intel E7200 cpu.

Today, i try to boot the new kernel again and i choose the memtest86+ option, then the memory test
begin. I saw a lot of errors and the errors just keep increasing. Finally my computer halted with
an endless long beep.

i think it should be the motherboard BIOS's problem, but i have upgraded the latest BIOS version.

is there anyone can help me? thanks in advance.

chanjar (chanjar) on 2008-09-01
description: updated
Gabriel Ruiz (anakron) wrote :

Its a real bug, but only your computer have it, cause in mine this doesn`t happened. I hope you could get a right answer.

chanjar (chanjar) on 2008-09-01
description: updated
chanjar (chanjar) on 2008-09-02
description: updated
description: updated
chanjar (chanjar) wrote :

No one can help? Is there not any advice or hint to solve this problem? No one have the same experience like me?

snoboy (snoboy79-gmail) wrote :

I am the same mistakes!
However, my configuration is:
i have an ASUS P5QL-PRO motherboard with a onboard ethernet card Atheros AR8121/AR8113/AR8114,
a NVIDIA GeForce 9600 GT video card, a SATA 250G harddisk, an Intel E7200 cpu.
The reason is estimated that motherboard!

Martijn Meijer (toolunious) wrote :

Seems to be the motherboard, I too have an ASUS P5QL-PRO.

Felix Geyer (debfx) wrote :

I have the same problem with P5QL-Pro and Intrepid alpha6.

Felix Geyer (debfx) wrote :

This is not an Ubuntu specific bug.

I did some more testing with other distributions and they both trigger the same bug (with slightly different error messages):
- Fedora 10 beta x86_64 (Kernel 2.6.27)
- openSUSE 11.0 i386 (Kernel 2.6.25)

So I guess this bug has been introduced in 2.6.25.
Is there a way to obtain more debugging information?

Martijn Meijer (toolunious) wrote :

I have tried some older versions (6.10 and 7.04). I do not know what kernel these are based on, but they do not work either. Secondly, I'm just trying to pull some attention to this bug because I hate this one :)

Felix Geyer (debfx) wrote :

Tested with intrepid beta:

PANIC: early exception 0e rip 10:ffffffff812aeaed error 0 cr2 ffffffffff341000

Felix Geyer (debfx) wrote :

I booted Intrepid with the parameter earlyprintk=vga
Here are the photos of the kernel output.

Felix Geyer (debfx) wrote :

Same problem with Intrepid beta and Asus P5QL PRO motherboard

Felix Geyer (debfx) wrote :
Changed in linux:
status: Unknown → Confirmed
Salgar (salgar) wrote :

Same problem with Asrock K7S8XE+ :(

Salgar (salgar) wrote :

Oh, my system boots with linux-image-2.6.25-2-386, but linux-image-2.6.27-4-generic leads to the error: BUG Int 14 : CR2

Felix Geyer (debfx) wrote :

There is an upstream patch available, that didn't make it into 2.6.27 final:
http://lkml.org/lkml/2008/10/9/267 (attached for convenience)

Please add it to the intrepid kernel.
I can confirm that it fixes this bug.

Changed in linux:
status: Confirmed → Triaged
tonfa (bboissin) wrote :

@Felix:

Can you ask Alan if he could send it to the stable kernel serie ?
Since it seems trivial and it fixes a regression, it looks to be the best thing to do (and that way it will automatically propagate to all the distros that use 2.6.27)

thanks.

mumismo (mumismo) wrote :

Any chance to get this on the Ubuntu version of the kernel shipped with 8.10 till we wait for 2.6.27.1 ?
It is pretty scary the prospect of updated Hardy's systems unable to boot anymore

mumismo (mumismo) wrote :

BTW, the patch is already included in 2.6.27-git3 (as of this writing the last stable kernel)

Martin Pitt (pitti) on 2008-10-13
Changed in linux:
assignee: nobody → canonical-kernel-team
milestone: none → ubuntu-8.10
Alexandru Guduleasa (gulyan89) wrote :

Same problem with Gigabyte GA-EP45-DS3P

Tim Gardner (timg-tpi) wrote :
Changed in linux:
assignee: canonical-kernel-team → timg-tpi
importance: Undecided → Medium
status: Triaged → Fix Committed
Changed in linux:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.27-7.11

---------------
linux (2.6.27-7.11) intrepid; urgency=low

  [ Amit Kucheria ]

  * STABLE queue: mac80211: fix two issues in debugfs
    - LP: #275227
  * SAUCE: Adds support for COMPAL JHL90 webcam

  [ Ben Collins ]

  * SAUCE: (no-up) x86: Quiet "Kernel alive" messages
    - LP: #39985
  * SAUCE: (no-up) Modularize vesafb
  * build/config: Enable vesafb module
  * build: Switch to vesafb as preferred.

  [ Leann Ogasawara ]

  * Add Dell Dimension 9200 reboot quirk
    - LP: #271370

  [ Michael Haas ]

  * SAUCE: Revert aufs changes from AppArmor merge

  [ Tim Gardner ]

  * fix virtio udeb layout
    - LP: #257739
  * Enabled CONFIG_EXT4DEV_FS=m
  * Changed default TCP congestion algorithm to 'cubic'
    - LP: #278801
  * SAUCE: ipw2200: change default policy for auto-associate
    - LP: #264104

  [ Upstream Kernel Changes ]

  * x86, early_ioremap: fix fencepost error
    - LP: #263543

 -- Tim Gardner <email address hidden> Sat, 11 Oct 2008 08:07:42 -0600

Changed in linux:
status: Fix Committed → Fix Released
Marco Scholl (traxanos) wrote :

I have the problem with th latest kernel version from stable release 8.10. my board is Gigabyte GA-M61P-S3

Changed in linux:
status: Fix Released → New
Marco Scholl (traxanos) wrote :

when i reset the computer it works. if i start the computer after i've unplugged the powercable the error will displayed.

Steve Langasek (vorlon) wrote :

Marco, why do you think that your problem is the same as this bug?

Marco Scholl (traxanos) wrote :

i have search for BUG Int 14 and i found only this bug

Severin Heiniger (severinh) wrote :

I tried to Install Ubuntu Intrepid on my new PC that didn't have an OS preinstalled and encountered this very bug. What would be the best way of installing Intrepid on this machine? I guess there's no updated Intrepid media that contains the patched kernel. Seems like there's no other way than installing Hardy and upgrading to Intrepid, right?

Felix Geyer (debfx) wrote :

This bug has been fixed before the Intrepid release.
So I think something else causes your problem.

Severin Heiniger (severinh) wrote :

Hi Felix,

I just noticed that I didn't use the final version of Intrepid, but an Alpha or Beta medium that was lying around. Installing Intrepid using the official ISO worked just fine. Sorry for bothering you.

Steve Langasek (vorlon) wrote :

"Int 14" is fairly generic as an error, and the bug reported here definitely appears to be resolved. Again marking as fixed. Marco, you may want to open a new bug report with more detail about your issue.

Changed in linux:
status: New → Fix Released
Fred (fred695) wrote :

I downloaded ubuntu-8.10-desktop-i386.iso a couple of weeks ago and I get an identical problem. The installation process stops shortly after displaying "Booting the kernel" and shows the error message:
    BUG: Int 14 : CR2 ffb41000
and then locks up.

The system has an Asus P5QL motherboard with a Core 2 Duo E8500 and 4 GB RAM.

It's disappointing to see that, although this bug appears to have been known about for some months, there is no mention of it in the 8.10 release notes.

Felix Geyer (debfx) wrote :

Are you sure you are using the final Intrepid version?

Like Steve said "BUG: Int 14" is a generic error message, so it might be a different bug.

Changed in linux:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.