Ubuntu

[intrepid] Resume from suspend does not work in 2.6.27-1

Reported by nanog on 2008-08-28
80
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Nominated for Intrepid by Damian Melniczuk

Bug Description

Resume from suspend fails and triggers a normal boot in 2.6.27-1. The suspend works and causes spin down and blinking suspend light. This is a regression from 2.6.26-5 and resume works perfectly with this kernel.

Ubuntu 8.10 alpha4

2.6.27-1-generic x86_64

Stéphane Graber (stgraber) wrote :

I observed the same behaviour on my HP Compaq 8510p.
Suspsending works as usual but when resuming, the laptop poweroff completely and I have to boot it again.

I'm running 2.6.27-1-generic on amd64.
Attached is the syslog entries that were written during the suspend test I did on 2.6.27-1.

nanog (sorenimpey) wrote :

I am running a dell m1330 and will attach relevant logs.

nanog (sorenimpey) wrote :
nanog (sorenimpey) wrote :
nanog (sorenimpey) wrote :
Pete Graner (pgraner) wrote :

Happens to me on a Dell Latitude D620 and a Dell Inspiron 6400

bhood (byron-phareware) wrote :

Reproducible on an HP Pavilion dv6000 (Linux version 2.6.27-2-generic (buildd@yellow) (gcc version 4.3.2 (Ubuntu 4.3.2-0ubuntu1) ) #1 SMP Thu Aug 28 17:18:43 UTC 2008) laptop. No indication of any failure in dmesg or syslog, but I will attach those on request.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: New → Triaged

Hi All,

Just a note that I believe the next 2.6.27-3 kernel upload will hopefully resolve this issue. Unfortunately 2.6.27-3 will not be available until after Alpha5 is released. If you can please watch for updates and test once 2.6.27-3 comes out that would be great. Please let us know your results. Thanks.

Pete Graner (pgraner) wrote :

BenC provided me with the 2.6.27-rc5 which is what 2.6.27-3 will be.

That kernel resolved this issue on the following notebooks:

MacBook Air
Dell Inspiron 8100
Dell Latitude D620
Dell Inspiron 6400

I tried suspend, hibernate 25 times each all worked as expected.

Russ Dill (russ-dill) wrote :

I know that before, the issue was caused by CONFIG_FTRACE. I've been building my own sauce of ubuntu kernels with this option disabled, and suspend/resume works. I'll have to test 2.6.27-3.

Tim Gardner (timg-tpi) on 2008-09-12
Changed in linux:
status: Triaged → Fix Released
Hoffmann (bubble-fish) wrote :

As for me, this issue is not resolved with the 2.6.27-3 kernel.

Any ideas?

Austriaco (lanieves) wrote :

Hi,

I can confirm this still happens with kernel 2.6.27-3

$ uname -a
Linux galar3 2.6.27-3-generic #1 SMP Wed Sep 10 16:02:00 UTC 2008 i686 GNU/Linux

This a VIT D2010 laptop. I'm attaching the output of lspci -vv

If any other info about the machine is required, just ask and I'll be happy to provide it.

Hi Guys,

For those of you still experiencing issues with the 2.6.27-3 kernel, can you first confrim that this issue did not exist with the 2.6.26 kernel? The reason I say this is because this bug report is specifically regarding a regression from the 2.6.26 kernel. Even though you may be experiencing the same symptoms of this bug report it could be that you actually have a different bug. I'd suggest probably opening a new bug report as this bug has been marked Fix Released and will not likely get much more attention. Thanks.

Eitan Isaacson (eeejay) wrote :

Hi,

I am still experiencing this too. I have a Lenovo Thinkpad T400.
Linux sparky 2.6.27-4-generic #1 SMP Wed Sep 24 01:30:51 UTC 2008 i686 GNU/Linux

I would try to boot into a 2.6.26 kernel, but it seems like those packages disappeared with some dist-upgrade, and now I can't find them online either.

Michal Sylwester (msylwester) wrote :

Hi,

I'm also still suffering from this, Compaq 6720s with 2.6.27-4-generic on x86_64.

I've tested it on 2.6.26-5-generic and it works there.

jdorwart (jdorwart) wrote :

This appears to be fixed on my HP1320us (dual core) with 2.6.27-7-generic.

filth (filth) wrote :

I still encounter this problem, I'm running the 2.6.27-7 kernel, on a 64bit intel core 2 duo, but with Ubuntu 8.10 rc1 (updated from BETA 32bit).

Linux loo 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686 GNU/Linux

gabrielitos (gabrielitos) wrote :

I encountered the problem running the 2.6.27-7-generic in the STABLE release, on a Amd64 processor.

suspend -> strange blinking suspend led -> instead of resume, normal boot.

Linux Protone 2.6.27-7-generic #1 SMP Thu Oct 30 04:12:22 UTC 2008 x86_64 GNU/Linux

CalderCoalson (ccoal) wrote :

Confirmed on dv6700z. Attaching my acpi-support file, although I have the same problem regardless of which settings I try, (except when POST_VIDEO=false it doesn't even suspend properly).

Steve Greene (sgreene59) wrote :

I see this behavior (normal boot rather that suspend) on my HP L2005CM laptop, using 64-bit kernel-2.6.27-7-generic.

SUSPEND_METHODS="dbus-pm dbus-hal pm-utils"

gabrielitos (gabrielitos) wrote :

I tried to use the /etc/acpi/sleep.sh /etc/acpi/prepare.sh and /etc/acpi/suspend.d/* config files from the Ubuntu 8.04 installation (where suspend worked) but the result was the same: hard reboot instead resuming from suspend and strange blinking led (frequence different from the Ubuntu 8.04).
I suppose it must be somewhat in the kernel.
I changed the status because there is no fix for this problem!

Changed in linux:
status: Fix Released → Confirmed
Eitan Isaacson (eeejay) wrote :

A note: I managed to resume/suspend successfully (maybe 6 times till now).
This is after disabling bluetooth in BIOS. I am not sure which kernel module is the culprit...

linoxman (linoxman-gmail) wrote :

I have the same problem with acer 4520 Nvidia Chipset. With 8.04, suspend and hibernate works well.

gabrielitos (gabrielitos) wrote :

I tried a the Ubuntu 8.10 livecd and I had the same problem from it (reboot instead resume from suspend).
My motherboard is a Asus A8V.

I confirm that bug on hardware: dell latitude d620
with kernel: 2.6.27-8-generic

Jorge Eduardo (jorge-birck) wrote :

Same bug here. My laptop sleeps, but dont returns to life. Im using 2.6.27-7-generic with Acer Aspire 4520

update:

- suspend to ram works
- hibernation don't works

Noel J. Bergman (noeljb) wrote :

Just as a data point, both suspend to ram and hibernate work for me.

  $ uname -r
  2.6.27-7-generic

  Host: T61p 6457-7WU

Suspend works quickly and wakes quickly. Hibernate takes a bit longer, naturally. On restarting the computer from hibernate, we come back through GRUB, then during the boot phase I can see the suspend LED blink. Then the screen goes wonky and the system APPEARS to be hung. But within the screen changes again and disk I/O occurs. Within another minute or so, the screen clears up, the unlock login appears, and I can get back to the newly resumed session.

zacktu (cannon) wrote :

On a Dell Latitude D610 with Intrepid, suspend didn't work, but hibernate did work. I moved and resized the swap partition. Didn't know about UUIDs, so hibernate said it couldn't find the swap partition. Since then, I've made UUID for swap agree everywhere. Hibernate doesn't work any more. The system just reboots.

Tom V (tvice) wrote :

I reported this bug yesterday but after reading this post it looks like it has been around for awhile. My laptop is a new HP G60 with Nvidia video card and AMD dual core Turion CPU. On a clean install of 8.10 64 bit I can hibernate and come back but if I sleep or suspend it will not resume. Kernel is 2.6.27-7. I am using the latest Nvidia driver available from the restricted drivers 177.80.
Sometimes when I resume from a suspend I can briefly, for a fraction of a second, see my desktop but then the screen goes black and all I have is a mouse cursor. From there a cold boot is all that I can do.

I can suspend to RAM and resume just fine but Hibernate won't resume, it just boots normally when I hit the button. Running Ubuntu 2.6.27-10.20-generic on ASUS C90S with the latest NVidia 177 driver and all patches applied as of today. Here's my /etc/uswsusp.conf:

# /etc/uswsusp.conf(8) -- Configuration file for s2disk/s2both
resume device = /dev/sda2
splash = y
compress = y
early writeout = y
image size = 1394284052
RSA key file = /etc/uswsusp.key
shutdown method = platform
suspend loglevel = 1
max loglevel = 1
edwin@edwinc90s:/etc/init.d$

Can I assist with any additional info?

Please see this comment from a developer concerning this bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/262423/comments/13

It is suggested to open a new bug.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Hi.
I probably know how to fix hibernation.
Before I had swap partition = ram. I made swap partition 2*ram big.
Then I did things from: http://louboldt.com/ilinuxmisc.htm#uuidswap

Now, hibernation and suspend work perfectly for me :)

 uname -a
Linux damel 2.6.18-6-686 #1 SMP Fri Dec 12 16:48:28 UTC 2008 i686 GNU/Linux

intrepid @ dell latitude d620

Cya :)

TJ (tj) wrote :

Are any users still suffering the symptoms described in the original bug report?

Resume from suspend fails and triggers a normal boot. The suspend works and causes spin down and blinking suspend light.

If not I propose we close this report as "Fix Released"

Hermes (PL) (hermes85pl) wrote :

I moved to 2.6.28-8-generic and still it's not good.

Hibernation works perfectly fine for me, but I cannot resume after I suspend. The screen stays off. The computer looks like it just hung since I cannot even toggle caps lock.

I use Asus A6000 A6Jc with Nvidia.

On Wed, Mar 4, 2009 at 1:39 AM, Hermes <email address hidden> wrote:
> I moved to 2.6.28-8-generic and still it's not good.
>
> Hibernation works perfectly fine for me, but I cannot resume after I
> suspend. The screen stays off. The computer looks like it just hung
> since I cannot even toggle caps lock.
>
> I use Asus A6000 A6Jc with Nvidia.
>
> --

i also have the same problem with suspend, after suspend screen stays off.
In particular, if I am in AC and i suspend and after that I turn to
battery, then the screen stays off, too!

I use Dell D830 with nvidia nvs 140m

This bug report was filed as a regression specific to the change from the 2.6.26 kernel to the 2.6.27 kernel.

@Hermes and @ Babis Babalis: please file new bug reports so we can fix whatever is wrong with the 2.6.28 kernel.

Thanks for helping.

Changed in linux:
status: Confirmed → Fix Released
FabioXXL (fabio-sabatti) wrote :

Hi there, I'm still having the same problem using the 2.6.27-13-server kernel, just updated.
I'm using a Lenovo Thinkpad T61p with Nvidia

When the system resume stay on a black screen for some minute and then reboot.

Do you need a new bug report for this?
Thanks

Please file a new bug report. A new report gives better information for the developers to be able to resolve the issue you are having. Thanks for helping improve Ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers