Ubuntu

Comment 4 for bug 252119

*1) Français
2) English
3) Nederlands

1) Français :*
Bonjour,
J'ai réinstallé Ubuntu pour tester si tout était correct dans les
commandes...

Code : (de http://doc.ubuntu-fr.org/audio_intel_hda)
*La doc :*

sudo apt-get install alsa-source
cd /usr/src
sudo tar jxvf /usr/src/alsa-driver.tar.bz2
gedit /usr/src/modules/alsa-driver/alsa-kernel/Documentation/ALSA-Configuration.txt
# POUR VOIR LA DOC

*Les drivers :
*

sudo apt-get install build-essential
(sudo apt-get install alsa alsa-oss alsa-utils alsa-base) # *UTILE* ????
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.16.tar.bz2
tar -jxf alsa-driver-1.0.16.tar.bz2
wget http://poiresdujardin.free.fr/patch/patch_realtek_mitac8227.tar.gz
tar -xzf patch_realtek_mitac8227.tar.gz
rm alsa-driver-1.0.16/sound/pci/hda/patch_realtek.c
mv patch_realtek.c alsa-driver-1.0.16/sound/pci/hda/
cd alsa-driver-1.0.16/
./configure --with-cards=hda-intel --with-oss=yes
make
sudo cp pci/hda/snd-hda-intel.ko /lib/modules/`uname
-r`/ubuntu/sound/alsa-driver/pci/hda/

sudo gedit /etc/modprode.d/alsa-base # *AJOUTER* à la fin : options
snd-hda-intel model=auto
sudo reboot
# *APRÈS* le redémarrage :
alsamixer # => *METTRE* Volume général, PCM, Front au maximum !

*En cas de problèmes :*

sudo gedit /etc/modprode.d/alsa-base

# AJOUTER (ou remplacer) à la fin :
options snd-hda-intel model=3stack-dig
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
#

sudo rm /lib/modules/`uname
-r`ubuntu/sound/alsa-driver/pci/hda/snd-hda-intel.ko # *UTILE* ?
(remplacer 'uname -r' par 2.6.24-19-generic ou 2.6.24-20-generic ?

sudo reboot

#*APRÈS* le redémarrage
sudo gedit /etc/modprode.d/alsa-base # *REMPLACER* : options
snd-hda-intel model=auto

Voilà, moi après cette démarche ça fonctionne sans problème (chez moi sur le
même pc avec Ubuntu Hardy 64bit) (excepté le microphone intégré).

********************************************

*2) ENGLISH :*
Hello
Yesterday I reinstalled Ubuntu Hardy 64bit and reconfigured ALSA :

Code : (from http://doc.ubuntu-fr.org/audio_intel_hda)
*Documentation :*

sudo apt-get install alsa-source
cd /usr/src
sudo tar jxvf /usr/src/alsa-driver.tar.bz2
gedit /usr/src/modules/alsa-driver/alsa-kernel/Documentation/ALSA-Configuration.txt
# TO CHECK the documentation

*Drivers : *

sudo apt-get install build-essential
(sudo apt-get install alsa alsa-oss alsa-utils alsa-base) # *USEFUL* ????
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.16.tar.bz2
tar -jxf alsa-driver-1.0.16.tar.bz2
wget http://poiresdujardin.free.fr/patch/patch_realtek_mitac8227.tar.gz
tar -xzf patch_realtek_mitac8227.tar.gz
rm alsa-driver-1.0.16/sound/pci/hda/patch_realtek.c
mv patch_realtek.c alsa-driver-1.0.16/sound/pci/hda/
cd alsa-driver-1.0.16/
./configure --with-cards=hda-intel --with-oss=yes
make
sudo cp pci/hda/snd-hda-intel.ko /lib/modules/`uname
-r`/ubuntu/sound/alsa-driver/pci/hda/

sudo gedit /etc/modprode.d/alsa-base # *PASTE* on the end : options
snd-hda-intel model=auto
sudo reboot
# *After* the reboot :
alsamixer # => *Switch* to the max : Mixer, PCM, Front !

*IF you have a bug again :*

sudo gedit /etc/modprode.d/alsa-base

# PASTE (or replace) on the end :
options snd-hda-intel model=3stack-dig
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
#

sudo rm /lib/modules/`uname
-r`ubuntu/sound/alsa-driver/pci/hda/snd-hda-intel.ko # *USEFUL* ?
(replace 'uname -r' by 2.6.24-19-generic or 2.6.24-20-generic ?

sudo reboot

# *After* the reboot
sudo gedit /etc/modprode.d/alsa-base # *REPLACE* : options
snd-hda-intel model=auto

After that I haven't any problem with alsa (except with the integrated
microphone...)

********************************

*3) Nederlands*:
Hallo
Gisteren heb ik opnieuw geïnstalleerd Ubuntu Hardy 64bit en aangepast ALSA:

*Code*: (van http://doc.ubuntu-fr.org/audio_intel_hda)
Documentatie:

sudo apt-get install alsa-source
cd /usr/src
sudo tar jxvf /usr/src/alsa-driver.tar.bz2
gedit /usr/src/modules/alsa-driver/alsa-kernel/Documentation/ALSA-Configuration.txt
# *na* te gaan of de documentatie

*Drivers : *

sudo apt-get install build-essential
(sudo apt-get install alsa alsa-oss alsa-utils alsa-base) # *HANDLEIDING* ????
wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.16.tar.bz2
tar -jxf alsa-driver-1.0.16.tar.bz2
wget http://poiresdujardin.free.fr/patch/patch_realtek_mitac8227.tar.gz
tar -xzf patch_realtek_mitac8227.tar.gz
rm alsa-driver-1.0.16/sound/pci/hda/patch_realtek.c
mv patch_realtek.c alsa-driver-1.0.16/sound/pci/hda/
cd alsa-driver-1.0.16/
./configure --with-cards=hda-intel --with-oss=yes
make
sudo cp pci/hda/snd-hda-intel.ko /lib/modules/`uname
-r`/ubuntu/sound/alsa-driver/pci/hda/

sudo gedit /etc/modprode.d/alsa-base # ZETTEN op het einde: : options
snd-hda-intel model=auto
sudo reboot
# *Na* het opnieuw opstarten:
 alsamixer # => *Overschakelen* naar de maximum: Mixer, PCM, Front!

*Als u een bug opnieuw**:*

sudo gedit /etc/modprode.d/alsa-base

# *ZETTEN* (of vervangen) op het einde:
options snd-hda-intel model=3stack-dig
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
#

sudo rm /lib/modules/`uname
-r`ubuntu/sound/alsa-driver/pci/hda/snd-hda-intel.ko # *ANDLEIDING*?
(vervang 'uname-r' door 2.6.24-19-generic of 2.6.24-20-generic ?

sudo reboot

#Na het opnieuw opstarten
sudo gedit /etc/modprode.d/alsa-base # *vervangen* : options
snd-hda-intel model=auto

Daarna heb ik geen probleem met alsa (behalve met de geïntegreerde microfoon
...)