uvcvideo: USB cam hangs after a few seconds (Patch available upstream)

Bug #243731 reported by Hitsch Thöny on 2008-06-28
28
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Dell Mini Project
Undecided
Gary Lasker
linux (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Leann Ogasawara

Bug Description

As described in the summary, the USB webcam hangs after a few seconds and in /var/log/syslog, these error messages appear:
Jun 28 15:43:31 McCrystals kernel: [ 618.650256] uvcvideo: Failed to resubmit video URB (-45).
Jun 28 15:43:31 McCrystals kernel: [ 618.650313] uvcvideo: Failed to resubmit video URB (-45).
Jun 28 15:43:31 McCrystals kernel: [ 618.650339] uvcvideo: Failed to resubmit video URB (-45).
Jun 28 15:43:31 McCrystals kernel: [ 618.650352] uvcvideo: Failed to resubmit video URB (-45).

A patch is available upstream: https://lists.berlios.de/pipermail/linux-uvc-devel/2008-March/003294.html (please note: berlios has an invalid certificate at the time writing)

Please include this patch in your official kernel module as I am new the linux and not able to compile a kernel by myself

raphael (raphoun) wrote :

I have this bug with my XPS M1530, i'm going to try the patch right now

raphael (raphoun) wrote :

it seems to work :)

I joined the patched module for 2.6.24-19-generic

you have to place it in /lib/modules/2.6.24-19-generic/kernel/drivers/usb/host/

Hitsch Thöny (hitsch-thoeny) wrote :

Thank you.
Unfortunately it didn't work:

hitsch@McCrystals:/lib/modules/2.6.24-19-generic/kernel/drivers/usb/host$ sudo modprobe ehci-hcd
FATAL: Error inserting ehci_hcd (/lib/modules/2.6.24-19-generic/kernel/drivers/usb/host/ehci-hcd.ko): Invalid module format

Brian Beck (brian-beck76) wrote :

I have the same problem. When I am using the built in camera on my Acer Aspire 5720Z. At seemingly random time all of a sudden the video display will become corrupt and messages like this will appear in /var/log/syslog:

Jul 24 22:39:03 tardis kernel: [ 4022.172447] uvcvideo: Failed to resubmit video URB (-45).
Jul 24 22:39:03 tardis kernel: [ 4022.172484] uvcvideo: Failed to resubmit video URB (-45).
Jul 24 22:39:03 tardis kernel: [ 4022.172517] uvcvideo: Failed to resubmit video URB (-45).

Camera model: Acer CrystalEye webcam
Kernel: Linux tardis 2.6.24-20-generic #1 SMP Thu Jul 17 16:29:46 UTC 2008 i686 GNU/Linux

I've attached the output from 'lsusb -v' the webcam is the first device in the list. I don't know it it's helpful or not, but I figured it couldn't hurt.

If there's anything I can do to help test this let me know.

Thanks,
Brian

Jean-Baptiste Lallement (jibel) wrote :

thanks for your report.

Marking to "confirmed"

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Ralph Janke (txwikinger) wrote :

The Intrepid Ibex 8.10 Beta release was most recently announced - http://www.ubuntu.com/testing/intrepid/beta . It contains the 2.6.27 Ubuntu kernel. It would be great if you could test and verify if this is still an issue. The status is being set to Incomplete until we receive further feedback. Thanks.

Changed in linux:
status: Confirmed → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
Nicola Ferralis (feranick) wrote :

The kernel in intrepid (2.6.27) fixes this. A patch should be applied in hardy, possibly backporting the version of the uvcvideo driver from intrepid to hardy, This is quite crucial, since hardy is LTS. In addition few other projects (specifically the dell-mini project) sufferst the same problem:

https://bugs.launchpad.net/dell-mini/+bug/297529

Thus I reopen this bug.

Changed in linux:
status: Invalid → New
romassi (romassi1977) wrote :

My Dell Mini suffers the same problem...Sometimes all the system crashes after trying using the webcam (with any software, like cheese skype or dell video chat).
I hope the solution should be soon backported to hardy (and so to the Dell Ubuntu lpia-version dedicated to Mini) due to the number of customers involved onto this problem

Hi All,

I'm marking this Fix Released for Intrepid and will nominate this for Hardy for the kernel team to consider for a Stable Release Update. Thanks.

Changed in linux:
status: New → Fix Released

Build Dell-Mini 20080913
Environment Dell Mini 9 BIOS A03

I cannot reproduce this in my build. I am using cheese and the internal 1.3 megapixel webcam on my machine. I have tried letting my machine idle in picture mode, in video mode and I also have tried taking pictures and recording video. Cheese is a bit laggy but that is a known bug, I can't make cheese crash at all. I suggest this bug be closed and reopened if the issue reappears and steps can be given to reliably reproduce this.

Óscar Frías (ofrias) wrote :

I can systematically reproduce the bug. Just opening Cheese and waiting for a few seconds.
I am using a Dell Mini shipped with Ubuntu and upgraded to BIOS A02.
What information do you need to reproduce the problem?
By the way, where did you get A03 BIOS ?

Óscar Frías (ofrias) wrote :

The bug is still there after upgrading to A03 BIOS.

Chris Gregan (cgregan) wrote :

This looks like an easy patch to work in to an update.

Changed in dell-mini:
assignee: nobody → pat-mcgowan
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

Please track hardy backport and meger in dell mini

Changed in dell-mini:
assignee: pat-mcgowan → gary-lasker
Changed in dell-mini:
status: Confirmed → Fix Committed
Changed in dell-mini:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions