Intel WLAN, 3945 (a/b/g) - low performance

Bug #223174 reported by AndreK on 2008-04-27
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

The 3945 performance is low, even from local SAMBA server, file copy never goes over 3Mbit.
Internet speed tests are also limited to 3-4Mbit.
This is with a strong 54Mbit connection - the laptop is also the only WLAN device on the WLAN router/AP.
Tested with Netgear router, and Cisco access point.

Ubuntu 8.04 driver/device iwl3954

Should I try non-free intel drivers ?

AndreK (andre-k) on 2008-04-27
description: updated
AndreK (andre-k) on 2008-04-27
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in linux.

Please include the output of the command 'uname -a' in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command 'dmesg > dmesg.log' and attach the resulting file 'dmesg.log' to this bug report.
3. Please run the command 'sudo lspci -vvnn > lspci-vvnn.log' and attach the resulting file 'lspci-vvnn.log' to this bug report.
For your reference, the full description of procedures for kernel-related bug reports is available at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance!

Errico Picchiarelli (munny) wrote :

Hi Brian, same problem here in my laptop with ubuntu 8.04 with all update,

my lspci for wireless device is:
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

my uname -a:
Linux munny-laptop 2.6.24-21-generic #1 SMP Tue Aug 12 13:37:22 UTC 2008 i686 GNU/Linux

The speed in my local network with wireless never goes over 3-400 KB/S, if i use wired conection i go until 6 MB/S,
if i use WinXP on same notebook with wireless connection i download about 4 MB/S.

Network Manager say me i 've 90% connection at 54Mb/S

I try with 3 different access point so i think there's a problem in ipw3945 driver.

Thanks, I hope i can help you!

Errico Picchiarelli

Errico Picchiarelli (munny) wrote :

Here there's my complete lspci

Brian Murray (brian-murray) wrote :

Your dmesg.log doesn't capture much network activity. Were you actively using the wireless network connection during that time period?

Errico Picchiarelli (munny) wrote :

Hi Brian,
here you find a new dmesg log while i do some transfer in my local network over ftp and samba.

Brian Murray (brian-murray) wrote :

I don't see anything in there, perhaps '/var/log/daemon.log' would have some information about the problem. Could you please attach that file? Thanks again.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Errico Picchiarelli (munny) wrote :

Hi Brian, Hi Leann,
I've installed kernel 2.6.27-2 and restricted modules from intrepid repository in my hardy...
It seems it's all ok here you can see my uname -a:

Linux munny-laptop 2.6.27-2-generic #1 SMP Thu Aug 28 17:20:02 UTC 2008 i686 GNU/Linux

The problem with my wireless connection it's the same, also with new kernel my transfer nevers goes over 400 K Byte/S, i tried as usual samba and ftp.

I attach my daemon.log, i hope this can help you.

Bye, Errico Picchiarelli

Errico Picchiarelli (munny) wrote :

Hi,
only for your interest:
I tried to install ndiswrapper with an old version of Intel Wireless driver (newer version does't work with ndiswrapper) and put iwl3945 in blacklist.
With this driver now the speed is ok, my transfer in over ftp is about 3MBytes/s and 1.5MB/s over samba.

Errico Picchiarelli

I wonder if this might be related also to bug 183796. However, it's regarding the iwl4965 driver. . .

https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/183796/comments/11

and the upstream intel bug:

http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1669

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Errico Picchiarelli (munny) wrote :

I tried this and it's work, so the problem seems QoS related also for iwl3945.

Now the speed in my local network is reasonable but not like with NDiswrapper, now i got 1.8MB/s over ftp and 1.1MB/s over samba.

This work also with hardy kernel 2.6.24-x

I hope this can help you.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

AndreK, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11-rc5

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: needs-kernel-logs needs-upstream-testing
Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.