Ubuntu 8.04 LTS Kernel does not support VIA C3 CPU

Bug #222253 reported by Coenraad Loubser on 2008-04-26
18
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

On a clean install of Ubuntu 8.04 LTS Alternative (text), upon first boot, it terminates with the following message:

This kernel requires the following features not present on the CPU:
0:6
Please use a kernel that is compatible with your system.

I believe that a server edition of Ubuntu should support VIA C3, as it makes an ideal low-power small form-factor server.

ubuntu@ubuntu:~$ cat /proc/cpuinfo
processor : 0
vendor_id : CentaurHauls
cpu family : 6
model : 9
model name : VIA Nehemiah
stepping : 8
cpu MHz : 997.516
cache size : 64 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr cx8 sep mtrr pge cmov pat mmx fxsr sse up rng rng_en ace ace_en
bogomips : 1997.24
clflush size : 32

The VIA C3 is the one with all the security features right? I used to have that CPU for a long time and I never had a problem with it. I think you are right about the low power being a problem. On the official website for the VIA C3 it says it is run on low power. I really don't have any suggestions or things that might help your situation but I did have an experience with the VIA C3.

KGB (g-gualeni) wrote :

I have the same messagge running ubunto server in virtual box with a pentiumM (Acer Aspire 9502WSMi)

Confimed on my Pentium-M too!

$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 13
model name : Intel(R) Pentium(R) M processor 1.60GHz
stepping : 6
cpu MHz : 600.000
cache size : 2048 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe up bts est tm2
bogomips : 1199.37
clflush size : 64

Andrew Rowson (growse) wrote :

Confirmed on my Thinkpad T40 (Pentium M) as well.

SirSydom (com-sirsydom) wrote :

Same for me on a VIA EPIA PD1000 with a 1 GHz Nehemiah (CIA C3)..

SirSydom (com-sirsydom) wrote :

forgot to mention that the message for me is "0:6 0:8"..

same /proc/cpuinfo as Coenraad, only cpu MHz and bogomips slitghly differ..

Flávio Martins (xhaker) wrote :

I can confirm this bug, on a Pentium M 1.5 system.
Being unable to boot the server kernel is not something you would expect.

Research returned that this has to do with PAE and/or VT.
Knowledgeable kernel hackers should confirm this.

Tim Gardner (timg-tpi) wrote :

The -server flavour requires PAE support in the CPU.

Changed in linux:
status: Confirmed → Won't Fix
Steve Langasek (vorlon) on 2008-05-06
Changed in linux:
milestone: ubuntu-8.04.1 → none
Jaap Hoetmer (jaap.hoetmer) wrote :

Tim, good suggestion, I enabled PAE support in VirtualBox and now the 8.04 server boots properly!
Thanks.

Murray Cumming (murrayc) wrote :

How was this just closed as WONTFIX? Surely there's some way to make Ubuntu 8.04 (Hardy) run on these PCs?

I'm reopening this bug in the hope of a better explanation. If this is really a hard requirement of the Ubuntu server version then, at the least, the installer should check for it.

Tim Bishop (geodog-twjb) wrote :

I ran into the same problem with installing 8.04.1 server onto a USB disk for use with a VIA CPU for a low power, silent, personal server.

Is there a workaround or easy way to switch kernels? I'm not super technical, but if someone pointed me to directions I could probably follow them.

Thanks in advance.

I'm adding to this bug, as it refers to EPIA boards, and identically the kernel does not boot, although the message in my case is slightly different:

This kernel requires the following features not present on the CPU:

pae cx8

What happened is that I installed 8.04.1 server OK to USB disk, booted several times while adjusting the base system, and ONLY hit this error after installing dm-crypt, which did update-initramfs as part of the installation.

At the following boot after dm-crypt installation, the kernel got rendered unusable, giving the message above.

The particular EPIA motherboard here is low-power EK 8000EG Fanless Dual LAN model. It is slow (with 800 MHz Luke CPU), but otherwise nothing truly antique at all: has SATA and is RoHS compatible, i.e. couple of years max. And of course, I have three of them waiting for a new kernel...

What makes this particularly interesting is that the same dm-crypt installation could be completed OK with EPIA EN 12000G motherboard (with C7 CPU). In terms of encryption support, these two should be the same, I guess the CPU does not report something correctly at boot, and the dm-crypt package is the only one that expects those two features to be present?

As this Luke CPU may therefore actually support these features, is there a way to force them on via grub command line in menu.lst, or is Luke CPU a lost case with dm-crypt?

OK, VIA boards may be niche, but they are nice, low power boards for many interesting uses, and have run all other Ubuntu kernels so far, although this is the first time I try dm-crypt on any of them.

Robstarusa (rob-naseca) wrote :

I ran into this as well. I posted in ubuntuforums but am not too hopeful.

Multics (multicsfan) wrote :

I have made custom kernels before, but I have no idea what to say in make menuconfig to get around this on an old HP laptop. I can boot of the cd and get to a /dev/sda1 shell prompt and look around, but there appears no solution yet that I've been able to find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers