Hibernate to disk and RAM halts since change from kernel 2.6.20 to 2.6.24

Bug #219675 reported by sd2k9 on 2008-04-19
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

SInce I changed from feisty to hardy, suspend to disk is freezing.

I tried suspending via s2disk, hibernate -F /etc/hibernate/sysfs-disk.conf,
echo -n "disk" > /sys/power/state - Results are always the same.

With all modules loaded: Black screen, no suspend happening
From Console, gdm stopped: Freezes while message "Snapshotting System ..."
                                      - or freeze while "Suspending Console(s) for sysfs-disk.conf
From Console, loaded modules reduced to minimum (attached "sus.modules-loaded"): Suspend working,
But on resume it's freezing (attached "resume-freeze-screenshot")

Failing with the following kernels: 2.6.22-14.46, 2.6.24-15.26, 2.6.24-16.30

Without any further tweaks it's working for 2.6.20-16.35

sd2k9 (sd2k9) wrote :
sd2k9 (sd2k9) wrote :

Output from sudo lspci -vv

sd2k9 (sd2k9) wrote :
dotnokato (dotnokato) wrote :

Similar bug.
Every time I try hibernate or suspend it freezes while "Suspending Console(s)".
I'm using kernel version 2.6.24-16, Ubuntu x64, AMDx64 with ATI video card

Works fine on my FSC S6410 laptop, but not on my desktop (kernel 2.6.24-16, Ubuntu hardy, amd64, Nvidia):
I tried all kinds of workarounds, including uswsusp in various versions, but the machine always freezes/hangs
just before writing to disk (or before it should go to sleep, respectively). Must be a kernel bug :-(

P.S. I also tried the kernel method alternative http://www.tuxonice.net/ which suspends successfuly but has other issues.
The problem also occurs for single user mode (init S) with a minimum of modules loaded. I attach the "lspci -vv" output.

Jason Oster (parasyte) wrote :

Same problem here, after upgrade from Gutsy to Hardy. lspci.log attached.

Jason Oster (parasyte) wrote :

$ uname -a
Linux CN212409 2.6.24-17-generic #1 SMP Thu May 1 14:31:33 UTC 2008 i686 GNU/Linux

I get freeze after "Suspending console(s)" on 2.6.24-17.31, but not on -16.30
Both start and seem to hibernate/suspend just fine (power off), but resuming fails.
"Suspending consoles" is seen when resuming from hibernate. Resuming from suspend shows black screen and monitor blinks yellow light instead of green (ie. graphics card does not have active output).

Hardware: Intel Q6600, nvidia graphics (w/proprietary driver), 4G.

Status:
linux-image-2.6.24-16-generic - 2.6.24-16.30 - works
linux-image-2.6.24-17-generic - 2.6.24-17.31 - does not work.

Hannes Pahlke (hpahlke) wrote :

I've got the same bug, since I've installed Ubuntu 8.04 Hardy:
Always when I try to hibernate or suspend it freezes while "Suspending Console(s)".

The kernel-update from 2.6.24-16 to 2.6.24-17 did not solve the problem.

Before with Ubuntu 7.10 Gutsy it worked fine for me.

Hardware: HP nc6220

I'vo got the same bug too.

linux-image-2.6.24-16-generic - 2.6.24-16.30 - works
linux-image-2.6.24-17-generic - 2.6.24-17.31 - does not work.

Intel DG33TL Mother Board.

proposed-updates had kernel linux-image-2.6.24-18-generic - 2.6.24-18.32, it exhibits this same problem. I didn't say it earlier, but I see it on 64bit. Asus P5K motherboard with P35 chipset.

I think this should be confirmed now.

Changed in linux-meta:
status: New → Confirmed
Jason Oster (parasyte) wrote :

This appears to be fixed for me with linux-image-2.6.24-19-generic, 2.6.24-19.33

The bootsplash 'freezes' momentarily while resuming from hibernation, but does get into GDM after a minute or so. I still get strange video artifacts during the bootsplash, but at least the main issue is resolved.

marius (marius-gala) wrote :

I'm quite noob but I'll try to share my experience.

I updated last week from linux-server (2.6.24.16.18) to 2.6.24.18.20 and hybernate doesn't work anymore.

I used it daily, so I'm sure it was properly working before (never tried suspend to ram, anyway)

Now, it shuts down but on resume freezes on "suspending console(s)".
(just after having read the memory image, I suppose: it loads hundreds of MB from the disk
just like the screenshot rola posted some posts above, then ouputs that string)

One single time I was able to boot by pressing don't-know-what keys (I was randomly hitting the keyboard to check responsivity)
but I wasn't able to reproduce this anymore (and if I leave it alone for long long times doesn't de-freeze by itself)

I attach my "sudo lspci -vv" log, hope it helps

Fedor Isakov (fisakov) wrote :

Running Hardy x64 on a Mac Pro ("early 2008" model, ATI graphics card).

Hibernate (suspend-to-disk) used to work with kernel 2.6.24.16, then stopped working after an upgrade to 2.6.24.18 with the exact same symptoms.

Just enabled hardy-proposed repo, run the upgrade to 8.04.1, which also installed 2.6.24.19 kernel: hibernate works again.

kernel 2.6.24.19 made suspend (can't test hibernate) work for me. Tested several times over several days.
64bit Hardy, intel Q6600, 4G mem, P35 chipset in Asus motherboard.

marius (marius-gala) wrote :

UPDATE: today I updated to 2.6.24-19 and it seems to work smoothly (tested also with subsequent cycles of hibernate/resume/hibernate/resume...)

Just like for Parasyte, the "progress bar" during boot freezes momentarily (at the same point where it was stopping with previous kernel) but then goes on.

Suspend doesn't bring me back to unlock screen anymore. It works again too.

No hardware or other configuration changes since my last post. It has to be the kernel update, IMHO.

Hannes Pahlke (hpahlke) wrote :

For me Suspend to Ram and Hibernate is still not working after the Upgrade to Kernel 2.6.24-19. It always freezes while "Suspending Console(s).

I would really appreciate any help in getting this probleme solved

hara (harak-iitm) wrote :

I am running on Kubuntu KDE4. 2.26.24-19-generic kernel. Installing "uswsusp" somehow solved my problem. I do not know why it solved the problem

hara (harak-iitm) wrote :

plus do not use adept for installing uswsusp

goibhniu (cillian-deroiste) wrote :

I'm running 64bit Hardy (upgraded from Gutsy) on a Q6600 with a Asus P5N-E SLI 650i Socket 775 motherboard. uswsusp worked great on Gutsy, but I have had no luck with Hardy yet. pm-hibernate gets me the blinking cursor and the log file says that it has done all the tasks it needs to do but it just sits there. s2disk looks a lot more encouraging, seems to create the image etc. but stops when it gets to "suspending console(s)". Even though I have the logging level set to 7 I can't see where it writes this to.

I have a usb keyboard and mouse which both get turned off when I try to suspend with either method, so I have no way to shut down safely with Alt+SysRq RSEIUB. I am getting very worried about damaging my hard drive now since I have tried many variations of this (with each kernel upgrade).

When I try to hibernate I do so without gdm and X and with the nvidia module unloaded.

Is seems like a lot of people with Q6600 chips are seeing this problem. (I'll add an lspci -vv later)

lopthopman (lopthopman-ann0) wrote :

Hibernate with 2.26.24-19-generic is still broken for me. I'm glad -19 is fixing it for a couple of you all, but no go here.

This is a vanilla install of 32-bit Ubuntu 8.0.4, fully updated. Running on a Dell notebook, Latitude D610.

Ubuntu 7.10 hibernates fine on the same machine.

lopthopman (lopthopman-ann0) wrote :

Ooops... I meant 2.6.24-19-generic

suspend (mcgrew) wrote :

Yeah, suspend isn't working for me with kernel version 2.6.24-19-generic, either. With an older kernel under Gutsy, I got it working by changing POST_VIDEO=true to POST_VIDEO=false in a file called /etc/default/acpi-support. That was a different, bug, though. My present one leaves text on the screen that ends with "Suspending console(s)"

dvo (mueller8) wrote :

For all the various updates of kernel 2.6.24 so far, my machine freezes at "Suspending console(s)".
I really wonder why nobody seems to be able to detect the reason for the regression since 2.6.20.

suspend (mcgrew) wrote :

Fixed this problem yesterday by installing my internal bcm4318 wifi card, I think. My computer no longer freezes with "Suspending console(s)" on the screen, but instead suspends successfully. It won't resume afterwards, but that' s a different bug. Check your system log and you might be able to figure out what's causing this problem.

dvo (mueller8) wrote :

For Asus M2NPV-VM, nVidia GeForce 6150, I finally found the solution - hooray :-)
Simply update the BIOS (from revision 0504 to revision 1301) as recommended at
http://fixunix.com/kernel/337502-swsusp-amd-x2-64-2-6-24-regression.html
So the problem was some incompatibility of the newer kernels with the older BIOS revisions.

BTW, I still have problems with pm-utils, therefore I use acpi-support:
In /usr/lib/hal/scripts/linux/hal-system-power-hibernate-linux
replace /usr/sbin/pm-hibernate $QUIRKS
by /etc/acpi/hibernate.sh force
In /usr/lib/hal/scripts/linux/hal-system-power-suspend-linux
replace /usr/sbin/pm-suspend $QUIRKS
by /etc/acpi/sleep.sh force

dvo (mueller8) wrote :

P.S.
For Asus M2NPV-VM, nVidia GeForce 6150, I use these settings in /etc/defaul/acpi-support:
ACPI_SLEEP=true
ACPI_SLEEP_MODE=mem
SAVE_VBE_STATE=false
POST_VIDEO=false
SAVE_VIDEO_PCI_STATE=true
USE_DPMS=false

goibhniu (cillian-deroiste) wrote :

I upgraded the bios on my motherboard from 0608 to 1101 (Asus P5N-E SLI) but this alone has not resolved the issue for me (pm-hibernate still leaves me with a blinking cursor, and s2disk freezes after "Suspending to console(s)").

Ravindran K (ravindran-k) wrote :

for me suspend and hibenation are working fine except some minor issues
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/255788

I'm using an Intel DG33TL Mobo.

Srivatsa Kanchi R (srivatsak) wrote :

I am seeing this problem on Thinkpad R51; which worked on earlier kernels very well.
i running the latest kernel

Andy Whitcroft (apw) wrote :

This is not a bug in the linux-meta package, moving to the linux package.

affects: linux-meta (Ubuntu) → linux (Ubuntu)

rola, thank you for reporting this and helping make Ubuntu better. Hardy desktop reached EOL on May 12, 2011.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue on a supported release? If so, could you please provide the information following https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume ? As well, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in a supported release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

description: updated
summary: - Hibernate/Suspend to disk and RAM halts since change from kernel 2.6.20
- to 2.6.24
+ Hibernate to disk and RAM halts since change from kernel 2.6.20 to
+ 2.6.24
tags: added: hardy needs-bisect needs-upstream-testing regression-release
tags: added: hibernate resume
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers