[Hardy] webcam stopped working after last kernel update

Bug #219252 reported by Michael Doube on 2008-04-18
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cheese
Unknown
Medium
HAL
Invalid
Undecided
Unassigned
Linux
Invalid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Vaio SZ650 with VGP-VCC7 webcam, supported by the R5u870 driver (http://wiki.mediati.org/Installation). Everything worked fine during Hardy Alpha but then at Beta stage something happened and I can't use my webcam anymore. Now Hardy has been released, with broken webcam support.

I think installing the latest kernel borked it, now I can't get webcam with any program, (cheese, xawtv, Skype, camorama) -. I have rebuilt ( 'make') and reinstalled ('make install') r5u870 just in case, but it makes no difference.

I can view a raw video stream (there I am! On the screen!) by running the following, so the driver still works:

]$ gst-launch-0.10 v4l2src ! ffmpegcolorspace ! ximagesink

camorama tells me it "Could not connect to video device (/dev/video0)"
Skype cannot detect a webcam at all
cheese displays a test pattern
xawtv says this:
-------------
This is xawtv-3.95.dfsg.1, running on Linux/x86_64 (2.6.24-16-generic)
xinerama 0: 1280x800+0+0
/dev/video0 [v4l2]: no overlay support
v4l-conf had some trouble, trying to continue anyway
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-*-ledfixed-medium-r-semicondensed--39-*-*-*-c-*-*-*, -*-bitstream vera sans-medium-r-normal--39-*-*-*-*-*-*-*, -*-luxi sans-medium-r-normal--39-*-*-*-*-*-*-*, -*-*-r-normal--39-*-*-*-*-*-*-*, -*-*-*-*--39-*-*-*-*-*-*-*,*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Error: Aborting: no fontset found
-----------------

uname -a
Linux doris 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux

This is echoed into dmesg:

[ 36.921902] uvcvideo: Found UVC 1.00 device <unnamed> (05ca:183a)
[ 36.922148] uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).
[ 36.922394] uvcvideo: Failed to query (129) UVC control 1 (unit 0) : -32 (exp. 26).
[ 36.922396] uvcvideo: Failed to initialize the device (-5).
[ 36.922415] usbcore: registered new interface driver uvcvideo
[ 36.922417] USB Video Class driver (v0.1.0)
.
.
.
[ 37.378763] usbcam: registering driver r5u870 0.11.0
[ 37.378795] r5u870-0: Detected Sony VGP-VCC7
[ 37.378797] r5u870-0: requesting microcode state
[ 37.379320] r5u870-0: camera reports negative microcode state
[ 37.379322] r5u870-0: loading microcode file "r5u870_183a.fw"
[ 37.379626] wmaster0: Selected rate control algorithm 'iwl-4965-rs'
[ 37.488173] r5u870-0: enabling microcode
[ 37.488290] r5u870-0: requesting microcode version
[ 37.488406] r5u870-0: camera reports version 0111
[ 37.488410] r5u870-0: interface 1 already claimed
[ 37.488413] r5u870-0: Found format 1: YUYV (4 frames)
[ 37.488415] r5u870-0: Found resolution 1: 640x480 ival 666666 (18432000 B/s)
[ 37.488417] r5u870-0: Found resolution 2: 320x240 ival 666666 (4608000 B/s)
[ 37.488419] r5u870-0: Found resolution 3: 176x144 ival 666666 (1520640 B/s)
[ 37.488421] r5u870-0: Found resolution 4: 160x120 ival 666666 (1152000 B/s)
[ 37.489525] r5u870-0: Found UVC control Hue [-180,180] def:0 info:03
[ 37.491783] r5u870-0: Added 8 WDM controls
[ 37.491785] r5u870-0: control Hue/uvc 06 <= 0
[ 37.491894] r5u870-0: control White Balance Red <= 127 [capture off]
[ 37.491895] r5u870-0: control White Balance Green <= 127 [capture off]
[ 37.491897] r5u870-0: control White Balance Blue <= 127 [capture off]
[ 37.491898] r5u870-0: control Auto White Balance <= 1 [capture off]
[ 37.491899] r5u870-0: control V-Flip <= 0 [capture off]
[ 37.491901] r5u870-0: control H-Flip <= 0 [capture off]
[ 37.491902] r5u870-0: control Privacy <= 0 [capture off]
[ 37.491903] r5u870-0: control Night Mode <= 0 [capture off]
[ 37.491927] r5u870-0: registered as video0
[ 37.491947] usbcore: registered new interface driver r5u870

Michael Doube (michael-doube) wrote :
Michael Doube (michael-doube) wrote :

The webcam is:
lsusb
Bus 006 Device 003: ID 05ca:183a Ricoh Co., Ltd

description: updated
Michael Doube (michael-doube) wrote :

Interestingly, when I boot into WinXP then restart (not shut down) back to Ubuntu, I get webcam function back.

description: updated
soulsurfa (soulsurfa) wrote :

i have exactly the same bug on my Sony TZ27GN.
my webcam is the same 05ca:183a.
I have been having the issue of it only being detected if i reboot from xp. which obviously i don't want to have to do. i run linux for a reason.

but I had no issues before hardy went full release. I'm sure it was working in Beta stage.

any one got any solutions so far?

is it just this cam model: 05ca:183a

Michael Doube (michael-doube) wrote :

Soulsurfa: check that your /etc/X11/xorg.conf uses EXA rather than XAA.

 Option "AccelMethod" "EXA"

I've had a strange experience with the webcam: sometimes the image works fine, other times it doesn't (see attached) when running

]$ gst-launch-0.10 v4l2src ! ffmpegcolorspace ! ximagesink

The Skype video stream is also broken when the above command is broken. Cheese works OK.

Rebooting from Gutsy or XP gives me this problem I think, which I have to do because of bug 178286

There hasn't been any recent activity in this bug report and we were wondering if this is still an issue? The Ubuntu kernel team is actively working on the upcoming Intrepid Ibex 8.10 release. If you could please test the latest Alpha release for Intrepid it would be much appreciated - http://www.ubuntu.com/testing . Please let us know your results. If the issue still exists, please also provide the appropriate debugging information as outlined at https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks in advance.

Changed in linux:
status: New → Incomplete
Michael Doube (michael-doube) wrote :

Leann

Both Skype and
]$ gst-launch-0.10 v4l2src ! ffmpegcolorspace ! ximagesink

Are working, while cheese just gives a test pattern (in Hardy 8.04.1). Will have a go with Intrepid Alpha and see what happens.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Michael Doube (michael-doube) wrote :

Hardy seems to be pretty stable now: Skype and
]$ gst-launch-0.10 v4l2src ! ffmpegcolorspace ! ximagesink

give me correct images, but cheese still just shows a test pattern. Will remove linux from this bug report and direct it at cheese instead.

Changed in linux:
status: Incomplete → Invalid
Changed in cheese:
importance: Undecided → Unknown
status: New → Unknown
Changed in cheese:
status: Unknown → Invalid
Changed in linux:
status: Invalid → In Progress
Changed in linux:
status: Unknown → Incomplete
Michael Doube (michael-doube) wrote :

According to the gnome bugzilla report, this is a bug in the r5u870 driver not making the webcam known to HAL in the correct manner. You can update your HAL info manually though, by following the instructions here:
http://bugzilla.gnome.org/show_bug.cgi?id=531835#c16

Clusty (clusty1) wrote :
Download full text (6.8 KiB)

Hey,

I still can't compile the driver (latest SVN) with ibex: 2.6.27:
---------------------------
make -C /lib/modules/2.6.27-4-generic/build M=/home/clusty/r5u870 V=0 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-4-generic'
  CC [M] /home/clusty/r5u870/usbcam/usbcam_fops.o
/home/clusty/r5u870/usbcam/usbcam_fops.c: In function ‘usbcam_v4l_ioctl’:
/home/clusty/r5u870/usbcam/usbcam_fops.c:1167: error: implicit declaration of function ‘video_usercopy’
/home/clusty/r5u870/usbcam/usbcam_fops.c:1171: error: implicit declaration of function ‘video_ioctl2’
/home/clusty/r5u870/usbcam/usbcam_fops.c:1159: warning: unused variable ‘udp’
/home/clusty/r5u870/usbcam/usbcam_fops.c: At top level:
/home/clusty/r5u870/usbcam/usbcam_fops.c:1213: error: unknown field ‘type’ specified in initializer
/home/clusty/r5u870/usbcam/usbcam_fops.c:1214: error: unknown field ‘type2’ specified in initializer
/home/clusty/r5u870/usbcam/usbcam_fops.c:1217: error: unknown field ‘vidioc_querycap’ specified in initializer
/home/clusty/r5u870/usbcam/usbcam_fops.c:1217: warning: initialization makes integer from pointer without a cast
/home/clusty/r5u870/usbcam/usbcam_fops.c:1218: error: unknown field ‘vidioc_enum_fmt_cap’ specified in initializer
/home/clusty/r5u870/usbcam/usbcam_fops.c:1218: warning: initialization makes integer from pointer without a cast
/home/clusty/r5u870/usbcam/usbcam_fops.c:1219: error: unknown field ‘vidioc_g_fmt_cap’ specified in initializer
/home/clusty/r5u870/usbcam/usbcam_fops.c:1219: warning: initialization makes integer from pointer without a cast
/home/clusty/r5u870/usbcam/usbcam_fops.c:1219: error: initializer element is not computable at load time
/home/clusty/r5u870/usbcam/usbcam_fops.c:1219: error: (near initialization for ‘usbcam_videodev_template.tvnorms’)
/home/clusty/r5u870/usbcam/usbcam_fops.c:1220: error: unknown field ‘vidioc_s_fmt_cap’ specified in initializer
/home/clusty/r5u870/usbcam/usbcam_fops.c:1220: warning: initialization makes integer from pointer without a cast
/home/clusty/r5u870/usbcam/usbcam_fops.c:1220: error: initializer element is not computable at load time
/home/clusty/r5u870/usbcam/usbcam_fops.c:1220: error: (near initialization for ‘usbcam_videodev_template.current_norm’)
/home/clusty/r5u870/usbcam/usbcam_fops.c:1221: error: unknown field ‘vidioc_try_fmt_cap’ specified in initializer
/home/clusty/r5u870/usbcam/usbcam_fops.c:1221: warning: initialization from incompatible pointer type
/home/clusty/r5u870/usbcam/usbcam_fops.c:1222: error: unknown field ‘vidioc_reqbufs’ specified in initializer
/home/clusty/r5u870/usbcam/usbcam_fops.c:1222: warning: initialization from incompatible pointer type
/home/clusty/r5u870/usbcam/usbcam_fops.c:1223: error: unknown field ‘vidioc_querybuf’ specified in initializer
/home/clusty/r5u870/usbcam/usbcam_fops.c:1224: error: unknown field ‘vidioc_qbuf’ specified in initializer
/home/clusty/r5u870/usbcam/usbcam_fops.c:1224: warning: initialization makes integer from pointer without a cast
/home/clusty/r5u870/usbcam/usbcam_fops.c:1225: error: unknown field ‘vidioc_dqbuf’ specified in initializer
/home/clusty/r5u870/usbcam/usbcam_fops.c:1225: warning: missing braces ar...

Read more...

Michael Doube (michael-doube) wrote :

Clusty

Try filing a bug on the r5u870 bug report page
http://bugs.mediati.org/r5u870/

mn.matrix (mn-matrix) wrote :

I have same issue with Intrepid on VAIO-FZ160E laptop. I have dual boot with Vista and Intrepid. Right after fresh install, my camera work fine. But after a few reboots, once in a while embedded (motion eye) camera stopped working at Cheese or Skype. It gave "No Camera found" and /dev/video0 is missing.

Even though I can always see Ricoh driver in my lsusb listing. I rebooted several times but did not work. BUT, interestingly, if I reboot to Windows Vista and come back to Intrepid my camera started working.

$ lsusb
Bus 003 Device 002: ID 05ca:1837 Ricoh Co., Ltd
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 047d:1048 Kensington
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

$uname -a
Linux mizzima 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i686 GNU/Linux
( this is the information right after I installed linux-backports-modules-intrepid package today)

Andres Mujica (andres.mujica) wrote :

Hi, it seems that the r5u870 module works up to 2.6.24

So there's an alternate procedure to make it work, it consists on loading the firmware and using it with the uvcvideo driver.

http://www.bitbucket.org/ahixon/r5u87x/

Follow this post:

http://ubuntu-virginia.ubuntuforums.org/showpost.php?p=6111718&postcount=9

or here:

http://lists.mediati.org/archives/r5u870-list/2008-September/000053.html

please note that it's not the ideal solution, this should be handled by hal (probably) but in the meantime would work for you.

Andres Mujica (andres.mujica) wrote :

this is the package in question.

Cédric Vivier (cedricv) wrote :

I've tried r5u87x on a Vaio SZ75, it loads and correctly detects and shows the camera in both lsusb and cheese....
BUT... the output is completely garbled (where there was no problem with the r5u870 module).

Does other Vaio owner have the same issue with r5870x?

Andres Mujica (andres.mujica) wrote :

Hi, anyone of the reports could confirm if this is still an issue with intrepid fully updated??

There's a PPA maintened by TJ with a r5u87x DKMS module, probably you should give it a try. BUT please take into account that this should be done at your own risk, so please be sure of what you're doing.

Also there's a Nees Packaging BUG that probaly should be linked against this bug also.

These are the url's that apply:

TJ's comment with instructions for enabling PPA repo (PLEASE BE SURE TO DISABLE AFTER INSTALLING PACKAGE)

http://ubuntuforums.org/showpost.php?p=5705645&postcount=13

TJ's PPA
https://edge.launchpad.net/~intuitivenipple/+archive

TJ's VAIO efforts:
http://ubuntuforums.org/showthread.php?t=465491

Needs Packaging Bug
https://bugs.edge.launchpad.net/ubuntu/+bug/120434

thanks for your help

Andres Mujica (andres.mujica) wrote :

Also, if the PPA is not working probably you should follow this instructions

https://bugs.edge.launchpad.net/ubuntu/+bug/120434/comments/31

as this module have changed and there's no official package yet (until the bug #120434) is solved.

sorry.

Andres Mujica (andres.mujica) wrote :

HAL is not really involved here (it seems is up to the driver to use HAL and the program to query HAL)

Changed in hal:
status: New → Invalid
Changed in r5u87x:
status: Unknown → Incomplete
Andres Mujica (andres.mujica) wrote :

Hi all, we need some testers for the latest svn from http://svn.mediati.org/svn/r5u870/trunk/ as the revision 109 solves the issues presented with the compilation under 2.6.27 kernel.

Please post your results here.

Thanks

Changed in linux:
status: In Progress → Incomplete
Changed in r5u87x:
status: Incomplete → Fix Released
Michael Doube (michael-doube) wrote :

r5u870 revision 109 compiles on 2.6.27-10 (Intrepid) but to get the camera to initialise you have to run programs with root privileges, e.g:

]$ sudo gst-launch-0.10 v4l2src ! ffmpegcolorspace ! ximagesink

Running as an ordinary user gives this error:

Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Could not open device "/dev/video0" for reading and writing.
Additional debug info:
v4l2_calls.c(477): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src0:
system error: Permission denied
Setting pipeline to NULL ...
FREEING pipeline ...

/dev/video0 permissions are:
crw-rw---- 1 root video 81, 0 2008-12-16 10:31 /dev/video0

Michael Doube (michael-doube) wrote :

A similar permissions error happens with xawtv:

intrepiduser@doris:~$ xawtv
This is xawtv-3.95.dfsg.1, running on Linux/x86_64 (2.6.27-10-generic)
xinerama 0: 1280x800+0+0
/dev/video0 [v4l2]: no overlay support
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video0: Permission denied
v4l2: open /dev/video0: Permission denied
v4l: open /dev/video0: Permission denied
no video grabber device available

Check that the user is part of video group, if not add it to that group

 (it should be by default, if not maybe is another bug..)

Michael Doube (michael-doube) wrote :

Ah, yes. I added video permissions to intrepiduser and also created a new unprivileged user and video is working for both. Strange, because intrepiduser was a testing user that I set up during installation, and should have full permissions.

Michael Doube (michael-doube) wrote :

Andres, r5u870 revision 109 fails to compile on Hardy, see attached output from make.

on ubuntu 9.04 beta with i386 archithecture same problem , a few days ago i can use my webcam, but after last upgrade, the webcam left to work,

gstreamer-propieters say

gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
gstreamer-properties-Message: Error running pipeline 'Video for Linux 2 (v4l2)': No se puede identificar el dispositivo «/dev/video0». [v4l2_calls.c(463): gst_v4l2_open (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src3:
system error: No existe el fichero ó directorio]

Andres Mujica (andres.mujica) wrote :

@Michael, just tested at Jaunty and it compiles fine and the module can be loaded. I cannot test if the webcam actually works as i don't have the hardware.

I tried with Hardy and you're right is not compiling there.

However, as this module is deprecated i'll suggest to check the bug #120434 as it already includes a package for using this webcam with uvcvideo and the userland tools developed by Alexander.

Meanwhile i'm marking this as fix commited, i must say that is not clear if this would ever make it into Ubuntu as explained at the mentioned bug.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux:
importance: Unknown → Undecided
status: Incomplete → New
status: New → Invalid
Andres Mujica (andres.mujica) wrote :

sorry, i mean mark as won't fix for Hardy as the module is deprecated. It compiles at intrepid and Jaunty at least.

Changed in linux (Ubuntu):
status: Invalid → Won't Fix
Changed in cheese:
importance: Unknown → Medium
status: Invalid → Unknown
Tino Meinen (a-t-meinen) wrote :

I have a Sony VIAO laptop here with a webcam with device ID 05ca:1830.
This is a Ricoh camera which needs the old r5u870 driver because this is a WDM type camera not a UVC one.

Compiling the driver no longer works on Ubunty Natty 10.04 because the 2.6.38 kernel has dropped videodev.h
You get this error when compiling:
ricoh-webcam-r5u870-0.11.6/r5u870/usbcam/usbcam.h:38:28: fatal error: linux/videodev.h: No such file or directory

In this thread
http://<email address hidden>/msg27519.html
it is suggested one could copy the (needed) contents of videodev.h over to libv4l1.h

Can anyone explain how to do that?
I'd like to get this webcam going under Natty.

Tino Meinen (a-t-meinen) wrote :

Thanks nmathew but these links are all about 0x183a (Sony Visual Communication Camera VGP-VCC7) which is a UVC camera and can use the new r5u87x driver.

I'm dealing with 0x1830 (Sony Visual Communication Camera VGP-VCC2) which is a WDM type and must use the older r5u870 driver.
It's a different beast.

nobin (nobin-mathew) wrote :

You can use the driver attached.

Steps to load the driver

#make
#make install KDIR=/path/to/kernel

or you can see the readme in the attached driver.

Attached driver has some fixes for usb buffer alloc API changes.

nobin (nobin-mathew) wrote :

Both the tool and driver says:

This driver supports the following OEM webcams:

05ca:1810 HP Pavilion Webcam - UVC
05ca:1830 Sony Visual Communication Camera VGP-VCC2 (for VAIO SZ)---> I think this is yours
05ca:1832 Sony Visual Communication Camera VGP-VCC3 (for VAIO UX)
05ca:1833 Sony Visual Communication Camera VGP-VCC2 (for VAIO AR1)
05ca:1834 Sony Visual Communication Camera VGP-VCC2 (for VAIO AR2)
05ca:1835 Sony Visual Communication Camera VGP-VCC5 (for VAIO SZ)
05ca:1836 Sony Visual Communication Camera VGP-VCC4 (for VAIO FE)
05ca:1837 Sony Visual Communication Camera VGP-VCC4 (for VAIO FZ)
05ca:1839 Sony Visual Communication Camera VGP-VCC6 (for VAIO CR)
05ca:183a Sony Visual Communication Camera VGP-VCC7 (for VAIO SZ)
05ca:183b Sony Visual Communication Camera VGP-VCC8 (for VAIO FZ)
05ca:1870 HP Pavilion Webcam / HP Webcam 1000

nobin (nobin-mathew) wrote :

Install libv4l for v4l1 support over v4l2.

Tino Meinen (a-t-meinen) wrote :

Thanks for looking into this nmathew.
The problem is when I want to compile the driver on ubuntu Natty 11.04 I get a compile error:

r5u870/usbcam/usbcam.h:38:28: fatal error: linux/videodev.h: No such file or directory

this is because videodev.h is no longer included in the 2.6.38 header files.
This problem was not in Maverick because the 2.6.35 header files still had those header files included.

nobin (nobin-mathew) wrote :

Oh, I use Maverik.

nobin (nobin-mathew) wrote :

will applications use /usr/include/linux/videodev.h, if not can't we include the old videodev.h with the driver.

nobin (nobin-mathew) wrote :

see this driver, this should compile in Natty,
I think there is only minor difference between Maverik and natty /usr/include/linux/videodev2.h

See this link . I tried it on Maverick and Natty their respective owner kernels and it works. Greetings.

http://www.nosinmiubuntu.com/2010/10/webcam-r5u870-en-ubuntu-1010-maverick.html

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.