Only one core working on dual core CPU

Bug #215785 reported by Adam Bagnall
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Vishal Rao

Bug Description

Binary package hint: linux-image-2.6.24-15-generic

This bug was present in Gutsy, I upgraded to Hardy to see if it had been resolved but it is still present. I have an AMD Athlon64 x2 5600+, which worked fine on my previous motherboard. I changed my motherboard to an ECS AMD690GM-M2 and now only one core works in Ubuntu, both cores are recognised in Windows. I have tried various things found via google. Booting with noapic makes no difference. acpi=off and acpi=ht result in an unbootable system. Disabling HPET in the bios makes no difference.

Revision history for this message
Adam Bagnall (bagnaj97) wrote :
Revision history for this message
Adam Bagnall (bagnaj97) wrote :
Revision history for this message
Adam Bagnall (bagnaj97) wrote :
Revision history for this message
Adam Bagnall (bagnaj97) wrote :

Under Hardy 64bit daily (11/04/08) both cores are detected, still an issue on 32bit.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Revision history for this message
Adam Bagnall (bagnaj97) wrote :

I've tested this evening with Intrepid daily-live 04-Aug-08 and both cores were working under 32bit. The problem still exists with the latest Hardy kernel.

Revision history for this message
Vishal Rao (vishalrao) wrote :

Same problem here with Intrepid Alpha 5 (amd64 kernel .27-2.3). Was not a problem with Hardy amd64 (latest) or Intrepid Alpha 4 previous amd64 kernel.

Hardware is HP Pavilion tx1302au Tablet PC with AMD Turion 64 TL-58 dual core 1.9 ghz CPU with nVidia Go 6150 motherboard.

I need to specify the "nolapic" option to get this to boot on Intrepid Alpha 5 with latest updates. gnome system monitor also shows single cpu.

Will attach dmesg, lspci and cpuinfo...

Revision history for this message
Vishal Rao (vishalrao) wrote :
Revision history for this message
Vishal Rao (vishalrao) wrote :
Vishal Rao (vishalrao)
Changed in linux:
status: New → Confirmed
Vishal Rao (vishalrao)
Changed in linux:
status: Confirmed → New
Revision history for this message
Vishal Rao (vishalrao) wrote :

Updated Ibex today and the issue no longer exists for me. I also don't need to specify the nolapic option at boot time either.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Thanks for the update. Adam, can you comment if this is fixed for you with the most recent Intrepid updates? Thanks.

Changed in linux:
status: New → Incomplete
Revision history for this message
Adam Bagnall (bagnaj97) wrote :

As stated on 2008-09-05 this is now fixed in Intrepid (both i686 and amd64). Hardy i386 still has the issue even with the latest updates.

Revision history for this message
Paulo Dias (paulo-miguel-dias) wrote :

I'm experiencing the same problem with intrepid beta 1 and a turion tl-60 x2.. i need to activate nolapic in order to be able to suspend/resume (if i dont, it just hangs), BUT i loose a cpu. i suspect the resume/suspend failure is a smp issue, since it works fine with one cpu disable via nolapic.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

@Paulo, care to open a new bug report as it seems you have different hardware than the orignal bug reporter and Adam has commented this is resolved for Intrepid.

Changed in linux:
status: Incomplete → Fix Released
Revision history for this message
Trey Blancher (ectospasm) wrote :

I get this problem about 85% of the time in Intrepid, and I haven't narrowed down the magic that brings up all four cores. It worked flawlessly for weeks, and downgrading to 2.6.27-9 from 2.6.27-11 didn't bring back all of my cores.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers