Laptop fan turns off and then stays off

Bug #211980 reported by Sam Freer on 2008-04-04
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu Hardy 8.04 2.6.25-15-generic

When I boot up my laptop the fan is running and the temperature is low (less than 40). After a while the temperature rises to about 55 and the fan turns off, the temp continues to rise until the CPU throttles down but the fan never comes on again.

I have the the noapic option set in menu.lst.

My /proc/acpi/thermal_zone/THRM/trip_points is set as:

critical (S5): 105 C
passive: 79 C: tc1=3 tc2=1 tsp=80 devices=CPU0
active[0]: 65 C: devices=FAN0
active[1]: 55 C: devices=FAN1

This was not an issue for me in 7.10.

Sam Freer (samfreer) wrote :

acpi details as follows:

acpi -t

Battery 1: charging, 88%, 00:19:08 until charged
Thermal 1: passive active[0], 77.0 degrees C

Sam Freer (samfreer) wrote :

syslog details from bootup

Sam Freer (samfreer) wrote :

My laptop is a Fujitsu Amilio L1310G

David Rando (david-rando) wrote :

I can confirm this problem too, exactly the same. Reported on https://bugs.launchpad.net/ubuntu/+bug/211980 but no solution (yet)

Sam Freer (samfreer) wrote :

I am now using the Hardy Release Candidate and this is still an issue. I appreciate that this problem may be only affecting a few people but for me it means that I can only use Ubuntu for 5-10 minutes before the laptop overheats and locks up.

akamuza (akamuza) wrote :

exactly the same problem.
using Ubuntu 8.04

with 7.10 - everything was fine.

laptop: Fujitsu Amilo L1310G

David Rando (david-rando) wrote :

I've just compiled 2.6.25 from kernel.org too, and the regression is still there, same acpi fan problem. Also, treid with acpi debug, dsdt with _WAK warning fixed.....

I think i've read something about this on the acpi-devel mailing list about some kind of bug, but don't know exactly. I've contacted with fujitsu on e-mail about some kind of bios update, but i doubt they'll reply me, or give me any new version.

Hope anyone knows what to do.

David Rando (david-rando) wrote :

Well, searching and searching for a solution I missed the main place to search: kernel list. And this was reported on 2005.

http://bugzilla.kernel.org/show_bug.cgi?id=5289

Quoting from there:
The issue is that ACPI first tries to read device power state from _PSC method,
if this is unsuccessful, it evaluates device state from the power resources,
defined for this device. In your DSDT the _PSC is defined with 0x00 value, and
never being updated later, so the device state is always reported ON.
With this patch the things should work as expected.

I have it running right now with the dsdt patched, and working great so far. Temperature is a bit higher but stable, and the fan are reported, at least, correctly.

I've attached the DSDT file that i'm actually running on. I'll confirm after a few days of work if this resolves the problem. Maybe it's a clue for some other people with other laptops having the same one.

Just be sure to put it on /etc/initramfs.... folder in uppercase (DSDT.aml) , use the update-initramfs option and use the acpi_no_auto_ssdt on kernel load, as described in the method to use custom dsdt files from the wiki.

David Rando (david-rando) wrote :

compiled aml file

Sam Freer (samfreer) wrote :

Following Evermann's guide the problem has now been fixed

1.Download the dsdt.aml file to my desktop
2.Using a terminal session copy and rename the file to /etc/initramfs-tools/DSDT.aml

cd Desktop
sudo cp dsdt.aml /etc/initramfs-tools/DSDT.aml

3.Navigate to the folder to check the new file

cd /etc/initramfs-tools/
ls -l

drwxr-xr-x 2 root root 4096 2008-04-16 16:23 conf.d
-rw-r--r-- 1 root root 17552 2008-04-28 20:29 DSDT.aml
drwxr-xr-x 2 root root 4096 2008-03-18 17:22 hooks
-rw-r--r-- 1 root root 801 2006-12-21 23:32 initramfs.conf
-rw-r--r-- 1 root root 191 2008-03-19 21:16 modules
drwxr-xr-x 11 root root 4096 2008-03-19 21:15 scripts
-rw-r--r-- 1 root root 316 2006-12-21 23:32 update-initramfs.conf

4.Update existing initramfs

sudo update-initramfs-tools -u

5.Add the acpi_no_auto_ssdt option to the kernal load in /boot/grub/menu.lst

emort (emort123) wrote :

u make it sound so easy... being fresh to this I don't get where the "kernal load" is... could you pleas post a cp of what i looks like?

5.Add the acpi_no_auto_ssdt option to the kernal load in /boot/grub/menu.lst

Hi Mate

You should have an entry in /boot/grub/menu.lst that looks like

title Ubuntu 8.04.1, kernel 2.6.24-19-generic
root (hd0,5)
kernel /boot/vmlinuz-2.6.24-19-generic
root=UUID=5388024c-8876-48dd-bd36-33d1aff81ef6 ro quiet splash
initrd /boot/initrd.img-2.6.24-19-generic
quiet

You just need to add acpi_no_auto_ssdt to the end of the line that
begins with 'kernel'

Sam

emort wrote:
> u make it sound so easy... being fresh to this I don't get where the
> "kernal load" is... could you pleas post a cp of what i looks like?
>
> 5.Add the acpi_no_auto_ssdt option to the kernal load in
> /boot/grub/menu.lst
>
>

ohme (ohme) wrote :

had a similar problem on a lg p1 laptop (ubuntu 8.04), and followed the advices (copied the dsdt.aml,sudo update-initramfs -u ,changed menu.lst). now I cannot even boot. it is stuck saying "starting up" ....

I tried to undo the changes gradualy (removed the changes from menu.lst -> no changes, removed dsdt.aml -> still no change).

so now I'm logging to an older kernel (2.6.22-15-generic)

what can I do to
1. undo the update-initramfs.
2. solve the fan problem
???

Nick Ellery (nick.ellery) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information.

Please include the information requested at https://wiki.ubuntu.com/DebuggingACPI as separate attachments.

Changed in linux:
status: Confirmed → Incomplete

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Sam Freer (samfreer) wrote :

This is still a problem in 8.10 Alpha 5

Thanks Sam,

Can you attach an updated dmesg output for the newer 2.6.27 kernel? Thanks.

Shawn vega (svega85-gmail) wrote :

hi I think i have the same problem because the fan stays on untill the computer gets hot then it just turns on and off.
anyways, here is my dmesg output

Changed in linux:
status: Incomplete → Confirmed
David Rando (david-rando) wrote :

This is going to be hard to resolve. Ḿost of the time is caused by an incorrect dsdt table generated by the kernel, mostly because to bad programmed bios, or bios too focused on microsoft windows.

In my case, as i posted, the l1310g fujitsu amilo has it and could resolved it loading a fixed dsdt table.

So first, try to see if you have an updated bios for your motherboard/laptop. If not, you'll have to add it manually (maybe in 2.6.27 is resolved, or will be on 2.6.28.... i don't know how the kernel is programmed on this, or how is treated to fix that way to handle the generation of the dsdt table, to be fixed because of this).

Google it to see if someone fixed the table for your motherboard/laptop, and, btw, if you fill a wiki page about it on wiki.ubuntu.com you'll help the others to resolve it ;-)

Shawn vega (svega85-gmail) wrote :

ok updating my bios fixed it for me

prettl (prettl-zsolt) wrote :

I think I’ve the same problem with Karmic: lately my laptop turn off its fan and never again turns it on until I restart Karmic. When I get this fan problem my laptop’s temperature is about 60-70 °C when it’s idle and 80-90 °C when it’s working.

Kernel: 2.6.31-14-generic #48-Ubuntu

I got this message in messages section about the error:

Oct 28 20:45:26 Asi kernel: [10896.902349] ACPI Exception: AE_TIME, Returned by Handler for [EmbeddedControl] 20090521 evregion-424
Oct 28 20:45:26 Asi kernel: [10896.902362] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_.FNCT] (Node f7018768), AE_TIME
Oct 28 20:45:26 Asi kernel: [10896.902412] ACPI Error (psparse-0537): Method parse/execution failed [\_TZ_.TCHG] (Node f7019e40), AE_TIME
Oct 28 20:45:26 Asi kernel: [10896.902455] ACPI Error (psparse-0537): Method parse/execution failed [\TZEV] (Node f7019e58), AE_TIME
Oct 28 20:45:26 Asi kernel: [10896.902492] ACPI Error (psparse-0537): Method parse/execution failed [\_GPE._L00] (Node f701d4c8), AE_TIME
Oct 28 20:45:26 Asi kernel: [10896.902536] ACPI Exception: AE_TIME, while evaluating GPE method [_L00] 20090521 evgpe-568

I found somewhere that this is a kernel bug which is corrected from 2.6.32-rc3 version and I'm wondering what I should do. I meant that I should wait because the bug would be corrected in the 2.6.31 kernel too, or I should go back to Jaunty, or I should use 2.6.32 kernel with karmic (by the way I don’t know how could I do this step).

David Rando (david-rando) wrote :

For me, on the fujitsu l1310g, using the acpi.power_nocheck=1 resolves all the problem in karmic and jaunty.

And with karmic, the problems with the sound because of the ati x200 chip is also gone (no more sound and usb problems).

Sam Freer, thank you for reporting this and helping make Ubuntu better. Hardy desktop reached EOL on May 12, 2011.
Please see this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We were wondering if this is still an issue on a supported release? If so, can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in a supported release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: hardy needs-bisect needs-upstream-testing regression-release
tags: added: intrepid
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.