Ubuntu

wrong ata device detected (Hardy Heron 2.6.24-15 & 16)

Reported by dino99 on 2008-04-03
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I'm using an Asus mobo P5wdh with c2d, Hardy Heron 2.6.24-14 (same thing with 24-15 / sysinfo 0.7 identify an other mobo than mine )
The trouble is when booting: a wrong device is detected corresponding in fact (found similar subject on google) to one of the Jmicron / Silicon chipset on the mobo.
So, booting is very long and i need to add irqpoll into grub.

Messages are: - (initramfs) 228.001986 ata4 s RST failed error 16
                        - hdio_get_identity failed for /dev/.tmp-8-16
                        - idm_validate_table disk read failed
                        - device is on Dma blacklist, disabling Dma

This mobo (and P5 asus family) is not very recent (2006/06) but frequently used by Linux community, and all bios or kernel updates have not solved the hardware detection. So , i wonder if some words (without disabling multi-cores cpu) could be adding into grub or some script to blacklist this "wrong device"

dino99 (9d9) wrote :
dino99 (9d9) wrote :
dino99 (9d9) wrote :
dino99 (9d9) wrote :
dino99 (9d9) wrote :
dino99 (9d9) wrote :
dino99 (9d9) wrote :
description: updated
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux the kernel for Hardy Heron.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
dino99 (9d9) wrote :
dino99 (9d9) wrote :
dino99 (9d9) wrote :

some news about that virtual device ata4 found after googling

this mobo p5wdh have module 975x (ich7r);
there are 3 sata avaliable: sata1, sata3, sata4 to plug hardware.
Sata2 is hired for raid with Sil4723 chipset: this one is identified as ata4 when i'm booting.

So, we need to find a way to blacklist this Sil4723 chipset as an ata device.

At present time, i only can boot if i add irqpoll & noprobe=ata4 in grub

dino99 (9d9) wrote :

Since LTS release, i use ahci mode in bios (and tweak xp to work with (dualboot)),
Now, that chipset is no more recognized as an ata device

dino99 (9d9) wrote :

Strange things found in previous dmesg.log

 PCI quirk: region 0800-087f claimed by ICH6 ACPI/GPIO/TCO
 PCI quirk: region 0480-04bf claimed by ICH6 GPIO

As you can see, ICH6 deal with PCI: my mobo have i975x chipset , that mean ICH7R, not ICH6 !!!

There is something wrong with hardware detection: look at previous log (dmidecode, lspci, ...)

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

dino99 (9d9) wrote :

well, since last kernel 2.6.27-7, detection of ata devices is ok.

so , it's no more a problem for me !!!

Thanks for the update dino99. Glad to hear this appears to be resolved. I'm setting this to Fix Released per your last comment. Thanks.

Changed in linux:
status: Triaged → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers