[breezy] usb mouse displays error on console during boot

Bug #20773 reported by Daniel Robitaille on 2005-09-02
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Ben Collins

Bug Description

If I boot my laptop with an external usb mouse connected (a logitech optical
mouse), one of the first thing that shows up on the console during the boot is
this error:

usb 1-2: device not accepting address 2, error -71

The same error is also in the output of dmesg:
[4294673.304000] usb 1-2: device not accepting address 2, error -71
[4294673.823000] usb 1-2: new low speed USB device using uhci_hcd and address 4
[4294675.033000] usbcore: registered new driver hiddev
[4294675.050000] input: USB HID v1.10 Mouse [Logitech Optical USB Mouse] on
usb-0000:00:1d.0-2
[4294675.050000] usbcore: registered new driver usbhid
[4294675.050000] drivers/usb/input/hid-core.c: v2.01:USB HID core driver

While the error appears harmless (the mouse works, except for the scroll wheel,
bug #20771), an error is not the nicest/user friendly thing to display on the
console during a boot.

Matt Zimmerman (mdz) wrote :

Try the suggestions at:

https://wiki.ubuntu.com/DebuggingIRQProblems

Raising severity since usually this does indicate a misbehaviour

Daniel Robitaille (robitaille) wrote :

I have tried the 4 suggestions in that wiki page. noapic, pci=noacpi and
acpi=off still show that error on the console. The laptop doesn't boot with
nolapic: I get the error IOAPIC[0]:invalid reference to irq0

No other external devices are connected beside the usb mouse.

I've got this problem, too.

I'm using a Logitech Mouseman Plus (actually the first model that had a scroll
wheel) on a Dell Latitude X1.

Same error, only on "USB 1-1".

Some more testing:

First, when booting without mouse, the errors is gone.

Second, I tried my Microsoft Optical Mouse instead of the Logitech Mouseman, and
the error appears with it, too.

I got the same problem "usb 1-2: device not accepting address 2, error
-71".Though I'm not on a laptop and my usb devices is a HP photosmart 7350 and a
bluetooth.
Never had trouble with them in Warty and hoary

Ben Collins (ben-collins) wrote :

Personally, I think if things work, the messages aren't really that important, but:

If possible, please upgrade to Dapper's 2.6.15-7 kernel. If you do not want to
upgrade to Dapper, then you can also wait for the Dapper Flight 2 CD's, which
are due out within the next few days.

Let me know if this bug still exists with this kernel.

Daniel Robitaille (robitaille) wrote :

The error message doesn't appear when using 2.6.15-7. thanks.

I can't test this with Flight 2, because of this bug:

http://bugzilla.ubuntu.com/show_bug.cgi?id=20694

Ben Collins (ben-collins) wrote :

(In reply to comment #8)
> I can't test this with Flight 2, because of this bug:
>
> http://bugzilla.ubuntu.com/show_bug.cgi?id=20694

Yes, you can. You can check the dmesg output to see if the error is in there.

Ok, it does not appear on my machine either. Thanks.

I'm sorry I have to re-open this bug. The error still appears during the boot process, at the very top of the screen. It does not appear in "dmesg" output though. Also, I have changed my mouse in the meantime, to a Logitech G5. The bug does not seem to depend on the mouse model used.

Changed in linux-source-2.6.15:
status: Fix Released → Confirmed

I should have added to my last comment: Dapper final.

André Barmasse (barmassus) wrote :

This bug is confirmed (and therefore still exists) with Feisty Fawn Beta on my Sony Vaio VGN-FS195VP with a Logitech M-UV94 USB mouse. Booting without the mouse attached on the USB port silences the message. Maybe it has something to do with the speed of the USB port or the fact that the mouse is an optical one? I have no clue! So it is just an rather annoying message from the kernel - but it does neither slow down the boot process or disable the mouse.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Dmitriy Altuhov (altuhov.su) wrote :

I can Confirm.
my kernel: 2.6.27-2-generic #1 SMP
Mouse: USB A4Tech SWOP-80
Notebook Mitac 8640

After upgrading to 2.6.27 kernel my USB mouse not working in two of 4 USB-ports.
For example.. connecting USB mouse to usb-port #1:
# lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

No mouse!

Connecting mouse to usb-port #2:
# lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 022: ID 09da:000a A4 Tech Co., Ltd Port Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Mouse found and working!

But usb-port #3 is the same as port #1 (mouse not working) and usb-port #4 is the same as #4 (mouse working)

And if I bootup with mouse connected to ports #1 or #3 i see some USB errors and mouse not working..

Dmitriy Altuhov (altuhov.su) wrote :

After update... mouse is working an any USB-port!
Great!

Kernel is the same 2.6.27-2-generic #1 SMP, but was updated glibc, cpp, libstdc+ and many other... maybe this helps me?

Right now i don't have problem, that i wrote upper...

Dmitriy Altuhov (altuhov.su) wrote :

Addon to my prevous post:

Mouse is working in ports 1 and 3 only if i connect other usb-device at usb-ports 2 or 4

Why that?

This bug report was marked as Confirmed a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Przemek K. (azrael) wrote :

This bug hasn't seen any real activity in a few years. The releases it was confirmed on are EOL now.
Dmitriy's issue is a separate issue, and it's most probably a hardware issue.
Dmitriy: if you are still experiencing your issue please verify it is not a hardware bug - check if it works the same in Windows or any other OS, and test if it still happens on the latest Ubuntu version.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
status: Fix Released → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.