Add additional Mediatek MT7921 WiFi/BT device IDs

Bug #1937004 reported by You-Sheng Yang
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
You-Sheng Yang
Focal
Undecided
Unassigned
Impish
Undecided
You-Sheng Yang
linux-oem-5.13 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Impish
Undecided
Unassigned

Bug Description

[SRU Justification]

[Impact]

Some Mediatek MT7921 Bluetooth doesn't work out of box.

[Fix]

One ID for Lite-On was included in upstream, but we need two additional
more from different vendors.

[Test Case]

With firmware from bug 1936452, this will bring up MT7921 Bluetooth.
Check BD address from output of `hciconfig`.

[Where problems could occur]

This brings up new devices that wasn't working. After being up and
running, we may face some other runtime issue, e.g. power consumption.

========== original bug description ==========

Mediatek MT7921 has been added to mainline kernel & firmware. Firmware part is being handled by bug 1936452, and WiFi fw loading failure in bug 1936790. This issue will focus on backport/add device IDs for MT7921:

  * Bus 001 Device 004: ID 0489:e0c8 Foxconn / Hon Hai Wireless_Device
  * Bus 002 Device 003: ID 13d3:3567 IMC Networks

linux$ git log --graph --oneline korg/master -- \
    drivers/bluetooth/ \
    drivers/net/wireless/mediatek/mt76/mt7921/

linux-firmware$ git log --graph --oneline korg/master -- \
    mediatek/WIFI_MT7961_patch_mcu_1_2_hdr.bin \
    mediatek/WIFI_RAM_CODE_MT7961_1.bin \
    mediatek/BT_RAM_CODE_MT7961_1_2_hdr.bin
* a7882719 linux-firmware: update frimware for mediatek bluetooth chip (MT7921)
* 2fd5139f linux-firmware: update firmware for MT7921 WiFi device to 20210612122753
* 42a66e5b linux-firmware: update firmware for MT7921 WiFi device
* 58fb90a0 linux-firmware: add frimware for mediatek bluetooth chip (MT7921)
* 391fd50d linux-firmware: add firmware for MT7921
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu27.18
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: u 1278 F.... pulseaudio
CasperMD5CheckResult: skip
Dependencies:

DistributionChannelDescriptor:
 # This is the distribution channel descriptor for the OEM CDs
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-focal-amd64-20200502-85+fossa-davos-adl+X135
DistroRelease: Ubuntu 20.04
InstallationDate: Installed on 2021-07-05 (16 days ago)
InstallationMedia: Ubuntu 20.04 "Focal" - Build amd64 LIVE Binary 20200502-05:58
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 192f:0616 Avago Technologies, Pte. ADNS-5700 Optical Mouse Controller (5-button)
 Bus 001 Device 002: ID 03f0:344a HP, Inc HP USB Slim Keyboard
 Bus 001 Device 004: ID 0489:e0c8 Foxconn / Hon Hai Wireless_Device
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Inspiron 3910
Package: linux-firmware 1.187.15+staging.9 [origin: LP-PPA-vicamo-linux-firmware-staging]
PackageArchitecture: all
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.13.0-9009-oem root=UUID=6ae05750-3063-48a4-92af-626f62ff75fc ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 5.13.0-9009.10+staging.2-oem 5.13.0
RelatedPackageVersions:
 linux-restricted-modules-5.13.0-9009-oem N/A
 linux-backports-modules-5.13.0-9009-oem N/A
 linux-firmware 1.187.15+staging.9
Tags: third-party-packages focal
Uname: Linux 5.13.0-9009-oem x86_64
UnreportableReason: This is not an official Ubuntu package. Please remove any third party package and try again.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 07/12/2021
dmi.bios.release: 0.8
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 0.8.22
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr0.8.22:bd07/12/2021:br0.8:svnDellInc.:pnInspiron3910:pvr:sku0AD3:rvnDellInc.:rn:rvr:cvnDellInc.:ct3:cvr:
dmi.product.family: OptiPlex
dmi.product.name: Inspiron 3910
dmi.product.sku: 0AD3
dmi.sys.vendor: Dell Inc.

Revision history for this message
You-Sheng Yang (vicamo) wrote :

MT7921 in Impish should be an non-issue when upgraded to kernel v5.14. Stay tuned.

Changed in linux-oem-5.13 (Ubuntu Impish):
status: New → Invalid
Changed in linux (Ubuntu Focal):
status: New → Invalid
Changed in linux (Ubuntu Impish):
status: New → Incomplete
status: Incomplete → Confirmed
Changed in linux-oem-5.13 (Ubuntu Focal):
status: New → In Progress
Changed in linux-firmware (Ubuntu Focal):
status: New → In Progress
Changed in linux-firmware (Ubuntu Impish):
status: New → In Progress
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Some firmware fixes for MT7921 are not available in linux-firmware version 1.198 forked for Impish. So fixes for impish linux-firmware will be necessary.

tags: added: oem-priority originate-from-1936882 somerville
Revision history for this message
You-Sheng Yang (vicamo) wrote :

linux-firmware part is being handled in bug 1936452. Removing from this.

no longer affects: linux-firmware (Ubuntu)
no longer affects: linux-firmware (Ubuntu Focal)
no longer affects: linux-firmware (Ubuntu Impish)
Revision history for this message
You-Sheng Yang (vicamo) wrote : AlsaInfo.txt

apport information

tags: added: apport-collected focal third-party-packages
description: updated
Revision history for this message
You-Sheng Yang (vicamo) wrote : CRDA.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : CurrentDmesg.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : IwConfig.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lspci.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lspci-vt.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lsusb-t.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : Lsusb-v.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcEnviron.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcInterrupts.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : ProcModules.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : PulseList.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : RfKill.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : UdevDb.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : WifiSyslog.txt

apport information

Revision history for this message
You-Sheng Yang (vicamo) wrote : acpidump.txt

apport information

You-Sheng Yang (vicamo)
description: updated
summary: - Support Mediatek MT7921 WiFi/BT
+ Add additional Mediatek MT7921 WiFi/BT device IDs
Revision history for this message
You-Sheng Yang (vicamo) wrote :
description: updated
Revision history for this message
You-Sheng Yang (vicamo) wrote :

Upstream 0489:e0c8 and 13d3:3567 to bluetooth-next: http://lists.infradead.org/pipermail/linux-mediatek/2021-July/027176.html

Revision history for this message
You-Sheng Yang (vicamo) wrote :
description: updated
Revision history for this message
You-Sheng Yang (vicamo) wrote :
AceLan Kao (acelankao)
Changed in linux-oem-5.13 (Ubuntu Focal):
status: In Progress → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
You-Sheng Yang (vicamo) wrote :
Changed in linux (Ubuntu Impish):
status: Confirmed → In Progress
Revision history for this message
You-Sheng Yang (vicamo) wrote :

verified linux-oem-5.13 version 5.13.0-1010.11 from focal-proposed.

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (5.6 KiB)

This bug was fixed in the package linux-oem-5.13 - 5.13.0-1010.11

---------------
linux-oem-5.13 (5.13.0-1010.11) focal; urgency=medium

  * focal/linux-oem-5.13: 5.13.0-1010.11 -proposed tracker (LP: #1937217)

  * Packaging resync (LP: #1786013)
    - [Packaging] update update.conf, follow impish

  * [SRU][OEM-5.13/U] Fix firmware reload failure of MT7921 (LP: #1936790)
    - mt76: mt7921: continue to probe driver when fw already downloaded

  * Backport support for AMD SMU statistics (LP: #1934809)
    - platform/x86: amd-pmc: Fix command completion code
    - platform/x86: amd-pmc: Fix SMU firmware reporting mechanism
    - platform/x86: amd-pmc: call dump registers only once
    - platform/x86: amd-pmc: Add support for logging SMU metrics
    - platform/x86: amd-pmc: Add support for logging s0ix counters
    - platform/x86: amd-pmc: Add support for ACPI ID AMDI0006
    - platform/x86: amd-pmc: Add new acpi id for future PMC controllers
    - platform/x86: amd-pmc: Use return code on suspend
    - platform/x86: amd-pmc: Fix missing unlock on error in amd_pmc_send_cmd()
    - platform/x86: amd-pmc: Fix undefined reference to __udivdi3

  * Skip rtcpie test in kselftests/timers if the default RTC device does not
    exist (LP: #1937991)
    - selftests: timers: rtcpie: skip test if default RTC device does not exist

  * Support AMD W6600 [1002:73E3] (LP: #1938145)
    - drm/amdgpu: add new dimgrey cavefish DID

  * Add additional Mediatek MT7921 WiFi/BT device IDs (LP: #1937004)
    - Bluetooth: btusb: Fixed too many in-token issue for Mediatek Chip.
    - Bluetooth: btusb: Add support for Lite-On Mediatek Chip
    - Bluetooth: btusb: fix memory leak
    - SAUCE: Bluetooth: btusb: Add Mediatek MT7921 support for Foxconn
    - SAUCE: Bluetooth: btusb: Add Mediatek MT7921 support for IMC Network
    - SAUCE: Bluetooth: btusb: Add support for Foxconn Mediatek Chip

  * Add new PCI MMIO based thermal driver [8086:461d] for Intel Alder Lake
    (LP: #1934741)
    - thermal/drivers/int340x/processor_thermal: Split enumeration and processing
      part
    - thermal/drivers/int340x/processor_thermal: Add PCI MMIO based thermal driver

  * On TGL platforms screen shows garbage when browsing website by scrolling
    mouse (LP: #1926579)
    - drm/i915/display: Disable PSR2 if TGL Display stepping is B1 from A0

  * Fix kernel panic caused by legacy devices on AMD platforms (LP: #1936682)
    - SAUCE: iommu/amd: Keep swiotlb enabled to ensure devices with 32bit DMA
      still work

  * Fix display output on HP hybrid GFX laptops (LP: #1936296)
    - drm/i915: Invoke another _DSM to enable MUX on HP Workstation laptops

  * Add support for AMD BCL DID (LP: #1936785)
    - SAUCE: drm/amdgpu: add another Renior DID

  * e1000e blocks the boot process when it tried to write checksum to its NVM
    (LP: #1936998)
    - SAUCE: e1000e: Do not take care about recovery NVM checksum

  * Mute/mic LEDs no function on some HP platfroms (LP: #1934878)
    - ALSA: hda/realtek: fix mute/micmute LEDs for HP ProBook 450 G8
    - ALSA: hda/realtek: fix mute/micmute LEDs for HP ProBook 445 G8
    - ALSA: hda/realtek: fix mute/micmute LEDs for HP ProBook 630 G8

  * ...

Read more...

Changed in linux-oem-5.13 (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Mario (mario156090) wrote :

What about Hiruse?

Bluetooth does not work for me, I'm using Hirsute + linux 5.14 RC6.

mario@Asus-Ubuntu:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 21.04
Release: 21.04
Codename: hirsute
mario@Asus-Ubuntu:~$

=========================================================

mario@Asus-Ubuntu:~$ inxi -nz
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp2s0 state: down mac: <filter>
  Device-2: MEDIATEK driver: mt7921e
  IF: wlp3s0 state: up mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  IF-ID-2: Pr0 state: down mac: <filter>
  IF-ID-3: virbr0 state: down mac: <filter>
  IF-ID-4: vpn0 state: down mac: N/A
mario@Asus-Ubuntu:~$
=========================================================

mario@Asus-Ubuntu:~$ hciconfig
hci0: Type: Primary Bus: USB
 BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0
 DOWN
 RX bytes:0 acl:0 sco:0 events:0 errors:0
 TX bytes:3 acl:0 sco:0 commands:1 errors:0

mario@Asus-Ubuntu:~$

======================================================
mario@Asus-Ubuntu:~$ dpkg -l linux-firmware
Deseado=desconocido(U)/Instalar/eliminaR/Purgar/retener(H)
| Estado=No/Inst/ficheros-Conf/desempaqUetado/medio-conF/medio-inst(H)/espera>
|/ Err?=(ninguno)/requiere-Reinst (Estado,Err: mayúsc.=malo)
||/ Nombre Versión Arquitectura Descripción
+++-==============-============-============-=================================
ii linux-firmware 1.197.3 all Firmware for Linux kernel drivers

Mario (mario156090)
Changed in linux (Ubuntu Impish):
status: In Progress → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.13.0-16.16

---------------
linux (5.13.0-16.16) impish; urgency=medium

  * impish/linux: 5.13.0-16.16 -proposed tracker (LP: #1942611)

  * Miscellaneous Ubuntu changes
    - [Config] update toolchain in configs

  * Miscellaneous upstream changes
    - Revert "UBUNTU: [Config] Enable CONFIG_UBSAN_BOUNDS"

 -- Andrea Righi <email address hidden> Fri, 03 Sep 2021 16:21:14 +0200

Changed in linux (Ubuntu Impish):
status: Confirmed → Fix Released
Revision history for this message
Mario (mario156090) wrote :

This bug is not solved for me.

zhenyuzhou (zhenyuzhou)
information type: Public → Public Security
information type: Public Security → Public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers