[i915] At shutdown the spinner logo disappears and a second later it comes back frozen for a while (in kernel 5.11 and later)

Bug #1923335 reported by Norbert
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
plymouth (Fedora)
Unknown
Unknown
plymouth (Ubuntu)
Medium
Daniel van Vugt

Bug Description

At shutdown the spinner logo disapear and a scond later it comes back and stay for 15sec. When I remove "splash" from the grub commandline the shutdown is fast (no extra 15 sec.). I can't find any hints in the log. It seem to happen after the log stopped.
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu62
Architecture: amd64
BootLog: Error: [Errno 13] Keine Berechtigung: '/var/log/boot.log'
CasperMD5CheckResult: unknown
CurrentDesktop: ubuntu:GNOME
DefaultPlymouth: /usr/share/plymouth/themes/bgrt/bgrt.plymouth
DistroRelease: Ubuntu 21.04
InstallationDate: Installed on 2021-01-29 (71 days ago)
InstallationMedia: Ubuntu 21.04 "Hirsute Hippo" - Alpha amd64 (20210129)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:0a2b Intel Corp. Bluetooth wireless interface
 Bus 001 Device 002: ID 0bda:568c Realtek Semiconductor Corp. Integrated Webcam HD
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Latitude 5580
Package: plymouth 0.9.5-0ubuntu3
PackageArchitecture: amd64
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.11.0-13-generic root=UUID=469b1c18-e632-4872-a47c-7b36bce081dc ro quiet splash vt.handoff=7
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.11.0-13-generic root=UUID=469b1c18-e632-4872-a47c-7b36bce081dc ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 5.11.0-13.14-generic 5.11.7
Tags: wayland-session hirsute
TextPlymouth: /usr/share/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
Uname: Linux 5.11.0-13-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/25/2020
dmi.bios.release: 1.18
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.18.2
dmi.board.name: 00C013
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.18.2:bd09/25/2020:br1.18:svnDellInc.:pnLatitude5580:pvr:rvnDellInc.:rn00C013:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.family: Latitude
dmi.product.name: Latitude 5580
dmi.product.sku: 07A8
dmi.sys.vendor: Dell Inc.

Revision history for this message
Norbert (asterix52) wrote :
description: updated
description: updated
description: updated
description: updated
Revision history for this message
Chris Guiver (guiverc) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

apport-collect 1923335

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Revision history for this message
Norbert (asterix52) wrote : CurrentDmesg.txt

apport information

tags: added: apport-collected hirsute wayland-session
description: updated
Revision history for this message
Norbert (asterix52) wrote : Dependencies.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : EtcDefaultGrub.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : HookError_ubuntu.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : Lspci.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : Lspci-vt.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : Lsusb-t.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : Lsusb-v.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : ProcEnviron.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : ProcModules.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : UdevDb.txt

apport information

Revision history for this message
Norbert (asterix52) wrote : acpidump.txt

apport information

Revision history for this message
Launchpad Janitor (janitor) wrote : Re: Longer shutdown with plymouth

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plymouth (Ubuntu):
status: New → Confirmed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Confirmed. Last time I was affected by this on a hirsute laptop, tapping escape to get out of the Plymouth animation seemed to suggest it was Snap Daemon holding everything up. But it doesn't seem to happen on my hirsute desktop.

tags: added: performance regression-release
Changed in snapd (Ubuntu):
status: New → Confirmed
summary: - Longer shutdown with plymouth
+ At shutdown the spinner logo disappears and a second later it comes back
+ frozen for a while
Changed in plymouth (Ubuntu):
importance: Undecided → Medium
Changed in snapd (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Daniel van Vugt (vanvugt) wrote : Re: At shutdown the spinner logo disappears and a second later it comes back frozen for a while

I'm still seeing this on most laptops I test impish on.

Maybe related to bug 1781889, but probably not. I think this is a new bug that started in 21.04.

tags: added: impish
Revision history for this message
Norbert (asterix52) wrote :
Revision history for this message
Norbert (asterix52) wrote :

Kernel Bug: https://bugzilla.kernel.org/show_bug.cgi?id=212469

I can't see any failure in the plymouth debug log.

Revision history for this message
Daniel van Vugt (vanvugt) wrote : Re: At shutdown the spinner logo disappears and a second later it comes back frozen for a while (in kernel 5.11 but 5.10.16 works)

Thanks Norbert. Reddit seems convinced this is a kernel regression in 5.11 which would line up with the findings here, so let's go with that for now.

summary: At shutdown the spinner logo disappears and a second later it comes back
- frozen for a while
+ frozen for a while (in kernel 5.11 but 5.10.16 works)
affects: plymouth (Ubuntu) → linux (Ubuntu)
no longer affects: snapd (Ubuntu)
Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

Please test latest drm-tip kernel:
https://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/current/

Headers are not needed.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Norbert (asterix52) wrote :

I tried 5.14.0-051400rc5drmtip20210809-generic.

No changes.

I can't get plymouth git to run. Can some help? The git version breaks the debian patches.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Revision history for this message
Daniel van Vugt (vanvugt) wrote (last edit ):

I can confirm the bug is still in the latest kernels and that it was introduced in the 5.11 series:

5.10.16 - good
5.10.60 - good
5.11.1 - broken
5.14.0-051400rc6drmtip20210820 - broken

Next will be to bisect in git but I won't have time to do that this week.

Revision history for this message
Norbert (asterix52) wrote :

plymouth have a rework of the shutdown handling in the git.

https://cgit.freedesktop.org/plymouth/log/

Maybe that helps.

Revision history for this message
Per-Inge (per-inge-hallin) wrote :
Download full text (3.2 KiB)

My Impish installation don't behave like that.
At restart
I see the spinner for about 4 sec, then black screen for about 12 sec until I see the "Asus logo" and a second later the grub menu.
The only customization is some extensions:
ArcMenu
Just Perfection to move the panel to bottom of the screen
Places Status Indicator
Vitals
Weather in The Clock
Ubuntu Dock is turned off
p-i@pi-asus-b550m-wifi:~$ inxi -Fz
System: Kernel: 5.13.0-14-generic x86_64 bits: 64 Desktop: GNOME 40.2 Distro: Ubuntu 21.10 (Impish Indri)
Machine: Type: Desktop System: ASUS product: N/A v: N/A serial: <filter>
           Mobo: ASUSTeK model: TUF GAMING B550M-PLUS (WI-FI) v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 1804
           date: 02/02/2021
CPU: Info: 6-Core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP cache: L2: 3 MiB
           Speed: 2876 MHz min/max: 2200/3700 MHz Core speeds (MHz): 1: 2876 2: 2878 3: 3599 4: 2875 5: 3595 6: 2876 7: 2446
           8: 2236 9: 2235 10: 2238 11: 2236 12: 2885
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] driver: amdgpu
           v: kernel
           Device-2: Logitech Webcam C250 type: USB driver: snd-usb-audio,uvcvideo
           Display: wayland server: X.Org 1.21.1.2 driver: loaded: amdgpu note: n/a (using device driver)
           resolution: 2560x1440~60Hz
           OpenGL: renderer: AMD Radeon RX 5700 (NAVI10 DRM 3.41.0 5.13.0-14-generic LLVM 12.0.1) v: 4.6 Mesa 21.1.4
Audio: Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio driver: snd_hda_intel
           Device-3: Logitech Webcam C250 type: USB driver: snd-usb-audio,uvcvideo
           Sound Server-1: ALSA v: k5.13.0-14-generic running: yes
           Sound Server-2: PulseAudio v: 15.0 running: yes
           Sound Server-3: PipeWire v: 0.3.32 running: yes
Network: Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
           IF: wlp6s0 state: down mac: <filter>
           Device-2: Realtek RTL8125 2.5GbE driver: r8169
           IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb
           Report: hciconfig ID: hci0 state: up address: <filter> bt-v: 3.0
Drives: Local Storage: total: 1.36 TiB used: 55.86 GiB (4.0%)
           ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP600 size: 465.76 GiB
           ID-2: /dev/nvme1n1 vendor: Kingston model: SA2000M8500G size: 465.76 GiB
           ID-3: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
Partition: ID-1: / size: 456.89 GiB used: 55.83 GiB (12.2%) fs: ext4 dev: /dev/sda2
           ID-2: /boot/efi size: 511 MiB used: 33.9 MiB (6.6%) fs: vfat dev: /dev/nvme0n1p1
Swap: ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swapfile
Sensors: System Temperatures: cpu: 35.6 C mobo: 40.0 C gpu: amdgpu temp: 42.0 C
           Fan Speeds (RPM): fan-1: 730 fan-2: 938 fan-3: 720 fan-7: 929 gpu: amdgpu fan: 0
Info: Processes: 373 Uptime: 3m Memory: 15.54 GiB used: 1.81 GiB (11....

Read more...

tags: added: rls-ii-incoming
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Comment #27 does sound like it fixes the same issue (https://bugzilla.redhat.com/show_bug.cgi?id=1941329). The plymouth fix will be in future version 0.9.6 (or later).

no longer affects: plymouth (Ubuntu)
Changed in plymouth (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Daniel van Vugt (vanvugt) wrote (last edit ):

It only took a week of bisecting to track down the kernel regression:

fe0f1e3bfdfeb53e18f1206aea4f40b9bd1f291c is the first bad commit
commit fe0f1e3bfdfeb53e18f1206aea4f40b9bd1f291c
Author: Ville Syrjälä <email address hidden>
Date: Thu Oct 1 18:16:35 2020 +0300

    drm/i915: Shut down displays gracefully on reboot

    Implement the pci .shutdown() hook in order to quiesce the
    hardware prior to reboot. The main purpose here is to turn
    all displays off. Some displays/other drivers tend to get
    confused if the state after reboot isn't exactly as they
    expected.

    One specific example was the Dell UP2414Q in MST mode.
    It would require me to pull the power cord after a reboot
    or else it would just not come back to life. Sadly I don't
    have that at hand anymore so not sure if it's still
    misbehaving without the graceful shutdown, or if we
    managed to fix something else since I last tested it.

    For good measure we do a gem suspend as well, so that
    we match the suspend flow more closely. Also stopping
    all DMA and whatnot is probably a good idea for kexec.
    I would expect that some kind of GT reset happens on
    normal reboot so probably not totally necessary there.

    v2: Use the pci .shutdown() hook instead of a reboot notifier (Lukas)
        Do the gem suspend for kexec (Chris)

    Cc: Lukas Wunner <email address hidden>
    Cc: Chris Wilson <email address hidden>
    Signed-off-by: Ville Syrjälä <email address hidden>
    Link: https://patchwork.<email address hidden>
    Reviewed-by: Jani Nikula <email address hidden>
    Reviewed-by: Chris Wilson <email address hidden>

 drivers/gpu/drm/i915/i915_drv.c | 16 ++++++++++++++++
 drivers/gpu/drm/i915/i915_drv.h | 1 +
 drivers/gpu/drm/i915/i915_pci.c | 8 ++++++++
 3 files changed, 25 insertions(+)

Revision history for this message
Daniel van Vugt (vanvugt) wrote (last edit ):

Despite comment #30 we probably don't want to *fix* the kernel. It sounds like this plymouth patch would be a better idea:

https://gitlab.freedesktop.org/plymouth/plymouth/-/merge_requests/138.patch

Or better yet, just snapshot plymouth git again which includes the fix.

Changed in linux (Ubuntu):
status: In Progress → Triaged
assignee: Daniel van Vugt (vanvugt) → nobody
status: Triaged → Won't Fix
summary: - At shutdown the spinner logo disappears and a second later it comes back
- frozen for a while (in kernel 5.11 but 5.10.16 works)
+ [i915] At shutdown the spinner logo disappears and a second later it
+ comes back frozen for a while (in kernel 5.11 and later)
Changed in plymouth (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Daniel van Vugt (vanvugt)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Revision history for this message
Norbert (asterix52) wrote :

This version work for me.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Changed in plymouth (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package plymouth - 0.9.5git20210406-0ubuntu1

---------------
plymouth (0.9.5git20210406-0ubuntu1) impish; urgency=medium

  * New upstream snapshot 20210406 (commit e55447500fa9) taken on
    2021-08-31 (upstream is unchanged since April) to get the latest bug
    fixes, in particular LP: #1923335.
  * plymouth.install: Add plymouthd-fd-escrow to support the above shutdown
    bug fix.
  * Refreshed debian/patches:
    - details-remove-separator.patch
    - details-update-status.patch
    - initramfsless-boot.patch
    - misc-changes.patch
    - ubuntu-default-devicetimeout.patch

 -- Daniel van Vugt <email address hidden> Tue, 31 Aug 2021 15:01:18 +0800

Changed in plymouth (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.