Comment 10 for bug 1842382

> openat(AT_FDCWD, "/lib/x86_64-linux-gnu/libvlccore.so.9", O_RDONLY|O_CLOEXEC) = 3

This is not the one from the package. You have another vlc installation that messes everything up.