Horizontal corrupted line at top of screen caused by framebuffer compression

Bug #1840236 reported by You-Sheng Yang on 2019-08-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
Linux
Invalid
Critical
linux (Ubuntu)
Undecided
You-Sheng Yang
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Undecided
You-Sheng Yang
linux-oem-osp1 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
You-Sheng Yang
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned

Bug Description

SRU Justification:

[Impact]
On IceLake platforms there might be a thin, horizon strap of corruption
image at the top of screen randomly after some series of window
operations and disappears within a second or so. This is found on
multiple platforms and is quite annonying that results in bad user
experience.

[Fix]
The upstream bug has been filed for previous platforms, e.g. GeminiLake
for an year or so, still working in progress, and so far this only known
work-around is to turn off framebuffer compression on affected platforms.

[Test Case]
The most easy way is to observe if such corruption appears during the
transition from GDM to gnome-shell.

[Regression Risk]
Low. The work-around for GeminiLake was landed to Linux stable 4.14.125
and has been backported to B/D.

======= Original Description ======

This is an follow-up for https://bugs.freedesktop.org/show_bug.cgi?id-108085 but found on IceLake platforms.

Right after GDM is login screen is rendered, there might be a thin strap of corrupted image at top of the display for a short while. Like f-d-o bug 108085, sometimes it can also be reproduced by clicking the date/time repeatedly to open and close the calendar several times. Etc.

Known work-around so far is to append kernel boot param "i915.enable_fbc=0".

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-5.0.0-1018-oem-osp1 5.0.0-1018.20
ProcVersionSignature: Ubuntu 5.0.0-1018.20-oem-osp1 5.0.18
Uname: Linux 5.0.0-1018-oem-osp1 x86_64
ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Thu Aug 15 16:41:01 2019
DistributionChannelDescriptor:
 # This is the distribution channel descriptor for the OEM CDs
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-bionic-amd64-20190418-59+beaver-osp1-loras+X14
InstallationDate: Installed on 2019-08-12 (3 days ago)
InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 20190418-12:10
SourcePackage: linux-signed-oem-osp1
UpgradeStatus: No upgrade log present (probably fresh install)

You-Sheng Yang (vicamo) wrote :
You-Sheng Yang (vicamo) on 2019-08-15
no longer affects: linux-signed-oem-osp1 (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1840236

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
You-Sheng Yang (vicamo) wrote :

I've also tried following kernel versions and they are all affected:

* v5.2.8 mainline
* v5.3-rc1 mainline
* v5.3-rc2 mainline
* v5.3-rc3 mainline
* v5.3-rc4 mainline
* drm-intel-next 2019-07-31 from https://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/2019-07-31/

description: updated

This is a duplicate to https://bugs.freedesktop.org/show_bug.cgi?id=108085 that happens on IceLake platform as well.

It can be reproduced on linux v5.3-rc6 today, with the reproduce steps listed in bug 108085, but one can easily found a horizontal line of corruption at the top of the screen when logging in from gdm.

Blacklist IceLake as https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=396dd8143bdd94bd1c358a228a631c8c895a1126 did for GeminiLake is a known work-around so far.

Created attachment 145160
dmesg, v5.3-rc6, drm.debug=0xe

Created attachment 145161
glxinfo

Created attachment 145162
lspci output

Created attachment 145163
proposed patch

Changed in linux (Ubuntu):
status: Incomplete → In Progress
You-Sheng Yang (vicamo) wrote :
Changed in linux (Ubuntu):
assignee: nobody → You-Sheng Yang (vicamo)
tags: added: patch

ICL issue tracked on fdo 103167 and WIP there.

Timo Aaltonen (tjaalton) wrote :

ICL is only enabled on eoan/osp1

Timo Aaltonen (tjaalton) on 2019-08-27
Changed in linux (Ubuntu Bionic):
status: New → Invalid
Changed in linux (Ubuntu Disco):
status: New → Invalid
Changed in linux-oem (Ubuntu Bionic):
status: New → Invalid
Changed in linux-oem (Ubuntu Disco):
status: New → Invalid
Changed in linux-oem (Ubuntu Eoan):
status: New → Invalid
You-Sheng Yang (vicamo) on 2019-08-27
no longer affects: linux-oem (Ubuntu)
Timo Aaltonen (tjaalton) on 2019-08-27
no longer affects: linux-oem (Ubuntu Bionic)
no longer affects: linux-oem (Ubuntu Disco)
no longer affects: linux-oem (Ubuntu Eoan)
You-Sheng Yang (vicamo) on 2019-08-27
tags: added: oem-priority originate-from-1836993 somerville
You-Sheng Yang (vicamo) wrote :
Changed in linux-oem-osp1 (Ubuntu Bionic):
assignee: nobody → You-Sheng Yang (vicamo)
status: New → In Progress
description: updated
Changed in linux:
status: Unknown → Confirmed

(In reply to Jani Saarinen from comment #5)
> ICL issue tracked on fdo 103167 and WIP there.

Accordingly, all the above details are set.

Changed in linux:
importance: Unknown → Critical
Seth Forshee (sforshee) on 2019-09-05
Changed in linux (Ubuntu Eoan):
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton) on 2019-09-09
Changed in linux-oem-osp1 (Ubuntu Bionic):
status: In Progress → Fix Committed

@Maarten, Is this issue related to Bug 111484? Since you investigated Bug 111484 any suggestions here?

You mean Lakshmi if 103167 is same?

(In reply to Jani Saarinen from comment #8)
> You mean Lakshmi if 103167 is same?

Sorry, yes it's Bug 103167 .

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.3.0-10.11

---------------
linux (5.3.0-10.11) eoan; urgency=medium

  * eoan/linux: 5.3.0-10.11 -proposed tracker (LP: #1843232)

  * No sound inputs from the external microphone and headset on a Dell machine
    (LP: #1842265)
    - SAUCE: ALSA: hda - Expand pin_match function to match upcoming new tbls
    - SAUCE: ALSA: hda - Define a fallback_pin_fixup_tbl for alc269 family

  * Horizontal corrupted line at top of screen caused by framebuffer compression
    (LP: #1840236)
    - SAUCE: drm/i915/fbc: disable framebuffer compression on IceLake

  * Add bpftool to linux-tools-common (LP: #1774815)
    - [Debian] package bpftool in linux-tools-common

  * Miscellaneous Ubuntu changes
    - update dkms package versions

  [ Upstream Kernel Changes ]

  * Rebase to v5.3-rc8

 -- Paolo Pisati <email address hidden> Mon, 09 Sep 2019 10:00:41 +0200

Changed in linux (Ubuntu Eoan):
status: Fix Committed → Fix Released

Likely identical, especially if disabling fbc from command line works.

marking this as dup. WIP on that has been already a while to understand cause of it.

*** This bug has been marked as a duplicate of bug 103167 ***

Reporter, please also try as suggested using i915.enable_fbc=0 if issue still exists.

Ah, so suggested workaround using i915.enable_fbc=0 also works?

Yes, basically whatever turns off fbc would work. Thank you.

Changed in linux:
status: Confirmed → Invalid
Timo Aaltonen (tjaalton) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
You-Sheng Yang (vicamo) on 2019-09-26
tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-osp1 - 5.0.0-1024.27

---------------
linux-oem-osp1 (5.0.0-1024.27) bionic; urgency=medium

  * bionic/linux-oem-osp1: <version to be filled> -proposed tracker
    (LP: #1846023)

  * alsa/sof: fix the hang issue on Dell Nebula MP platforms (LP: #1845904)
    - ALSA: hda: clear output link mappinp
    - ALSA: SOF: disable L1SEN for capture stream
    - ALSA: sof: refine stop-start sequence for driver and FW
    - ALSA: sof: disable debug message for production release

  [ Ubuntu: 5.0.0-31.33 ]

  * disco/linux: 5.0.0-31.33 -proposed tracker (LP: #1846026)
  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts
  * /proc/self/maps paths missing on live session (was vlc won't start; eoan
    19.10 & bionic 18.04 ubuntu/lubuntu/kubuntu/xubuntu/ubuntu-mate dailies)
    (LP: #1842382)
    - SAUCE: Revert "UBUNTU: SAUCE: shiftfs: enable overlayfs on shiftfs"

 -- Timo Aaltonen <email address hidden> Fri, 04 Oct 2019 11:24:05 +0300

Changed in linux-oem-osp1 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in linux-oem-osp1 (Ubuntu Disco):
status: New → Fix Released
Changed in hwe-next:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.