Ubuntu

USB pendrive, write speed

Reported by Ops on 2008-01-14
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

In accord with the #19172 bug, it says that is fixed, but i'm having the same problem with Kubuntu/Ubuntu 7.10. I use kubuntu at work and ubuntu at home, when i use my pendrive to copy to it something (usually bigger than 200Mb), it starts the copy with the transfer speed at 20~22Mb and after some seconds the speed drops drastically and stays at 600~800Kb.

I'm using the following kernel: 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

Thanks in advance,
Eduardo

Oleksij Rempel (olerem) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at [WWW] https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in

Oleksij Rempel (olerem) wrote :

Please try if it working with newest livecd http://cdimage.ubuntu.com/releases/8.04/alpha-3/

Georg Hooss (hooss) wrote :

I have a similar problem with usb 2.0 devices,
apparently the system does not find the ehci hardware in my box.
see bug #192234 for detailed diagnostics.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

zpon (zpon-dk) wrote :

I am having the same problem, starts out at ~20 mb/sec but ends up about 2mb/sec-100kb/sec

zpon (zpon-dk) wrote :

I have used the night updating my ubuntu install (update-manager -d), but sadly the problem is still a problem. I just moved about 1gb file to my usb pen, and the speed started at 8 mb/sec and ended at 1.5 mb/sec. The usb pen is a Kingston DataTravler 100 8GB. The computer is a ThinkPad T61.

$ lspci | grep -i usb
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)

Can you paste the output of 'cat /proc/version_signature' so we know which kernel you are using? Thanks.

zpon (zpon-dk) wrote :

Sure, I did a fresh install of ubuntu the other day, but I still start at about 8mb/sec and ends at about 3-2mb/sec

$ cat /proc/version_signature
Ubuntu 2.6.27-7.16-generic

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Marcos Diaz (marcos-diaz) wrote :

The bug persists after 2 years, with ubuntu 8.10 write start with 20-30 MB/s and decreases to 2-3 MB/s in a few seconds, sometimes (1%) start keep on 20-30 MB/s and has no data flow cuts, so seems like a kernel/mudule fail.

The problem is not a hardware specific (I try with many pc and many pendrives) but this is my spec:

uname -a:
Linux ******* 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux

ubuntu ver:
Ubuntu 8.10 (Intrepid) updated to 22-dec-2008

My personal opinion is this bug is critical because it blatantly wrong in a basic daily operation... really does not say anything good from our system.

Oleksij Rempel (olerem) wrote :

The speed drops because at the beginning of writing the data will be copied to the filesystem cache and only after this file system will try to flash the cache to the usbdrive. If the drive is to slaw it will reduce copy speed. Normally if file system mount with option sync no cache will be used and you will see real speed of your drive.

Do you have any linux configurations where it hase better speed ? What say kernel log about this, are there any warnings ? Use dmesg to find this out.

Try fallowing test. Umount your usb stick, start terminal and run this commands:

sudo mount -o sync /dev/sdb1 /mnt/
# will mount with option sync usb stick if it located on /dev/sdb1 to the directory /mnt

sudo dd if=/dev/zero of=/mnt/test.dd bs=1M count=100
#will write 100M to usb drive and return writing speed.

My Kingstone usb-stick will return:
104857600 Bytes (105 MB) kopiert, 130,25 s, 805 kB/s
This is normal, real speed if sync used.
Write speed depends on filesystem block sice.

Andy Whitcroft (apw) wrote :

It is would also be helpful to have the dmesg output relating to the USB sticks insertion. Insert the stick and you should see something similar to the following in the output of the dmesg command:

    [102386.120296] usb 5-1: new high speed USB device using ehci_hcd and address 5
    [102386.255443] usb 5-1: configuration #1 chosen from 1 choice
    [102386.257622] scsi9 : SCSI emulation for USB Mass Storage devices
    [102386.264768] usb-storage: device found at 5
    [102386.264779] usb-storage: waiting for device to settle before scanning
    [102391.264352] usb-storage: device scan complete

This has information on how fast the USB connection is to the device. If you could paste that into this bug.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Valentin Neacsu (bkraptor) wrote :

Just as I was moving all my files from my EXT4 home drive to an external USB drive (in case you're wondering, I'm dumping Ubuntu) I hit this exact same bug. Starting speed is about 40 MB/s with HDD led being constantly lit and ending up around 3 MB/s with almost no HDD activity on the LED. This bug right here is one of the many examples of bugs for which I can no longer use Ubuntu.

Ops (eduf-santos) wrote :

Hi guys, 3 new versions has been launched and untill now the problem still exist. Any news about it?

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Ops (eduf-santos) wrote :

Yes, unfortunately the issue remains. Nothing has changed. The transfer for pendrive stars with a good speed and after some short time, it starts to decrease and stablish around 300~800kb.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Kaur Männamaa (kaurman) wrote :

Fishor's comment (#11) made me think.

I tried to copy to a flashdisk which I had previosuly manually mounted with the mount -o async parameter. It seems that speed indeed improved quite a bit. Can't say for sure though, as terminal doesn't report speed by default while copying.

The kernel I'm using is: 2.6.24-27-rt

I'd be glad if anyone tested and had a look at the transfer rates

Kaur Männamaa (kaurman) wrote :

As sorry as I am to say this, I did some additional tests and found that async does not solve the problem after all.
I apologize if I caused confusion.

Same problem here. Kernel 2.6.31-20, karmic 9.10, amd64. Tested with different pendrives, mobilephones etc.
Additionaly tested with the proposed kernel (21) with even more errors. This problem sucks.
I think this is really a critical bug by assuming that thousands of users are working with pendrives and usb-harddrives on a daily basis.
If you need more info - just ask...

Ops (eduf-santos) wrote :

Almost 2 years now and still no solution for such annoying and deterrent bug. With this bug, is almost impossible to transfer any file larger than 1GB to any pendrive, smartphone, etc... Can someone look into this pleasse.

NKK (kiknadze) wrote :

To my experience speed drop happens if the drive uses VFAT, but not with ext3/4.
So imho there's something wrong with vfat driver part, not USB...

NKK (kiknadze) wrote :

Ah, forgot to mention, NTFS works fine

bg2b (david-davidlong) wrote :

Same experience here (though with the latest Debian); using VFAT results in horrible performance, but NTFS works great. Thanks to NKK for the hint.

ilesal (ilesal) wrote :

WHY HAS THIS NOT BEEN SORTED!!!??? 2008-2010, I am still having to dual boot with Win7 just to be able to transfer files to external HDD and USB sticks.

Kaur Männamaa (kaurman) wrote :

You may consider this a silly suggestion but maybe you should upgrade to 10.04? It seems that there are no such problems with its kernel.

madjihad (madjihad) wrote :

I'm using 10.04, and I have the same prombem...almost the same.
Small files writes even too fast!

100+0 records in
100+0 records out
104857600 bytes (105 MB) copied, 0.82643 s, 127 MB/s

And the the speed falls more and more, when the file size is growing up.

1000+0 records in
1000+0 records out
1048576000 bytes (1.0 GB) copied, 182.326 s, 5.8 MB/s

After filesize about 4GB it takes hours...
Filesystem is NTFS.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers