Ubuntu

Hardy alpha [2-6] daily-live i386 don't boot

Reported by Patrice Vetsel on 2008-01-09
44
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
QEMU
Undecided
Unassigned
linux (Gentoo Linux)
Won't Fix
Medium
linux (Ubuntu)
Medium
Ben Collins

Bug Description

Binary package hint: casper

Since hardy alpha2 i386 daily-live, the system don't boot.

Look at screenshot attached. This PC have seen dapper/feisty/gutsy livre cd booting well.

What kind of informations can i provide ?

Patrice Vetsel (vetsel-patrice) wrote :

screenshot

Patrice Vetsel (vetsel-patrice) wrote :

I can add that the cd is OK because i'v done a vmware installation with it.
My motherboard is a Gigabyte GA K8N Ultra 9
http://www.gigabyte.fr/Products/Motherboard/Products_Spec.aspx?ProductID=1868

and i have 1 IDE DD and 2 SATA DD (no raid)

Tormod Volden (tormodvolden) wrote :

Other useful information could be the output from dmidecode, lspci -nn, lshal -t, and dmesg.

Patrice Vetsel (vetsel-patrice) wrote :

dmidecode

Patrice Vetsel (vetsel-patrice) wrote :

lspci -nn

Patrice Vetsel (vetsel-patrice) wrote :

lshal -t

Patrice Vetsel (vetsel-patrice) wrote :

dmesg

Tormod Volden (tormodvolden) wrote :

You can get a shell early in the initrd by booting with the boot option break=premount (see /usr/share/initramfs-tools/init for more information). From there you might be able to find out more. For instance, you can mount a hard drive (or usb stick) by hand and copy dmesg output to it. Do you see all drives under /sys/block ? Is the complaining hdc your single IDE drive, or the CDROM?

Tormod Volden (tormodvolden) wrote :

The option break=mount is maybe better, because with premount you have to start scripts/init-premount/udev to have all devices discovered.

break=mount is not usefull because system hangs before break
break=premount offer me a busybox shell but without keyboard (i'v an usb keyboard) i can't do anything

Tormod Volden (tormodvolden) wrote :

Hard luck :) You can hack your own initrd to have all usb modules needed for the keyboard listed in conf/modules. But it's getting awkward, so I hope someone else has a clue about what's going on and can chime in.

Same problem with amd64 version of the daily-live iso.

Problem cames up very quickly, at the very beginning of the boot, and hdc seems to be my IDE cdrom. This weekend i will try to remove sata HD and move cdrom in ide place…

Tormod Volden (tormodvolden) wrote :

If you have a 1GB USB stick, the easiest workaround would be to copy the CD to it (including the .disk directory). You can still boot the kernel from the CD, but as soon as the kernel is booting, eject the CD and let the initrd search for the CD contents on the USB stick instead.

Before testing usb stick i'v removed all DD and floppy, moved cdrom from hdc to hda and reboot.

I'v the same problem, but now on hda.

Is it the same problem with breezy (i believe or dapper)), when, for the first time, ubuntu distribution enabled the DMA for cdrom. Before enabling DMA my cdrom can't boot the distribution (it's a plextor).

Tormod Volden (tormodvolden) wrote :

There used to be a kernel option ide=nodma - can you try it?

So with a:
PLEXTOR PX-740A -> can't boot
Matsushita SR-8584-B -> can't boot

but with a :
Traxdata CDD4911/45 -> i can boot ! :)

This is definitively a kernel bug. Some cd/dvd/reader are not well initialised by the kernel.

Should i report this bug upstream ?

Hi Patrice,

If you are able to confirm this issue exists with the upstream kernel, then yes I'd really encourage you to also make an upstream bug report at bugzilla.kernel.org. For help with building and booting the upstream kernel as well as reporting bugs at bugzilla.kernel.org, please refer to:

https://wiki.ubuntu.com/KernelTeam/GitKernelBuild

Thanks!

Changed in linux:
status: New → Incomplete
Brian Curtis (bcurtiswx) wrote :

I don't know if this is a possible workaround. Would Installing with the Alpha-2 CD and using the internet to upgrade be acceptable?

Steve Langasek (vorlon) wrote :

Patrice, can you confirm whether this issue exists with either the upstream kernel as Leann mentioned, or with the current hardy kernel as included on more recent daily live images?

With daily dekstop i386 20080125 i can't boot too.

Here are 2 messages that may be interresting :

hdc: UDMA/33 mode selected
and
[48.64.8954] Driver 'sd' needs updating - please use bus_type methods

I's installed a alternate version (1 week old) so:

Why can i boot and install with alternate kernel and not with desktop kernel ? What's the differences ?

I'v noted a big problem with alternate install, that may be informative for this bug. Tell me if i should create a new Bug report.
This problem is that root partition are completely mixed.


## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=2a41eaec-258b-45d9-8c3f-703bbd190213 ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd1,0)


# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

# howmany=all
title Ubuntu hardy (development branch), kernel 2.6.24-5-generic
root (hd1,0)

--> this must be (hd2,0) ///////////////////////////////////

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sdc1
title Microsoft Windows XP Professionnel
root (hd2,0)
--> this must be (hd0,0) ///////////////////////////////////

savedefault
makeactive
map (hd0) (hd2)
--> this must be deleted ///////////////////////////////////

map (hd2) (hd0)
--> this must be deleted ///////////////////////////////////

chainloader +1

Onkar Shinde (onkarshinde) wrote :

I recently upgraded my ibook G4 (ppc) to hardy and the upgrade was somehow borked. I don't know what happened exactly. I see usplash for long time and then get a shell (ash).

So I decided to do a reinstall. I used ppc nightly 'Alternate CD' of date 26th. It also has this issue. So certainly this is not specific to Live CD.
Please note that I have not tested any Live CD.

Onkar as your hardware is quite different than the original reporter's hardware it would make more sense for you to open a new bug report. Thanks for your cooperation!

Changed in linux:
status: Unknown → Confirmed

May be can i test alpha 1 and alpha2 to test if this is a regression ?!

But i can't find anymore iso of alpha 1 and 2

Steve Langasek (vorlon) wrote :

Sorry, but old alphas are not kept around on the servers due to space considerations.

Same problems here like Patrice´s, I´ve a Plextor 740A and when trying with alpha4 the installation exits at the very beginning to a (initramfs) shell, i don´t kwon how to save dmesg lspci or lshal outputs for your information but if you instruct me i can do it. I have tried amd64 and i386 versions and it´s the same.

Changed in linux:
importance: Undecided → High
milestone: none → hardy-alpha-5
status: Incomplete → Confirmed

Same problems here like Patrice's.
Only with an extra USB stick I could start (See message of Tormod Volden on 2008-01-11 above).
I have a Philips DVDR1640, and used Hardy-alpha4. Disabling DMA didn't help.
After starting with the USB stick, the dmesg contains almost no information, so I let it fallback to BusyBox again an checked that dmesg.
My BIOS settings for my dvd-rewriter are PIO mode 4 and UDMA mode 2, but dmesg says "UDMA/3". Is that okay? Since I use a normal IDE-cable (not a UDMA cable).

[ 3.054] hdc: PHILIPS DVDR14P, ATAPI CD/DVD-ROM drive
[ 3.059] hdc: host max PIO5 wanted PIO25(auto-tune) selected PIO4
[ 3.068] hdc: UDMA/3 mode selected
[ 3.066] ide1 at 0x10-0x17,0x36 on irq 1
...
[ 6.098] hdc: lost interrupt
[ 6.099] hdc: task_in_intr: status=0x5 { DriveReady SeekComplete DataRequest Error }
[ 6.099] hdc: task_in_intr: error=0x0 { }

I confirm that i can boot with a 2.6.24 kernel using :

Fedora 9 Alpha
and
openSUSE 11.0 Alpha 2

I just tested "openSUSE-11.0-Alpha2-GNOME-LiveCD-i386.iso", which uses kernel "2.6.24-6-default".
This works fine.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
status: Confirmed → Triaged

Today, with hardy 20080212 daily-live iso i'v tested another PC here at work.
This is a completely different PC than mine (via/intel, AMD/intel, Nvidia/ati).
The iso boot well, i switch the original cd drive by my plextor and the iso don't boot :(

I'm remembering years ago, when modules didn't get loaded in right order, may be it's the same here ?!

Just tested the same daily-live, and as you would expect it does not boot on my computer.
During startup the kernel 2.6.2-7-generic is used.
This problem didn't happen before on my computer, and I started in 2003 with linux (Debian).

Is it the process of hardware detection, probing , modules loading, the same in livecd AND in an installed system ?

Because doing installation with another cd driver, and after, when I re-install my Plextor, the installed system doesn't complain and all is working...

I know that the alternate-cd sometimes differs from the Live-cd.
But I don't know enough to help further, and I don't have a spare partition at the moment.
Other similar bugs: Bug #182996, Bug #182996.

In my previous message I mentioned the same bug twice. There is one other bug (with a duplicate).

And is this the same problem too? Bug #179336.

WoW.

Adding "all_generic_ide" as boot parameters, allow me to boot the cd and to reply to this bug from this running alpha4 live cd.

I attach my new dmesg with this parameter

Thanks! That is a good workaround.
I just added the text "all_generic_ide" (without quotes) at the end of the boot parameters and it works.

I ask kernel team : where is the bug come from ?

Now we know the tips, is it a problem in kernel sources (missing a patch that fedora or opensuse have ?) or is it a problem in the order of modules loading (because this is working in an already system but not in live cd) ?

I'm ready to test what you want to fight this bug :)

Unfortunately "all_generic_ide" did not work for me using Alpha 5. I couldn't get any further than the boot option screen. All of the choices bombed out immediately with "I/O Error accessing boot CD"

Steve Langasek (vorlon) wrote :

Nick,

I'm fairly certain that the error you're describing is a different problem than this bug, which mentions neither this "I/O Error accessing boot CD" message nor returns an error immediately from the boot menu. Perhaps the CD you burned is bad? Have you checked the integrity of the CD?

Nick B. (futurepilot) wrote :

Terribly sorry. It appears to have been a bad burn. The Integrity check hung at the very end with with "Buffer I/O error on device sr0 logical block ########" Oddly enough the CD did boot on that particular machine which I though must mean that the CD was fine. The initial error sounded very similar to this bug and I though they must be connected. Again, sorry for the mix up.

Ben Collins (ben-collins) wrote :

This is likely hardware specific. I suspect DMA issues.

Changed in linux:
importance: High → Medium
milestone: hardy-alpha-5 → hardy-alpha-6
Yuriy Kozlov (yuriy-kozlov) wrote :

I encountered this problem on 2008-02-27 daily-live amd64 and on alpha5 i386. I have these CD drives, with the same symptoms:
SM-BENQ DVD DD DW1640
SS-SAMSUNG SCR-3232

Adding all_generic_ide to boot parameters worked. Adding ide=nodma did not. I had previously installed from the same alpha 5 CD on a different machine and it worked.

Maybe this is a clue because the Plextor 740a and Benq DW1640 share the same hardware, even you can flash Plextor with Benq firmware. For the Samsung, I don´t know.

And now, since 1 week, my Plextor refuse to work under Gnome. Before that I use all_generic_ide to by-pass this bug, and after that all was ok with my cd reader.
But now my cd-drive simply do not work. Can't open it. I have a blank cd icon on desktop (it's empty). More we go and more problems occurs…

Like Patrice, I also have a Gigabyte motherboard, AMD64, 2xSATA drives, 1xIDE drive and a Phillips DVD drive (not copying Patrice, just coincidence) and can confirm that I´m also experiencing the same problem. Also when loading up 7.10 and doing a "update-manager -d" dist upgrade, also have the blank cd icon on my desktop, with the CD/DVD drive being unavailable (K3b states that no CD drive detected. Brassero is less helpful). Additionally seem to be unable to mount the drive manually. I´m a relative newbie, but will help if you tell me what to do, in jargon I´d be able to understand.

pyth (pyth) wrote :

I also have the problem with a self-compiled 2.6.24.3 from kernel.org and the BENQ DVD DD DW1620.
System: ASUS P4P800, Intel P4 with HT, 2 IDE devices (DVD and HDD on hda) and 1GB RAM.

pyth (pyth) wrote :

I don't know if this was already mentioned, but 2.6.23.17 seems to be OK and 2.6.25-rc3 has still the same problem (at least on my machine).

Steve Langasek (vorlon) on 2008-03-09
Changed in linux:
milestone: hardy-alpha-6 → ubuntu-8.04-beta
description: updated
pyth (pyth) wrote :

Though there seems to be some work (2.6.25-rc5, commit b348487f0dc06f09a4c0d9e353eaa66e70230c7d) on that or (maybe) a similar issue, I still have the same problem with 2.6.25-rc5.

pyth (pyth) wrote :

Seems that the bug is already present in 2.6.24-rc1.

psernetz (patrick-sernetz-com) wrote :

I have the same problem with a BENQ DVD DD DW1620

Got the same on plextor PX-740A, like patrice.
As sp said that the bug has happened somewhere between 2.6.23 and 2.6.24-rc1, I will try to do a bisect this evening.
Maybe I will be able to point this out.

TeoLinuX (matteo-mori) wrote :

Same problem with both alpha6 and nightly 20080311

I have similar HW: ASUS A8N SLI deluxe (nvidia nForce4 CK804) ; AMD64 3500+ ; Philips DVDR1640 ; nvidia 6600GT (NV43)
Suspect DMA issues on that HW combination

notice that I'm using the hardy kernel 2.6.24-8 (32 bit) from backports on my gutsy 7.10 with much satisfaction...
Not tried the all_generic_workaround_yet

TeoLinuX (matteo-mori) wrote :
TeoLinuX (matteo-mori) wrote :

I tried with my Plextor 740A+alpha 6+Asus with chipset nforce4 -> don't boot, and Plextor 740A+alpha6+Asus with chipset G33 -> don't boot

Only FYI

I did the bisect yesterday and I find out that the bug seems to be in this commit:
b140b99c413ce410197cfcd4014e757cd745226a
( http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=b140b99c413ce410197cfcd4014e757cd745226a;hp=88b2b32babd46cd54d2de4d17eb869aea3383e11 )

I sent a mail on the linux-ide mailing list, so let's hope the kernel 2.6.24.4 will be ok.

Nice work, thanks Richard.

Ok.
If i set my Plextor PX-740A to Slave, all is working ! GREAT !!!

I should add for informations that my PX740-A is alone on IDE1 (hdc/hdd) and was set to MASTER of course.

pyth (pyth) wrote :

Same situation on my machine with the BENQ DVD DD DW1620, as described above by Patrice.
I've tested 2.6.24.3 and 2.6.25-rc5 from kernel.org without any additional patches.

Ok, so I opened a bug report on bugzilla, and the kernel guys are on it.
Richard.

Changed in linux:
status: Confirmed → Invalid
Changed in linux:
status: Unknown → In Progress
Lars Bratthall (larsbratthall) wrote :

Confirming bug on motherboard ASUS Maximus Extreme SE.

Configuration:
2 * DVDs connected to motherboard, which has a Jmicron controller.Multiple ASUS motherboards seem to have that. One is a to be identified OEM-drive, the other a modern Samsung DVD-burner.
A set of HDs connected to an AMDC 3ware hardware Raid controller connected using SATA2
System works perfectly well using another OS.

Multiple distributions (Knoppix 5.1.1, Debian etch RC1, Sabayon, DVDs burned at different stations) correctly start installations from the OEM DVD. Early in the process, they cannot reach the files on the DVD and show distribution-dependent erratic behaviour..

Will try all_generic_ide, but would prefer not to have to do that. Some distributions give me a limited shell.

Possibly related bugs/descriptions:
https://bugs.launchpad.net/ubuntu/+source/cdrom-detect/+bug/11827
http://forums.debian.net/viewtopic.php?t=22983 (there, interesting link to a dist based on Debian Etch that may be working)
https://lists.ubuntu.com/archives/ubuntu-bugs/2005-January/028277.html

Seems there is a long-running bug here, related to mixed IDE/SATA2-systems?

@Lars : look at upstream bug report you will find more usefull informations (seting drive as slave etc.)

Ben Collins (ben-collins) wrote :

A good workaround for this would be to drop to busybox (break=top) and modprobe pata_amd or pata_via (depending on your hardware) then exit the shell.

Changed in linux:
milestone: ubuntu-8.04-beta → ubuntu-8.04
status: Triaged → Fix Committed

I mark as In progress like upstream bug.
Is there a patch to test somewhere ?

Changed in linux:
status: Fix Committed → In Progress
Changed in linux:
assignee: ubuntu-kernel-team → ben-collins
status: In Progress → Fix Committed
Changed in qemu:
status: New → Invalid
jpunit (johnhuymaier) wrote :

Confirmed on Kernel 2.6.24-12-generic #1 SMP

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.24-13.23

---------------
linux (2.6.24-13.23) hardy; urgency=low

  [Alessio Igor Bogani]

  * rt: Updated configuration files

  [Ben Collins]

  * openvz: New custom flavour for OpenVZ
  * config: Disable IDE AMD driver in favor of PATA version
    - LP: #181561
  * config: Disable IDE VIA driver in favor of PATA version
    - LP: #181561
  * drivers/video: Restore gutsy backlight dimming behavior
    - LP: #205261
  * build/config: Enable CONFIG_CIFS_WEAK_PW_HASH
    - LP: #202445

  [Colin Ian King]

  * SAUCE: Add support for version 4 of Chelsio NICs in cxgb3 driver
    - LP: #201893

  [Kees Cook]

  * AppArmor: re-add missing "type" field in syslog reports.
    - LP: #202888
  * kvm: reset TSS on x86_64 to avoid ioperm bitmap corruption
    - LP: #144900

  [Stefan Bader]

  * USB: EHCI: add separate IAA watchdog timer
    - LP: #198619
  * SAUCE: Always use SCO protocol (disable eSCO support)
    - LP: #39414
  * PM: Introduce PM_EVENT_HIBERNATE callback state
    - LP: #201086

  [Tim Gardner]

  * Disable DRM suspend/resume on pre-915 Intel chips
    - LP: #207496
  * frame buffer regression - screen blank except for blinking cursor after fbcon
    vtswitch
    - LP: #201591

 -- Tim Gardner <email address hidden> Wed, 19 Mar 2008 10:05:05 -0400

Changed in linux:
status: Fix Committed → Fix Released

I can confirm it has been fixed. ASUS A8N SLI deluxe (nvidia nForce4 CK804), AMD64 3500+, Samsung DVD rewriter, nvidia 6600GT here.
Thanks. Now ubuntu-modules 2.6.24-13 has got to be built.

Darren Worrall (dazworrall) wrote :

I tried booting from the latest daily (01-Apr-2008 08:15) and hit the same problem. Should the daily build contain the updated package?

Jorge G (geojorg) wrote :

I tried the Daily build 01/03/08 and had the same problema just like Otacon, when would the 2.6.24-13 module be released for Hardy ?

Onkar Shinde (onkarshinde) wrote :

I think there are no *modules* packages corresponding to the latest linux-image package yet. So unless and untill they are available the problem will remain on daily CD.

Changed in linux:
status: Unknown → Invalid
Jorge G (geojorg) wrote :

Bug fix with daily live 05/03/08 the new linux kernel 2.6.25-15 solve the issue, hope someone else can confirm.

Jorge G (geojorg) wrote :

I completely write the wrong thing is the daily live 05/04/08 and the linux kernel 2.6.24-15. The bug is fixed.

John S. Gruber (jsjgruber) wrote :

The fix above is a move from the AMD and VIA drivers to newer PATA ones. When I moved to the new kernel yesterday my computer would no longer boot. I found that the reason was that the PATA drivers renamed my drives from /dev/hd? to /dev/sd? with my partitions similarly renamed.

Now I have my own grub menu with the old name listed as root, so the system hung. That's my responsibility and I deserve no sympathy. That's why I haven't posted a bug report for the hang.

It does suggest a couple of rhetorical questions, however--

1. Will the migration to the new drivers through live-cd installations and through upgrades take care of the necessary changes to boot-loaders and /etc/fstab?

I assume the mounts by volumeid in /etc/fstab will mitigate potential /etc/fstab problems if it can be assumed they have all been converted. Maybe there is some other conversion mechanisms I don't know about, too.

2. For busybodies like me should there be mention of the change in the release notes?

Like I said, they are rhetorical questions I bring up since the release is in beta. I'd bet they've already been considered carefully but I thought I might bring them up just in case.

Thanks.

I'm assuming the 8.04 Live CD Beta didn't have this fix and the daily build CDs did because with booting from the latter the PATA hard drive is now longer available, i.e. this fix is a regression for some users.

    PATA drive available: Linux version 2.6.24-12-generic (buildd@yellow) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu4)) #1 SMP Wed Mar 12 22:31:43 UTC 2008 (Ubuntu 2.6.24-12.22-generic)
    PATA drive missing: Linux version 2.6.24-16-generic (buildd@yellow) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Thu Apr 10 12:47:45 UTC 2008 (Ubuntu 2.6.24-16.30-generic)

Some interesting lines from the latter's dmesg.

    [ 129.387661] PCI: Setting latency timer of device 0000:00:04.0 to 64
    [ 129.388040] pata_pdc2027x 0000:01:09.0: version 1.0
    [ 129.488423] pata_pdc2027x 0000:01:09.0: PLL input clock 16650 kHz
    [ 129.518914] scsi0 : pata_pdc2027x
    [ 129.519528] scsi1 : pata_pdc2027x
    [ 129.519546] ata1: PATA max UDMA/133 mmio m16384@0xfcff4000 cmd 0xfcff57c0 irq 17
    [ 129.519548] ata2: PATA max UDMA/133 mmio m16384@0xfcff4000 cmd 0xfcff55c0 irq 17
    [ 132.016226] pata_amd 0000:00:04.0: version 0.3.10
    [ 132.016263] PCI: Setting latency timer of device 0000:00:04.0 to 64
    [ 132.016312] scsi2 : pata_amd
    [ 132.016451] scsi3 : pata_amd
    [ 132.016992] ata3: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xf000 irq 14
    [ 132.016995] ata4: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xf008 irq 15
    [ 137.203403] ata3: port is slow to respond, please be patient (Status 0xd0)
    [ 142.011621] ata3: SRST failed (errno=-16)
    [ 142.178359] ata4: port disabled. ignoring.

Teathief (d4rkf4th3r) wrote :

This bug effects IDE ports on the ASUS P4P800-VM (Intel 865G) motherboard itself.
I've tested several drives on it, both lite-on and k-hypermedia drives.
I can't confirm if it effects the hard drives or not since I can't get further in the boot process.

slayer (antoniochiaravalloti) wrote :

i confirm problems with ide ports on a via motherboard that i can't solve by modifying the cable attachements or jumper settings.

here it is my detailed bug report https://bugs.launchpad.net/ubuntu/+bug/222547

so the only solution is changing modules every time the kernel gets updated? please tell me not...

Jorge G (geojorg) wrote :

Have you tried to add all_generic_ide in the boot parameters for the kernel.

slayer (antoniochiaravalloti) wrote :

yes, it boots and it's able to mount the ide partitions.. but the system is very slow and always freezes and locks up. definitely not a solution. I had written it on my bug report

Changed in linux:
status: In Progress → Fix Released
Changed in linux:
status: Invalid → Fix Released
Changed in linux (Gentoo Linux):
status: Fix Released → Won't Fix
Changed in linux (Gentoo Linux):
importance: Unknown → Medium
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.