[Hardy]HP printer is not detected properly by HPLIP

Bug #181242 reported by Pramod Dematagoda on 2008-01-08
74
This bug affects 3 people
Affects Status Importance Assigned to Milestone
hplip (Ubuntu)
Critical
ozone baby
libusb (Ubuntu)
Critical
Unassigned
linux (Ubuntu)
Critical
Ubuntu Kernel USB Team
udev (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: hplip

I have an HP officejet 4255 all-in-one machine, it works just perfectly using HPLIP on Ubuntu 7.04 and 7.10, but on Ubuntu 8.04 it does not work properly.

The machine is properly detected and installed and no errors are received during the install, but after the install, HPLIP shows the printer to be disconnected even though I do know that it is indeed connected properly. A reboot of the system does not fix the issue, I even installed the printer by specifying the location but it still didn't work.

Please run:

/usr/lib/cups/backend/hp

and post the output.

Also run the printingbuginfo script

https://wiki.ubuntu.com/PrintingBugInfoScript

However there doesn't appear to be a hardy repo for it yet...you could try changing the gutsy to hardy and giving that a shot..

Till any idea when there will be a hardy repo for the printingbuginfo script?

A

/usr/lib/cups/backend/hp gve me this:-

direct hp "Unknown" "HP Printer (HPLIP)"

The printingbuginfo output is attached.

Till Kamppeter (till-kamppeter) wrote :

I have discovered the same problem today. Something in the kernel or UDEV has changed which made HPLIP generally not seeing HP printers on USB anymore. I have observed it for 3 printers: HP PhotoSmart A710, HP LaserJet 3390, HP LaserJet 1020. These are very different models, so probably all HP printers are affected.

This is a severe problem, so I raise its priority to "Critical".

I also add tasks for UDEV and the kernel.

Changed in hplip:
importance: Undecided → Critical
status: New → Triaged
Changed in linux:
assignee: nobody → ubuntu-kernel-usb
importance: Undecided → Critical
milestone: none → hardy-alpha-3
status: New → Triaged
Changed in hplip:
milestone: none → hardy-alpha-3
Changed in udev:
importance: Undecided → Critical
milestone: none → hardy-alpha-3
status: New → Triaged
Changed in libusb:
importance: Undecided → Critical
milestone: none → hardy-alpha-3
status: New → Triaged
Till Kamppeter (till-kamppeter) wrote :

HPLIP accesses printers via libusb and not via the usblp kernel module. So the bug can be in

- Kernel: Lower-level USB modules
- UDEV: Problem in permission assignment of /dev/bus/usb/XXX/YYY files
- libusb (task added)
- HPLIP: Requirement for update to fit to recent changes

The "usb" backend of CUPS is able to find and access the printers, so the usblp kernel module seems to be OK, at least for HP printers.

I consider the problem critical because there is a loss of most important functionalities of HP printers and MF devices connected via USB:

- No borderless printing
- No scanning
- No memory card access
- No faxing
- No ink level check and nozzle cleaning

Ethernet/WLAN-connected HP devices are not affected.

I am using Hardy and did the last full update around five hours ago. I have also rebooted after yesterday's kernel update.

Till,

We've been waiting for hardy to become a little more mature to do our testing. However I'll take a look at this ASAP.

A

Steve Langasek (vorlon) wrote :

milestone changed to 8.04-beta; this bug needs to be fixed before release but shouldn't block an alpha release that's due out tomorrow while the nature of the problem is still up in the air.

Till, are you investigating this further on the hplip side, or do we need support from the kernel/udev folks?

FWIW, I've just tested with an HP PSC750; from hardy. The printer is detected fine when I connect it, though any print jobs stall in state 'pending' and are never printed with the autoconfigured hplip device. If I reconfigure it as a USB device instead of an hplip device, test page prints fine.

This is with hardy 2.6.24-2-generic/amd64, udev 117-3.

Changed in hplip:
milestone: hardy-alpha-3 → ubuntu-8.04-beta
Changed in libusb:
milestone: hardy-alpha-3 → ubuntu-8.04-beta
Changed in linux:
milestone: hardy-alpha-3 → ubuntu-8.04-beta
Changed in udev:
milestone: hardy-alpha-3 → ubuntu-8.04-beta
Till Kamppeter (till-kamppeter) wrote :

I am not sure in which component the bug is, therefore I have added all these components. I have also subscribed the HPLIP developers at HP so that they investigate the problem. The support of the kernel/udev/libusb folks is also needed. Everything was working fine before applying the general updates from yesterday and the kernel update from the day before yesterday. As these updates do not include HPLIP there is more probability that the bug is outside HPLIP.

Concerning the PSC750: It seems that for older models the problem also exists but for newer models it is even worse as they do not get detected at all.

Till Kamppeter (till-kamppeter) wrote :

I have tried to boot older kernel versions (instead of the current 2.6.24-3):

2.6.24-2: Problem persists.
2.6.22-14 (Kernel of Gutsy): HPLIP correctly detects the printers

So as a workaround one can simply boot the Gutsy kernel on Hardy systems which were updated from Gutsy.

This also shows that the problem is most probably in the kernel. I did all my tests with a Hardy system, I only booted different kernels.

I don't have a HP printer.

What is actually the problem? You assigned this to a huge number of packages, which suggests it's simply not working and you haven't done any detailed debugging?

The kernel has indeed changed the way that usb devices are exposed, they appear in a different section of /sys now -- if HPLIP is relying on /sys structure, that's a bug, it should be changed to use HAL instead, since /sys structure is not stable.

As far as I know, the /dev/bus/usb/XXX/YYY devices are unchanged.

Reset udev status to incomplete - this has not been confirmed as a udev bug, or triaged to understand the problem

Changed in udev:
status: Triaged → Incomplete

Dave, Raghu, Don, Aaron, can you check how HPLIP is finding devices? The new 2.6.24 kernel has changed the internal structure of the /sys/ file system which can perhaps interfere with the device detection by HPLIP. Consider also using HAL for device detection.

Ok I looked at a Hardy system.

You need to update your version of 55-hpmud.rules file with the latest the 55-hpmud.rules in the hplip 2.7.12 tar ball. I know Ubuntu uses a modified hpmud.rules file which is ok, but your copy is out-of-date. I have made some udev changes since the "usb_device" name has changed in the latest kernel.

I have a attached an updated 55-hpmud.rules file that should work.

Also you can remove the 45-hplip.rules file since it is redundant with 55-hpmud.rules file installed.

-dave

Changed in libusb:
status: Triaged → Invalid
Changed in linux:
status: Triaged → Invalid
Changed in udev:
status: Incomplete → Invalid
Changed in hplip:
status: Triaged → In Progress

Dave, I have tested your file and it works perfectly now, with and without 45-hplip.rules removed. Thank you.

I will package HPLIP 2.7.12 soon. For time up to then everyone who encounters this problem please replace /etc/udev/rules.d/55-hpmud.rules by the file which Dave has attached with the previous posting.

Changed in hplip:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 2.7.12-0ubuntu1

---------------
hplip (2.7.12-0ubuntu1) hardy; urgency=low

  * Now upstream release
     o PJL support for HP LaserJets for in-band status check
     o New print modes for LJJetReady device class (HP Color LaserJet
       3600/3500/3550).
     o Improvement of plug-in download by hp-setup.
     o Bug fixes, especially for fax.
     o New models supported: HP LaserJet M2727 MFP (printing only, no
       scanning or fax), HP LaserJet M1005 MFP (printing only, no scanning),
       HP LaserJet 1000/1005, HP Color LaserJet 3600/3500/3550, HP LaserJet
       9040.
  * debian/rules, debian/45-hplip.rules, debian/check_mfp_printer: Removed
    /etc/udev/rules.d/45-hplip.rules and check_mfp_printer, HP provides a
    solution from upstream now.
  * debian/55-hpmud.rules: Updated for compatibility with kernel 2.6.24 and
    newer (Ubuntu bug LP: #181242).
  * debian/patches/87_move_documentation.dpatch: Updated patch for new HPLIP
    version.

 -- Till Kamppeter <email address hidden> Sat, 12 Jan 2008 14:34:49 +0000

Changed in hplip:
status: Fix Committed → Fix Released
ozone baby (evilguard) wrote :

I have nearly the same problem. I have just installed Kubuntu 8.04 and I have all packages updated. My printer is HP LaserJet 1200. So I run hp-setup, choose USB, then my printer model appears - I choose it and click Next button. But the program doesn't respond and I get the following output:
Traceback (most recent call last):
  File "/usr/share/hplip/ui/setupform.py", line 258, in showPage
    self.updatePPDPage()
  File "/usr/share/hplip/ui/setupform.py", line 541, in updatePPDPage
    ppds = cups.getSystemPPDs()
  File "/usr/share/hplip/prnt/cups.py", line 243, in getSystemPPDs
    path = os.path.join(cups_ppd_path, ppd)
  File "/usr/lib/python2.5/posixpath.py", line 62, in join
    elif path == '' or path.endswith('/'):
AttributeError: 'NoneType' object has no attribute 'endswith'

Changed in hplip:
assignee: nobody → evilguard
status: Fix Released → New

This has been fixed in the HPLIP tip code, and will be publicly released in
our next release cycle. I can supply a patch if needed.

On Mon, Mar 10, 2008 at 2:54 AM, ozone baby <email address hidden> wrote:

> I have nearly the same problem. I have just installed Kubuntu 8.04 and I
> have all packages updated. My printer is HP LaserJet 1200. So I run
> hp-setup, choose USB, then my printer model appears - I choose it and click
> Next button. But the program doesn't respond and I get the following output:
> Traceback (most recent call last):
> File "/usr/share/hplip/ui/setupform.py", line 258, in showPage
> self.updatePPDPage()
> File "/usr/share/hplip/ui/setupform.py", line 541, in updatePPDPage
> ppds = cups.getSystemPPDs()
> File "/usr/share/hplip/prnt/cups.py", line 243, in getSystemPPDs
> path = os.path.join(cups_ppd_path, ppd)
> File "/usr/lib/python2.5/posixpath.py", line 62, in join
> elif path == '' or path.endswith('/'):
> AttributeError: 'NoneType' object has no attribute 'endswith'
>
>
> ** Changed in: hplip (Ubuntu)
> Assignee: (unassigned) => ozone baby (evilguard)
> Status: Fix Released => New
>
> --
> [Hardy]HP printer is not detected properly by HPLIP
> https://bugs.launchpad.net/bugs/181242
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Don, please provide the patch, as it is really an urgent bug for Hardy LTS (Long-Term Support).

dwelch91 (dwelch91) wrote :

On Mon, Mar 10, 2008 at 7:19 AM, Till Kamppeter <email address hidden>
wrote:

> Don, please provide the patch, as it is really an urgent bug for Hardy
> LTS (Long-Term Support).
>
> --
> [Hardy]HP printer is not detected properly by HPLIP
> https://bugs.launchpad.net/bugs/181242
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in hplip:
status: New → Triaged
ozone baby (evilguard) wrote :

installation of the printer went succesfully after applying patch, but I got anpther problem - the install printer is not available. I can see it in hp-toolbox, and when I send job to it - it doesn't print anything.

ozone baby (evilguard) wrote :

eldarik@eldarik-desktop:~$ hp-info

HP Linux Imaging and Printing System (ver. 2.8.2)
Device Information Utility ver. 3.4

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Using device: hp:/usb/HP_LaserJet_1200?serial=00CNC9076273

hp:/usb/HP_LaserJet_1200?serial=00CNC9076273

error: Unable to communicate with device (code=12): hp:/usb/HP_LaserJet_1200?serial=00CNC9076273
error: Error opening device (Device not found). Exiting.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 2.8.2-0ubuntu3

---------------
hplip (2.8.2-0ubuntu3) hardy; urgency=low

  * debian/patches/hp-setup_crash.dpatch: Fix crash of hp-setup (LP: #181242)
  * debian/patches/hp_clj_3600_best_color_mode.dpatch: Fix "Best" color mode of
    the HP LaserJet 35xx/36xx (LP: #200147).

 -- Till Kamppeter <email address hidden> Thu, 13 Mar 2008 12:08:52 +0100

Changed in hplip:
status: Triaged → Fix Released

I have applied the patch to fix the hp-setup crash which ozone baby has reported on 2008-03-10. ozone baby please check whether you are able to set up print queues with hp-setup and whether you are able to print. In case something does not work, report here and reopen the bug.

Martin Pitt (pitti) on 2008-03-13
Changed in libusb:
milestone: ubuntu-8.04-beta → none
Changed in linux:
milestone: ubuntu-8.04-beta → none
Changed in udev:
milestone: ubuntu-8.04-beta → none

I got the Hardy ISO for x64 yesterday, and this bug is still in there.

I can print without a problem, even print a test page through the HP toolbox, but it keeps reporting a communication issue with it and is not working properly.

Surely this cannot be hard to fix, like others stated on Gutsy it was working without a problem.

Btw, 2.8.2-0ubuntu3 doesn't show up in Synaptic in the x64 version of Hardy.

Jon Arnold (jonarnoldsemail) wrote :

The rules file mentioned above is identical to the one I have. I'm using a PSC 1400. I have the latest version of HPLIP.

My printer is detected and can print but none of the supply details or functions. hp-info gives
"error: Unable to communicate with device (code=12): hp:/usb/PSC_1400_series?serial=CN564B50PH04BN
error: Error opening device (Device not found). Exiting."

The toolbox GUI gives a "Device communication error" code 5012.

All of this worked fine in Gutsy...

Savvas Radevic (medigeek) wrote :

Hardy Heron 8.04 (alpha 5 to beta) updated
I also get this for my printer: HP Laserjet P1006
$ /usr/lib/cups/backend/hp
direct hp "Unknown" "HP Printer (HPLIP)"

the problem seems to be with libqt3-mt as the file attribute is 640 for one of its files
I have filed this as a separate bug:

$ ls -l /etc/qt3/
total 8
-rw-r----- 1 root root 761 2008-04-10 08:37 qt_plugins_3.3rc
-rw-r--r-- 1 root root 975 2008-01-21 21:01 qtrc

as a normal user:
$ hp-toolbox

HP Linux Imaging and Printing System (ver. 2.8.2)
HP Device Manager ver. 11.0

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

QSettings: failed to open file '/etc/qt3/qt_plugins_3.3rc'
error: Unable to communicate with device (code=12): hp:/usb/HP_LaserJet_P1006?serial=AC094VM
warning: Device not found
error: Unable to communicate with device (code=12): hp:/usb/HP_LaserJet_P1006?serial=AC094VM
warning: Device not found

with root priviledges it's normal:
$ gksu hp-toolbox

HP Linux Imaging and Printing System (ver. 2.8.2)
HP Device Manager ver. 11.0

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

I filed it as a separate bug for libqt3-mt bug 214962

Savvas Radevic (medigeek) wrote :

Actually no, I changed its file attributes to 644, but it still popped up the same message as a normal user.
Looks like for hp-toolbox, hp-info and /usr/lib/cups/backend/hp I require root priviledges:

$ sudo /usr/lib/cups/backend/hp
direct hp:/usb/HP_LaserJet_P1006?serial=AC094VM "HP LaserJet P1006" "HP LaserJet P1006 USB AC094VM HPLIP" "MFG:HP;MDL:HP LaserJet P1006;CLS:PRINTER;DES:HP LaserJet P1006;SN:AC094VM;"

Savvas Radevic (medigeek) wrote :
Savvas Radevic (medigeek) wrote :

/usr/lib/cups/backend/hp hp-info and hp-toolbox should ask or state that it requires root priviledges in order to function and output info properly.
Oh and system > preferences > hp toolbox should be in system > administration, since it's root-dependant

Changed in hplip:
status: Fix Released → Confirmed
Jon Arnold (jonarnoldsemail) wrote :

I can confirm that running all three of those with sudo fixes the problem.

Jon Arnold (jonarnoldsemail) wrote :

Also, I would be interested in knowing what the rational for this change was. I think it makes sense to require root privileges for adding/deleting printers, but it shouldn't for seeing their status.

Savvas Radevic (medigeek) wrote :

ok, so: they shouldn't ask for root privileges for information about the printer and the printer status

This problem where the HP devices are not working in the hp-toolbox is related to this bug:

https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/195782

Where the users need to be added to the "scanner" group for the device to work correctly with the hp-toolbox. This is because the scanner group adds additional permissions to the usb ports that does not come default. Till, Johannes, and the printing team are working on a solution regarding with how hal detects and assigns permissions to the HP devices.

If you add the user to the scanner group hp-toolbox will then work correctly.

This is a critical bug and there are 2-3 other threads going that have the same resolution. So either the scanner group needs to be added to the default user by default or the hal work around needs to be implemented before release...

I haven't seen an update from the printing team on this in a while..anyone have an update? Till?

You may notice that the bugs are reporting different problems but the solution is the same. So I'm reference back to the other bug because there has already been extensive conversation about this and the solution..

Aaron

Savvas Radevic (medigeek) wrote :

The device does work perfectly, at least for printing in my case. I'm the only user on this desktop machine, so my username was automatically added during updates/upgrades.
The only problem is that hp-toolbox and hp-info and /usr/lib/cups/backend/hp can't show the info about the printer and printer status when I am a normal user, while it shows ok with root privileges (gksu hplip-toolbox).

And I am included in the group:
$ cat /etc/group | grep -i "lp\|scan\|hp"
lp:x:7:
scanner:x:104:hplip
lpadmin:x:108:username

I even added my username in the lp group, it didn't make any change, the device in hplip-toolbox still has an a big red "x" next to it.

It looks like more of a usb permission problem to me:
$ lsusb
Bus 007 Device 001: ID 0000:0000
Bus 006 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 004: ID 046d:c016 Logitech, Inc. M-UV69a Optical Wheel Mouse
Bus 003 Device 001: ID 0000:0000

$ sudo lsusb
[sudo] password for username:
Bus 007 Device 008: ID 03f0:3e17 Hewlett-Packard
Bus 007 Device 001: ID 0000:0000
Bus 006 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 004: ID 046d:c016 Logitech, Inc. M-UV69a Optical Wheel Mouse
Bus 003 Device 001: ID 0000:0000

 If you add the user to the scanner group it should fix it...

Does it?

Aaron

Jon Arnold (jonarnoldsemail) wrote :

Yes adding myself to the scanner group fixes it.... Still kind of a pain. There should be instruction somewhere within the program telling people to do that if that is truly the desired process.

Savvas Radevic (medigeek) wrote :

it does fix it here too, thanks

ozone baby (evilguard) wrote :

I can confirm that bug is fixed. hp-toolbox doesn't show any errors, and hp-info gives correct output.

Colin Watson (cjwatson) on 2008-04-28
Changed in hplip:
milestone: ubuntu-8.04-beta → later
jlopezay (jlopezay) wrote :

I'm still with the problem. Maybe because, I'am not using correctly the patch (its my first time) Could somebody tell me what I have to do with the patch file?

I have then cups.py file in /usr/share/hplip/prnt/

Thanks.

Savvas Radevic (medigeek) wrote :

> I'm still with the problem. Maybe because, I'am not using correctly the
> patch (its my first time) Could somebody tell me what I have to do with
> the patch file?

No need to patch anymore, I think the problem was fixed properly in
official ubuntu hardy heron release.

You just need to add your username in the scanner group do this in
terminal: gksu gedit /etc/groups
Then find the line similar to this: scanner:x:104:hplip
Change to this: scanner:x:104:hplip,youruser

..where you add a comma and "youruser" to be your username. Save and
close, log out and log in again, it should be fixed

For me the remaining problem looks like (already fixed) bug #195782. Is this correct?

SlackRider (bsdreko) wrote :

I have had the same problem with a hp1020 laser jet printer the problem was with hardy kubuntu 8.04 the problem was that the hplip setup detected the printer installed it but then the printer can't be probed and the firmware can't be loaded this was due to the following
root account is disabled (locked) in ubuntu and if u take a closer look to the udev rules for hp you will see that it's all owned by root also the device lp0 in both /dev/usb/lp0 and /dev/lp0 are both owned by root (Try ls -l /dev/lp0)
so this wouldn't have happened with bsd however it happens here with Ubuntu there are actually two solutions for this the first is

to change the 55-phmud.rules as david did here for he changed all the users to own part in the rules to user lp (make sure you have user lp :) ) but the trick here is to put the file in the installation dir (udev dir) and then reinstall after that it should work just fine

the second solution is

just go to user management unlock root then add all privileges to root to access all open a terminal and su to root when u login each time and the printer should work just fine with the original install

This is just a temp solution i recommend anybody here in touch with HP LIP to talk to them about modifying the 55 files in the rules to suit all (meaning no root privileges)

David Mills (d-mills) wrote :

OK, just FYI this also affects network printers.

I can currently print using socket:x.x.x.x:9100 uris but hp:/net/xxx?ip=x.x.x.x uris don't work

ozone baby (evilguard) wrote :

I am still expierencing this issue. It's occasional now - sometimes printer works properly, sometimes it is not detected (hp-info messages an error). Right at the moment I am not able to reproduce the bug, because it is printing now, but I don't know when it stops working again

Alex Krjuger (krjuger) wrote :

I am still have a problem.
Printer - HP Laserjet 1005. My printer is detected but can't print...

melodyoutside (melodyoutside) wrote :

I think this actually may be my issue, and I had posted a question a few days ago (nobody's responded)...but this looks like it. (See Question#36642).

 ozone baby wrote on 2008-05-12: (permalink)

I am still expierencing this issue. It's occasional now - sometimes printer works properly, sometimes it is not detected (hp-info messages an error). Right at the moment I am not able to reproduce the bug, because it is printing now, but I don't know when it stops working again

<that goes for me too. Right now it's in the "not printing stage", and it says there is a communication error 5012. About 3 hours ago, I could print fine, except that the duplexer wasn't working (this is a new printer!). It's an HP All-in-one Officejet Pro L7680. I noticed that most of the printers in this thread are all laser jets- this one is an ink jet.

Any suggestions?

Can Kaya (ckaya) wrote :

I still see the "not detected" popup.

I really can't understand how an update can cause such a big problem that affects common/basic/everyday tasks like printing. Edgy had been considered to be the buggiest release of Ubuntu ever, but in my opinion Hardy -despite of being an LTS release- has already gotten the first place.

Can Kaya (ckaya) wrote :

I downloaded the latest hplip automatic installer from http://hplip.sourceforge.net/ , but it doesn't help. This one only seems to remove the notification, but printing status of documents seem to be "processing" forever.

sven 22 (sjhoward-telus) wrote :

On two new installs of Hardy 32-bit 8.04, the HP1000 driver is installed but never prints, despite indicating "processing." Status is eventually reported as "complete"

sven 22 (sjhoward-telus) wrote :

Hello again.

I tried adding adding the user name to the scanner line in /etc/group, as Jon and Savvas have discussed, but the HP printer still will not print.

Hello,
I think this is the right place to write what I've experienced.

I am running Hardy Server ed. w/ Hp Deskjet 840C.

Installed hplip, ordered hp-testpage, it didn't work.
Running hp-check showed 8 dependency errors. All missed packages were not X-windows related.

Now, I have installed hplip from hplip.sf.net, and it works perfectly. The crucial negative aspect of this installment is that I cannot un-install this package from aptitude.
Will check-install work in this case?

Interestingly, this has removed the ubuntu's hplip.

I've seen that hplip do not depend on any ppd package. I think it should be fixed.

Forest (fdenger-gmail) wrote :

ok here is my experience, I installed a photosmart 7260 printer via USB. It auto detected perfeclly, everything fine. Printed a few pages. Then tried to print from a windows vista system on my network, and it gave a media jam error. After this, no print jobs could ever be done on the printer until I unplug the printer, unplug the USB, then replug the printer to power and then replug usb. If I tried to just cycle power on the printer it would continue to lock up the printer.

Ok, so I did this, and printing from linux seems to work fine. But after a few pages (like 3-4 pages) it stoped being responsive again. So I did the whole usb/power cord unplug thing and it works. So I would try another print from a windows sytem on my same subnet, and then thats when it crashes again. with media jam error. Every time I do a print from windows on a remote system I got this error (couldn't test with a linux system remotely tho). Does not sound like a permissions problem at all, untill i came across this bug report!!!

 ....and it definitely was a permissions problem as far as I can tell. First, let me explain what I did to "work around" the problem:

"the second solution is just go to user management unlock root then add all privileges to root to access all open a terminal and su to root when u login each time and the printer should work just fine with the original install

This is just a temp solution i recommend anybody here in touch with HP LIP to talk to them about modifying the 55 files in the rules to suit all (meaning no root privileges)"

Ok, so I followed this advice to the letter from a previous post to this bug report (not sure why opening a terminal window to root would do any good, but oh well). And now the printer prints from the windows system 100% of the time and the linux system (locally) 100% of the time... But do I need to continue to keep a root terminal opened at all time until this bug is fixed?

Forest (fdenger-gmail) wrote :

Ok, to update my last post. I logged out and logged back in, and evne opened a root window, (terminal, su to root) and now printing from the remote system doesn't work again and it locks up the printer.... I can't figure this one out. I have no idea why it worked yesterday and not today. I tried a complete reboot and still no go. This forum in this bug report looks like several different problems, but the one I'm experiencing is that the printer locks up when you send a job to it from a remote system via http cups printing, but not when I send a job locally to it. Strange.

jan (jan-ubuntu-h-i-s) wrote :

ForestL Please look at the log file. Check if this behavior is not related to ANOTHER bug:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/218921

Konrad Materka (kmaterka) wrote :

I had similar issue wit HP DJ 845C - very old, but good printer. It is USB printer.

Printer didn't worked, hp toolbox show communication error 5012. After usb cable printer was working, printer dwo documents and again stopped (with the same error in hp toolbox). Cups interface (localhost:631) and KDE frontend simply shows, that document is "processed".

I removed AppArmor, which caused problem with other printer - 710C (parraler port, not usb) , I will see if it helps. 710C is not supported by HPLIP, but removing apparmor (or simply removing apparmor rules for cups) helped. This was long time ago and I can't test apparmor now - maybe in 3 or 4 weeks.

Konrad Materka (kmaterka) wrote :

AppArmor issue may be connected with bug 218921.
Problems commented on this bug may be caused by few different problems.

some logs with may point apparmor:

Aug 29 12:01:14 mazurkiewicz-desktop DeskJet_845C?serial=CN1741M0BTSX: prnt/backend/hp.c 496: unable to connect hpssd socket 2207: Connection refused
Aug 29 12:01:14 mazurkiewicz-desktop DeskJet_845C?serial=CN1741M0BTSX: io/hpmud/musb.c 135: unable get_string_descriptor -71: Protocol error
Aug 29 12:01:14 mazurkiewicz-desktop DeskJet_845C?serial=CN1741M0BTSX: io/hpmud/musb.c 603: invalid product id string ret=-71
Aug 29 12:01:14 mazurkiewicz-desktop DeskJet_845C?serial=CN1741M0BTSX: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Aug 29 12:01:14 mazurkiewicz-desktop DeskJet_845C?serial=CN1741M0BTSX: io/hpmud/musb.c 603: invalid product id string ret=-1
Aug 29 12:01:14 mazurkiewicz-desktop DeskJet_845C?serial=CN1741M0BTSX: io/hpmud/musb.c 1058: unable to open hp:/usb/DeskJet_845C?serial=CN1741M0BTSX
Aug 29 12:01:14 mazurkiewicz-desktop kernel: [ 761.001335] usb 1-2.3: usbfs: USBDEVFS_CONTROL failed cmd hp rqt 128 rq 6 len 255 ret -71
Aug 29 12:01:14 mazurkiewicz-desktop DeskJet_845C?serial=CN1741M0BTSX: prnt/backend/hp.c 496: unable to connect hpssd socket 2207: Connection refused
Aug 29 12:01:14 mazurkiewicz-desktop DeskJet_845C?serial=CN1741M0BTSX: prnt/backend/hp.c 636: INFO: open device failed; will retry in 30 seconds...
Aug 29 12:01:14 mazurkiewicz-desktop kernel: [ 761.086439] audit(1220004074.224:5): type=1503 operation="inode_permission" requested_mask="::rw" denied_mask="::rw" name="/dev/tty" pid=9387 profile="/usr/sbin/cupsd" namespace="default"
Aug 29 12:01:14 mazurkiewicz-desktop kernel: [ 761.517457] usb 1-2.3: usbfs: USBDEVFS_CONTROL failed cmd hpijs rqt 128 rq 6 len 255 ret -71
Aug 29 12:01:14 mazurkiewicz-desktop hpijs: io/hpmud/musb.c 135: unable get_string_descriptor -71: Protocol error
Aug 29 12:01:14 mazurkiewicz-desktop hpijs: io/hpmud/musb.c 603: invalid product id string ret=-71
Aug 29 12:01:14 mazurkiewicz-desktop hpijs: io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Aug 29 12:01:14 mazurkiewicz-desktop hpijs: io/hpmud/musb.c 603: invalid product id string ret=-1
Aug 29 12:01:14 mazurkiewicz-desktop hpijs: io/hpmud/musb.c 1058: unable to open hp:/usb/DeskJet_845C?serial=CN1741M0BTSX

Konrad Materka (kmaterka) wrote :

Invalidate my comments :P Probably a hardware problem, broken mobo... :(

I have the experiences described here however my printer is ethernet connected.
*** I can ping the printer without troubles.
*** I can browse the printer web console without trouble.
*** I can print test pages from the web console without troubles.
*** I have tried reboot of the laptop and the printer without success.
*** Queued print jobs show pending or printing without output.
*** Yes, the mundane user is part of the scanner group.

After install, it worked fine from a wifi connected Ubuntu 8.04 Hardy laptop
(Emperor Linux Raven tablet).
In routine operation, i took the laptop offline. Now cups reports that the
printer is not connected. None of my ministrations have restored the "connection."

I have an HP OfficeJet 7310 connected using 100baseT ethernet.

~~~ Saint 0;-D

René Brink (rene-brink) wrote :
Download full text (5.3 KiB)

I just bought a brand new PH Photosmart C6280 All-in-one and I have the problems explained in the origtional poster of this bug. Iam using HArdy 8.04-1 (with all updates).

What works: detecting and Installing

If I print to the printer I get the message "printer not connected" or "Paper jam". My logs (messages, syslog, etc.) are filling up with messages of errors. Sometimes after a few minutes a piece of paper is comming out of the printer with a single line of a document, but mostly only garbage.

lsmod | grep usb

usb_storage 73664 0
libusual 19108 1 usb_storage
usblp 15872 0
usbhid 32128 0
hid 38784 1 usbhid
scsi_mod 151436 6 usb_storage,sbp2,sr_mod,sg,sd_mod,libata
usbcore 146412 8 usb_storage,libusual,usblp,wacom,usbhid,ehci_hcd,ohci_hcd

tail -f /var/log/messages

Dec 7 12:14:46 test-desktop kernel: [14975.146143] usb 3-3: reset high speed USB device using ehci_hcd and address 48
Dec 7 12:14:47 test-desktop kernel: [14975.689654] usb 3-3: reset high speed USB device using ehci_hcd and address 48
Dec 7 12:14:47 test-desktop kernel: [14976.233198] usb 3-3: reset high speed USB device using ehci_hcd and address 48
Dec 7 12:14:48 test-desktop kernel: [14976.752771] usb 3-3: reset high speed USB device using ehci_hcd and address 48
Dec 7 12:14:48 test-desktop kernel: [14977.162925] usb 3-3: USB disconnect, address 48
Dec 7 12:14:48 test-desktop kernel: [14977.163225] usblp0: removed
Dec 7 12:14:48 test-desktop kernel: [14977.276368] usb 3-3: new high speed USB device using ehci_hcd and address 49
Dec 7 12:14:49 test-desktop kernel: [14977.819875] usb 3-3: new high speed USB device using ehci_hcd and address 50
Dec 7 12:14:49 test-desktop kernel: [14978.363426] usb 3-3: new high speed USB device using ehci_hcd and address 51
Dec 7 12:14:50 test-desktop kernel: [14978.884259] usb 3-3: new high speed USB device using ehci_hcd and address 52
Dec 7 12:15:08 test-desktop kernel: [14997.399541] usb 3-3: new high speed USB device using ehci_hcd and address 53
Dec 7 12:15:09 test-desktop kernel: [14997.943085] usb 3-3: new high speed USB device using ehci_hcd and address 54
Dec 7 12:15:09 test-desktop kernel: [14998.486632] usb 3-3: new high speed USB device using ehci_hcd and address 55
Dec 7 12:15:10 test-desktop kernel: [14999.006200] usb 3-3: new high speed USB device using ehci_hcd and address 56

If I look into the syslog I see that the linux kernel is constantly claming that the aparatus is not accepting the address:

tail -f /var/log/syslog

Dec 7 12:26:29 test-desktop hal_lpadmin: Found configured printer: Photosmart_C6200_USB
Dec 7 12:26:29 test-desktop NetworkManager: <debug> [1228649189.220612] nm_hal_device_removed(): Device removed (hal udi is '/org/freedesktop/Hal/devices/usb_device_3f0_6a11_MY87UHH31J0506_if1_printer_MY87UHH31J0506').
Dec 7 12:26:29 test-desktop NetworkManager: <debug> [1228649189.232485] nm_hal_device_removed(): Device removed (hal udi is '/org/freedesktop/Hal/devices/usb_device_3f0_6a11_MY87UHH31J0506_if1').
Dec 7 12:26:29 test-desktop NetworkManager: <debug> [1228649189.257562] ...

Read more...

Changed in hplip (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Changed in libusb (Ubuntu):
status: Invalid → Fix Released
Changed in linux (Ubuntu):
status: Invalid → Fix Released
Changed in udev (Ubuntu):
status: Invalid → Fix Released
Changed in hplip (Ubuntu):
status: Confirmed → Fix Released
Changed in hplip (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released

I did not make these changes.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers