HP ProBook 470 G5, LED's in Hotkeys f5, f8 and f11 without function

Bug #1811254 reported by kuehhe1 on 2019-01-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Anthony Wong
Bionic
Undecided
Unassigned

Bug Description

Notebook: HP ProBook 470 G5 (3KZ03EA)
Distro: Linux Mint 19.1 Tessa
Desktop: Cinnamon 4.0.8
Kernel: 4.15.0-43-generic x86_64 bits: 64

The functions of all hotkeys are given, but the LED's in the [f5] Speaker-mute, [f8] Micro-mute and [f11] Wireless on/off Buttons do not show the status. Disturbing is also the LED in [f11] permanently lit.

This is my first bug report to launchpad and I ask for leniency and troubleshooting support.

I created 12 logs, unfortunately the upload did not work at once:

acpi_listen.txt
apt-cache-policy
dmesg.log
lsb_release
lsinput.log
lspci-vnvn.log
rfkill_list.txt
udev-db.txt
version.log
xev keypress test.txt
xkbcomp.txt
xkbmap.txt

Previous attempts:
My on-board search for other HP ProBook Hotkey LED-issues led me to this bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1705586

but the solution to the file: /etc/modprobe.d/alsa-base.conf
to supplement the entry: options snd-hda-intel mode = mute-led-gpio

did not lead to the solution here. Presumably, the failure results from a different ubuntu-version and/or a another kernel.

Information: This problem was previously discussed on linuxmintusers.de: https://www.linuxmintusers.de/index.php?topic=51737.msg710376#msg710376

kuehhe1 (kuehhe1) wrote :
kuehhe1 (kuehhe1) wrote :
kuehhe1 (kuehhe1) wrote :
kuehhe1 (kuehhe1) wrote :
kuehhe1 (kuehhe1) wrote :
kuehhe1 (kuehhe1) wrote :
kuehhe1 (kuehhe1) wrote :
kuehhe1 (kuehhe1) wrote :
kuehhe1 (kuehhe1) wrote :
kuehhe1 (kuehhe1) wrote :
kuehhe1 (kuehhe1) wrote :
description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: bionic
kuehhe1 (kuehhe1) on 2019-01-10
description: updated
summary: - LED's in Hotkey f5, f8 ans f11 without function
+ LED's in Hotkey f5, f8 and f11 without function
description: updated
kuehhe1 (kuehhe1) on 2019-01-10
description: updated
kuehhe1 (kuehhe1) on 2019-01-10
description: updated
kuehhe1 (kuehhe1) on 2019-01-10
summary: - LED's in Hotkey f5, f8 and f11 without function
+ HP ProBook 470 G5, LED's in Hotkeys f5, f8 and f11 without function
kuehhe1 (kuehhe1) wrote :
kuehhe1 (kuehhe1) wrote :

Hello,
my on-board search for other hotkey LED-issues led me to this bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1705586

but the solution to the file: /etc/modprobe.d/alsa-base.conf

to supplement the entry: options snd-hda-intel mode = mute-led-gpio

did not lead to the solution here. Presumably, the failure results from a different ubuntu-version and/or a another kernel.

kuehhe1 (kuehhe1) on 2019-01-15
description: updated
description: updated
kuehhe1 (kuehhe1) on 2019-01-15
description: updated
kuehhe1 (kuehhe1) on 2019-01-16
description: updated
Anthony Wong (anthonywong) wrote :

The correct line to put in /etc/modprobe.d/alsa-base.conf should be:
options snd-hda-intel model=mute-led-gpio
Please correct it and try again.

Please also upload the output from alsa-info (run alsa-info in a terminal).

kuehhe1 (kuehhe1) wrote :

Hello Anthony Wong,
many, many thanks for your reply.

I have just corrected it, now the LED's in the Hotkey's [f6] speaker-mute and [f8] micro-mute function when pressed the keys.

I have tested the alsa-info in terminal, the output-file: alsa-info.txt.NvwoSl3f4d is attached.

Now only a correction for the LED in Hotkey [f11] Wlan On-Off is missing. Is there hope?

best regards
Helmut Kühnel

Anthony Wong (anthonywong) wrote :

Is F11 LED stayed on when BOTH wlan and bluetooth are off?

Changed in linux (Ubuntu):
assignee: nobody → Anthony Wong (anthonywong)
importance: Undecided → Medium
kuehhe1 (kuehhe1) wrote :

Yes, the f11 LED is always lit, even if Wi-Fi and Bluetooth are disabled.

kuehhe1 (kuehhe1) wrote :

Whereby it would be correct in case of deactivation of Wlan or Bluetooth if the LED lights up, at least it is so under Windows10.

Anthony Wong (anthonywong) wrote :

Can you please download the kernel packages from https://people.canonical.com/~ypwong/lp1811254/ and install them with 'dpkg -i *.deb', reboot to this test kernel, and then see if it fixes your speaker and mic mute LED problem?
I need time to fix the F11 LED at the moment.

kuehhe1 (kuehhe1) wrote :

The problem is that the LED in f11 is always lit.

Important info: the LED is only off when I reboot with active Wlan / Bluetooth in Windows10 to Ubuntu.In Ubuntu it is then off and does not change even after pressing the F11 their status.

Anthony Wong (anthonywong) wrote :

Before you boot into the test kernel in #20, please remove "options snd-hda-intel model=mute-led-gpio" from /etc/modprobe.d/alsa-base.conf first.
If it works, I will send the proper fix to upstream so that you no longer need to modify /etc/modprobe.d/alsa-base.conf.

kuehhe1 (kuehhe1) wrote :

Ok, I'm trying to install the kernel packages and removee before "options snd-hda-intel model=mute-led-gpio" from /etc/modprobe.d/alsa-base.conf first.

I will get back to you later....

Many Thanks for your activity

kuehhe1 (kuehhe1) wrote :

Hallo Anthony Wong,
I downloaded the kernel packages from https://people.canonical.com/~ypwong/lp1811254/ and installed them with 'dpkg -i * .deb'. After restarting this test kernel, Function will see the LED's for speaker and microphone mute. After each hotkey actuation, the LED also changes from On> <Off to its status.

Its OK, very god job.

One question, the update management provides the kernel: linux-meta (4.15.0.43.45) bionic; urgency = medium to upgrade. Should I ignore that?

Best Regards
Helmut

kuehhe1 (kuehhe1) wrote :

in the attached the changed current alsa-base.config.txt with commented out # line:
#options snd-hda-intel model=mute-led-gpio

Best Regards
Helmut

Anthony Wong (anthonywong) wrote :

Thanks for verification. As to your question regarding linux-meta (4.15.0.43.45), it is an older version and you can ignore that.

kuehhe1 (kuehhe1) wrote :

Hallo Anthony Wong,
thanks for your reply.

A first question, through the test kernel comes the Update Manager confused and shows me that although the kernel 4.15.0-43 is installed the kernel 4.15.0-43 can be installed. Could I reinstall the standard kernel and then make the corection in "/etc/modprobe.d/alsa-base.conf" and insert "options snd-hda-intel model=mute-led-gpio"?

kuehhe1@HP470:~$ dpkg -l *4.15.0-43* | egrep '^ii '
ii linux-headers-4.15.0-43 4.15.0-43.46 all Header files related to Linux kernel version 4.15.0
ii linux-headers-4.15.0-43-generic 4.15.0-43.46lp1811254 amd64 Linux kernel headers for version 4.15.0 on 64 bit x86 SMP
ii linux-image-unsigned-4.15.0-43-generic 4.15.0-43.46lp1811254 amd64 Linux kernel image for version 4.15.0 on 64 bit x86 SMP
ii linux-modules-4.15.0-43-generic 4.15.0-43.46lp1811254 amd64 Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
ii linux-modules-extra-4.15.0-43-generic 4.15.0-43.46lp1811254 amd64 Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP

But I have one more question, you say: "I need time to fix the F11 LED at the moment." Is this problem also being addressed in this topic, or do I have to send a new Bug-Report?

And then you say: "I will send the proper fix to upstream so that you no longer need to modify /etc/modprobe.d/alsa-base.conf." Does that mean that this fix will later be included in all kernels or does it concern a specific fix for alsa?

Thanks again for your support and have a nice weekend.
Best Regards
Helmut

Hi,

On Sat, 19 Jan 2019 at 15:20, kuehhe1 <email address hidden> wrote:

> Hallo Anthony Wong,
> thanks for your reply.
>
> A first question, through the test kernel comes the Update Manager
> confused and shows me that although the kernel 4.15.0-43 is installed
> the kernel 4.15.0-43 can be installed. Could I reinstall the standard
> kernel and then make the corection in "/etc/modprobe.d/alsa-base.conf"
> and insert "options snd-hda-intel model=mute-led-gpio"?
>

Yes, you should reinstall the original kernel to replace the test kernel
provided by me, and you have to add back that line to alsa-base.conf so
that LEDs will work.

>
> kuehhe1@HP470:~$ dpkg -l *4.15.0-43* | egrep '^ii '
> ii linux-headers-4.15.0-43 4.15.0-43.46 all
> Header files related to Linux kernel version 4.15.0
> ii linux-headers-4.15.0-43-generic 4.15.0-43.46lp1811254 amd64
> Linux kernel headers for version 4.15.0 on 64 bit x86 SMP
> ii linux-image-unsigned-4.15.0-43-generic 4.15.0-43.46lp1811254 amd64
> Linux kernel image for version 4.15.0 on 64 bit x86 SMP
> ii linux-modules-4.15.0-43-generic 4.15.0-43.46lp1811254 amd64
> Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
> ii linux-modules-extra-4.15.0-43-generic 4.15.0-43.46lp1811254 amd64
> Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
>
>
> But I have one more question, you say: "I need time to fix the F11 LED at
> the moment." Is this problem also being addressed in this topic, or do I
> have to send a new Bug-Report?
>

I suggest you to report the F11 LED issue to upstream kernel at
https://bugzilla.kernel.org/enter_bug.cgi?product=Platform%20Specific%2FHardware
.

>
> And then you say: "I will send the proper fix to upstream so that you no
> longer need to modify /etc/modprobe.d/alsa-base.conf." Does that mean
> that this fix will later be included in all kernels or does it concern a
> specific fix for alsa?
>

This fix will be included in all kernels in the future, but that will take
some time as it takes time to backport.

kuehhe1 (kuehhe1) wrote :

Hello Anthony Wong,
ok, then I'll suggest you:
1. i w'll reinstall the test kernel, install the old kernel and modify /etc/modprobe.d/alsa-base.conf to "options snd-hda-intel model = mute-led-gpio" ;)
2. i follow your suggestion and report the f11 LED error to: https://bugzilla.kernel.org/enter_bug.cgi?product=Platform Specific / Hardware ...
3. and see when their update will flow into future kernels. ;)

I assume that this Thread / Bug is closed and thank you for your great support.

Best Regards
Helmut

kuehhe1 (kuehhe1) wrote :

Hallo Anthony Wong,
before, a copy paste error had crept in again.
Correctly i modify with: "options snd-hda-intel model=mute-led-gpio" ;)

Info: the standard Kernel 4.15.0-43.46 is installed and aktiv.

i has report the F11 LED issue to upstream kernel at: https://bugzilla.kernel.org/show_bug.cgi?id=202367 and wait for Response now. ;)

Best Regards
Helmut

Launchpad Janitor (janitor) wrote :
Download full text (12.4 KiB)

This bug was fixed in the package linux - 4.19.0-13.14

---------------
linux (4.19.0-13.14) disco; urgency=medium

  * linux: 4.19.0-13.14 -proposed tracker (LP: #1815103)

  * linux-buildinfo: pull out ABI information into its own package
    (LP: #1806380)
    - [Packaging] autoreconstruct -- base tag is always primary mainline version

  * [Packaging] Allow overlay of config annotations (LP: #1752072)
    - [Packaging] config-check: Add an include directive

  * Disco update: 4.19.20 upstream stable release (LP: #1815090)
    - Fix "net: ipv4: do not handle duplicate fragments as overlapping"
    - drm/msm/gpu: fix building without debugfs
    - ipv6: Consider sk_bound_dev_if when binding a socket to an address
    - ipv6: sr: clear IP6CB(skb) on SRH ip4ip6 encapsulation
    - ipvlan, l3mdev: fix broken l3s mode wrt local routes
    - l2tp: copy 4 more bytes to linear part if necessary
    - l2tp: fix reading optional fields of L2TPv3
    - net: ip_gre: always reports o_key to userspace
    - net: ip_gre: use erspan key field for tunnel lookup
    - net/mlx4_core: Add masking for a few queries on HCA caps
    - netrom: switch to sock timer API
    - net/rose: fix NULL ax25_cb kernel panic
    - net: set default network namespace in init_dummy_netdev()
    - ravb: expand rx descriptor data to accommodate hw checksum
    - sctp: improve the events for sctp stream reset
    - tun: move the call to tun_set_real_num_queues
    - ucc_geth: Reset BQL queue when stopping device
    - net: ip6_gre: always reports o_key to userspace
    - sctp: improve the events for sctp stream adding
    - net/mlx5e: Allow MAC invalidation while spoofchk is ON
    - ip6mr: Fix notifiers call on mroute_clean_tables()
    - Revert "net/mlx5e: E-Switch, Initialize eswitch only if eswitch manager"
    - sctp: set chunk transport correctly when it's a new asoc
    - sctp: set flow sport from saddr only when it's 0
    - virtio_net: Don't enable NAPI when interface is down
    - virtio_net: Don't call free_old_xmit_skbs for xdp_frames
    - virtio_net: Fix not restoring real_num_rx_queues
    - virtio_net: Fix out of bounds access of sq
    - virtio_net: Don't process redirected XDP frames when XDP is disabled
    - virtio_net: Use xdp_return_frame to free xdp_frames on destroying vqs
    - virtio_net: Differentiate sk_buff and xdp_frame on freeing
    - CIFS: Do not count -ENODATA as failure for query directory
    - CIFS: Fix trace command logging for SMB2 reads and writes
    - CIFS: Do not consider -ENODATA as stat failure for reads
    - fs/dcache: Fix incorrect nr_dentry_unused accounting in shrink_dcache_sb()
    - iommu/vt-d: Fix memory leak in intel_iommu_put_resv_regions()
    - selftests/seccomp: Enhance per-arch ptrace syscall skip tests
    - NFS: Fix up return value on fatal errors in nfs_page_async_flush()
    - ARM: cns3xxx: Fix writing to wrong PCI config registers after alignment
    - arm64: kaslr: ensure randomized quantities are clean also when kaslr is off
    - arm64: Do not issue IPIs for user executable ptes
    - arm64: hyp-stub: Forbid kprobing of the hyp-stub
    - arm64: hibernate: Clean the __hyp_text to PoC after resume
    - gpio: altera...

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
kuehhe1 (kuehhe1) wrote :

Hello and hello,
many thanks for the bug fix. After installing kernel 4.19.19, the hotkey LED [f5] and [f8] will now work. I've just upgraded to kernel 4.19.24 and that's what the LEDs work with. :)

PS: My bug report because of the hotkey LED [f11] Wlan On-Off on: https://bugzilla.kernel.org/show_bug.cgi?id=202367#c0 is still unanswered

Many thanks and best regards to Antony Wong and the team
kuehhe1

Changed in linux (Ubuntu Bionic):
status: New → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
kuehhe1 (kuehhe1) wrote :

At that time the kernel 4.19.24 proposed by launchpad and installed with Ukuu already solved the problem. With the current kernel 4.15.0-58 the problem still exists.

 Meanwhile, I use the kernel 5.0.0-25, so or at least these two (2) bugs are fixed as well.

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
status: Fix Released → Confirmed
Changed in linux (Ubuntu):
status: Fix Released → Confirmed
kuehhe1 (kuehhe1) on 2019-08-17
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Bionic):
status: Confirmed → Fix Released

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial

Hi @kuehhe1,

Please do not change the status of the bug tasks to 'Fix Released', this is done automatically by the Launchpad bot when the fix is available in -updated.

The comment regarding the verification is asking for tests with the Bionic kernel currently in -proposed, which is 4.15.0-60.67. Version 4.15.0-58.64 doesn't contain the fix, so it's expected to fail. Would you be able to test the fix again with kernel 4.15.0-60.67?

Thank you.

Changed in linux (Ubuntu Bionic):
status: Fix Released → Fix Committed
kuehhe1 (kuehhe1) wrote :

Hallo,
I was able to install according to the instructions: https://wiki.ubuntu.com/Testing/EnableProposed the kernel 4.15.0-60.67 and test successfully. The kernel now offers the desired LED hotkey support without option: options snd-hda-intel mode = mute-led-gpio in: /etc/modprobe.d/alsa-base.conf.

inxi -S
System: Host: HP470 Kernel: 4.15.0-60-generic x86_64 bits: 64 Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina

dpkg -l | grep linux-image
ii linux-image-4.15.0-58-generic 4.15.0-58.64 amd64 Signed kernel image generic
ii linux-image-4.15.0-60-generic 4.15.0-60.67 amd64 Signed kernel image generic
ii linux-image-generic 4.15.0.60.62 amd64 Generic Linux kernel image

Great work, all good, Many Thanks

kuehhe1 (kuehhe1) wrote :

Hallo again,
after installing kernel 4.15.0-60.67, the hotkey LED [f5] and [f8] will now work.

But the hotkey LED [f11] Wlan On-Off is allways on

PS: My bug report because of the hotkey LED [f11] Wlan On-Off on: https://bugzilla.kernel.org/show_bug.cgi?id=202367#c0 is still unanswered

Many thanks and best regards
kuehhe1

kuehhe1 (kuehhe1) on 2019-08-28
Changed in linux (Ubuntu Bionic):
status: Fix Committed → Confirmed

Hi @kuehhe1,

Thank you for your feedback.

Based on your comment #40, I am going to mark the verification failed for Bionic and the Launhpad bot will mark the bug as 'Fix Released' once the kernel is promoted to -updated. After that happens, please feel free to re-open it so we can work on the issue that's still present for [f11].

Thank you.

tags: added: verification-failed-bionic
removed: verification-needed-bionic
kuehhe1 (kuehhe1) wrote :

Hello Kleber Sacilotto de Souza,

regarding the current bug with [f11],
how do I recognize that the kernel was upgraded to "-updated"?

I am also unclear which attitude (status) for (Bionic) I have to choose afterwards. Unfortunately, this is the first cooperation with bugs.launchpad.net so all these questions.

Best regards
kuehhe1

Launchpad Janitor (janitor) wrote :
Download full text (235.3 KiB)

This bug was fixed in the package linux - 4.15.0-60.67

---------------
linux (4.15.0-60.67) bionic; urgency=medium

  * bionic/linux: 4.15.0-60.67 -proposed tracker (LP: #1841086)

  * [Regression] net test from ubuntu_kernel_selftests failed due to bpf test
    compilation issue (LP: #1840935)
    - SAUCE: Fix "bpf: relax verifier restriction on BPF_MOV | BPF_ALU"

  * [Regression] failed to compile seccomp test from ubuntu_kernel_selftests
    (LP: #1840932)
    - Revert "selftests: skip seccomp get_metadata test if not real root"

  * Packaging resync (LP: #1786013)
    - [Packaging] resync getabis

linux (4.15.0-59.66) bionic; urgency=medium

  * bionic/linux: 4.15.0-59.66 -proposed tracker (LP: #1840006)

  * zfs not completely removed from bionic tree (LP: #1840051)
    - SAUCE: (noup) remove completely the zfs code

  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts

  * [18.04 FEAT] Enhanced hardware support (LP: #1836857)
    - s390: report new CPU capabilities
    - s390: add alignment hints to vector load and store

  * [18.04 FEAT] Enhanced CPU-MF hardware counters - kernel part (LP: #1836860)
    - s390/cpum_cf: Add support for CPU-MF SVN 6
    - s390/cpumf: Add extended counter set definitions for model 8561 and 8562

  * ideapad_laptop disables WiFi/BT radios on Lenovo Y540 (LP: #1837136)
    - platform/x86: ideapad-laptop: Remove no_hw_rfkill_list

  * Stacked onexec transitions fail when under NO NEW PRIVS restrictions
    (LP: #1839037)
    - SAUCE: apparmor: fix nnp subset check failure when, stacking

  * bcache: bch_allocator_thread(): hung task timeout (LP: #1784665) // Tight
    timeout for bcache removal causes spurious failures (LP: #1796292)
    - SAUCE: bcache: fix deadlock in bcache_allocator

  * bcache: bch_allocator_thread(): hung task timeout (LP: #1784665)
    - bcache: never writeback a discard operation
    - bcache: improve bcache_reboot()
    - bcache: fix writeback target calc on large devices
    - bcache: add journal statistic
    - bcache: fix high CPU occupancy during journal
    - bcache: use pr_info() to inform duplicated CACHE_SET_IO_DISABLE set
    - bcache: fix incorrect sysfs output value of strip size
    - bcache: fix error return value in memory shrink
    - bcache: fix using of loop variable in memory shrink
    - bcache: Fix indentation
    - bcache: Add __printf annotation to __bch_check_keys()
    - bcache: Annotate switch fall-through
    - bcache: Fix kernel-doc warnings
    - bcache: Remove an unused variable
    - bcache: Suppress more warnings about set-but-not-used variables
    - bcache: Reduce the number of sparse complaints about lock imbalances
    - bcache: Fix a compiler warning in bcache_device_init()
    - bcache: Move couple of string arrays to sysfs.c
    - bcache: Move couple of functions to sysfs.c
    - bcache: Replace bch_read_string_list() by __sysfs_match_string()

  * linux hwe i386 kernel 5.0.0-21.22~18.04.1 crashes on Lenovo x220
    (LP: #1838115)
    - x86/mm: Check for pfn instead of page in vmalloc_sync_one()
    - x86/mm: Sync also unmappings in vmalloc_sync_all()
    - mm/vmalloc.c: add priority threshold to __purge_vmap_area_lazy()...

Changed in linux (Ubuntu Bionic):
status: Confirmed → Fix Released
kuehhe1 (kuehhe1) on 2019-09-02
Changed in linux (Ubuntu Bionic):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
kuehhe1 (kuehhe1) wrote :

As recommended in answer # 41, reopened because the error persists with [f11] LED on. Greeting kuehhe1

Changed in linux (Ubuntu Bionic):
status: Fix Released → New
kuehhe1 (kuehhe1) on 2019-10-19
Changed in linux (Ubuntu Bionic):
status: New → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.