Mute key LED does not work on HP ProBook 440

Bug #1705586 reported by Benjamin Halbrock on 2017-07-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Zesty
Medium
Unassigned

Bug Description

[SRU Justification]
[Impact]
Mic mute led on HP ProBook 440 G4 does not work.

[Test Case]
The led should indicate mic mute/unmute status.

[Fix]
Commit 5cd5b1bdfb0137d0e814a51ff203d72c76b9f375 add GPIO mic mute led
support for HP ZBook 15u G3. Mic mute led on HP ProBook 440 G4 is also
supported.

[Regression Potential]
Low, very limited laptops will be affected.

---

this is probably a duplicate of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1683277, but I was asked to file a new bug.

The mute button on my laptop has a led that changes the color based on the status of the audio-master channel. At least it should.

There is a slider for the LED in alsamixer but it doesn't change anything.

Are there any tests I should run?

cat /proc/version_signature > Ubuntu 4.10.0-28.32-generic 4.10.17
---
ApportVersion: 2.20.4-0ubuntu4.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: benjamin 2550 F.... pulseaudio
CurrentDesktop: Unity:Unity7
DistroRelease: Ubuntu 17.04
HibernationDevice: RESUME=UUID=4ce0e490-8f95-4de2-9a8f-456e1455444d
InstallationDate: Installed on 2015-06-07 (774 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:0a2a Intel Corp.
 Bus 001 Device 002: ID 04ca:7063 Lite-On Technology Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: HP HP ProBook 440 G4
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.10.0-28-generic.efi.signed root=UUID=27108123-06bd-4347-a0c5-9ea2ba62a034 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.10.0-28.32-generic 4.10.17
RelatedPackageVersions:
 linux-restricted-modules-4.10.0-28-generic N/A
 linux-backports-modules-4.10.0-28-generic N/A
 linux-firmware 1.164.1
Tags: zesty
Uname: Linux 4.10.0-28-generic x86_64
UpgradeStatus: Upgraded to zesty on 2017-07-09 (11 days ago)
UserGroups: adm cdrom dip libvirt libvirtd lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 06/18/2017
dmi.bios.vendor: HP
dmi.bios.version: P85 Ver. 01.06
dmi.board.name: 822E
dmi.board.vendor: HP
dmi.board.version: KBC Version 42.65
dmi.chassis.asset.tag: 5CD709684F
dmi.chassis.type: 10
dmi.chassis.vendor: HP
dmi.modalias: dmi:bvnHP:bvrP85Ver.01.06:bd06/18/2017:svnHP:pnHPProBook440G4:pvr:rvnHP:rn822E:rvrKBCVersion42.65:cvnHP:ct10:cvr:
dmi.product.name: HP ProBook 440 G4
dmi.sys.vendor: HP

CVE References

description: updated

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1705586

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected zesty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.13 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.13-rc1/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

still exists with Linux ThinkPad-Edge 4.12.0-041200-generic #201707022031 SMP Mon Jul 3 00:32:52 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

and yes, I should rename my computer :)

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Kai-Heng Feng (kaihengfeng) wrote :

Add "options snd-hda-intel mode=mute-led-gpio" to "/etc/modprobe.d/alsa-base.conf", see if this works.

hello kai,
unfortunately
adding "options snd-hda-intel mode=mute-led-gpio" to "/etc/modprobe.d/alsa-base.conf
didn't work.

Kai-Heng Feng (kaihengfeng) wrote :

Do you use kernel version > 4.12?

I'm running it again

Linux probook 4.12.0-041200-generic #201707022031 SMP Mon Jul 3 00:32:52 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Kai-Heng Feng (kaihengfeng) wrote :

mode=mute-led-gpio enables mic mute led for 840 G3.

Can you file an upstream bug for this issue? Maybe some dev have the machine to look into this issue.

can you give me a hint where exactly I should file this bug.

Is https://bugzilla.kernel.org/ the right place?

And can I just reference this bug here?

Kai-Heng Feng (kaihengfeng) wrote :

Yes, you can reference the bug here.

And https://bugzilla.kernel.org/ is the right place.

File bug with these additional information:
Product -> Drivers
Component -> Sound(ALSA)

Kai-Heng Feng (kaihengfeng) wrote :

Sorry, it should be "model" instead of "mode".

it is working with

adding "options snd-hda-intel model=mute-led-gpio" in "/etc/modprobe.d/alsa-base.conf

and kernel >= 4-12

Thank you very much :D

Do you know if this change will be merged in the ubuntu kernel?

Kai-Heng Feng (kaihengfeng) wrote :

The necessary bits to make LED work are all in the kernel, we just need to add new ID to let the driver knows this machine also needs "mute-led-gpio" functionality.

So how can I create a patch with the hw-id included?

Kai-Heng Feng (kaihengfeng) wrote :

Well, I'll send a patch if the result of testing kernel [1] is positive:

[1] http://people.canonical.com/~khfeng/lp1705586/

Your build is working flawlessly.

#hp-mute-led-fix
#options snd-hda-intel model=mute-led-gpio
/etc/modprobe.d/alsa-base.conf (END)

and
$ uname -a
Linux probook 4.11.0-12-generic #17~lp1705586 SMP Tue Jul 25 17:49:59 CST 2017 x86_64 x86_64 x86_64 GNU/Linux

As I can'T give you a plus one.

Thank you very much for the incredibly fast responses :D

description: updated
Seth Forshee (sforshee) on 2017-08-02
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Bryan Guerrero (bmg1001) wrote :

I am not on Ubuntu, but actually Arch, and creating the file, with gedit, alsa-base.conf in /etc/modprobe.d/ with the line " options snd-hda-intel mode=mute-led-gpio " worked for my HP Spectre X360 (15-ap012dx) so it seems that this fix works throughout various other distros and HP machines as well.

Kai-Heng Feng (kaihengfeng) wrote :

Well, you need to send a patch to add those models' ID to let Linux kernel supports it out of the box.

Stefan Bader (smb) on 2017-08-11
Changed in linux (Ubuntu Zesty):
status: New → Fix Committed
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.12.0-11.12

---------------
linux (4.12.0-11.12) artful; urgency=low

  * linux: 4.12.0-11.12 -proposed tracker (LP: #1709929)

  * CVE-2017-1000111
    - packet: fix tp_reserve race in packet_set_ring

  * CVE-2017-1000112
    - udp: consistently apply ufo or fragmentation

  * Please only recommend or suggest initramfs-tools | linux-initramfs-tool for
    kernels able to boot without initramfs (LP: #1700972)
    - Revert "UBUNTU: [Debian] Don't depend on initramfs-tools"
    - [Debian] Don't depend on initramfs-tools

  * Miscellaneous Ubuntu changes
    - SAUCE: (noup) Update spl to 0.6.5.11-ubuntu1, zfs to 0.6.5.11-1ubuntu3
    - SAUCE: powerpc: Always initialize input array when calling epapr_hypercall()

  * Miscellaneous upstream changes
    - selftests: typo correction for memory-hotplug test
    - selftests: check hot-pluggagble memory for memory-hotplug test
    - selftests: check percentage range for memory-hotplug test
    - selftests: add missing test name in memory-hotplug test
    - selftests: fix memory-hotplug test

 -- Seth Forshee <email address hidden> Thu, 10 Aug 2017 13:37:00 -0500

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-zesty' to 'verification-done-zesty'. If the problem still exists, change the tag 'verification-needed-zesty' to 'verification-failed-zesty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-zesty

works on
Linux probook 4.10.0-33-generic #37-Ubuntu SMP Fri Aug 11 10:55:28 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

changed tag to verification-done-zesty

tags: added: verification-done-zesty
removed: verification-needed-zesty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers