Ubuntu

Hardy alpha 2 - 5 won't boot

Reported by Greg T. on 2007-12-30
16
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
linux (Ubuntu)
High
Unassigned

Bug Description

I've successfully burned the Hardy alpha 2 release (md5 sums match) but it will not install. After a few moments it drops to Busybox and will not get beyond the point of loading the kernel.

My Feisty CD works, so this must be a relatively recent issue. I'm running a A8N32-SLI Deluxe motherboard with a Nvidia GeForce 6600, Plextor DVDR PX-740A (hda), two Raptor SATA drives (sda & sdb), and a Seagate IDE drive (hdc).

The screen messages I'm seeing at boot suggest a problem with the CD/DVD player. These include:

hda: lost interrupt
hda: task_in_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
hda: task_in_intr: error=0x00 { }
ide: failed opcode was: 0xa1

I've also seen a message suggesting a problem with the floppy disk:

end_request: I/O error, dev fd0, sector 0

This "end_request" message appears repeatedly (perhaps 8 times) before the installation drops to Busybox. I see no error messages regarding the SATA drives, just the IDE drives. Both of the IDE drives are configured as master, not cable select.

Greg T. (gjtbiz) wrote :

The installation will make some progress if I add all_generic_ide as a boot option when booting from the CD. This gets me past Busybox. However, the booting proceeds very slowly, hanging for a time on USB messages, and when I finally am able to get to the partitioner, I see that it has listed my Seagate IDE as sda, when it should be hdc.

Stanley Sokolow (overbyte) wrote :

What processor is in your computer and which architecture (32-bit i386, 64-bit, etc) are you installing of this alpha-2?

Saivann Carignan (oxmosys) wrote :

Very interesting. I've see similar problems and perhaps that I can help finding where is the problem

Floppy disk : Do you have a floppy disk reader in your computer? If no, can you access your BIOS and look if there's any floppy disk activated somewhere in the BIOS. If the BIOS tells ubuntu that there's a floppy disk reader when it's not the case, it already happened that ubuntu won't boot, waiting for the Floppy disk to react.

Master Drives : Make sure you didn't put two harddrive configured as Master on the same IDE cable. If you have two drives on the same IDE cable, the hard drive at the end of the cable must be the master and the other must be the slave.

SATA Controller : Some Intel SATA controllers ( and maybe some others ) act like if they are IDE controllers in order to make Windows XP work without crashing ( it's pretty hard to make Windows really works on SATA controllers... ) but this gives a problem to Linux which works very great both with IDE and SATA controllers because this strange behavior seems to be adapted for Windows only. My own computer is a Dell vostro and ubuntu did have the same behavior, detecting my drives as SATA and not IDE and crashing half of the time at boot. Normally, you can change the controller mode in BIOS and set it to "SATA" or "RAID" rather than "IDE" and it should fix your issue.

If one of the 3 solutions did work for you, can you tell it here as we can gather more information about your hardware and contribute to already opened bug report?

Thanks for your contribution to ubuntu!

Saivann Carignan (oxmosys) wrote :

IMPORTANT NOTE : I forgot to say that changing settings in the BIOS can't make your computer explode, but it still needs some skills. Working with precaution is clearly a good thing. You should also know that if Windows is already installed on your computer and that you change the BIOS settings to SATA or RAID, Windows will probably crash on a blue screen until you set back the BIOS settings to IDE.

Changed in linux:
assignee: nobody → saivann
status: New → Incomplete
Greg T. (gjtbiz) wrote :

I'm using the 32-bit i386 architecture with an Athlon 64 3200+ processor.

Thanks for the information. I have a working floppy drive and I'm sure that my drives are cabled properly. Each of the drives has a separate cable and is configured as master. On my mobo, my SATA controllers are from NVIDIA. I'll check the BIOS settings, but I haven't had issues in that regard with previous installations. For instance, after being unable to use the Hardy CD, I dropped in an old Feisty CD and it installed fine. I then upgraded to Gutsy and then Hardy using "update-manager -d".

Saivann Carignan (oxmosys) wrote :

Greg T. : Thanks to look deeper about your SATA controller. Nvidia SATA controllers sounds like hardware that can cause these kinds of problems to me, and in my opinion, its the #1 suspect for that problem since almost all Hard Drives / Floppy disks / CD/DVD Drives get serious errors. If you say that it worked perfectly before with Feisty and others, this can be a regression. But before all, can you :

1. Look if you can configure the BIOS to use "RAID" or "SATA" mode for you controller and look if it fixes your problem
2. ( Within Ubuntu Feisty/Gutsy, any that works ), type this on a terminal : sudo lspci -vvnn > lspci-vvnn.log
3. Attach the lspci-vvnn.log file to that bug report ( which should have been created in your home directory. )

Thanks for your detailed report. Don't forget that it's never too late to add informations in the description if you find some new information that you didn't see the first time.

Greg T. (gjtbiz) wrote :

I went into my BIOS and enabled the "nVidia RAID Function", and then enabled RAID capabilities for each of my SATA ports (1-4). No change; I still received the same error messages before being dropped to BusyBox.

I note messages that rapidly scrolled by to the effect of, "NVIDIA CK-804: BIOS didn't set cable bits correctly" and "NVIDIA CK-804: Not 100% native mode".

I've also attached the file you requested. I turned the RAID options off again before booting into Ubuntu (Gutsy) on another partition, as I don't use RAID and turning it on adds a few seconds to my boot time.

Not the answer you were looking for, I suppose, but I hope this helps nonetheless.

Saivann Carignan (oxmosys) wrote :

Thanks for these precious informations. I set the bug to confirmed, Importante to High and I assign the bug to ubuntu-kernel team.

Changed in linux:
assignee: saivann → ubuntu-kernel-team
importance: Undecided → High
status: Incomplete → Confirmed

I've seen similar behaviour on a PC at university, so I removed the "splash quiet" options to see the boot messages. Shortly after booting an Alpha-2 hardy-desktop-i386 CD the floppy drive LED turned on, the drive started making noises and lots of floppy I/O errors were displayed. After a while hard drive started moving its heads. After that floppy started moving again, and then the hard drive. This process repeated several times and after that only the BusyBox prompt appeared. After putting a floppy disk inside the drive and rebooting the process was faster, but still stopped at the BusyBox prompt.

On my laptop which obviously doesn't have a floppy drive, the booting process just stuck - no X, no installer, no normal "login:" prompt. I was able, however, to reboot the machine using Alt+Ctrl+Delete.

I checked the CD and the MD5 checksums match. Previously other LiveCD's worked, Feisty, PCLinuxOS, Mint, OpenSUSE, Etch. It's only the Hardy CD that's broken at the moment.

What information would you like to receive to diagnose this problem? Unluckily, I'd be able to get at the problematic university machine on Monday 14th.

Greg T. (gjtbiz) wrote :

That describes well what I saw (and heard): A lot of thrashing about. Placing a disk in the floppy drive did no good.

You might want to confirm that you were using the 32-bit i386 CD and list your motherboard, graphics card, and CD model, and also state whether you are using any SATA drives (in my case, I boot from a SATA drive and keep my data on an IDE hard drive).

Saivann Carignan (oxmosys) wrote :

Kiktor Wandachowicz : Thanks for your contribution to that bug report. You can follow instructions here to provided needed informations to kernel developers. https://wiki.ubuntu.com/KernelTeamBugPolicies .

Most probably that you'll not be able to do most of what is described in this wiki because that the kernel doesn't seem to load correctly so I think that the most important would be that you type this in a terminal from a ubuntu version which boot without problems ( Gutsy? ) and give us back the output file ( lspci-vvnn.log ).

sudo lspci -vvnn > lspci-vvnn.log

Saivann Carignan (oxmosys) wrote :

Hardu alpha 3 is out, can you also test if this problem happens with this new alpha release?

Greg T. (gjtbiz) wrote :

I just tried the Alpha 3 CD, but I'm getting what appears to be the same problem as before.

I am testing Hardy Alpha 4 at the moment and the problem still exists. I've downloaded todays updates which raised the kernel number to 2.6.24-7. But it changed nothing on this topic. :(

psernetz : Can you also provide the resulting file from that command on a terminal ( you can do it from ubuntu Gutsy ) :

sudo lspci -vvnn > lspci-vvnn.log

Hi,

I've tried to upload my log to launchpad... but for some reason my
firefox crashes everytime I try to upload something... So I send it by
mail.

Am Freitag, den 08.02.2008, 23:08 +0000 schrieb Saïvann Carignan:

> psernetz : Can you also provide the resulting file from that command on
> a terminal ( you can do it from ubuntu Gutsy ) :
>
> sudo lspci -vvnn > lspci-vvnn.log
>

psernetz (patrick-sernetz-com) wrote :
Download full text (11.8 KiB)

00:00.0 Host bridge [0600]: VIA Technologies, Inc. VT8366/A/7 [Apollo
KT266/A/333] [1106:3099]
 Subsystem: ASRock Incorporation K7VT2 motherboard [1849:3099]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort+ >SERR- <PERR-
 Latency: 0
 Region 0: Memory at e0000000 (32-bit, prefetchable) [size=64M]
 Capabilities: [a0] AGP version 2.0
  Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit-
FW+ AGP3- Rate=x1,x2,x4
  Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP+ GART64- 64bit- FW- Rate=x4
 Capabilities: [c0] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:01.0 PCI bridge [0604]: VIA Technologies, Inc. VT8366/A/7 [Apollo
KT266/A/333 AGP] [1106:b099] (prog-if 00 [Normal decode])
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort+ >SERR- <PERR-
 Latency: 0
 Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
 Memory behind bridge: dbe00000-dfefffff
 Prefetchable memory behind bridge: bbc00000-dbcfffff
 Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- <SERR- <PERR-
 BridgeCtl: Parity- SERR- NoISA+ VGA+ MAbort- >Reset- FastB2B-
 Capabilities: [80] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:09.0 Multimedia video controller [0400]: Brooktree Corporation Bt878
Video Capture [109e:036e] (rev 11)
 Subsystem: Avermedia Technologies Inc AverMedia AVerTV DVB-T 771
[1461:0771]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
 Latency: 32 (4000ns min, 10000ns max)
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at dbdfe000 (32-bit, prefetchable) [size=4K]
 Capabilities: [44] Vital Product Data
 Capabilities: [4c] Power Management version 2
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:09.1 Multimedia controller [0480]: Brooktree Corporation Bt878 Audio
Capture [109e:0878] (rev 11)
 Subsystem: Avermedia Technologies Inc AverMedia AVerTV DVB-T 771
[1461:0771]
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
 Latency: 32 (1000ns min, 63750ns max)
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at dbdff000 (32-bit, prefetchable) [size=4K]
 Capabilities: [44] Vital Product Data
 Capabilities: [4c] Power Management version 2
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:0b.0 Multimedia audio controller [0401]: Creative Labs SB Live!
EMU10k1 [1102:0002] (rev 08)
 Subsystem: Creative Labs CT4832 SBLive! Value [1...

Thanks for your contribution!

John McHugh (mrmcq2u) wrote :

I have also been suffering from this issue since the first hardy alpha... I have an AMD dual core 64bit machine with nvidia graphics card, two sata drives and the nvidia sata controller on my gigabyte motherboard. I'm going to try the all_generic_ide option to see if that does anything. Never had an issue with previous versions of ubuntu and this machine before so i can also confirm this is definitely a hardy problem.

Saivann Carignan (oxmosys) wrote :

Tretle : Thanks for your comment on the bug report. In order to help developers, can you provide :

1. The file created by this command on a terminal : sudo lspci -vvnn > lspci-vvnn.log
2. Error or strange messages that you might notice if you boot without usplash on the liveCD (You can type F6 before booting ubuntu from the LiveCD, and by removing "splash" and "quiet" before pressing the Enter key).

Caco (caco-nabuo) wrote :

if i boot in verbose mode in Hardy alpha 5 i get this errors:

hda: status error: error=0x00 { }
ide: failed opcode was: unknown
hda: drive not ready for command
hda: status error: status 0x59 { DriveReady SeekComplete DataRequest Error }
hda: status error: error=0x00 { }
ide: failed opcode was: unknown
hda: drive not ready for command
kjournald starting. Commit interval 5 seconds
EXT3-fs:mounted filesystem with oredered data mode.

this repeated for about 10 times, then it prompts me to BusyBox: if i enter modprobe all_generic_ide i get:

FATAL: Module all_generic_ide not found.

My Athlon 64 3500+ pc with Radeon X600 Pro PCIE card has two sata hard drives; IDE channel 0 master is the cd writer from which i boot Hardy.

I tried to disable IDE channel 1 which is empty from BIOS, i have a Gigabyte mobo provided with NVIDIA sata/pata controller

all kind of raid is disabled, ide channel 1 disabled, i even disabled floppy drive, but nothing changes

it sounds strange to me that Ubuntu looks for hda (not present) instead of sda (my Windows xp drive) or sdb (Ubuntu Gutsy)

I also have a SATA cd writer which i could put on my machine instead of the pata cd writer, in order to disable ide controller completely, but i'm not sure if this could help...

Saivann Carignan (oxmosys) wrote :

Thanks for these very detailed informations. To give us a complete and detailed list of your hardware, can you attach the file created by this command on a terminal ?

lspci -nnvv > lspci-nnvv.log

Caco (caco-nabuo) wrote :

I've had the same problem with hardy alpha 5.
after some time, it falls under the busybox prompt.
(I had no problem with ubuntu 6.04)

There may be an interesting detail : I've got also a plextor DVDR PX-740A. (hda)
(motherboard asus a7n8x-e deluxe)

I managed to save some logs (dmesg, casper.log and /proc/ide/hda/*).
It may be useful.

Each time I did a cat /proc/ide/hda/capacity, I got some "hda: drive not ready for command" and a capacity of 25888529.
(it is strange that the copy of this file gave me 75043832).

Another strange thing:
the 1st time I did cat /proc/ide/hda/identify, there was only zeros, (and the hda not ready for command).
the other times I got something else (but always the hda not ready for command).

And finally, the DVD doesn't respond anymore, even after a reboot. I had to switch off the computer in order to make it work again.

I hope this can help solving the problem.

Laurent Claessens (moky-math) wrote :

I have the same problem with alpha6 (Ubuntu and kubuntu). After launching the liveCD, I enter the busybox.

In qemu, I notice the following unusual (for me) message before boot:

[ 0.000000] ACPI: no DMI BIOS year, acpi=force is required to enable ACPI
[ 14.464065] PCI : PIIX3: Enabling Passive Release on 0000:00:01.0
Loading, please wait...

and then, after a little time of usual boot, it goes to the BusyBox, as described before.

+++

Here is the description of another attempt I did.

* Install K-Gutsy from live-CD
* apt-get update, apt-get dist-upgrade
* reboot
* kdesu 'adept_manager --dist-upgrade-devel' (following http://doc.ubuntu-fr.org/installer_une_version_instable)
* reboot

=> BusyBox
During the boot (and inside the busybox), the tty1 continuously says

exception Emask 0x0 SAct 0x0 SErr x0x action 0x2 frozen
cmd 00/00:00:00:24:00/00:00:00:00:00/a0 tag 0 pio 36 in
status: {DRDY}

After a while, it said me
ata2 WARNING: synchronous SCSI scan failed without making any progress

and then it continued "exception Emask 0x0 ..."

Attached : lspci --vvnn

Hope it helps,
have a nice WE
Laurent

I've got some more informations (cf https://bugs.launchpad.net/ubuntu/+source/linux/+bug/179336/comments/25 ):

Ubuntu server and ubuntu alternate are booting ok. (wich is a good thing!)
but I still got the problem on ubuntu desktop (x86) alpha6.

I would have tried with another cd player, but I've got only one...

Richard.

seems to be the same problem than reported in :
https://bugs.launchpad.net/bugs/182996

Saivann Carignan (oxmosys) wrote :

Richard Genoud : Thanks for finding this out.

Even if bug 182996 is newer than this one, I set this bug as a duplicate because the other ones already contains discussions concerning upstream problem and the upstream bug is linked. Informations inside this bug report will still be available for bug contacts and developers but any further discussions should take place in the new bug report. Thanks for all the time you took to improve that bug report.

Changed in linux:
status: Unknown → Fix Released

@Saïvann Carignan

The bug 181561 is also a duplicate and is not set as one. ( https://bugs.launchpad.net/bugs/181561 )

They found interestings workarouds like addind all_generic_ide to the kernel command line.
A bug was open on the kernel bug tracker (http://bugzilla.kernel.org/show_bug.cgi?id=9837) but still no news.

Saivann Carignan (oxmosys) wrote :

Thanks again :)

I'm running now 2.6.24-15-generic kernel and it works again. DVD drive is plugged in, system fully encrpyted... works fine.... I just noticed that harddisk labelling got changed again. Up to now it was hdX and sdY... now all is sdY again... in my crypttab I just changed from hdX to UUID - works prefectly.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.