[ZenBook S UX391UA, Realtek ALC294, Mic, Internal] No sound at all

Bug #1784485 reported by Pawel on 2018-07-30
108
This bug affects 20 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

Internal speaker - not sound at all
Cable Headphonse - realy quiet disorted sound
Bluetooth headphones - sound works fine

On Windows 10 everything works fine.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: alsa-base 1.0.25+dfsg-0ubuntu5
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: pmichalski 7964 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Mon Jul 30 22:32:10 2018
InstallationDate: Installed on 2018-07-17 (12 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:PCH failed
Symptom_Card: Wbudowany dźwięk - HDA Intel PCH
Symptom_DevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gdm 2988 F.... pulseaudio
                      pmichalski 7964 F.... pulseaudio
Symptom_Jack: Mic, Internal
Symptom_Type: No sound at all
Title: [ZenBook S UX391UA, Realtek ALC294, Mic, Internal] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/18/2018
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX391UA.204
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX391UA
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX391UA.204:bd05/18/2018:svnASUSTeKCOMPUTERINC.:pnZenBookSUX391UA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX391UA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: ZenBook S
dmi.product.name: ZenBook S UX391UA
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Pawel (pawel-t) wrote :
Pawel (pawel-t) wrote :
nik (nik.gnomic) wrote :

found this page looking for information for same model laptop running Manjaro, also confirmed sound working on windows 10
found another page for ALC294 codec - https://askubuntu.com/questions/986140/no-sound-output-ubuntu-17-10-asus-zenbook-13
all 3 appear to have common problem caused by windows 10 shutdown

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
sojusnik (sojusnik) wrote :

This also happens on Manjaro, see https://forum.manjaro.org/t/alc294-analog-audio-card-detected-but-no-sound-internaly-or-headphones/54089/16

Did somebody already find a solution or knows how to debug this properly?

Arnau Prat Gasull (aeronau) wrote :

I am experiencing the same problem running Ubuntu and Windows 10 on the same Zenbook model. Sound working on Windows 10 but not on Ubuntu 18.04. I have not managed to solve the problem.

Shreyas Mandre (shreyasmandre) wrote :

Same issue for me. I have Ubuntu 18.04 on Asus UX391UA. No sound either through headphones or speakers.

sojusnik (sojusnik) wrote :

I even installed Windows on an external drive, because the author of this thread (https://askubuntu.com/questions/986140/no-sound-output-ubuntu-17-10-asus-zenbook-13) assumed that a proper shutdown of Windows could solve this issue for Linux users, but it didn't help either.

sojusnik (sojusnik) wrote :

BTW, can somebody confirm that this ZenBook S UX391UA on Ubuntu 18.04 runs quite hot, even while doing normal "office stuff"?

At some point the preinstalled thermald daemon even forcefully shuts down Ubuntu, preventing it from overheating. "Package temperature above threshold, cpu clock throttled" normally appears before this in the logs.

The only solution I've found is to remove the thermald package. Didn't observe any undesirable side effects so far.

Nitish (nitd24) wrote :

Not facing any issues due to heating so far. Primarily using the laptop for coding.
It does occasionally gets heated, but then nothing that causes any problems.
I'll update if I face anything.

osimbora45 (osimbora45) wrote :

Also affects me (ASUS Zenbook UX931U)

Tomasz Przybył (fademind) wrote :

Also affected Asus VivoBook R542UF

```
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook 15_ASUS Laptop X542UF
  v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: X542UF v: 1.0 serial: <filter>
  UEFI: American Megatrends v: X542UF.303 date: 03/15/2018
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  v: kernel bus ID: 00:1f.3
  Sound Server: ALSA Kernel: 4.19
```
```
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC294 Analog [ALC294 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
```
Dmesg parts
```
[ 12.342528] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC294: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[ 12.342531] snd_hda_codec_realtek hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 12.342533] snd_hda_codec_realtek hdaudioC0D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[ 12.342535] snd_hda_codec_realtek hdaudioC0D0: mono: mono_out=0x0
[ 12.342536] snd_hda_codec_realtek hdaudioC0D0: inputs:
[ 12.342538] snd_hda_codec_realtek hdaudioC0D0: Mic=0x1b
```
```
[ 12.634171] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input18
[ 12.634389] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input19
[ 12.634563] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input20
[ 12.634737] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input21
[ 12.634905] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input22
[ 12.635045] input: HDA Intel PCH HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input23
```

Jan Smeds (jan-smeds) wrote :

Same problem for me...

sojusnik (sojusnik) wrote :

Still no sound, even on Ubuntu 18.10.

sojusnik (sojusnik) wrote :

I've opened another issue regarding this notebook. It's about overheating. Would be very helpful, if you could share your experience here: https://askubuntu.com/questions/1087672/unusually-hot-asus-ux391ua

Abhishek Sharma (helkaistari) wrote :

I'm also having an issue with my ux391ua running MATE18.04 with no Windows 10 installed. There is sound output audible with headphones on and volume >100% but it is very distorted and crackly. 18.10 was not helpful and updating kerenel to 19 doesn't change anything.

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC294 Analog [ALC294 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

pacmd list-cards
1 card(s) available.
    index: 0
 name: <alsa_card.pci-0000_00_1f.3>
 driver: <module-alsa-card.c>
 owner module: 7
 properties:
  alsa.card = "0"
  alsa.card_name = "HDA Intel PCH"
  alsa.long_card_name = "HDA Intel PCH at 0xec228000 irq 135"
  alsa.driver_name = "snd_hda_intel"
  device.bus_path = "pci-0000:00:1f.3"
  sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
  device.bus = "pci"
  device.vendor.id = "8086"
  device.vendor.name = "Intel Corporation"
  device.product.id = "9d71"
  device.product.name = "Sunrise Point-LP HD Audio"
  device.form_factor = "internal"
  device.string = "0"
  device.description = "Built-in Audio"
  module-udev-detect.discovered = "1"
  device.icon_name = "audio-card-pci"

I've tried various mixer related avenues which do nothing. I noticed that pavucontrol shows sound btw.

Karen Chaltikian (chaltik) wrote :

Asus UX430U mid-2018 edition.
Dual boot Win10/Ubuntu 18.04 LTS
Audio works fine on Windows both through laptop speakers and 3.5mm jack headphones
When booted in Ubuntu -- no sound on laptop speakers or headphones.

confirm the pavucontrol shows audio streaming.

alsamixer all outputs set to "oo".

odeiber (o-deiber) wrote :

hello
I just bought a zenbook asus S UX391UA under windows 10; I installed Ubuntu 18.10 64 bits in dual boot and I have the same problem: no sound (although it works correctly under Windows)

thank you

Karen Chaltikian (chaltik) wrote :

To add to the above: shutting down the laptop and then starting from there in Ubuntu, as suggested in one of the workarounds above, actually made the sound work

sojusnik (sojusnik) wrote :

@Karen Chaltikian

Good news! Although I've tried this on my UX391UA, but without success.

Can you describe your procedure step-by-step?

I have the issue as well. I have a dual boot system with following.
Zenbook UX490UAR
Ubuntu 18.04.1
Windows 10

I think this is due to windows not properly shutting down and holding on to a hardware device, although not sure how. Managed to resolve by a full shutdown. i.e. go to shutdown on the windows start menu and hold shift while pressing restart. A screen will appear where you can select to shutdown.

After the restart and logging into ubuntu, sound works .
For the volume control related bug, there was a guide here : https://askubuntu.com/questions/906303/volume-control-on-asus-zenbook-3

sojusnik (sojusnik) wrote :

Can somebody confirm that the above mentioned procedure also works with an UX391UA.

It does NOT work on my UX391UA.

Nitish (nitd24) wrote :

The above procedure does not work on my UX391UA either :(

Greg (buchovagabond) wrote :

I have same issue on new Asus ZenBook 14 UX433FA (ALC294) on Ubuntu 10.04.1 (NO dual boot).

Tried the 4.19.2 kernel and nothing changed.

Looking forward to some sort of fix/workaround!

craig jackson (craig-jackson) wrote :

Same on Asus Zenbook UX533 with Realtek ALC294. No sound on Kubuntu 18.10 (4.18.0-11-generic) - speakers or headphones. Dual boot with Windows 10. Windows 10 sounds work fine.

craig jackson (craig-jackson) wrote :

Interestingly, if I put the sound device into power save mode and wait a few seconds before playing a sound, I can actually hear it perffectly clearly, but after repeating the playing of the sound a few times, it distorts then disappears:

  sudo -i
  echo 10 >/sys/module/snd_hda_intel/parameters/power_save
  sleep 10
  aplay /usr/share/sounds/alsa/Front_Center.wav

Pawel (pawel-t) wrote :

Guys please keep this ticket for Zenbook S UX391UA nad ALC294.
UX533 is different issue. This not make sense. I've got 3 other Asus laptops, where sound worked perfectly on Linux.

Rebooting through Windows 10 or setting card in power_save does not work on UX391UA.
I bought external usb-c soundcard and now I am using it with headphones.

I think that without support from Realtek (for example Kailang Yang <email address hidden> https://www.systutorials.com/linux-kernels/84502/alsa-hda-realtek-new-codecs-support-for-alc234-alc274-alc294-linux-4-4-12/), Kernel Alsa team, Canonical team or Asus there will be no changes.
I've tried to contact all of them but without any results.

craig jackson (craig-jackson) wrote :

Hi Pawel,

You may be right, but I think the common thread in all the laptops exhibiting this problem is the ALC294. Does the power save trick mentioned in my comment work for you at all?

Cheers,
Craig

chovy (anchovy) wrote :

I have the pavucontrol showing audio but no sound is coming out of the spakers.

ACL294 on Asus Zenbook UX433FA-DH74

aditya lele (adityadlele) wrote :

Same problem with Asus Zenbook UX533FD.

Also, can someone please specify the windows shutdown method?
"i.e. go to shutdown on the windows start menu and hold shift while pressing restart. A screen will appear where you can select to shutdown." This doesn't work.

I am dual booting Win10 and Ubuntu 18.04.

chovy (anchovy) wrote :

I've tried everything. Nothing works. I originally booted into windows once and then installed linux over it. I did not power off I only did a reboot, some people are saying powering off from windows fixes sound on linux, which makes me think its some bios setting, but I don't see anything for sound settings in bios.

I no longer have windows so I can't boot into it.

VanVan (w-o) wrote :

I have the same issue on new Asus ZenBook 14 UX433FA (ALC294) on Ubuntu 2018.10 with Realtek ALC294.

aditya lele (adityadlele) wrote :

The only workaround that I have found till now is using a bluetooth headset. It works perfectly well.

VanVan (w-o) wrote :

Yes, I can confirm that bluetooth works well, but I hope we can find a way to use internal sound, it's a good quality speaker for a small laptop :)

Alban Boissard (albatas) wrote :

Hello,
sorry for my poor english, I am french.

A had exactly the same issue with a ASUS Zenbook UX433, and I fund a solution.

The issue comes from the Kernel part of the Alsa drivers.

Daniel Drake and Jian-Hong Pan provided a patch in the alsa mailing list to fix this issue for UX533/UX433 laptop (and maybe other Asus models) :
http://mailman.alsa-project.org/pipermail/alsa-devel/2018-December/142572.html

This patch is not in the current kernel, nor in 4.20rc tree as far I can see.
Fortunatly, you can find a patched version of the files in :
https://github.com/endlessm/linux/tree/master/sound
(A nice, easy to use linux distro)

What I did :
- clone official Kernel source repo (4.19-7 in my case)
- clone endless Os repo
- Copy the "sound" folder from endless tree to official kernel tree.
- Compile the "no more official" Kernel.
(I followed this tuto : https://wiki.archlinux.org/index.php/Kernel/Traditional_compilation because I use Manjaro, based on Arch) You have to find an appropriate tuto for Ubuntu. It was the firt time I compile a kernel.)
- Use this kernel : the sound work perfectly.

Note : I'm absolutly not a linux expert, it maybe exists a better way to use the patch than recompile the kernel.

Hi,

ALC294 works but you will have to recompile the kernel :/

A patched was made that you can find at
http://mailman.alsa-project.org/pipermail/alsa-devel/2018-December/142689.html

Be carefull there are 3 mails containing differents patches of the same file sound/pci/hda/patch_realtek.c

Personnally I have a ASUS UX433 laptop and I applied this patch on the linux-4.19.8.tar.xz kernel with a Debian distro.
Once done all works ok.

It should works also on a ASUS UX533.

Hope this helps.

Mohamed.

chovy (anchovy) wrote :

I'm using Ubuntu 18.04. Does anyone know if its possible to apply this patch? I would need idiot proof instructions.

chovy (anchovy) wrote :

I tried installing kernel 4.20-rc5 and sound speakers (built in) still don't work.

Changed in linux (Ubuntu):
status: New → Incomplete
35 comments hidden view all 115 comments
sojusnik (sojusnik) wrote :

@Ben

Thanks!

Patching and compiling the kernel is out of my league. I prefer the user-friendly and "foolproof" way through the Kernel Update Utility for Ubuntu (UKUU), mentioned above. Afaik, I can't edit the patch_realtek.c file when doing so with UKUU.

Do you know if it's already planned to merge the UX391UA line too? If not, can somebody mention this to the kernel developers.

VanVan (w-o) on 2018-12-19
Changed in alsa-driver (Ubuntu):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
craig jackson (craig-jackson) wrote :

I can confirm the following fixed the no-sound issue on my UX533 per buchovagabond's post above:

    sudo ukuu --install v4.19.10

Cheers,
Craig

1 comments hidden view all 115 comments
chovy (anchovy) wrote :

sorry 4.19.10 worked, but 4.19.11 doesn't.

chovy (anchovy) wrote :

4.19.10 no longer works :(

I booted into windows and now sound doesn't work. Sound works fine in windows but not Ubuntu.

chovy (anchovy) wrote :

Fixed, for anyone using windows on a dual boot, you have to SHUTDOWN from windows. and then power on and go into Ubuntu. If you RESTART from windows sound will not work in Ubuntu.

chovy (anchovy) wrote :

4.19.11 works

Belen Guaranda (bellengc) wrote :

Hello, I've recently bought an UX533FD ASUS, with the same sound problem. Sorry, though I´m an ubuntu user I have no experience in compiling kernels, and after reading this thread, I have two questions: 1)Is the fix available in kernel 4.19.11? 2) Is this command: sudo ukuu --install v4.19.11 the only one to execute?

Santiago Londoño (slondon0) wrote :

I managed to solve it in my Asus ZenBook UX433F. I'm running Ubuntu 18.04.
I upgraded the Kernel to v4.19.11 as to Jorge Castro's answer to this question:

https://askubuntu.com/questions/119080/how-to-update-kernel-to-the-latest-mainline-version-without-any-distro-upgrade

Here are the exact steps I followed:

1. Download the appropriate files from:

https://kernel.ubuntu.com/~kernel-ppa/mainline/

For example:

linux-headers-4.19.11-041911_4.19.11-041911.201812191931_all.deb
linux-headers-4.19.11-041911-generic_4.19.11-041911.201812191931_amd64.deb
linux-image-unsigned-4.19.11-041911-generic_4.19.11-041911.201812191931_amd64.deb
linux-modules-4.19.11-041911-generic_4.19.11-041911.201812191931_amd64.deb

2. Install each one in the appropriate order:

sudo dpkg -i linux-headers-4.19.11-041911_4.19.11-041911.201812191931_all.deb
sudo dpkg -i linux-headers-4.19.11-041911-generic_4.19.11-041911.201812191931_amd64.deb
sudo dpkg -i linux-modules-4.19.11-041911-generic_4.19.11-041911.201812191931_amd64.deb
sudo dpkg -i linux-image-unsigned-4.19.11-041911-generic_4.19.11-041911.201812191931_amd64.deb

3. Restart. In GRUB choose "Advanced options for Ubuntu". Select the new Kernel version.

Cheers

sojusnik (sojusnik) wrote :

@Santiago Londoño

Or you could have used UKUU: https://github.com/teejee2008/ukuu

Too bad that the 4.20 kernel doesn't contain the fix for the UX391UA :/

VanVan (w-o) wrote :

@sojusnik
It should be included for UX391UA, I committed it on 19 December
https://github.com/torvalds/linux/commit/9cf6533e8060d3896b88ea14b27f620e6504b84b

sojusnik (sojusnik) wrote :

@VanVan

That's strange!

To be on the safe side, I even did a fresh Ubuntu 18.10 installation and updated to the 4.20 kernel with UKUU, but I still don't have sound. Neither from the internal, nor the external speakers. I've played around with alsamixer in the terminal – without success.

Can somebody confirm that they got the sound running just by installing the latest kernel (4.20) on the ASUS UX391UA (that's the model this issues is actually about)?

sojusnik (sojusnik) wrote :

Some additional sysinfo with inxi:

System: Host: mir Kernel: 4.20.0-042000-generic x86_64 bits: 64 Desktop: Gnome 3.30.1
           Distro: Ubuntu 18.10 (Cosmic Cuttlefish)
Machine: Type: Laptop System: ASUSTeK product: ZenBook S UX391UA v: 1.0 serial: <filter>
           Mobo: ASUSTeK model: UX391UA v: 1.0 serial: <filter>
           UEFI [Legacy]: American Megatrends v: UX391UA.301 date: 10/15/2018

BTW, ASUS released recently a new BIOS version, but it still doesn't solve our problem: https://www.asus.com/de/Laptops/ASUS-ZenBook-S-UX391UA/HelpDesk_BIOS/

Ben (z80-ben) wrote :

The UX391UA fix is not in 4.20 as it was already a release candidate. To get sound working on this model you'll need to download the 4.20 source, apply the patch to sound/pci/hda/patch_realtek.c then compile and install the kernel.

sojusnik (sojusnik) wrote :

Thanks Pawel!

Ian George (hatboxcrafts) wrote :

Can confirm that installing kernel 5.0-rc1 using UKUU that sound from the speakers and earphones now work on my Zenbook UX391UA.

Confirm solved for kernel 4.20 via Ukuu for Asus Zenbook ux433f

Hello guys,

I followed your discussion to try to solve my problem. Now sound works in my PC, but I've got some other problems that came with.

My PC is an Asus UX333FN, and I'm currently running on Ubuntu 18.04 with kernel 4.20. It came with 4.15.0.29.31 originally.

When following the steps to install new kernels, above 4.18, I always get these messages :

W: Possible missing firmware /lib/firmware/nvidia/gv100/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/sw_method_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/sw_bundle_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/sw_nonctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/sw_ctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/gpccs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/gpccs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/fecs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/fecs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/acr/ucode_load.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/acr/unload_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/acr/bl.bin for module nouveau
(This time I was trying to install 4.18 for example)

As I said, sound works, but my problem now is apparently the NVIDIA Card (it has a Geforce MX150). Sometimes my screen and my mouse freeze, and I also get something like in the attached picture. I also need to press two times the Fn keys for it to start working, which didn't happen with the other kernel.

Has someone faced the same problem?

Thank you a lot

Eric (ericbskis) wrote :

Confirming that install 4.19.10 via ukuu as mentioned by Craig in comment #78 worked for me on zenbook ux533FD with no windows install.

Lucia Di Fino (luciadf) wrote :

I encounter the exact same problems of Thales Loiola Raveli on an ASUS 14 UX433FN with Linux Mint 19.1 Cinnamon.

When will the patch be added to a Linux Mint-supported kernel version? Please please please, it's hard to have a brand-new but mute PC :/

Zhuokun Yang (salkvmcv) wrote :

The problem can been solved by updating to the newest 4.19.x kernel. I am a Ubuntu user with Asus UX433FA. After a few testing, I can confirm that newer kernel 4.19.17 currently available in kernel.org is the solution (I tried out 4.19.8 as well but I experienced something else so I decided to use 4.19.17, which, by default, accepts the changes suggested by Jian-Hong).

However, I am using a dual boot system. There is a minor problem that bugs me: even if I turned off the fast boosting in BIOS, if I boot into Windows then restart and try to boot into Ubuntu, the sound will distort and disappear eventually. The solution would be completely shutdown Windows every time you want to switch between the OS. Hope this could be solved in the future.

A good thing though, is after installing the new kernel, the original 4.15.x kernel that ships with Ubuntu 18.04 can also output sound properly !!!

But, I have always got the feeling that the sound quality on Ubuntu is not as good as that of Windows. I might be over-sensitive tho.

Zhuokun Yang (salkvmcv) wrote :

@Thales Loiola Raveli

Try to blacklist the nouveau; go to the software updates -> additional driver to look for nvidia driver. I am fortunate that I did not get the mx150 model.

I confirm that install 4.19.10 via ukuu worked for me on zenbook ux533FD with windows 10 dual boot!

Now I can play PC game with my windows 10, and develop on my ubuntu 18.04!

Thank you all very much!

You guys are the best!

antubis (avreon) wrote :

I also want to confirm that the sound has come back when I upgraded the kernel to 4.19.18. I am using Mint 19.1 and by default it didn't work.

Warning! I first upgraded to 4.20.5 but it didn't work. I switched to the 4.19 and it magically started to work!

And on a side note it works better than the stock windows version. The sound card was making weird static noises when used on Windows 10.

Maksym Antonyuk (maks2002) wrote :

Hey All. I run into troubles with sound also on my Asus UX331UAL (EG022T) laptop with ALC294 sound card. I run Kubuntu 18.04.
I confirmed that after updating kernel to v4.19.19 Sound works well. Updated only kernel without any patches. Updated using Ukuu app. And it is not depending form method of shutdown windows OS (shutdown or restart).
Thanks this topic)

PS: I also run into other troubles. When laptop in sleep mode when running Kubuntu battery is not charging (battery led not lighting). When I trying to charge laptop when Kubuntu work normally, the battery starts charging (battery led lighting), but it never finishes charging and led always lighting with orange. When I shutting down my laptop battery charging in normal mode. Also, all works perfectly in Windows.
Did the anyone run into such troubles? And I will appreciate if anyone can forward me to the solution for this issue.

Maksym Antonyuk (maks2002) wrote :

Small Update. Yes, sometimes when I work on Windows and reboot to Kubuntu sound card stop working.
When I load back to Windows and next shutdown it. And after that sound card begins work correctly.

antubis (avreon) wrote :

I have the issue that Maksym is talking about. Indeed using 4.19.18 "fixed" the problem but it seems to be fixed somehow randomly. When I restart the laptop and enter my paassword, Linux Mint tries to play an intro chime but it gets cut off at the middle or at the end. I have to restart, login and it may or maynot fix the issue. After few restarts it starts working permanently for the duration of the session but this is not a real solution, isn't it? If someone is aware how to fix this issue please raise your voice!

VanVan (w-o) wrote :

@avreon Keep in mind there is two different fixes to the kernel depending on your hardware :
- Fix for UX333, UX433, UX533 and some others starting from 4.19.10
- Fix for UX391UA and some others starting from kernel 5.0-rc1

uecm (uecm) wrote :

Quick question, I have exactly the same problem but with one small difference. I have Asus Q325UA which is pretty much the black version of UX391UA as far as I know. lshw gives out the following information

system Q325UAR
bus Q325UAR

My concern is that since the system reports a different model, it will require yet another different line to be added to the patch. Can somebody shed some light if that model needs to be added separately or will the UX391UA fix the problem on QA325UA as well?

Also, how should I go about submitting a request for the QA325UA if needed?

Thanks!

xiajiexing (xingxiajie) wrote :

confirmed my sound problem was solved using
-Linux Kernel 4.19.10
on my
-aus zenbook ux533fd
-dual boot windows 10 and ubuntu 16.04

by following the next steps:

1. install Ukuu

sudo add-apt-repository ppa:teejee2008/ppa

sudo apt-get update

sudo apt-get install ukuu

2. install kernel 4.19.10

sudo ukuu --install v4.19.10

3.restart(reboot)->select "advanced options" -> select kernel version 4.19.10

for more questions, simply: <email address hidden>

thanks the commends upon, especially #78 #96

thanks all !

antubis (avreon) wrote :

So I switched to Linux Kernel 5 since RC-5 and I was switching to the latest version ever since a new one is released. It seems that the 5 branch has fixed the issue for good. I am on 5.0.1 and have no issue with output. *fingers crossed*

However I do have an issue with the input. Cannot recognize my internal microphone. Not a big issue as I don't speak that much or I can use different devices for that communication but the mic is the last bit that is not working on that "damn" Asus Zenbook.

1 comments hidden view all 115 comments
Javier Marzan (javiermrz) wrote :

[Edited] (Didnt find how to edit a post)

Confirmed kernel 4.19.17 solved my problem.
Notebook Model: Asus Zenbook UX433FN
Ubuntu 18.10.
Dual Boot with Windows 10.

I changed the kernel with the visual interface of ukuu, easy and simple.
You just select the version, install, and then reboot. In the GRUB menu, select Advanced Options for Ubuntu, and select the desired kernel version.
If you have an Nvidia card it's possible that ukuu gets stuck in "setting up linux-headers" while installing the kernel version. Only thing you have to do to solve this is Disable Secure Boot from the BIOS.

Thanks to all in this thread, saved my life :D

uecm (uecm) wrote :

@VanVan

Just updated to kernel 5.0 and the sound on my model ( Asus Q325UAR / dual boot ) does NOT work.
How/where can I submit a report so that the model is included in the list for the fix?

As far as I am aware the Q325UAR hardware is exactly the same as UX391UA but the model was targeted at a different retailer.

Thanks!

Daniel van Vugt (vanvugt) wrote :

The kernel fix (comment #77) only checks for the laptop model name, not anything else. So it will only work for "ASUS UX391UA". If you have a different model of laptop then please open a different bug.

https://mailman.alsa-project.org/pipermail/alsa-devel/2018-December/143282.html

no longer affects: alsa-driver (Ubuntu)
Changed in linux (Ubuntu Disco):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Cosmic):
status: New → Confirmed
Changed in linux (Ubuntu Bionic):
status: New → Confirmed
Ben (z80-ben) wrote :

The Q325UAR is quite different from the UX391UA so as @vanvugt points out, a separate bug report should be opened for that and any model other than the UX391UA, which now has this issue fixed.

Stephan Griesel (sgriesel) wrote :

Thank you @Santiago Londoño your solution worked. Just to add I also had to disable secure boot else it was not booting up.

Yaroslav (jasow) wrote :

Thank you @Santiago Londoño. I spend a lot of hours trying to fix this problem on my ux533fd. You saved me)

Displaying first 40 and last 40 comments. View all 115 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers