[radeon] Ubuntu boots to a black screen

Bug #1784473 reported by Amit Dube on 2018-07-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
mutter (Ubuntu)
Undecided
Unassigned

Bug Description

After a fresh install of ubuntu 18.04LTS(dual booted with windows 7) when I selected ubuntu from the grub menu to boot into the OS. But I got a black screen I waited for few seconds but I was still at black screen. So, I forced shutdown the laptop. Again in second attempt to login I got black screen this time I waited for more than a minute and pressed power button once which suspended the pc then I pressed enter and I was presented with login screen. To solve the problem I followed this guide https://askubuntu.com/questions/1029624/ubuntu-18-04-live-boot-leads-to-blank-screen

and changed quiet splash to nomodeset quiet splash. After applying this fix there was no black screen at the time of login, but the laptop started to freeze randomly even when left idle for more than 30 mins it would freeze. I had force shutdown each time and this happened very frequently.
I again changed nomodeset quiet splash to quiet splash, which again leads to black screen after selecting ubuntu from the grub menu. I also did RAM test using Memtest86 from GRUB and everything was fine

systemd-analyze time
Startup finished in 6.015s (kernel) + 1min 26.820s (userspace) = 1min 32.836s
graphical.target reached after 1min 25.472s in userspace

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Tue Jul 31 00:17:48 2018
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
DkmsStatus: virtualbox, 5.2.10, 4.15.0-29-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GpuHangFrequency: Several times a day
GpuHangReproducibility: Seems to happen randomly
GpuHangStarted: Immediately after installing this version of Ubuntu
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Sumo [Radeon HD 6480G] [1002:9648] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Sumo [Radeon HD 6480G] [103c:3564]
InstallationDate: Installed on 2018-07-26 (4 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
MachineType: Hewlett-Packard HP Pavilion g4 Notebook PC
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_IN
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic root=UUID=007c6619-ca84-4c0f-8b16-7fa740dc0c3e ro quiet splash vt.handoff=1
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/24/2014
dmi.bios.vendor: Insyde
dmi.bios.version: F.6D
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3564
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 21.47
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.6D:bd01/24/2014:svnHewlett-Packard:pnHPPaviliong4NotebookPC:pvr0691130000204610000610100:rvnHewlett-Packard:rn3564:rvr21.47:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV G=N L=CON B=HP S=PAV
dmi.product.name: HP Pavilion g4 Notebook PC
dmi.product.version: 0691130000204610000610100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.91-2
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.5-0ubuntu0~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.5-0ubuntu0~18.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: amit 2479 F.... pulseaudio
 /dev/snd/controlC0: amit 2479 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2018-07-26 (4 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
MachineType: Hewlett-Packard HP Pavilion g4 Notebook PC
Package: mutter 3.28.2-2~ubuntu18.04.1
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_IN
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic root=UUID=007c6619-ca84-4c0f-8b16-7fa740dc0c3e ro quiet splash vt.handoff=1
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-29-generic N/A
 linux-backports-modules-4.15.0-29-generic N/A
 linux-firmware 1.173.1
Tags: bionic
Uname: Linux 4.15.0-29-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirt lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 01/24/2014
dmi.bios.vendor: Insyde
dmi.bios.version: F.6D
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3564
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 21.47
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.6D:bd01/24/2014:svnHewlett-Packard:pnHPPaviliong4NotebookPC:pvr0691130000204610000610100:rvnHewlett-Packard:rn3564:rvr21.47:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV G=N L=CON B=HP S=PAV
dmi.product.name: HP Pavilion g4 Notebook PC
dmi.product.version: 0691130000204610000610100
dmi.sys.vendor: Hewlett-Packard
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: amit 2479 F.... pulseaudio
 /dev/snd/controlC0: amit 2479 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2018-07-26 (4 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
MachineType: Hewlett-Packard HP Pavilion g4 Notebook PC
Package: mutter 3.28.2-2~ubuntu18.04.1
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_IN
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic root=UUID=007c6619-ca84-4c0f-8b16-7fa740dc0c3e ro quiet splash vt.handoff=1
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-29-generic N/A
 linux-backports-modules-4.15.0-29-generic N/A
 linux-firmware 1.173.1
Tags: bionic
Uname: Linux 4.15.0-29-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirt lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 01/24/2014
dmi.bios.vendor: Insyde
dmi.bios.version: F.6D
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3564
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 21.47
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.6D:bd01/24/2014:svnHewlett-Packard:pnHPPaviliong4NotebookPC:pvr0691130000204610000610100:rvnHewlett-Packard:rn3564:rvr21.47:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV G=N L=CON B=HP S=PAV
dmi.product.name: HP Pavilion g4 Notebook PC
dmi.product.version: 0691130000204610000610100
dmi.sys.vendor: Hewlett-Packard

Amit Dube (amitdube) wrote :
Daniel van Vugt (vanvugt) wrote :

I think this might be the same as bug 1782347. What do you think?

tags: added: black-screen radeon
summary: - Xorg freeze
+ [radeon] Ubuntu boots to a black screen
affects: xorg (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
Changed in mutter (Ubuntu):
status: New → Incomplete
Amit Dube (amitdube) wrote :

I think they are not same. In bug https://bugs.launchpad.net/bugs/1782347 the user says he needs to boot with nomodeset for both the installed and liveCD.
I can boot with bootable pendrive just fine without using nomodeset.

Also the user says "GDM3 will not boot (the screen will keep on flashing in semi-textual mode, with a white mouse arrow stuck)."

I on the other hand get a black screen(no mouse cursor or flashing) after selecting ubuntu from grub menu.
Work-around for this is that I wait for a minute and press the power button to suspend and press any key to get to the login screen.
So I think GDM3 Boots.

I aslo tried your advice
"Please edit your /etc/gdm3/custom.conf and comment out:

  WaylandEnable=false"

but it didn't work and had to boot with work-around I mentioned above.

Also adding nomodeset allowed me to boot without black screen, but it randomly froze the laptop forcing to do a force shutdown. So I removed nomodeset.

tags: added: apport-collected
description: updated

apport information

Amit Dube (amitdube) wrote : CRDA.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Amit Dube (amitdube) on 2018-07-31
description: updated
Daniel van Vugt (vanvugt) wrote :

Saying "GDM3" is actually incorrect but we understand what they mean. When someone says that they just mean the login screen never arrives. But problems with the login screen not appearing are generally to do with Mutter which provides the graphics foundation for the login screen and the shell.

Also, if a live USB session works then that would usually suggest it's a problem with the Mutter Wayland backend. Because a live USB session avoids Wayland and uses X11 instead. The login screen on the other hand is always Wayland.

The workaround of "edit your /etc/gdm3/custom.conf and comment out: WaylandEnable=false" would usually solve cases like this. So please check that you are NOT using "nomodeset" when you try that.

Amit Dube (amitdube) wrote :

"So please check that you are NOT using "nomodeset" when you try that"
yes i tried it without nomodeset.
I removed nomodeset yesterday becasue it froze the laptop randomly.

Changed in linux (Ubuntu):
status: Incomplete → New
Changed in mutter (Ubuntu):
status: Incomplete → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.18 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.18-rc7

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Amit Dube (amitdube) wrote :

After installing upstream kernel the issue is solved though boot time is long.
I get this screen(https://ibb.co/isQYTz) after selecting the kernel from grub, not an issue to me but thought to inform you.
Also can I remove the kernel because had remove virtualbox

description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-fixed-upstream
To post a comment you must log in.