ELAN1200 touchpad not working at all with kernel 4.15+; Recognized as ITE 8910 keyboard

Bug #1777679 reported by Alistair Sutter on 2018-06-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Laptop is an Asus-GL503VD

Touchpad is an ELAN touchpad model 1200.

This bug is relative to the Asus-GL503VD and any Asus laptop using the ELAN1200 touchpad.

I tried Arch, Debian, Ubuntu 14/16/18, Pop_OS, Sabayon Linux, Fedora. Same problem, touchpad is totally unresponsive.

From what I understand the touchpad is being recognized as a keyboard and I cannot get any driver to recognize it: elan-i2c or synaptics.

The touchpad is also being recognized as a USB device.

This behaviour was consistent on kernels 4.15.0-22, 4.15.0-23 and 4.17.1.
Right now trying to make it work on kernel 4.15.0-23 because it seems more "main-stream".

Note: I have a keyboard recognized as AT Translated Set 2 keyboard which makes me believe I do not need ITE8910 to be a keyboard.

Note2: Been researching LKM development. Managed to make a signed 'hello world' lkm and make it output in dmesg. Willing to help debug/develop the driver for this touchpad.
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ttr 1798 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.04
HibernationDevice: RESUME=UUID=7791e5a6-d685-49b9-93d7-017c1abf4b89
InstallationDate: Installed on 2018-06-10 (9 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
MachineType: ASUSTeK COMPUTER INC. GL503VD
NonfreeKernelModules: nvidia_modeset nvidia
Package: linux (not installed)
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-23-generic root=UUID=98160487-6d8d-429c-830c-035e5faeb890 ro CONFIG_MODVERSIONS=true nvidia.modeset=1 nouveau.modeset=0 acpi=force i8042.reset i8042.nomux i8042.nopnp i8042.noloop
ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-23-generic N/A
 linux-backports-modules-4.15.0-23-generic N/A
 linux-firmware 1.173.1
Tags: bionic
Uname: Linux 4.15.0-23-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip libvirt lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 10/03/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: GL503VD.304
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: GL503VD
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrGL503VD.304:bd10/03/2017:svnASUSTeKCOMPUTERINC.:pnGL503VD:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnGL503VD:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: GL
dmi.product.name: GL503VD
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1777679

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Alistair Sutter (taitair) wrote :
Alistair Sutter (taitair) wrote :
Alistair Sutter (taitair) wrote :
Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected bionic
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: New → Confirmed
summary: - ELAN1200 touchpad not working at all with kernel 4.15+; Recognized at
+ ELAN1200 touchpad not working at all with kernel 4.15+; Recognized as
ITE 8910 keyboard
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.17 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.18-rc1

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Alistair Sutter (taitair) wrote :

As stated in the bug description this was already tested on kernel 4.17, unsuccessfully.

kernel-bug-exists-upstream

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Alistair Sutter (taitair) wrote :

kernel-bug-exists-upstream

Alistair Sutter (taitair) wrote :

Update: Bug seems to be related to i2c-hid

Cannot boot properly with i2c-hid. Had to blacklist i2c-hid a while ago.
Un-blacklisting i2c-hid causes boot to fail with black-screen with ctrl+alt+f* combos unresponsive.

I don't know how to debug i2c-hid since the black-screen stops me from accessing anything even terminal login.

Alistair Sutter (taitair) wrote :

Update: Seems like the TouchPad is not to be found anywhere on my system.
I know that it is USB from the dmesg output however when I tried to see its usb descriptors with lsusb -vd I only saw reports for keyboard-related functions.
I cannot find the descriptors which would look like a touchpad.

Maxime TEIL (maxime+t) wrote :

Hi everyone,

I'm late in this discussion but I may have a solution for those who are in the same case than Alistair Sutter and me before.
This solution works if you use the kernel command 'acpi_osi=!" and maybe some else.
I had exactly the same issue on my Asus FX503VD with the same config. I tried everything I found on several forums without success... until today!

If you get one of the latest kernel (4.17.2 for me) and remove the kernel parameter 'acpi_osi=!' you should find the elantech touchpad with xinput and use it (for years I hope...) without bugs with the screen backlight... et voilaaaa!

Sorry for my frenglish.

Maxime

Cristian Francu (francu) wrote :

I can confirm Maxime's solution works on my Asus FX73V which uses the Elan 1200 touchpad. I'm using gentoo with kernel 4.17.2, with all the relevant config options enabled (I2C, HID, ELAN, etc). I had 'acpi_osi=!' as a kernel parameter. Once I removed it the touchpad started working.

Thanks Maxime!
Cristian

Alistair Sutter (taitair) wrote :

Hi Maxime,

I never used the kernel parameter acpi-osi=! while I was on 4.17. I will install 4.17.2 to make sure the problem hasn't been solved.
I noticed you wrote "elantech touchpad". Elantech is a different touchpad than mine.

Cristian mentions the Elan1200 touchpad though which is the right one. Both of your comments make me think the issue is ACPI related.

Thanks, will try the very latest kernel, check grub parameters, and get back to you.

Alistair Sutter (taitair) wrote :

Thanks everyone, 4.17.2 seems to fix the problem. Did not need any acpi GRUB parameters and unblacklisted i2c-hid without any problems.

I now have touchpad control!

To anyone who runs into this problem here is the solution:

- get the prerequisits: sudo apt install git fakeroot build-essential ncurses-dev xz-utils libssl-dev bc
- Download the source for kernel 4.17.2 on kernel.org.
- Extract the tar.xz file in a folder of your choosing with tar -xJf.
- Go in the extracted folder and copy your current configuration which is in /boot/ with `cp /boot/config-$(uname -r) ./.config` (Might need to be root)
- run `make menuconfig`, save the config to .config and exit.
- run `make -j <numberofavailablecpucores>` (if you forget -j it will take for ever)
- run `make modules_install -j <numberofavailablecpucores>`
- run `make install -j <numberofavailablecpucores`

If everything goes correctly, initramfs and grub should get updated automatically, if not:

- run `update-initramfs -c -k 4.17.2`
- run `update-grub`

Kernel was now installed correctly. Make sure i2c-hid is not blacklisted and reboot.

Hope this helps someone!

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Gaston Castro (gcastro89) wrote :

I also have an AsusGL503VD with an ELAN touchpad listed by xinput as:

ELAN1200:00 04F3:3090 Touchpad

I installed the kernel 4.17.2 by .deb packages availables on ppa ubuntu kernel mainline (kernel.ubuntu.com/~kernel-ppa/mainline/).

The touchpad is detected but cursor freezes and jumps around randomly. i2c-hid is listed on lsmod and I have tried with the xorg synaptics touchpad driver (xserver-xorg-input-synaptics package) but the weird behavior remains. Also tried with i8042 and acpi related kernel commands on the grub config.

Are you getting completely clean operation? can you provide new diagnostics files, like your lsmod output?

Alistair Sutter (taitair) wrote :

Hi Gaston. This bug report was for the touchpad not being detected. I managed to get it detected by installing kernel 4.17.2 from kernel.org.

For the erratic behaviour/disconnects please go to this bug report and share your problem there:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1778087

Cheers!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers