Comment 0 for bug 1774181

Xenial is currently lacking full support of upstream's Spectre v1 mitigation. As a first step to get there, add the array_index_nospec macro and all the (simple) patches that make use of it.