Wifi realtek 8822be BUG <=18.04

Bug #1761693 reported by paag on 2018-04-06
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I am a regular linux user and i have bought last week a new computer that comes with the realtek 8822be wireless chipset.

While using Ubuntu 16.04(Kernel version updated to 4.14 where we started to have support to this chipset) or both 18.04 beta 1 and final version i found a problem:

1º when i boot all this versions with the kernel version >= 4.14, i found out that the driver is instaled and she is detected in the network manager.Anyway, when i used she won´t work and in few secconds later will shutdown. When i go to the wifi settings i can´t find networks!

2º I use modprobe so that i can manipulate my drivers/modules and i can start to work with my wifi card:
-> modprobe -rv r8822be
-> modprobe -v r8822be aspm=0

The problem is that when i connect to a 5ghz frequency router, i have very slow download speed 8 mbps max (Usually my speed is approximately 200/210 mbps in wifi mode).In the outher hand when i connect to a 2.4ghz frequency router it works fine!

Thanks

Best regards
---
ApportVersion: 2.20.9-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: teste 1285 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.04
HibernationDevice: RESUME=UUID=9fdace6b-915c-4770-8261-aa8dcaa735b1
InstallationDate: Installed on 2018-04-07 (0 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Beta amd64 (20180404)
MachineType: ASUSTeK COMPUTER INC. X411UN
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-13-generic.efi.signed root=UUID=1d0c4a1b-32fe-43b2-ae21-2b0d9101e5fc ro quiet splash vt.handoff=1
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-13-generic N/A
 linux-backports-modules-4.15.0-13-generic N/A
 linux-firmware 1.173
StagingDrivers: r8822be
Tags: bionic staging
Uname: Linux 4.15.0-13-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 08/04/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X411UN.300
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X411UN
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX411UN.300:bd08/04/2017:svnASUSTeKCOMPUTERINC.:pnX411UN:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX411UN:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: X
dmi.product.name: X411UN
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

paag (paaag) on 2018-04-06
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1761693/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
paag (paaag) on 2018-04-06
description: updated
description: updated
summary: - Wifi realtek 8822be BUG
+ Wifi realtek 8822be BUG <=18.04
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1761693

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.16 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16

Changed in linux (Ubuntu):
importance: Undecided → Medium
paag (paaag) wrote : AlsaInfo.txt

apport information

tags: added: apport-collected bionic staging
description: updated
paag (paaag) wrote : CRDA.txt

apport information

paag (paaag) wrote : CurrentDmesg.txt

apport information

paag (paaag) wrote : IwConfig.txt

apport information

paag (paaag) wrote : Lspci.txt

apport information

paag (paaag) wrote : Lsusb.txt

apport information

paag (paaag) wrote : ProcCpuinfo.txt

apport information

apport information

paag (paaag) wrote : ProcEnviron.txt

apport information

apport information

paag (paaag) wrote : ProcModules.txt

apport information

paag (paaag) wrote : PulseList.txt

apport information

paag (paaag) wrote : RfKill.txt

apport information

paag (paaag) wrote : UdevDb.txt

apport information

paag (paaag) wrote : WifiSyslog.txt

apport information

paag (paaag) wrote :

I am making a little Logbook and picture data about the problem and i will put it here later. Anyway, i run apport-collect 1761693 as requested and the data is being collected and I will send it to you.

paag (paaag) wrote :

The debug works like :

1º I started by doing a "fresh" installation of Ubuntu

2º I checked the system first and i tried to use the wifi. (won´t work)
The files are:
-> iwconfig.txt;
-> Hardware_data.txt (Data of the chipset);
-> dmesg_first (dmesg report)
-> Pictures -> first_1 (wifi list) , first_2 (trying to use) , first_3 (wifi list disappeared)
-> dmes_sec.txt

3º applying commands

-> modprobe -rv r8822be
-> modprobe -v r8822be aspm=0

4º Wifi working but 2.4ghz normal and 5ghz very slow
-> iwconfig_after.txt
-> dmesg_after.txt

paag (paaag) wrote :

Lastly, in the version v4.16 kernel[0] wifi won't work in any moment

paag (paaag) wrote :

I think i solve the problem using this process:

1º Fresh Ubuntu system.
2º Pick another driver for the chipset card -> rtlwifi-next -> https://github.com/rtlwifi-linux/rtlwifi-next
3º Reboot the machine.

So you can try to solve problem for stable version: 26th April Stable Ubuntu 18.04 LTS

NOTE: i can not confirme that this will work in the kernel 4.16.

paag (paaag) wrote :

After 24h i can confirm that my solution is not stable. If i turn off the machine the problem is back and this time is not speed in question but the network manager that will "collapse".

Anyway, i can confirm that i can use the wifi card in any frequency, but is not stable and will drop after boot many times until the network manager crash.

Changed in linux (Ubuntu):
status: Incomplete → New
paag (paaag) wrote :
Download full text (12.0 KiB)

[ 140.014404] ---[ end trace 06d9b1a38644b1a5 ]---
[ 146.093218] r8822be: [ERR]Pwr cmd polling timeout!!
[ 146.093228] r8822be: [ERR]Pwr cmd offset : 5!!
[ 146.093231] r8822be: [ERR]Pwr cmd value : 0!!
[ 146.093235] r8822be: [ERR]Pwr cmd msk : 2!!
[ 146.093238] r8822be: [ERR]Read offset = 5 value = 2!!
[ 146.093242] r8822be: [Err]pwr sub seq parser fail, status = 0x28!
[ 146.093245] r8822be: Handle power off cmd error
[ 159.806294] r8822be: halmac_init_hal failed
[ 159.806317] r8822be: halmac_init_hal failed
[ 159.806333] r8822be: halmac_init_hal failed
[ 159.806350] r8822be: halmac_init_hal failed
[ 159.806366] r8822be: halmac_init_hal failed
[ 159.806381] r8822be: halmac_init_hal failed
[ 159.806396] r8822be: halmac_init_hal failed
[ 159.806411] r8822be: halmac_init_hal failed
[ 159.806427] r8822be: halmac_init_hal failed
[ 159.806442] r8822be: halmac_init_hal failed
[ 165.923616] r8822be: [ERR]Pwr cmd polling timeout!!
[ 165.923626] r8822be: [ERR]Pwr cmd offset : 5!!
[ 165.923630] r8822be: [ERR]Pwr cmd value : 0!!
[ 165.923633] r8822be: [ERR]Pwr cmd msk : 2!!
[ 165.923637] r8822be: [ERR]Read offset = 5 value = 2!!
[ 165.923640] r8822be: [Err]pwr sub seq parser fail, status = 0x28!
[ 165.923644] r8822be: Handle power off cmd error
[ 198.838942] r8822be: halmac_init_hal failed
[ 198.838966] r8822be: halmac_init_hal failed
[ 198.838982] r8822be: halmac_init_hal failed
[ 198.838997] r8822be: halmac_init_hal failed
[ 198.839013] r8822be: halmac_init_hal failed
[ 198.839029] r8822be: halmac_init_hal failed
[ 198.839044] r8822be: halmac_init_hal failed
[ 198.839060] r8822be: halmac_init_hal failed
[ 198.839076] r8822be: halmac_init_hal failed
[ 198.839091] r8822be: halmac_init_hal failed
[ 204.947841] r8822be: [ERR]Pwr cmd polling timeout!!
[ 204.947851] r8822be: [ERR]Pwr cmd offset : 5!!
[ 204.947854] r8822be: [ERR]Pwr cmd value : 0!!
[ 204.947858] r8822be: [ERR]Pwr cmd msk : 2!!
[ 204.947861] r8822be: [ERR]Read offset = 5 value = 2!!
[ 204.947864] r8822be: [Err]pwr sub seq parser fail, status = 0x28!
[ 204.947868] r8822be: Handle power off cmd error
[ 262.061429] r8822be: halmac_init_hal failed
[ 262.061481] r8822be: halmac_init_hal failed
[ 262.061524] r8822be: halmac_init_hal failed
[ 262.061568] r8822be: halmac_init_hal failed
[ 262.061607] r8822be: halmac_init_hal failed
[ 262.061646] r8822be: halmac_init_hal failed
[ 262.061685] r8822be: halmac_init_hal failed
[ 262.061728] r8822be: halmac_init_hal failed
[ 262.061767] r8822be: halmac_init_hal failed
[ 262.061807] r8822be: halmac_init_hal failed
[ 268.168199] r8822be: [ERR]Pwr cmd polling timeout!!
[ 268.168209] r8822be: [ERR]Pwr cmd offset : 5!!
[ 268.168212] r8822be: [ERR]Pwr cmd value : 0!!
[ 268.168216] r8822be: [ERR]Pwr cmd msk : 2!!
[ 268.168219] r8822be: [ERR]Read offset = 5 value = 2!!
[ 268.168222] r8822be: [Err]pwr sub seq parser fail, status = 0x28!
[ 268.168226] r8822be: Handle power off cmd error
[ 295.841849] r8822be: halmac_init_hal failed
[ 295.841871] r8822be: halmac_init_hal failed
[ 295.841888] r8822be: halmac_init_hal failed
[ 295.841903] r8822be: halmac_init_hal failed
[ 295.841918] r8822be: halmac_init_ha...

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Kai-Heng Feng (kaihengfeng) wrote :

Please try v4.17-rc1.

There are some new commits for 8822be.

paag (paaag) wrote :

Thx for the info. I will wait that the final bionic beaver version comes out and i will try the new kernel on that version.

paag (paaag) wrote :

Meanwhile, i upgraded my kernel for the version 4.17-rc1 but the problem remains. When i boot the machine the system detects the wifi but he only works for a few sec (5/10 sec max). Then the wifi loses connection from the network that he was connected and in the end (20/30 sec) the Available networks disappear and the network manager stops working.Also, during this 20/30 sec process the operating system seems to be limited and slower

To mitigate this problem i have made two things:

1º /etc/modprobe.d/blacklist.conf -> blacklist rtl8822be (Because i found out that in the system was two wifi drivers)

2º /etc/modprobe.d/r8822be.conf -> options r8822be aspm=0

When i do this, the wifi card works fine, the operation system works smooth and i can reboot the system without problem!This works in ubuntu, linux mint, and other distribution that i have tested due to this problem.

Kindly regards.

paag (paaag) wrote :

Hello some new data about this issue,

While testing the new stable version of the bionic beaver i detected something interesting. The wifi connection or the network manager only switches off when i open the browser. I used the bionic beaver (2018-04-25 22:47) bootable USB and i have made this log book for you:

image 1 - boot;
image 2 - wifi connection;
image 3, 4 and 5 - ping (www.google.com; www.ubuntu.com) without problems;
image 6 - opening firefox (waiting 10 sec before trying again ping).
image 7 - In the end, neither ping or firefox are receiving packages;
image 8 - wifi loses connection and the signal is lost;
image 9 - wifi network vanish.

Attached are the images and dmesg log of the beginning of the process and at the end.

Kai-Heng Feng (kaihengfeng) wrote :

Please file an upstream bug at https://bugzilla.kernel.org/
Product: Drivers
Component: network-wireless

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.