Comment 10 for bug 1748922

Steve Langasek (vorlon) wrote :

Tested by adding {xenial,artful}-{updates,proposed} to sources.list on a bionic system:

$ sudo apt install linux-tools-4.4.0-116
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linux-tools-4.4.0-116 : Depends: binutils (< 2.27) but 2.30-8ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.
$ sudo apt install linux-tools-4.4.0-117
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libdw1 libelf1 libpci3 libunwind8 linux-tools-common
The following NEW packages will be installed:
  libdw1 libelf1 libpci3 libunwind8 linux-tools-4.4.0-117 linux-tools-common
0 upgraded, 6 newly installed, 0 to remove and 1 not upgraded.
Need to get 699 kB/1161 kB of archives.
After this operation, 3933 kB of additional disk space will be used.
Do you want to continue? [Y/n] ^C
$

$ sudo apt install linux-tools-4.13.0-37-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linux-tools-4.13.0-37-generic : Depends: linux-tools-4.13.0-37 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
$ sudo apt install linux-tools-4.13.0-38-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libdw1 libelf1 libnuma1 libpci3 libunwind8 linux-tools-4.13.0-38
  linux-tools-common
The following NEW packages will be installed:
  libdw1 libelf1 libnuma1 libpci3 libunwind8 linux-tools-4.13.0-38
  linux-tools-4.13.0-38-generic linux-tools-common
0 upgraded, 8 newly installed, 0 to remove and 2 not upgraded.
Need to get 1100 kB/1584 kB of archives.
After this operation, 6991 kB of additional disk space will be used.
Do you want to continue? [Y/n]
$

So this works as expected.