[Asus K501UQ] Touchpad stops working after suspend

Bug #1746372 reported by Sergey Zolotarev on 2018-01-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

When Ubuntu wakes up after suspend the touchpad doesn't work.

WORKAROUND: Use the nvidia proprietary drivers.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: linux-image-4.13.0-32-generic 4.13.0-32.35
ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
Uname: Linux 4.13.0-32-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: szx 1685 F.... pulseaudio
CurrentDesktop: GNOME
Date: Wed Jan 31 05:40:49 2018
InstallationDate: Installed on 2018-01-23 (7 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:0a2a Intel Corp.
 Bus 001 Device 002: ID 04f2:b54b Chicony Electronics Co., Ltd
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. K501UQ
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-32-generic.efi.signed root=UUID=04181349-688b-425f-899c-822fcf6a409b ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-32-generic N/A
 linux-backports-modules-4.13.0-32-generic N/A
 linux-firmware 1.169.2
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/13/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K501UQ.300
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K501UQ
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK501UQ.300:bd09/13/2016:svnASUSTeKCOMPUTERINC.:pnK501UQ:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnK501UQ:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: K
dmi.product.name: K501UQ
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Sergey Zolotarev (szx) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Sergey Zolotarev, thank you for reporting this and helping make Ubuntu better.

In order to allow additional upstream mainline kernel developers to examine the issue, at your earliest convenience, could you please test the latest mainline kernel available from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D ? Please keep in mind the following:
1) The one to test is at the very top line at the top of the page (not the daily folder).
2) The release names are irrelevant.
3) The folder time stamps aren't indicative of when the kernel actually was released upstream.
4) Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds .

If testing on your main install would be inconvenient, one may:
1) Install Ubuntu to a different partition and then test this there.
2) Backup, or clone the primary install.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the mainline kernel, please comment on which kernel version specifically you tested. If this issue is not reproducible in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, and Y are the first two numbers of the kernel version, and Z is the release candidate number if it exists.

If the issue is reproducible with the mainline kernel, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Also, you don't need to apport-collect further unless specifically requested to do so.

It is most helpful that after testing of the latest mainline kernel is complete, you mark this report Status Confirmed.

Lastly, to keep this issue relevant to upstream, please continue to test the latest mainline kernel as it becomes available.

Thank you for your help.

summary: - Touchpad stops working after suspend
+ [Asus K501UQ] Touchpad stops working after suspend
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
description: updated
Sergey Zolotarev (szx) wrote :

I installed the latest kernel (4.15) from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.15/ but it didn't help. Touchpad worked for a few seconds after wakeup but then it stopped working. Also same issue with reboot again, don't know why you deleted it.

tags: added: kernel-bug-exists-upstream
tags: added: kernel-bug-exists-upstream-4.15
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Sergey Zolotarev, to advise, reports focus on one issue per report. This report is scoped to touchpad not working after suspend, not everything that may or may not work after suspend, or whatever other issues you may have.

Despite this, could you please provide the missing information from https://wiki.ubuntu.com/DebuggingKernelSuspend ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Sergey Zolotarev (szx) wrote :

This patch worked for me with v4.15 kernel:

https://paste.ubuntu.com/26496011/

I basically found the old patch and added an entry for K501UQ there. The author changed his code from using DMI_PRODUCT_NAME to DMI_CHASSIS_TYPE since then but that doesn't work for my laptop apparently.

tags: added: kernel-da-key
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Sergey Zolotarev (szx) wrote :

I was wrong, this didn't fix the bug. After a few more suspends and wakes the touchpad is dead again.
I think it may depend on how many times the system is suspended or for how long it was suspended.

Changed in linux (Ubuntu):
status: Triaged → Incomplete

Sergey Zolotarev, please boot into latest mainline kernel with no patching/modifications, and provide the information from #5.

Sergey Zolotarev (szx) wrote :

1. The issue occurs when resuming from suspend.
2. Suspend by closing the lid.
3. Resume by lifting the lid.
4-10. Can't provide this information because I can't get to the console after waking up.
11. See suspend_stats.txt.
12. Can't SSH into the laptop after resume - ssh says "No route to host". But under normal conditions I can SSH into it.

Sergey Zolotarev (szx) wrote :

Could this be the cause?

[ 4381.182926] irq 109: nobody cared (try booting with the "irqpoll" option)
[ 4381.182932] CPU: 2 PID: 0 Comm: swapper/2 Tainted: G OE 4.13.0-32-generic #35-Ubuntu
[ 4381.182933] Hardware name: ASUSTeK COMPUTER INC. K501UQ/K501UQ, BIOS K501UQ.300 09/13/2016
[ 4381.182934] Call Trace:
[ 4381.182935] <IRQ>
[ 4381.182941] dump_stack+0x63/0x8b
[ 4381.182943] __report_bad_irq+0x35/0xc0
[ 4381.182945] note_interrupt+0x24b/0x2a0
[ 4381.182948] handle_irq_event_percpu+0x54/0x80
[ 4381.182950] handle_irq_event+0x3b/0x60
[ 4381.182951] handle_fasteoi_irq+0x75/0x120
[ 4381.182954] handle_irq+0x1a/0x30
[ 4381.182956] do_IRQ+0x46/0xd0
[ 4381.182958] common_interrupt+0x1af/0x1af
[ 4381.182959] </IRQ>
[ 4381.182962] RIP: 0010:cpuidle_enter_state+0x130/0x2d0
[ 4381.182963] RSP: 0018:ffffc0e34193fe58 EFLAGS: 00040246 ORIG_RAX: ffffffffffffffbe
[ 4381.182965] RAX: ffff9fae05d22ac0 RBX: 000003fc12da146f RCX: 000000000000001f
[ 4381.182965] RDX: 000003fc12da146f RSI: 000003f8d7449b52 RDI: 0000000000000000
[ 4381.182966] RBP: ffffc0e34193fe98 R08: 00000000ffffffff R09: 0000000000000008
[ 4381.182967] R10: ffffc0e34193fe28 R11: 0000000000000001 R12: ffff9fae05d2b400
[ 4381.182968] R13: 0000000000000000 R14: 0000000000000001 R15: ffffffff97f7a098
[ 4381.182970] ? cpuidle_enter_state+0x120/0x2d0
[ 4381.182972] cpuidle_enter+0x17/0x20
[ 4381.182974] call_cpuidle+0x23/0x40
[ 4381.182975] do_idle+0x19a/0x200
[ 4381.182976] cpu_startup_entry+0x73/0x80
[ 4381.182978] start_secondary+0x175/0x1b0
[ 4381.182980] secondary_startup_64+0x9f/0xa0
[ 4381.182982] handlers:
[ 4381.182985] [<ffffffff96ce8300>] irq_default_primary_handler threaded [<ffffffffc0884940>] elan_isr [elan_i2c]
[ 4381.182990] Disabling IRQ #109

Sergey Zolotarev (szx) wrote :

Unfortunately I can't perform steps 4-10 in the suspend debugging guide because the display is not working after waking up when doing pm_trace (it's turned off), and I can't SSH into the system from another computer because the network seems to be down as well (No route to host). When the laptop is booted properly I can SSH into it without issues.

Sergey Zolotarev, the latest mainline kernel is now 4.15.1. As per your logs, you were booted in the Ubuntu kernel. So that upstream may review, could you please provide the information with latest mainline?

Sergey Zolotarev (szx) wrote :

I've installed the 4.15.1 kernel, what should I do next? I'm having the same pm_trace issue as before.

Sergey Zolotarev, to clarify, have you always had the issue of the display not working after waking up and you can't SSH into it, or is this something that started recently?

tags: added: latest-bios-300
Sergey Zolotarev (szx) wrote :

I installed Ubuntu on this laptop a couple of weeks ago, so I can't say. But before Ubuntu I was using Fedora 27 for around 2 months and I didn't experience this problem there.

I'm attaching dmesg output after another touchpad incident, from 4.15.1 this time. I hope it helps. It looks like this may have something to do with nouveau, should I try using the proprietary NVIDIA drivers?

Sergey Zolotarev, to clarify, let us focus on the timeframe from since you installed Ubuntu a couple weeks ago to present.

1) To advise, it wouldn't hurt to see how things change when you use the nvidia proprietary driver. However, you will want to use the Ubuntu kernel (not mainline) before installing it and while using it. For information on nvidia versions available one may see https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia .

2) To clarify, when you resume from suspend, is it that one of the three following outcomes occur or only two:
* Upon resume the display is not working and you can't SSH into it.
* It resumes but only the touchpad isn't working.
* It resumes and everything is working fine.

3) It would be helpful if you out the nvidia card from the pc to see if this influences your resume results.

Sergey Zolotarev (szx) wrote :

1) I've been using the drivers from NVIDIA with the normal (not mainline) kernel 4.13.0-32 for the past week and haven't had this touchpad issue.

2) When I resume from suspend the touchpad either works or it doesn't. It always stops working after I suspend/resume a few times. How much times can vary, but it's inevitable. The problem with the display occurs only when I enable pm_trace and then suspend and resume.

3) I don't think I can remove the NVIDIA card from this laptop. Even if I can I'm too afraid I'll break something and it will stop working.

description: updated

Sergey Zolotarev:

Given the nvidia drivers are a WORKAROUND, it appears the touchpad not working is correlated to an issue with the graphics driver nouveau.

Hence, in order to upstream this, could you please remove the WORKAROUND, install the latest mainline kernel (now 4.16-rc1), reproduce, and attach the dmesg?

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers