[regression] hibernation (freezes on resume) since 4.13.0-25.29

Bug #1743094 reported by Jørgen Best on 2018-01-13
612
This bug affects 121 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Artful
Medium
Unassigned
linux-hwe (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-384 (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
Undecided
Unassigned

Bug Description

After hibernating the system and than resuming it the system reboots notifying that it is resuming and than stops/freezes. The system does not respond to anything (no tty's other notifying textg are available).

After booting kernel 4.10-042 the hibernation and hibride hibernation/sleep functions as proposed.
---
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jb 1717 F.... pulseaudio
CurrentDesktop: X-Cinnamon
DistroRelease: Linux 18.3
HibernationDevice: RESUME=UUID=00059f88-0cf2-44a0-a23d-f0a995cb1478
InstallationDate: Installed on 2017-12-10 (34 days ago)
InstallationMedia: Linux Mint 18.3 "Sylvia" - Release amd64 20171124
MachineType: Acer Aspire S3-391
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-26-generic root=UUID=5397ffb7-8114-45c4-824f-b1da7cce468c ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.13.0-26.29~16.04.2-generic 4.13.13
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-26-generic N/A
 linux-backports-modules-4.13.0-26-generic N/A
 linux-firmware 1.157.14
Tags: sylvia
Uname: Linux 4.13.0-26-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 10/31/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V2.10
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: Hummingbird2
dmi.board.vendor: Acer
dmi.board.version: V2.10
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V2.10
dmi.modalias: dmi:bvnInsydeCorp.:bvrV2.10:bd10/31/2012:svnAcer:pnAspireS3-391:pvrV2.10:rvnAcer:rnHummingbird2:rvrV2.10:cvnAcer:ct10:cvrV2.10:
dmi.product.family: ChiefRiver System
dmi.product.name: Aspire S3-391
dmi.product.version: V2.10
dmi.sys.vendor: Acer

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1743094

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

kernel 4.4.0-109 (with kaiser patch against meltdown) does also function all-right.

See attachment for system info.

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: apport-collected sylvia
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Can also confirm that 4.13.0-26-generic causes the computer to fail to resume from hibernation. Downgrading to 4.10.0-42-generic fixes the problem.

Computer: Dell XPS 13 9360
BIOS: 2.5.0

When attempting to resume from hibernation, the LUKS password prompt is displayed, but the screen goes black immediately after entering the password. The Caps Lock key does not work, so I assume the kernel hangs. After leaving the computer for ~30 seconds, the fans begin to run at full speed.

I'm experiencing the same problem with kernel 4.13.0-26-generic, 4.10 series works fine.

Specs:
Intel i7-6700k (using intel-microcode 3.20180108.0~ubuntu16.04.2)
16 GB RAM, 4 GiB Swap
NVidia GTX 970 (nvidia-384.111-0ubuntu0.16.04.1 drivers)

Launchy (launchy-0) wrote :

Hi there,
I face the same problem: 4.13.0-26-generic causes freeze on resume from hibernation.
The 4.10.x kernel series works flawless on my Medion Core i3 Notebook.

Leif Arne Storset (lastorset) wrote :

4.13.0-30.33 (available in artful-proposed) appears to have fixed it for me.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-bisect
Dirk Bachmann (bacdi) wrote :

tested hibenate-resume cycles with a couple of other 4.13 kernels:
4.13.0.16 - works
4.13.0.21 - works
4.13.0.25 - broken
4.13.0.30 - broken (from Canonical Kernel Team PPA)

System:
HP 250 G6 Notebook w/ Intel i3-6006U
Linux Mint 18.2 Sonya

no resume log available in kernel log.

Jørgen Best (jorgenbest) wrote :

If I knew how I might be able to bisect. I found some info on the issue (see links), I think I can compile a kernel if I knew the options that the kernel I used was compiled with. I'm not really a programmer so if I have to read through (too much) code I will fail. Is there a link for Ubuntu standard kernel compiling?

I understand from Dirk Bachmann that some where between 4.13.0.21 en 25 thinks got broken. I understand that I need the first kernel that broke and the one before and somehow have to compare them with git. At least I should be able to find out at what update things got broken.

How can I successfully run the script "git bisect run" step by step if I have to hibernate the system and each time I do this the system will freeze at resume? I assume the analysis will be aborted each time.

If someone has a link to some more info (for a not really programmer), I'll give it a try.

Links:
https://www.kernel.org/doc/html/latest/admin-guide/bug-bisect.html
https://lwn.net/Articles/317154/

Maarten Sijm (mpsijm) wrote :

Same issue here: when trying to resume from hibernation, my laptop screen stays black and I have to force kill it.
Been scrolling through the logs, but there seems to be no data between when I started hibernation and after I restarted my laptop after the force-kill.

Christian Sarrasin (sxc731) wrote :

Same issue here, fresh install of stock Ubuntu 17.10(.1) on a ThinkPad X1 Carbon gen5, kernel 4.13.0-25-generic, with LUKS-encrypted swap partition sitting alongside the root partition. The same hardware/setup worked fine on Zesty but as we know, that just went EoL.

Just to add: the machine seems completely frozen at resume based on the keyboard caps-lock LED test. I do get the LUKS password prompt so that part seems fine.

Hibernation is critical functionality from a security standpoint as an alternative to far less secure suspend to RAM functionality.

Please let us know how/if we can help progressing this bug.

Zsone (zsone) wrote :

Same issue with a Lenovo W520 on 16.04.3 LTS with 4.13.0-26. The quite fresh 4.14.13 kernel (Canonical Kernel Team PPA) solves this "resuming from hibernation" problem. I agree that this is a very important bug that should be solved soon.

Dirk Bachmann (bacdi) wrote :

Kernel 4.14.13 fixes the issue for me too.
(installed as outlined by http://linuxg.net/install-kernel-4-14-on-ubuntu/)

Nonny Moose (moosenonny10) wrote :

I found part of the kernel log describing the failed boot.
Line 642 seems relevant:

    Jan 21 09:12:41 laptop kernel: [ 1.254367] PM: Hibernation image not present or could not be loaded.

Lu Do (tchio.ludo) wrote :

4.13.0-30.33 (available in artful-proposed) don't work for me

4.14.14 works well

I can also confirm that with 4.13.0-30, hibernate did not work, but installing 4.14.13-041413-generic works perfectly.

DenisP (denisp) wrote :

I can confirm that my Laptop freezes on resume from hibernate with Kernel 4.13.0-25 and 4.13.0-31. Last working Kernel version is 4.13.0-21 .
My Laptop is Lenovo Thinkpad T470.

Ariel (rellieberman) wrote :

Same issue affects me after updating to kernel 4.13.0-31.

Resuming starts but after a few seconds screen goes dark and nothing can be done except forcing off the laptop.

Also found "Hibernation image not present or could not be loaded" in kernel log.

Maurice (mak-5) wrote :

Same issue with a Lenovo Y580 on 16.04.3 LTS with 4.13.0-26. I agree that this is a very important bug that should be solved soon.

Maurice (mak-5) on 2018-01-25
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Mikko Suniala (suniala) wrote :

I can confirm the issue on (but not necessarily limited to) 4.13.0-31 and 4.13.0-32 (that I just got 15 minutes ago while upgrading).

I'm running Xubuntu 16.04.3 LTS on a Lenovo Thinkpad X220 with i5-2450M.

DenisP (denisp) wrote :

I can confirm that issue is still present with the kernel 4.13.0-32.

richbl (richbl) wrote :

Also still failing under kernel 4.13.0-32.

I'm running 17.10 on a Dell XPS 15 9560.

                       | systemctl hibernate | systemctl hybrid-sleep | s2disk
-----------------------+----------------------+------------------------+---------
4.13.0-25 : ?? : ?? : broken
4.13.0-31 : ?? : ?? : broken
4.13.0-32 : broken : ?? : broken
4.14.15-041415-generic : work : broken : ??

Ubuntu 17.10
Lenovo ThinkPad T470p

TJ (tj) wrote :

Looking at Dirk Bachmann's comment #23 I did a:

gitlog Ubuntu-4.13.0-18.21..Ubuntu-4.13.0-25.29

That shows the major changes are the x86/mm PTI patches to address the Meltdown issue.

Dirk: can you boot 4.13.0-25 with the kernel command-line option "nopti" and do your hibernate/resume tests and report back?

TJ (tj) on 2018-01-27
summary: - hibernation broken (freezes with resume) in kernel linux-
- image-4.13.0-26-generic
+ [regression] hibernation (freezes on resume) due to PTI
tags: added: regression-release suspend-resume

User confirmed on IRC that "nopti" allowed 4.13.0-25 to resume from hibernation.

Dirk Bachmann (bacdi) wrote :

Unfortunately, "nopti" (GRUB_CMDLINE_LINUX_DEFAULT="nopti loglevel=7 no_console_suspend") does not at all make a difference for me.

Tested hibernate-resume cycles with 4.13.0-25, 4.13.0-26, 4.13.0-31 and 4.13.0-32.

DenisP (denisp) wrote :

Adding nopti to kernel command line doesn't solve the issue for me.
Tested with the Kernel 4.13.0-32 on Lenovo Thinkpad T470.

Zsone (zsone) wrote :

Keep in mind that the 4.14.x PPA kernels also have PTI enabled, still hibernation works fine with them.

DenisP (denisp) wrote :

For me hibernation doesn't work with 4.14.14 PPA kernel.

richbl (richbl) wrote :

Still failing under kernel 4.13.0-32 x86_64 with `nopti` parameter added.

I'm running 17.10 Wayland on a Dell XPS 9560.

Not working on Dell Inspirion 7328 and Lenovo Yoga 520, last working kernel 4.13.0.21. Nopti doesn't solve issue.

Steve (stevebot) wrote :

Works fine for me with 4.14.15-041415-generic. I did not try disabling PTI with 4.13.0-26-generic. Also, I'll note that I only noticed this problem after updating my BIOS (including the latest Intel microcode update and Intel ME patch). Computer: Dell XPS 9360

DenisP (denisp) wrote :

For me hibernation doesn't work with 4.14.15-041415-generic Kernel. However the symptoms are different than with other kernels that have problems with hibernation post 4.13.0-21 kernel, with 4.14.15 the resume from hibernation is performed but my gnome session is broken and lost after the resume. Tested on Lenovo T470 on Ubuntu 17.10.

richbl (richbl) wrote :

@denisp, what do you mean "broken and lost after the resume?" What specifically is occurring? What errors are getting generated, etc?

Zsone (zsone) wrote :

If resume is performed and only the graphical interface is crashing (so you can switch to text console, and you have your processes running), then it's probably a different issue. The original problem described there is that after resume the computers were simply frozen, not responding to anything.

TJ (tj) wrote :

I've updated the title to reflect the additional test results. It would see the bug is in the memory-manager code that was changed to support the PTI workarounds but which is not conditional on pti/nopti.

summary: - [regression] hibernation (freezes on resume) due to PTI
+ [regression] hibernation (freezes on resume) since 4.13.0-25.29
TJ (tj) wrote :

Can everyone check which version of the Intel microcode updates package is installed? There's a suggestion the bug may be due to that. You should see:

$ apt-cache policy intel-microcode
intel-microcode:
  Installed: 3.20180108.0+really20170707ubuntu16.04.1
  Candidate: 3.20180108.0+really20170707ubuntu16.04.1

This is the package that backed out the Intel 20180108 microcode with the previous 20170707 release.

Please report back if hibernate still fails with the 20170707 microcode and kernel 4.13.0-25 or later.

DenisP (denisp) wrote :

I reverted intel microcode package to the 20170707 version:

intel-microcode:
  Installiert: 3.20170707.1
  Installationskandidat: 3.20180108.0+really20170707ubuntu17.10.1

After that I performed hibernation tests with following kernel versions: 4.13.0-25, 4.13.0-31 and 4.13.0-32. The result is the same behavior as before, black screen and freeze on resume from hibernation. Tested on Ubuntu 17.10 with Lenovo Thinkpad T470.

Nothing Lee (nthlee) wrote :

ubuntu 16.04,4.13.0-31-generic is now running on my ThinkPad x230.

I was writing my diary when the battery ran out. The indicator
told me (as usual) that my laptop is going to hibernate. When I plug
in the AC adapter and turned it on, I met this black screen and freeze
on resume.

At the same time, the fan of my laptop began to work full-power.

I really should have saved my diary before the indicator showed up!

Ariel (rellieberman) wrote :

I have reverted my microcode back to original version (removed the microcode package) and the error persisted.

Also attached are errors i get on boot. Most of them have only started appearing after the fatal kernel update witch caused the hibernation issue.

Dirk Bachmann (bacdi) wrote :

I've not installed intel-microcode package and never had.

Steve (stevebot) wrote :

Is it possible that the system is freezing before it has a chance to apply the OS microcode, so instead it crashes while using the BIOS' microcode? (I'm not sure exactly when the OS microcode gets applied) Is there anyone here with this problem who hasn't updated their BIOS in the last 2 months?

Dirk Bachmann (bacdi) wrote :

I purchased the notebook middle of November last year - no BIOS update since. So BIOS is certainly much older than 2 month.

Ariel (rellieberman) wrote :

My BIOS hasn't been updated for over a year.

TJ (tj) wrote :

Thanks for all the feedback; we'll need to build some test kernels to bisect the regression. Stay tuned.

W4RH4WK (warhawk) wrote :

Lenovo T460s here, suffering from the same problem. BIOS and Intel ME is up-to-date.

Note that using Kernel Mainline (4.15) also seems to sidestep this bug, unless that's a false negative for some other reason (e.g. kernel mainline has an implicitly different load configuration, so isn't creating the conditions for the bug).

I was guided to triage against kernel mainline following instructions here...
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1744065

I note some others have had failures booting 4.15 even though a recent mainline based on 4.15 allowed me to resume my desktop from hibernation successfully.

Probably goes without saying, but saying it anyway. If you don't use the same kernel for boot and for resume, I speculate that could create some issues, so hopefully everyone who is testing a given kernel makes sure they clean boot and hibernate resume using the same grub kernel option. Hibernating with one kernel configuration, and resuming with another would have unknown stability I guess. Sorry to waste time if this is already stated somewhere else.

I'm not sure if it's a freeze or just a graphical issue in my case and there may be two bugs at work here it sounds like. Will try to figure out if mine is indeed a freeze to check Ariel's flagging my reported bug as a duplicate of the one experienced by the OP in this thread.

Zsone (zsone) wrote :

Correct me if I missed something, but since the affected range is so broad (and growing), is there anyone who has hibernation working on Ubuntu with the recent official 4.13.0-25+ kernels?

In my case, (my original report at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1744065 ) I went from...

intel-microcode: Installed: (none)

...to...

intel-microcode: Installed: 3.20180108.0+really20170707ubuntu17.10.1

...and it made no difference when booting linux-image-4.13.0-31-generic

Still don't know if it's only graphics. I get no login screen and just a black screen on resume from hibernate. When experiencing the black screen I can't use CTRL+ALT+F1 to switch to a terminal. The fan doesn't spin up. I don't have a CAPS LOCK light, so I can't tell that way. Simply a non-responsive machine with a black screen. I think it's the same as the OP, given the kernel version it appeared, fact it's a Lenovo Thinkpad X230 and apparently identical behaviour. If there are steps I can take to help with triage happy to do so, but I currently have no means of investigating further, given there is no way to even tell the machine is running or not.

Maarten Sijm (mpsijm) wrote :

Still not working for me on kernel version 4.13.0-32.
intel-microcode version: 3.20180108.0+really20170707ubuntu16.04.1

Resume from hibernation: screen black, can't switch to TTY. Fans didn't spin up. My external mouse didn't wake up, probably because it couldn't connect. I'll try the CAPS LOCK light next time.

Yes, it's a freeze and not just graphical. Resuming from a good kernel makes OpenSSH available remotely even with no input at the lock screen. However, resuming from a bad kernel when the screen is black, OpenSSH is unavailable remotely. This suggests that the OS has hung altogether in the black screen case and it's not just a display issue.

W4RH4WK (warhawk) wrote :

I can confirm that the freeze is not just graphical. There is no log output when resuming the system. Yet, what seems interesting to me: I can apparently mute / unmute the speakers. While there is no sound during the freeze the mute / unmute indicator led on my keyboard changes. So it's not a total system freeze.

Maurice (mak-5) wrote :

I can also confirm the same (buggy, unable to resumt) behaviour with kernel 4.13.0-32-generic on Lenovo T420.

Nonny Moose (moosenonny10) wrote :

@warhawk (assuming that's a laptop) Are you sure that's not just a hardware mute? Because Num Lock, Caps Lock, etc. don't work.

tags: removed: needs-bisect

Confirm the same bug with Intel inspiron 14z and linux-mint 18.3.

4.10.0-42-generic => resuming works fine
4.13.0-31.34~16.04.1 => resuming broken
4.13.0-32.35~16.04.1 => resuming broken

Sandheep Menon (gr-sandeep1) wrote :

Same issue with Lenovo T470 running Ubuntu Gnome 16.04.3
Hibernate works fine with 4.10.0-42-generic
Broken in 4.13.0-31.34~16.04.1
Had to point the grub to use 4.10.0-42-generic for fixing the issue.

Oliver R. (oliverr) wrote :

I can confirm the issue on a ThinkPad T420 running Linux Mint 18.3 Xfce.
4.13.0-32 freezes
4.10.0-42 works

Ari Birnbaum (ceiphr) wrote :

I can confirm this issue on a Razer Blade Stealth (2015-2016) running Ubuntu 16.04, 17.04, and 18.04.I've updated from Ubuntu Gnome 16.04 to Ubuntu Gnome 17.04 to Ubuntu 18.04 and experienced the issue on all versions.
4.14.15-041415-generic -> resuming broken

varacanero (varacanero) wrote :

Same for 4.13.0-32-generic on Ubuntu 17.10.

varacanero (varacanero) wrote :

I also checked that my Laptop doesn't respond to ssh connects which worked before.

Oliver R. (oliverr) wrote :

The issue is not present on my ThinkPad X200, i.e. resume from hibernate works with kernel 4.13.0-32.

The X200 runs a clone of the Mint 18.3 installation of my T430s, which shows the issue as reported in comment #73 (where I erroneously wrote it was a T420).

The T430s has an Intel(R) Core(TM) i7-3520M CPU @ 2.90GHz,
the X200 an Intel(R) Core(TM)2 Duo CPU P8400 @ 2.26GHz.

Is there any more useful information I can bring?

I can confirm this for ThinkPad E580 for newly installed 16.04 LTS.

Oliver R. (oliverr) wrote :

The issue is also not present on my ThinkPad X300 with an Intel(R) Core(TM)2 Duo CPU L7100 @ 1.20GHz.

Has anyone found the bug being present on a processor older than i3? If I haven't missed anything, all cases reported here have i3, i5, or i7.

Andy Whitcroft (apw) on 2018-02-07
tags: added: kernel-pti
Oliver R. (oliverr) wrote :

I must correct my post #77: The X200 now shows the bug, but differently. There is no blank screen, but the last screen before hibernation is visible. Other than that, the system is absolutely frozen as in the other cases. So this is an example of a pre-i3 processor with the bug being present.

In addition to my post #78: same kernel, so same problem persists in 18.04 alpha (Bionic Beaver). Installing 4.14.13-041413 (and hibernate after a new reboot) as suggested above solved this problem for me.

I would strongly suggest that the Bionic developer team will consider to include this version in the release.

David Emmett (kropotkin) wrote :

I have the same problem. The system fails to resume after hibernate. I have tested it with the following kernels:

4.13.0.21 - works
4.13.0.25 - broken
4.13.0.31 - broken
4.13.0.31 - broken

Working in latest 4.13.0-33.36 from artful-proposed.

Sorry not fixed, was mislead by strange behavior.
If i will reboot from latest working kernel .21 to 4.13.0-33.36, resume from hibernation fail with logs:
[ 3.101197] PM: Using 3 thread(s) for decompression.
               PM: Loading and decompressing image data (510246 pages)...
[ 3.101206] Hibernate inconsistent memory map detected!
[ 3.101207] PM: Image mismatch: architecture specific data
[ 3.101209] PM: Read 2040984 kbytes in 0.01 seconds (204098.40 MB/s)
[ 3.101748] PM: Error -1 resuming
[ 3.101750] PM: Failed to load hibernation image, recovering.
[ 3.102068] PM: Basic memory bitmaps freed

varacanero (varacanero) wrote :

I tried with 4.13.0.33.35 from artful-proposed on a x230 (i7-3520M) without success. Same behaviour, after resuming from hibernate image I have a blank, unresponsive screen.

DenisP (denisp) wrote :

I have done some further testing and now I can report that resume from hibernation works for me with 4.15 mainline kernels. Only that my X11 session crashes upon resume from hibernation because of a segmentation fault in libinput.so. It seems that this crash in X11 is not related to this bug.

varacanero (varacanero) wrote :

I can also confirm that with the 4.15 mainline kernel (4.15.0-041500-generic for amd64) resume from hibernate works!

tags: added: pti
Changed in linux (Ubuntu Artful):
status: New → Confirmed
importance: Undecided → Medium
varacanero (varacanero) wrote :

Hibernation works again with 4.15.0.10.11 from bionic-proposed as well !

No working on 4.15.0.10.11 from bionic-proposed for me, booting with clean session.

Suspend, hibernate, and suspend-hybrid works for me on 4.15.0-041500-generic as well.

Changed in linux (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Shan Khaliq (shanklq) wrote :

Using Ubuntu Mate 17.10
Kernel Linux 4.13.0-32 -> Broken
Suspend works fine
Hibernation resume leaves a black screen.

Steve (stevebot) wrote :

Is it possible to test 4.15 from bionic-proposed on xenial? The mainline kernels break my wi-fi adapter so it would be nice to use something that includes the extra Ubuntu drivers.

Yeah, I got the bug too.

For ubuntu 17.10 on HP 2000, I can confirm version 4.16rc2 of the linux kernel has this bug fixed.

Marc Dziadek (mdziadek) wrote :

With kernel 4.13.0-31, 4.13.0-32 and 4.13.0-36 resume from hibernate freeze every time.
After applying 'no_console_suspend' in grub, some more infos are printed to console:

PM: quiesce of devices complete after x msec
PM: late quiesce of devices complete after x msec
PM: noirq quiesce of devices complete after x msec
ACPI:EC: event blocked
ACPI:EC: EC stopped
Disabling non-boot CPUs
smpboot: CPU 1 is now offline
smpboot: CPU 2 is now offline
smpboot: CPU 3 is now offline

Now the output ends.
The system become unresponsive.
No chance to switch to other console or enter any command.

After reboot (without resume) no infos exists in kern.log.

I see the exact same boot log as Marc Dziadek above, and I can't find this recorded anywhere on next boot either.

It has been asked before here: "Is it possible to test 4.15 from bionic-proposed on xenial?" Can anyone offer input on this? I know how to add xenial's proposed repository; is it safe to just substitute "bionic" in that line in sources.list? What else, if anything, might need to be done to get this kernel working?

Andrés Moreno (andrewmg1980) wrote :

I have the same problem and until i don't discharge battery i can't use again.

- Ubuntu xenial 16.04.4
- kernel 4.13.0-36
- Intel Core i5-6200U and Intel HD Graphics 520

While it's being bug fix, i have disabled hibernate on Ubuntu.

ibrokeit (ibrokeit) wrote :

had the same issue, fixed with newer mainline kernel

Ubuntu 16.04 xenial
Intel Core i7-3520M CPU @ 3.6GHz x86_64

using repo HWE kernel (linux-image-generic-hwe-16.04):
     4.13.0.36.55 ---> hibernation broken

using mainline kernel (linux-image-4.15.9-041509-generic):
     4.15.9-041509-generic ---> hibernation works

how to install (bc people asked and I don't want to clutter bug report):
     https://pastebin.com/3Cg4jeeH

Lei Yu (yuleihit) wrote :

I had the same issue. Expecting someone to fix it, but still none update.

right now I have to use 4.10 to have resume work

Iain (strawp) wrote :

I've been following this for a while. 16.04 isn't going to get the 4.15 kernel until August (https://wiki.ubuntu.com/Kernel/Support) but 18.04 is going to ship with it (https://wiki.ubuntu.com/BionicBeaver/ReleaseNotes) and that gets a stable release on 26 April.

I think everyone has the option of one of three things:

1. Do ibrokeit's guide on how to use the mainline 4.15 kernel (and be unsupported but apparently have hibernate working again)
2. Wait for a month for 18.04 to come out and then upgrade, getting a supported 4.15 kernel with it and presumably working hibernate
3. Wait until August for 4.15 to be included in 16.04

Personally I've put up with no hibernate for a couple of months already so I'm just going to wait for 18.04 (which I was going to upgrade to anyway) rather than risk the stability of my work machine, however small that risk might be.

Maurice (mak-5) wrote :

Hi Lain, thanks for summing things up. It's a pity that we will have to wait until August to get this issue fixed in 16.04.

I've been living without hibernate for a couple of weeks now and HATE it.

I still hope some patch emerges isolating the issue and this patch gets backported to 16.04....

Tyler Hicks (tyhicks) wrote :

Hello - I'm unable to reproduce this bug because I can't use hibernation on my system but I may have spotted the problem while fixing a different bug. Could someone that's still affected by this bug, when using the 4.13.0-38.43 kernel, please try out the test kernel that I built here:

  https://people.canonical.com/~tyhicks/lp1743094/artful/

Please report back if the test kernel fixes the problems that you were experiencing on resume. Thanks!

Lei Yu (yuleihit) wrote :

Hi Tyler, I just tested it on my PC.For me, the problem persists. My computer still freezes on resuming. Switched back to 4.10. thanks.

Tyler Hicks (tyhicks) wrote :

Thanks for giving it a try. I'm disappointed that it didn't fix the issue for you.

I'd appreciate it if at least one more affected user could give the test kernel a shot to help rule out the chance of multiple bugs being involved.

Martin (g-martin-2) wrote :

Dear Tyler, thank you for your efforts. Unfortunately it's the same with me as with Lei: The new kernel freezes when waking up. Cheers, Martin

Mohammad Razavi (mrazavi) wrote :

I have a Thinkpad T470p laptop and I had the same problem since upgrading from 4.13.0-21 to 4.13.0-25 in xenial. Resume after hibrnate doesn't work. I updated to bionic (devel) with 4.15.0-13-generic kernel but hibrnate still doesn't work. It will not freeze, but a fresh new session will be resumed :-(

Radu Axente (radax05) wrote :

Ubuntu MATE 17.10 with kernel 4.15.x & 4.16.x - hibernate / resume from hibernate works as expected.

Ubuntu (vanilla) & Ubuntu MATE 18.04 Beta 1 / Beta 2 with kernel 4.15.x & 4.16.x - resume from hibernate does not work.

See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1759860

Ariel (rellieberman) wrote :

I can confirm that Hibernation resume works flawlessly once updating to 4.15.0-13 on a Linux Mint 18.3 even thought the error persisted on the 4.13.

Same here resuming perfectly on 4.15.0-13 on Linux Mint 18.3.

Dirk Bachmann (bacdi) wrote :

Hi Tyler,

unfortunately, your 4.13.0-38 test kernel https://people.canonical.com/~tyhicks/lp1743094/artful/ doesn't resolve the resume issue for me either.

Linux Mint 18.2 Sonya on HP 250 G6 Notebook w/ Intel i3-6006U.

Olleg Samoylov (olleg) wrote :

Confirm that the this bug exist with linux-image-4.13.0-38-generic (last) and linux-image-4.13.0-25-generic. linux-image-4.13.0-21-generic is fine.

This bug affects linux-hwe kernel 4.13.0-25.29 and above on Ubuntu 16.04 LTS (Xenial) and Ubuntu 17.10 (Artful).

Changed in linux-hwe (Ubuntu):
status: New → Confirmed
no longer affects: linux-hwe (Ubuntu Artful)

Please ignore line no longer affects: linux-hwe (Ubuntu Artful). My intention was to indicate it affects the linux-hwe kernel 4.13.0-25.29 and above.

Wayne Jessee (waynejessee) wrote :
Download full text (3.9 KiB)

I have same problem.

Linux UbuntuPC 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:16:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

00:00.0 Host bridge: Intel Corporation Device 3ec2 (rev 07)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
00:08.0 System peripheral: Intel Corporation Skylake Gaussian Mixture Model
00:14.0 USB controller: Intel Corporation 200 Series PCH USB 3.0 xHCI Controller
00:16.0 Communication controller: Intel Corporation 200 Series PCH CSME HECI #1
00:17.0 SATA controller: Intel Corporation 200 Series PCH SATA controller [AHCI mode]
00:1b.0 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port #17 (rev f0)
00:1b.4 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port #21 (rev f0)
00:1c.0 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port #1 (rev f0)
00:1c.2 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port #3 (rev f0)
00:1c.3 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port #4 (rev f0)
00:1c.4 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port #5 (rev f0)
00:1c.6 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port #7 (rev f0)
00:1d.0 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port #9 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device a2c9
00:1f.2 Memory controller: Intel Corporation 200 Series PCH PMC
00:1f.3 Audio device: Intel Corporation 200 Series PCH HD Audio
00:1f.4 SMBus: Intel Corporation 200 Series PCH SMBus Controller
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde PRO [Radeon HD 7750/8740 / R7 250E] (rev 87)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
02:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM961/PM961
07:00.0 USB controller: ASMedia Technology Inc. Device 2142
08:00.0 Network controller: Intel Corporation Wireless 3165 (rev 81)

Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 12
On-line CPU(s) list: 0-11
Thread(s) per core: 2
Core(s) per socket: 6
Socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 158
Model name: Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz
Stepping: 10
CPU MHz: 824.102
CPU max MHz: 4700.0000
CPU min MHz: 800.0000
BogoMIPS: 7392.00
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 256K
L3 cache: 12288K
NUMA node0 CPU(s): 0-11
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave...

Read more...

ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gdm 2093 F.... pulseaudio
                      yug 3986 F.... pulseaudio
DistroRelease: Ubuntu 18.04
HibernationDevice: RESUME=UUID=9125b1e1-1e9e-4bb6-942d-aced081667e9
InstallationDate: Installed on 2018-05-10 (5 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
MachineType: Entroware Kratos
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.15.0-20-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-20-generic N/A
 linux-backports-modules-4.15.0-20-generic N/A
 linux-firmware 1.173
Tags: bionic
Uname: Linux 4.15.0-20-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True
dmi.bios.date: 06/15/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.05.14E
dmi.board.asset.tag: Tag 12345
dmi.board.name: Kratos
dmi.board.vendor: Entroware
dmi.board.version: R3
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Notebook
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.05.14E:bd06/15/2017:svnEntroware:pnKratos:pvrR3:rvnEntroware:rnKratos:rvrR3:cvnNotebook:ct10:cvrN/A:
dmi.product.family: Not Applicable
dmi.product.name: Kratos
dmi.product.version: R3
dmi.sys.vendor: Entroware

tags: added: bionic

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Raphaël Droz (raphael-droz) wrote :

On freshly installed bionic.
When suspending from a text tty I can see a couple of lines at resume (mostly related to wifi and icc profile in ~/.local/share/icc), then it hangs after a couple of seconds.

May 15 01:22:54 kratos systemd[1]: Started Getty on tty4.
May 15 01:22:54 kratos gnome-shell[1924]: Failed to apply DRM plane transform 0: Permission denied
May 15 01:22:54 kratos gnome-shell[1924]: Failed to set power save mode for output eDP-1: Permission denied
May 15 01:22:54 kratos gsd-color[2258]: failed to set screen _ICC_PROFILE: Failed to open file “/home/yug/.local/share/icc/edid-2a314e28a76ee089ed6b07ab7269ee33.icc”: Permission denied
May 15 01:24:13 kratos NetworkManager[1401]: <info> [1526358253.1419] manager: sleep: sleep requested (sleeping: no enabled: yes)
May 15 01:24:13 kratos NetworkManager[1401]: <info> [1526358253.1421] device (wlp4s0): state change: disconnected -> unmanaged (reason 'sleeping', sys-iface-state: 'managed')
May 15 01:24:13 kratos gnome-shell[1924]: Screen lock is locked down, not locking
May 15 01:24:13 kratos NetworkManager[1401]: <info> [1526358253.1455] manager: NetworkManager state is now ASLEEP
May 15 01:24:13 kratos wpa_supplicant[1397]: nl80211: deinit ifname=p2p-dev-wlp4s0 disabled_11b_rates=0
May 15 01:24:13 kratos whoopsie[2589]: [01:24:13] offline
May 15 01:24:13 kratos gnome-shell[1924]: Failed to set power save mode for output eDP-1: Permission denied
May 15 01:24:13 kratos gsd-color[2258]: failed to set screen _ICC_PROFILE: Failed to open file “/home/yug/.local/share/icc/edid-2a314e28a76ee089ed6b07ab7269ee33.icc”: Permission denied
May 15 01:24:13 kratos wpa_supplicant[1397]: nl80211: deinit ifname=wlp4s0 disabled_11b_rates=0
May 15 01:24:18 kratos systemd[1]: Reached target Sleep.
May 15 01:24:18 kratos systemd[1]: Starting Suspend...
May 15 01:24:18 kratos systemd-sleep[22018]: Suspending system...

Brett Johnson (linuxturtle) wrote :

This is still a problem in bionic as well. I just did a clean install on a workstation which exhibits the problem, but I also have a laptop which was upgraded from 17.10, which has not ever exhibited the problem.

I've attached lshw output for the two machines (inara is the machine for which suspend/resume works, vera is the one that doesn't)

Brett Johnson (linuxturtle) wrote :

Hmm, in a somewhat disheartening turn of events, I thought I'd try installing the nvidia proprietary driver on my workstation (that's what I had installed on 16.04, when suspend/resume worked). ...And now, suspend/resume works perfectly (and quickly) on the workstation. So maybe this is a nouveau bug? Is everyone else having problems using nvidia graphics hardware with the nouveau driver?

Raphaël Droz (raphael-droz) wrote :

Intel on Entroware laptop for me so hardly a driver problem (but maybe not even the same bug)
efficient diagnosis procedure welcomed.

Pablo180 (paultait22) wrote :

I have Nvidia graphics and I am using the Nvidia drivers so it isn't just a nouveau driver problem. But it may be worth re-installing the nvidia drivers again to see if that solves the problem for me.

Pablo180 (paultait22) wrote :

Re-installing the nouveau and nvidia drivers didn't work for me sadly. The problem persists.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Hans Hansen (hans005) wrote :

I have a variant of this problem that I can not find anywhere else:

I have the same problem of black screen (white cursor not blinking in the left upper corner) when I do a lock screen!

Suspend problem is also present. Computer goes down correctly after pressing suspend, but when it is supposed to wake up, I get the above described screen (NO splash screen, NO message from grub).

I am not sure if I should open a new bug for this....

Kernel: 4.15.0-22
OS: Xubuntu bionic
PC: Lenovo P51
GDriver: NVidia proprietry, Lenovo BIOS already set to NOT use CPU internal graphics

Happy to provide further infos if anybody is interested.

I can't wake from standby with linux-image-4.15.0-22-generic

But: linux-image-4.15.0-1006-oem is working for me

GDriver: NVidia proprietry
---
Adding "nouveau.modeset=0" to GRUB_CMDLINE_LINUX didn't work either.
https://www.dell.com/community/Inspiron/Suspend-resume-problems-on-Ubuntu-18-04/td-p/6072410

Small update to #139

my syslog was getting spammed with:
kernel: nouveau 0000:01:00.0: fifo: SCHED_ERROR 20 []

which led to a full /tmp

Adding "nouveau.modeset=0" to GRUB_CMDLINE_LINUX_DEFAULT got rid of that.

Is there any update on this issue? Hibernation works with kernel 4.10 but I can't keep using that forever...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-384 (Ubuntu):
status: New → Confirmed
Rus Sh (break1) wrote :

Have a same bug on desktop PC
Motherboard HB7-Plus, 16Mb RAM, Intel i7-4770 3.4 CPU

uname -a
Linux rtuser-break-G 4.13.0-43-generic #48~16.04.1-Ubuntu SMP Thu May 17 12:56:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

After each restoring hibernate PC freeze tight.

Rus Sh (break1) wrote :

I manually install 4.13.0-21 from here https://launchpad.net/~canonical-kernel-team/+archive/ubuntu/ppa/+build/13870500 and hibernate began to work!

Hans Hansen (hans005) wrote :

Update to #138:

My problem seems to be related to Bug #1752053 and Bug #1773113. And for me now everything more or less works again by using this workaround from Bug #1752053 posting #123:

---------snip----------------
I found a silly workaround (after trying many many other suggestions / driver re-installs), now using nvidia-driver-396 or nvidia-driver-390; create (if not exists) a file /etc/rc.local, with this content:

#!/bin/bash

sleep 1

exit 0

And make it executable: chmod 755 /etc/rc.local
---------snip----------------

Maybe this helps some people.

Christian Sarrasin (sxc731) wrote :

Just to clarify above comment from hans005: from what I can read here his problem (#138, #145) was a completely different issue: standby with nvidia GPU.

This regression relates to *hibernation* (not mere standby) and AFAIK, has been experienced with a variety of GPUs (included Intel integrated GPUs as in my case) so it's quite likely *not* a condition related to GPU drivers or model in use - although it's common for less run-of-the-mill dGPUs to exacerbate such issues I suppose.

I don't believe there are any workarounds to the issue accurately captured by the bug's headline.

Juancho (cabajuan) wrote :

I manually install 4.17.0-041700-generic from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17/ and hibernate is working very fine!

Maurice (mak-5) wrote :

Now, there is a solution for all people on Ubuntu 16.04.

You can now install the package "linux-image-generic-hwe-16.04" and it's recommended dependencies. The package contains Kernel 4.15 which will make hibernate work again.

Just tested and confirmed on Lenovo Y580 with Ubuntu 16.04.

Maurice (mak-5) wrote :

Sorry, the correct package in the post above is called "linux-image-generic-hwe-16.04-edge".

Edge is important so you get the newest version.

Taylor Raack (track16) wrote :

Confirmed with a Lenovo V570 that using the generic HWE 16.04 edge kernel restores hibernation ability. I needed to install both linux-image-generic-hwe-16.04-edge" and "linux-headers-generic-hwe-16.04-edge".

Maarten Sijm (mpsijm) wrote :

Using a HP ZBook Studio G3 Mobile Workstation, hibernation works for me again using the HWE kernels on Linux 16.04.

$ apt-mark showmanual | grep ^linux
linux-base
linux-generic
linux-generic-hwe-16.04
linux-headers-generic-hwe-16.04
linux-libc-dev
linux-signed-generic-hwe-16.04
linux-sound-base
linux-tools-generic
$ uname -a
Linux zbook-workstation 4.15.0-24-generic #26~16.04.1-Ubuntu SMP Fri Jun 15 14:35:08 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

This bug was nominated against a series that is no longer supported, ie artful. The bug task representing the artful nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Artful):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers