Comment 616 for bug 1734147

Madani (madani1982) wrote :

Hi. I'm experiencing problems that look very similar to the ones described in this bug report (can't boot from USB, changes made in UEFI won't save). This I noticed a couple days ago when trying to install a new distro, that failed with "Installing for x86_64-efi platform. Could not delete variable: interrupted system call. Grub-install:error:efibootmgr failed to register the boot entry: block device required"

I had Ubuntu 17.10 installed last year.

To make a long story short, I tried boot-repair and it failed, I tried installing other distros and got the same message. I tried upgrading the UEFI and it failed. It seems I can't even get a grub menu or prompt at startup. My computer boots to the message "no boot device on HDD". I can still boot however, if I pres F9 and manually choose "boot from EFI file" and select the proper .efi file (I can boot into Lubuntu 18.10).

My computer is an HP Pavilion 14-n249nf

I initially asked about the problem at https://askubuntu.com/questions/1104515.

1. how can I know for sure if this bug is the source of my problems ?
2. I followed the repair method described in the bug description. I can install kernel 4.15 without problems. But with no grub prompt at startup, how can I make sure to boot the right kernel that will fix my issues ?

thanks in advance for some answers