[hotkeys] fn keys don't work on vaio vgn-bx296xp

Bug #173366 reported by jseabra on 2007-12-02
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Medium
Unassigned
udev (Ubuntu)
Medium
Unassigned

Bug Description

Hello

 None of hotkeys of the sony vaio VGN-BX296XP seem to work apart from the mute button (which seems to be hw implemented).
 I contacted the developer of the sony_laptop module and he replied that my laptop seems to be using the GHKE method.
 The dmesg output shows the same scan code for ALL keys:

Use 'setkeycodes e075 <keycode>' to make it known.
[Unknown key released (translated set 2, code 0xf5 on isa0060/serio0).

 I could find lots of people complaining of similar problems but solutions are sparse,quite cryptical and varie alot from model to model.No info for this model could be found.
 Is there a simple way to solve this?

 João Seabra

jseabra (jseabra) wrote :

Nobody was taking care of it and its kind of annoying the keys don't work :-/

heinjan (heinjan) wrote :

Same here with a Sony Vaio VGN-BX196VP. The FN-keys generate the following 2 lines in dmesg:

[13688.810924] atkbd.c: Unknown key released (translated set 2, code 0xf5 on isa0060/serio0).
[13688.810939] atkbd.c: Use 'setkeycodes e075 <keycode>' to make it known.

This is with the latest 8.10 Beta, last synaptic update 13 october 2008.

heinjan (heinjan) wrote :

Still happening with the latest (17 april 2009) jaunty beta.

kernel-janitor (kernel-janitor) wrote :

Hi jseabra,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . Please then run following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux-image-`uname -r` 173366

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Architecture: i386
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=c61ca0c9-3f04-4ac8-b5e6-fdf0d4acf29c
MachineType: Sony Corporation VGN-BX196VP
Package: linux-image-2.6.31-3-generic 2.6.31-3.19
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-3-generic root=UUID=c286e7db-d177-420a-965e-3147e5127ae3 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=nl_NL.UTF-8
 LANGUAGE=nl_NL.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
RelatedPackageVersions: linux-backports-modules-2.6.31-3-generic N/A
Uname: Linux 2.6.31-3-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/10/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: R0190X5
dmi.board.name: Q-Project
dmi.board.vendor: Sony Corporation
dmi.board.version: 01
dmi.chassis.asset.tag: Reserved
dmi.chassis.type: 10
dmi.chassis.vendor: Reserved
dmi.chassis.version: Reserved
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrR0190X5:bd07/10/2006:svnSonyCorporation:pnVGN-BX196VP:pvrC100TRX5:rvnSonyCorporation:rnQ-Project:rvr01:cvnReserved:ct10:cvrReserved:
dmi.product.name: VGN-BX196VP
dmi.product.version: C100TRX5
dmi.sys.vendor: Sony Corporation

Changed in linux (Ubuntu):
status: Incomplete → New
tags: added: apport-collected

Still happening with karmic (20 july 2009, 2.6.31-3-generic kernel)

Jul 20 23:09:48 casper kernel: [ 7350.274589] atkbd.c: Unknown key released (translated set 2, code 0xf5 on isa0060/serio0).
Jul 20 23:09:48 casper kernel: [ 7350.274598] atkbd.c: Use 'setkeycodes e075 <keycode>' to make it known.

Jeremy Foshee (jeremyfoshee) wrote :

heinjan,
    Thank you for checking this for Karmic.

-JFo

Roy Jamison (xteejx) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Sorry this was not dealt with efficiently, but if this is still a problem, could you test with the Live CD of the development release, Lucid Lynx. You can find out more about the development release at http://www.ubuntu.com/testing/. If so, please run "apport-collect 173366" without quotes, bearing in mind you may need to install python-launchpad-integration from the Universe repository, and also when asked you will need to select "Change Anything" in Launchpad for apport to be able to collect this debugging information. Thank you again.

Changed in udev (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Incomplete
summary: - fn keys don't work in vaio vgn-bx296xp
+ [hotkeys] fn keys don't work in vaio vgn-bx296xp
summary: - [hotkeys] fn keys don't work in vaio vgn-bx296xp
+ [hotkeys] fn keys don't work on vaio vgn-bx296xp
jseabra (jseabra) wrote :

As far as it concerns me I'm no longer interested in the solution.
Sony Vaio is not a good laptop (to use with linux) due to too many proprietary/closed hw/drivers.
Thank you for your interest!

Roy Jamison (xteejx) wrote :

I'm sorry to hear that. I shall leave this as Incomplete in case anyone else with the same laptop can provide that information. If you have a different model, please file a separate bug report for this, as it may not be exactly the same, and we will sort out the duplicates if there are any. Failing that, this bug report should close automatically in ~60 days. Thank you in advance!

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.20.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC260 Analog [ALC260 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC260 Analog [ALC260 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0c: heinjan 3885 F...m pulseaudio
 /dev/snd/pcmC0D0p: heinjan 3885 F...m pulseaudio
 /dev/snd/controlC0: heinjan 3885 F.... pulseaudio
CRDA: Error: [Errno 2] Bestand of map bestaat niet
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xb0000000 irq 20'
   Mixer name : 'Realtek ALC260'
   Components : 'HDA:10ec0260,104d0900,00100400 HDA:14f12bfa,104d0200,00090000'
   Controls : 11
   Simple ctrls : 6
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=f50e4a80-e102-4aa2-bd4e-0a9b11dd0056
MachineType: Sony Corporation VGN-BX196VP
Package: udev 149-5
PackageArchitecture: i386
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=5097b878-02d8-49d1-a9db-a5b608659d19 ro quiet splash
ProcEnviron:
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Regression: No
RelatedPackageVersions:
 linux-backports-modules-2.6.31-14-generic N/A
 linux-firmware 1.28
Reproducible: Yes
RfKill:

Tags: lucid needs-upstream-testing lucid
TestedUpstream: No
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/10/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: R0190X5
dmi.board.name: Q-Project
dmi.board.vendor: Sony Corporation
dmi.board.version: 01
dmi.chassis.asset.tag: Reserved
dmi.chassis.type: 10
dmi.chassis.vendor: Reserved
dmi.chassis.version: Reserved
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrR0190X5:bd07/10/2006:svnSonyCorporation:pnVGN-BX196VP:pvrC100TRX5:rvnSonyCorporation:rnQ-Project:rvr01:cvnReserved:ct10:cvrReserved:
dmi.product.name: VGN-BX196VP
dmi.product.version: C100TRX5
dmi.sys.vendor: Sony Corporation

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

heinjan (heinjan) wrote : Lspci.txt

apport information

heinjan (heinjan) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

heinjan (heinjan) wrote : UdevDb.txt

apport information

apport information

apport information

heinjan (heinjan) wrote :

Still happening with a Sony Vaio VGN-BX196VP. The FN-keys generate the following 2 lines in dmesg, just as the initial reporter encountes:

Jan 25 21:15:18 casper kernel: [ 658.550159] atkbd.c: Unknown key released (translated set 2, code 0xf5 on isa0060/serio0).
Jan 25 21:15:18 casper kernel: [ 658.550168] atkbd.c: Use 'setkeycodes e075 <keycode>' to make it known.

This is with the latest 10.04 alpha, last synaptic update 25 januari 2010.

Roy Jamison (xteejx) wrote :

It might help to have a look at the "Step-by-step Troubleshooting" section at https://wiki.ubuntu.com/Hotkeys/Troubleshooting
Please attach any files resulting from these tests, and any relevant information. Thank you.

Changed in udev (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Indeed, following Hotkeys/Troubleshooting and attaching the scancode -> key name mapping will help here. Thanks!

Changed in udev (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
Changed in linux (Ubuntu):
status: Incomplete → Invalid
assignee: Ubuntu Laptop Team (ubuntu-laptop) → nobody
heinjan (heinjan) wrote :

The problem is that every non-working FN-hotkey gives the same scancode in the logging:

[13688.810924] atkbd.c: Unknown key released (translated set 2, code 0xf5 on isa0060/serio0).
[13688.810939] atkbd.c: Use 'setkeycodes e075 <keycode>' to make it known.

So the solution isn't as simple as mapping a scancode to a key name.

Martin Pitt (pitti) wrote :

Ah, I missed that. Reassigning to the kernel then, thanks!

Changed in udev (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu):
status: Invalid → Confirmed
description: updated
crazyegg (zhangxi1982) wrote :

I have similar problem with my Vaio vgn-s59cp/b, the Fn keys used to work in ubuntu 6.06~9.04, however, none of them work in Ubuntu 10.04. here is some information I can provide:

/lib/udev/findkeyboards
AT keyboard: input/event3
module: input/event5

sudo /lib/udev/keymap -i input/eventX
and press Fn+F2~F7, nothing happens. however it do recognize the keys such as esc/enter, etc.

cat /sys/class/dmi/id/sys_vendor
Sony Corporation

cat /sys/class/dmi/id/product_name
VGN-S59CP_B

Roy Jamison (xteejx) wrote :

Thank you for the update. Since this is likely to be a kernel issue, we will need you to test the mainline kernel build (it's not too difficult don't worry). The instructions for doing so are under the "Installing Mainline Kernels" section at https://wiki.ubuntu.com/KernelTeam/MainlineBuilds. If this is still a problem, it can then be reported upstream to the kernel developers so this can be included in a future release as per the Kernel Team's Policy. Thank you.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Roy Jamison (xteejx) wrote :

@crazyegg: Please file another bug report for a different model, as this is for the Sony Vaio VGN-BX series. Thank you.

heinjan (heinjan) wrote :

@Teej: still happening the daily mainlinebuild (kernel version 2.6.34) from the mentioned PPA while pressing FN+F7 (same log message for the other non-working FN-keys):
heinjan@casper:~$ uname -a
Linux casper 2.6.34-999-generic #201004051003 SMP Mon Apr 5 10:02:54 UTC 2010 i686 GNU/Linux
heinjan@casper:~$ cat /var/log/messages|tail -4
Apr 5 20:41:02 casper kernel: [ 48.289910] atkbd serio0: Unknown key pressed (translated set 2, code 0xf5 on isa0060/serio0).
Apr 5 20:41:02 casper kernel: [ 48.289915] atkbd serio0: Use 'setkeycodes e075 <keycode>' to make it known.
Apr 5 20:41:03 casper kernel: [ 48.397245] atkbd serio0: Unknown key released (translated set 2, code 0xf5 on isa0060/serio0).
Apr 5 20:41:03 casper kernel: [ 48.397250] atkbd serio0: Use 'setkeycodes e075 <keycode>' to make it known.
heinjan@casper:~$

Same with Lucid (updated 5 april 2010):
heinjan@casper:~$ uname -a
Linux casper 2.6.32-19-generic #28-Ubuntu SMP Wed Mar 31 17:46:20 UTC 2010 i686 GNU/Linux
heinjan@casper:~$ cat /var/log/messages|tail -4
Apr 5 20:46:59 casper kernel: [ 169.047621] atkbd.c: Unknown key pressed (translated set 2, code 0xf5 on isa0060/serio0).
Apr 5 20:46:59 casper kernel: [ 169.047630] atkbd.c: Use 'setkeycodes e075 <keycode>' to make it known.
Apr 5 20:46:59 casper kernel: [ 169.140701] atkbd.c: Unknown key released (translated set 2, code 0xf5 on isa0060/serio0).
Apr 5 20:46:59 casper kernel: [ 169.140709] atkbd.c: Use 'setkeycodes e075 <keycode>' to make it known.
heinjan@casper:~$

Roy Jamison (xteejx) wrote :

Upgraded status to Triaged. It has been reported to the linux kernel developers at https://bugzilla.kernel.org/show_bug.cgi?id=15702 and Launchpad will track the status of this. You may need to check on the bug in the upstream tracker to see if the developers need any more debugging information from you, so this is being passed on to be dealt with by them. Thank you again for reporting this to us and please report any further bugs you find. :)

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in linux:
status: Unknown → Confirmed
Changed in linux:
importance: Unknown → Medium

jseabra, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11-rc7

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
tags: removed: apport-collected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.