SQUASHFS error while booting from live cd

Bug #172937 reported by X-pLoSioN on 2007-11-29
This bug affects 18 people
Affects Status Importance Assigned to Milestone
linux (Fedora)
Won't Fix
linux (Mandriva)
linux (Ubuntu)

Bug Description

Some users have reported being unable to boot from the Ubuntu LiveCD, due to SquasFS errors like this:

[ 135.292409] SQUASHFS error: sb_bread failed reading block 0x9d7f3
[ 135.292411] SQUASHFS error: Unable to read fragment cache block [275faa28]
[ 135.292413] SQUASHFS error: Unable to read page, block 275faa28, size 23a7

These errors can be due to a variety of reasons:

    * bad media (solution: try burning the iso image to a new disc)
    * a bad dvd drive (solution: if possible, try using a different cd/dvd drive)
    * bad memory modules (solution: use memtest86+ to check your memory)
    * a corrupted iso image (solution: run an md5 checksum, and if they don't match, download the iso image again)
    * an optical drive connected via SATA instead of PATA and running in Enhanced mode (solution: change the IDE configuration to "compatible" in the BIOS)

This is all described in more detail here:

Nanley Chery (nanoman) wrote :

Have you run the test to see if the burned disc had errors?

X-pLoSioN (tobiasburg) wrote :

i have checked the disc and it has no errors.
i try a new one and post the results as soon as possible.

Lieven (lieven-debels) wrote :

I have the same problem using Hardy Alpha 2.
I only get other hexadecimal values.

I get another error though:
Buffer I/O error on device sr0, logical block 267571. (the number doesn't say much, because I get other numbers as well)

I'll try reburning using another CD-writer.

Lieven (lieven-debels) wrote :

Seems I have a bad CD-writer, using another one, the problem is fixed.

tad1073 (tad1073) wrote :

i am having the same problem w/ the live cd I ordered from ubuntu.

arqbrulo (arqbrulo) wrote :

I am having the same issue with Hardy Alpha 2. I also get the SQUASHFS and BUFFER I/O errors. I will burn the iso using another burner and post my results.

arqbrulo (arqbrulo) wrote :

Burning the iso using a different burner worked. Both times it was burned in WIndows. The first time using InfraRecorder the second time using Nero.

Description of problem:
Fails on install

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:

Created attachment 294692
anaconda dump

Did you verify your media?

several times and every time it verified ok

Reassigning to kernel based on the following error messages, which are
indicative of driver problems, hardware problems, or media problems (which seem
to be ruled out by running media check):

<3>SQUASHFS error: zlib_inflate returned unexpected result 0xfffffffd, srclength
65536, avail_in 630, avail_out 65536
<3>SQUASHFS error: sb_bread failed reading block 0xd7a1
<3>SQUASHFS error: Unable to read page, block 35e2988, size 5d76

Some hardware stats : Compaq Proliant 1600, 2x 500Mhz, 1Gb Memory, Smart Array
3200 Raid Controler, 1 floppy drive, 1 DVD IDE drive.

Tried Fedora 7 installs ok only mouse is not working, Fedora 3 installs ok
mouse works, will test other versions after download.

Fedora-8-i386-DVD.iso - not working when English for language is used Keyboard
choice crash, Dutch language partitioning is reached.

F-7-i386-DVD.iso - during install no mouse.

FC3-i386-disc1.iso - floppy does not mount during install.

ska.ndal (ska.ndal) wrote :

i have this problem in hardy beta
i am using virtualbox with the iso-file, so it is not a failure in the cd .. but i will try it with a new download of the iso-image ...
if it is important: it is a x86-machine

ska.ndal (ska.ndal) wrote :

ok, the iso-file was damaged .. no it's working ..

Bryce Harrington (bryce) wrote :

Probably this error messages is caused by a variety of errors, that may be unrelated. I myself just experienced this issue with a downloaded iso; I burnt the cd and tried booting it in two different drives but had the SQUASHFS and Buffer I/O errors. I threw the CD in the trash basket and burnt the same iso to a new CD, and that time it worked.

However, I see in other bugs, others have reported the same error messages but it seems to be something other than bad media:

#200688 - when libdvdcss is not installed
#120389 - misdetected drive
#135094 - stalling due to missing floppy drive
#94119 - misdetected drive
#187807 - Some sort of DMA problem, only affects reading CD's

I have a gut feeling that bug #110636 might have something to do with at least some of these bugs, but no solid clue.

Bryce Harrington (bryce) wrote :

Here's a couple more with this error message:

162908 - Bad CD locks up SATA system
148466 - Bug in pata_serverworks kernel module, workaround with libata.pata_dma=1

These two bugs have some interesting suggestions that the issue is bad error handling in the SATA kernel module. Several bugs seem to be in systems with both SATA and PATA devices, so maybe there is a conflict or incompatibility between them?

Changed in linux:
importance: Undecided → High
status: Incomplete → Confirmed

Thanks Bryce,

I've gone ahead and followed up with the majority of those reports you listed. Having read all the comments here, it seems we can close this report out as the errors were either attributed to bad media or bad hardware. Thanks.

Changed in linux:
status: Confirmed → Invalid

Also met this on a Tyan motherboard with Intel 5000 chipset.

F8 i386 & x86_64 both fail.

F9 i386 pre-release does work.

dmidecode being attached here for reference.

Created attachment 304393
dmi decode from TYAN-Tempest-i5000VS-S5372-LC/LH

nebojsa (nebojsa22) wrote :

I've downloaded 8.04 desktop i386 and 64 twice (from MIT today and from Canadian mirror yesterday) and checked MD5 sum and all 4 matched. I've burned them using two different Windows machines. None of iso works and all of them report the same error "...SQUASHFS ... unable to read page..." and I've been trying to install on two different computers started yesterday and I'm now giving up. Oh, and all CDs report problems with between 10 and 18 files. What's interesting is that when I run check repeatedly it reports different number of problems every time. Of course, as a developer I'd jump on this to point out that there's a problem with everything else but distribution, so you can close this if you want but also as a developer I can guarantee you that there's a problem with this distribution for I had not a single problem with 7.10 nor with Fedora ISOs and I'm burning a dozen of both CDs and DVDs a week and have no problems at all. As for bad hardware, yeah, right: "it works on my box" I've heard this one and have to adim used it myself many a time... I guess I'll have to put up a bit more with ~!@#$%^ Windows...

I'm also having this problem. No CD burning problem, as I am using unetbootin through USB. So... what should I do? I don't really think this bug should be closed. And I don't believe that all of us got bad ISO files from the online repos. I checked the MD5 and matches. I am using Kubuntu 8.04.01 live CD.

JT (spikyjt) wrote :

Although I have not had a problem installing from and versions of the install CD, I have had this error with squashfs. I am using it for a running system, with aufs, so that the OS is reset to its original form after each reboot. Most of the time it is fine, but sometimes I get this error with a particular build of my system. If it works it will always work, but if I build one that comes up with this error, it always fails. The weird thing is that if I mount the filesystem via loopback on my normal system, it appears to be fine. Could this be a problem with the version of squashfs used in 8.04? Has it changed since 7.10? Unfortunately I can't find anything in common with the versions of my system that don't work, as opposed to those that do. I shall dig further...

JT (spikyjt) wrote :

Hmm bizarre. If I increase the block size with mksquashfs, the problem disappears. Even with the same file structure. I had tried re-running mksquashfs previously, to no avail. Definitely suggests a bug in squashfs. But is it a bug with the ubuntu build of squashfs, or upstream? The problem is it is so difficult to replicate. I will try building squashfs myself and testing against a file structure that failed before.

Rami Al-Rfou' (rmyeid) wrote :

I have got the same error as the first post

I tried to add this option to the kernel

and it worked for me but the error message appeared again for 25 times as the above error message.

I got the solution from

Changed in linux:
status: Invalid → Confirmed
Dimitrios Symeonidis (azimout) wrote :

shouldn't this be assigned to the "casper" source package?

Dimitrios Symeonidis (azimout) wrote :

hmmm, it seems this might be related to bad memory modules (which would explain the ide=nodma solution).

can someone try running the memtest86+ from their grub menu and report back?

Changed in linux:
status: Confirmed → Incomplete
John Blance (john-blance) wrote :

I get the SQUASHFS error: sb_bread failed reading block while trying to boot from a known good 8.04.1 LiveCD

.... as per Dimitrios' suggestion memtest shows that my second memory module has gone bad - doh!

Removed the bad module and all is now working.

So for me the error (same as for the original poster) _was_ due to bad memory.

Kaltsi (kaltsi) wrote :

I got this error to on a NetServer LH 6000 3U. I will test mem and report again.

Kaltsi (kaltsi) wrote :

I tested the memory and it is good. I woud like install ubuntu 8.04.1 server, but I get MD5SUM error. And the SQUASHFS logs error. (live cd and alternative cd don't work too)

Dimitrios Symeonidis (azimout) wrote :


kaltsi, if you get an md5 sum error on the .iso file, you need to download it again (and check md5 again before burning it to a disc).

one thing you can do to avoid having to burn cds is use unetbootin to "burn" the iso to a flash disc

Dimitrios Symeonidis (azimout) wrote :

Ok, summing up:

- for lieven and arqbrulo, the problem was caused by a bad dvd reader
- for ska.ndal, the iso image was corrupt
- for john blance it was bad memory modules
- tad1073 and nebojsa never got back to us

could everyone else try md5 sum, memtest86+, different media and a different drive? these seem to be the most common causes to the problem...

For me, it was also broken DVD reader, I can confirm it because it never worked again :-)
unetbootin through USB was the only solution I could use.

description: updated


I'm experiencing this with an "old" Pentium 4 desktop, and it's not any of the above problems:

 - I've tested with 5 (five!) different CD readers.
 - I've successfully booted the CD in other computers, and verified both the iso image and final cd to be OK.
 - I've checked the memory with memtest86+, both for the "default tests" and for the "bit fade test". All ok.

This problem exists with both 8.10 and 7.10 for the same pc.

I've had similar trouble with 7.10 on another PC, and an "all-generic-ide" option made it work. Unfortunately nothing that I've tried works for this one... I suspect it may have something to do with the fact that this PC's motherboard has SATA support, but all the drives are PATA.

This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we may not be able to fix it before Fedora 8 is end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora please change the 'version' of this
bug to the applicable version. If you are unable to change the version,
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:

Rob York (robyork) wrote :

Sorry if people have already posted this solution... but...

I have a ASUS x83vm-x1 and tried to install Kubuntu 8.10 from a live CD. Would start the install and then give
[ 135.292409] SQUASHFS error: sb_bread failed reading block 0x9d7f3
[ 135.292411] SQUASHFS error: Unable to read fragment cache block [275faa28]
[ 135.292413] SQUASHFS error: Unable to read page, block 275faa28, size 23a7

Thinking it was a defect CD, I ran the check disk and check memory utilities which both reported no problems.

I then tried the an OFFICIAL CD UBUNTU 8.04 I recieved in the mail. It also reported the same errors.

I went into BIOS and changed the IDE settings to COMPATIBILITY MODE. Viola! It worked. Hope this helps someone else out.

Rob York (robyork) wrote :

PS -- I HATE Vista! Thank GOD I got Kubuntu installed!

Changed in linux:
status: Unknown → Confirmed
Changed in linux:
status: Unknown → Confirmed
Rami Al-Rfou' (rmyeid) wrote :

This problem was solved for me by changing the DVD reader. The first one was old, even it works fine with movies and songs.

Andres Mujica (andres.mujica) wrote :

I've looked through squashfs mailing lists and a lot of forums reports, and *almost* all the cases where caused by HW failure, i've just added to the wiki page the only case not described there (a faulty cable)

So if someone can give evidence that is not a HW issue would be more than welcome the corresponding logs and data.

Maybe as Bryce pointed out is a compatibility issue between sata and pata componentes on some motherboards.

Anyway i've opened a bug at sourceforge project's page hoping that someone can take a look into this.


Dimitrios Symeonidis (azimout) wrote :

in order to avoid confusion, i'm marking this as "won't fix", since this is not an ubuntu bug, but almost always a hw issue...

Changed in linux:
status: Incomplete → Won't Fix

These errors are often caused by HW issues:
# bad memory modules (solution: use memtest86+ to check your memory)
# a bad dvd drive (solution: if possible, try using a different cd/dvd drive)
# bad data cable (solution: change it for a new one)
# bad media (solution: try burning the iso image to a new disc)
# a corrupted iso image (solution: run an md5 checksum, and if they don't match, download the iso image again)

This is all described here: https://help.ubuntu.com/community/SquashfsErrors

description: updated

Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Changed in linux:
status: Confirmed → Won't Fix
Mike (bild85) wrote :

It seems like this error is often memory-related, but the error messages indicate it's usually bad media. Is it possible to add the possibility of bad memory to the error message? The pop-up error I got was:

"The installer encountered an error copying files to the hard disk: [Errno 5] Input/output error
This is often due to a faulty CD/DVD disk or drive, or a faulty hard disk. It may help to clean the CD/DVD, to burn the CD/DVD at a lower speed, to clean the CD/DVD drive lens (cleaning kits are often available from electronics suppliers), to check whether the hard disk is old and in need of replacement, or to move the system to a cooler environment."

But dmesg had the following:
[ 1228.553400] kjournald starting. Commit interval 5 seconds
[ 1228.553598] EXT3 FS on sda5, internal journal
[ 1228.553605] EXT3-fs: mounted filesystem with ordered data mode.
[ 1349.994012] SQUASHFS error: zlib_inflate returned unexpected result 0xfffffffd, srclength 131072, avail_in 352, avail_out 92175
[ 1349.994024] SQUASHFS error: sb_bread failed reading block 0x77162
[ 1349.994029] SQUASHFS error: Unable to read fragment cache block [1dc4df1a]
[ 1349.994035] SQUASHFS error: Unable to read page, block 1dc4df1a, size a972

If the error message is going to be helpful enough to suggest a solution, it would help to include both probable solutions. Otherwise people are chasing the idea that the media is bad when it isn't.

eneth80 (eneth80) wrote :

I am trying to make that laptop computer work again, I hope this is the right place to post. I run windows, and it says that the partition cannot be recognized. I run the ubuntu installation with the acpi=off option, but the installation stops at 5%. But I can confirm that acpi=off helps, at least it goes on with the installation. A memtest86+ cannot be completed, the computer at a certain point goes off. It sounds to me that the hard disk is corrupted.
Question: I can buy a new hard disk, but how can I check that the memory modules (I have an additional external 1GB ram) are ok?

Jonas Ådahl (jadahl) wrote :

The solution I found was burn with Disc-At-Once mode (with cdrecord) when burning (the same) ISO file. Burning in Track-At-Once (TAO) mode made the CD unusable. Can't tell if it's the CD burner that burned it wrong the (several) times I burned it using default (TAO) mode, but, as I said, burning a single time with DAO made it work to boot up.

Changed in linux:
status: Confirmed → Invalid
stickman (mgherm) wrote :

I had the same scenario as Rob York and can confirm that changing IDE mode to "Compatible" in the BIOS fixes the install issue (I had already tested my memory and the installation disc and both were fine). I have also been able to change the IDE mode back to "Enhanced" after installing (otherwise my existing windows installation won't boot).

It appears that in some newer laptops the optical drive uses SATA instead of PATA and the installer can't handle it properly. I have had this problem with 8.04, 8.10 and 9.04, but I've only tried this fix with 9.04

description: updated
hatchetgal01 (ashlee-ayliffe) wrote :

My PC had 2 sata harddrives, and the linux mint 2009 live CD booted perfectly and i was able to install Linux mint on my second sata harddrive no problems, but the pc that i actually want linux on is a lil bit older and only has IDE capabilities, no sata (and some other issues) :o( so off i go and put the IDE hard drive in my (sata capable) PC, and with this harddrive connected to the PC, im getting these 'SQUASHFS error: unable to read page' etc etc i have changed the IDE mode to "compatible" and run tests everything seems fine, im under the impression that the media was not the problem anyway as it worked fine with sata harddrives
any clues people???? this is driving me insane!!!! X(

devel (devel-talktalk) wrote :
Download full text (3.8 KiB)

Symptoms: DVD drive read errors when trying to load live distros, or play films under Linux.

For example:
  SQUASHFS error: sb_bread failed reading block ...
  SQUASHFS error: Unable to read page, block ..., size ...

  end_request: I/O error, dev sr0, sector ...
  Buffer I/O error on device sr0, logical block ...

Tests/Results: (I tried...)
(a) Ubuntu 7.04 'Fiesty Faun' (DVD) live boot
    OK (Note: treats DVD-Drive as device hdc.)

(b) Ubuntu 8.04 'Hardy Heron' (DVD) live boot
    BAD - errors like example above.

(c) Xubuntu 8.04 (CDR) live boot and media check
    BAD - errors like example above.

(d) Ubuntu 8.10 'Intrepid Ibex' (DVD) live boot
    BAD - but errored later, after failing to start X.

(e) Ubuntu 9.10 'Karmic Koala' (DVD) live boot
    BAD - errors like example above.

(f) OpenSuse 10.2 (DVD) live boot and media check

(g) OpenSuse 10.3 (DVD) live boot and media check

(h) OpenSuse 11.0 (DVD) live boot and media check
    OK! A later version that works?!

(i) OpenSuse 11.1 (DVD) live boot

(j) OpenSuse 11.2 (DVD) live boot

(k) Knoppix 5.3.1
    OK (Note: although kernel is late-ish it still treats CD as device hdc...)

NOTE: Disks that do not work in the Test System DO work in a more modern PC...

Test System:
  Advent 5480DVD
  [SiS Chipset]
  [Old circa 2000, PIII (Coppermine) 800MHz]
  BIOS circa 2001
  RAM upgraded to 512MB
  DVD upgraded to Pioneer DVR KD08 (this is only 8months old from manufacture)
  HDD upgraded to 40GB

Things tried that *DID* *NOT* solve problem:
- Used 'regionset' utility to set region on the new DVD drive.
- Apply kernel parameters mix'n'match of the following:
- Memory test - shows my SDRAMs are good.

Media Check Experiment:
Aborting install of OpenSuse 10.2 we get a menu including the media check option.
If I swap DVD for e.g. 10.3 then select this option, it successfully verifies DVD, even though 10.3 will not verify *itself* successfully. That is, aborting 10.3 install and doing media check on itself fails!
i.e. the Linux SW version running the media dictates whether the DVD works, not a media problem.

Windows Experiment:
Replace HDD with old HDD with Windows ME (!) on.
This can successfully play DVD movies.
After this, which confirms the region setting, the Linux DVD behaviour is no different - same problems.
(So the dead Windows ME or *old* Linux are my best bet for playing DVDs on this HW?!?! Both are security risks so such a machine could NOT be connected to the net.)

Experimental Conclusions:
- There is nothing wrong with the media - it must be accepted that at least most of them are good - in fact I think they all are.
- There is nothing wrong with the DVD drive.
- There is nothing wrong with the computer HW in general.
- There *IS* something wrong with (newer) Linux DVD/CD driver SW on this HW...
- ... - it is emergent on more recent Linux SW versions, possibly when IDE got wrapped to make it look like SCSI.

+++ Workaround Solution +++ :
After all else failed I finally find the libata.dma kernel parameter works when excluding DMA on CD i.e. [in the following manner]
(***Works o...


Christian Loos (cloos) wrote :

I hade the same problem on my MSi Wind U100 Netbook.
I tried with a CD with the ubuntu-9.10-desktop-i386.iso image, doesn't work.
After that I build a bootable USB Stick with unetbootin and the image above and got the same error.

I then changed in bios (version 10G) under Advanced the AHCI Mode from Disabled (default) to Enabled and then the bootable USB Stick works.

cornware-cjp (cjp) wrote :

I have this problem with Ubuntu 10.04 on a HP nx6110 laptop. The boot options mentioned above didn't work.

Checking the CD for errors reported 3 errors. OTOH, I used the very same CD to install Ubuntu on a desktop computer, and there it (eventually) worked. The best I got so far on the laptop is that it starts installing files on the harddisk, and stops at 22% with an I/O error dialog.

I tried to make new burns of the CD, using the computer where 10.04 is installed. The disk with the 3 errors was created with the default CD burning software of Ubuntu, so, for a change, I used k3b for my other attempts. I tried different speeds, and I also tried DAO. The new CDs are even worse than the first one. With the new CDs, the boot manager of the CD-ROM complains that it can't read the CD-ROM, as soon as I press enter on an option like 'install Ubuntu'.

cornware-cjp (cjp) wrote :

I have a solution to this problem, that helped me, and may also help other people for who the above solutions didn't work:

Use the Netboot installer!!

The netboot installer is a lot smaller than the live CD, because it doesn't contain any packages: instead, it downloads these from the Internet while installing. This will help you if this problem is caused somehow by errors on the CD-R: the probability that the netboot installer hits one of these errors is lower, because of the smaller size of the netboot image. It worked for me!

Now that I have 10.04 on my nx6110(*), I used it to burn the live CD again. I used Brasero with 4x speed (the lowest possible), and I used a CD-R from a different series. To my surprise, the CD self-check didn't report ANY errors! So I booted the CD, which it did (it still mentioned filesystem problems in the boot messages, but they didn't seem to be a problem). I did not try the installer, because I didn't want to disturb my current 10.04 installation.

That made me wonder whether my first series of CD-Rs was guilty of the problem. So, I took another CD-R from the old series, and made another live-CD burn with EXACTLY the same hardware, software and settings, and the result was: a CD with errors!

My conclusion: in my case, the problem was a bad series of CD-Rs. This was further confirmed by comparing the files on the failed CD-Rs with the files in the .iso image: there were differences.

My BAD series is:
Maxell CD-R "up to 52x" 20 pack 5mm case 700MB
Barcode 4 902580 349554

My GOOD series is:
Sony CD-R 700MB x30 (1x - 48x compatible)
Barcode 4 901780 808465

At least I didn't waste half a dozen of GOOD CD-Rs on this issue! :-)

(*) I forgot to mention: I installed an extra 1024MiB of RAM. However, Memtest86 doesn't report any problems.

Bump (bump55) wrote :

I experience the error when installing xubuntu using the Wubi method (after loading xubuntu from the windows menu starts installing and I get the error):

[ 29.679870] VIA 82xx Audio 0000:00:07.5: sharing IRQ 10 with 0000:00:0e.1
[ 29.679879] VIA 82xx Audio 0000:00:07.5: sharing IRQ 10 with 0000:00:0f.0
[ 29.680030] VIA 82xx Audio 0000:00:07.5: setting latency timer to 64
[ 31.769189] lp0: using parport0 (interrupt-driven).
[ 40.075068] eth0: no IPv6 routers present
[ 74.903804] NTFS driver 2.1.29 [Flags: R/O MODULE].
[ 81.190040] QNX4 filesystem 0.2.3 registered.
[ 81.364872] Btrfs loaded
[ 90.596351] Adding 261112k swap on /host/ubuntu/disks/swap.disk. Priority:-1 extents:1 across:261112k
[ 104.800436] EXT4-fs (loop2): mounted filesystem with ordered data mode
[ 288.909464] SQUASHFS error: zlib_inflate error, data probably corrupt
[ 288.909481] SQUASHFS error: squashfs_read_data failed to read block 0x11b3773e
[ 288.909490] SQUASHFS error: Unable to read data cache entry [11b3773e]
[ 288.909494] SQUASHFS error: Unable to read page, block 11b3773e, size 17512
[ 288.909531] SQUASHFS error: Unable to read data cache entry [11b3773e]
[ 288.909534] SQUASHFS error: Unable to read page, block 11b3773e, size 17512
[ 288.909557] SQUASHFS error: Unable to read data cache entry [11b3773e]
[ 288.909561] SQUASHFS error: Unable to read page, block 11b3773e, size 17512
[ 288.909574] SQUASHFS error: Unable to read data cache entry [11b3773e]
[ 288.909578] SQUASHFS error: Unable to read page, block 11b3773e, size 17512
[ 288.909591] SQUASHFS error: Unable to read data cache entry [11b3773e]
[ 288.909594] SQUASHFS error: Unable to read page, block 11b3773e, size 17512
[ 288.909609] SQUASHFS error: Unable to read data cache entry [11b3773e]
[ 288.909612] SQUASHFS error: Unable to read page, block 11b3773e, size 17512
[ 288.909626] SQUASHFS error: Unable to read data cache entry [11b3773e]
[ 288.909630] SQUASHFS error: Unable to read page, block 11b3773e, size 17512
[ 288.909644] SQUASHFS error: Unable to read data cache entry [11b3773e]
[ 288.909647] SQUASHFS error: Unable to read page, block 11b3773e, size 17512
[ 288.909664] SQUASHFS error: Unable to read data cache entry [11b3773e]
[ 288.909667] SQUASHFS error: Unable to read page, block 11b3773e, size 17512

Bump (bump55) wrote :

I've successfully workarounded it, modifying the command line options for grub with

all_generic_ide pci=nommconf

and for grub

ide=nodma acpi=off

Anyway I added those commands to the boot menu that appears after you install ubuntu with grub, and such grub does come with an entry that says "ACPI workarounds" and in that entry the acpi=off is set but misses the ide=nodma so it fails.

Bump (bump55) wrote :
Rune K. Svendsen (runeks) wrote :

I just experienced this error, and it seems to be caused by a faulty USB stick.

I downloaded a daily build of Maverick, and confirmed that the md5 sums matched. This image was written to a USB stick using the Startup Disk Creator.
I first booted this USB stick on a laptop and got the error, then rewrote the image to the USB stick, tried to boot the laptop again and got the same error. Then I tried to boot another computer with the USB stick and the same error appeared, so it seems unlikely that it is a hardware related issue.
After writing the image to a new USB stick, the laptop boots without errors.

Rune K. Svendsen (runeks) wrote :

I have another bit of information to add to this bug report.

I just tried booting the presumably faulty USB stick on a third computer with the same results. So all signs point to the USB stick as the cause for this. I also tried booting another USB stick, to which the the same ISO file has been written with the same program as was used with the presumably faulty USB stick. This new USB stick boots all three computers without errors.

And here's something unusual that I can't quite explain: When I check the md5 sums of the files on the presumably faulty USB stick, they all come out fine! So this, presumably faulty, USB stick reliably won't boot on three computers, while another USB stick holding the exact same image will. But when the content of this, presumably faulty, USB stick is checked for md5 sum mismatches, none are found!

Blair (crazy-fingers-16) wrote :

I have a Biostar BIOS and was getting this error installing 10.10. ISO was OK and memory was OK.

BIOS IDE settings were "Enhanced" and I changed to "Sata Only" (no "compatible" option). Is that the same as choosing "compatible"? Strange since the description seems to indicate that the problem occurs when it is set to "Enhanced" or "SATA Only", but clearly in my case choosing "SATA only" fixed it.

PXE/NFS: Can SquashFS deal with temporary read-errors at all ?

I bootet ubuntu-10.04.1-desktop-i386.iso over NFS (as described in http://tinderblog.wordpress.com/2009/04/29/ubuntu-live-cdnetwork-boot/)
and found the diskless system serveral times hanging after a day or so with unrecoverable:

ubuntu kernel: [69366.882128] SQUASHFS error: squashfs_read_data failed to read block 0x28fecab6
ubuntu kernel: [69366.882135] SQUASHFS error: Unable to read metadata cache entry [28fecab6]
ubuntu kernel: [69366.882137] SQUASHFS error: Unable to read inode 0xf8c2c10ee

My Impression is that squashfs just can not handle temporary read-errors which may occur on NFS as as well as due to local IDE- or other HW-Iritations.

Having used diskless customized Knoppix - that survived server-reboots using compressed_fs instead of squashfs - I would like to migrate to Ubuntu but I doubt if i can do without repacking casper/filesystem.squashfs ...

Changed in linux (Mandriva):
importance: Unknown → Critical
Alecz20 (alexguzu) wrote :

I have also encountered this issue with a USB stick.

The temporary solution was to reboot. Sometimes it would work other times it would not.

Put the ISO on another USB stick, and the problem no longer occurred.

ProzakLord (jamiguet) wrote :

I had the same problem installing on a Toshiba NB-10t.
It got fixed by adding the following paramenters to the kernel at startup.

ide-core.nodma=0.1 ide-core.nobprobe=0.0 ide-core.nobprobe=0.1 pci=nommconf pci=noacpi

This was on a Ubuntu 14.04 LTS which has a 3.13 Kernel

Best of luck.

A. Eibach (andi3) wrote :

Reinald, this is VERY interesting what you've written!

"and found the diskless system serveral times hanging after a day or so with unrecoverable:"

This is exactly what I could witness on my live cd. It will work perfectly for one day, then these artifacts will come up.
Whatever you're trying to start, xterm or so, it will always give the error message that Bump has reported as well:

[ xxx.yyyyyy] SQUASHFS error: zlib_inflate error, data probably corrupt

My CD *is* perfectly clean and well-burned. Because it works for 24 hours. Hence, I don't believe the "bad hardware" fairy-tale at all.

vnON (vitalii-zdanevich) wrote :

All hardware the same - but I can live boot of 14.04 x64 but can not 14.04.3 x64

vnON (vitalii-zdanevich) wrote :

12.04.5 not have this problem

Bump (bump55) wrote :

I'm having this same issue with ubuntu-16.04.1-desktop-amd64.iso

The md5 of the downloaded file is correct, and if I make an iso of the recorded dvd the md5 matches also. Furthermore, if I mount the iso on linux and check the md5sums inside the iso, they all match.

The problem, however, is when booting the dvd from an external dvd writer. The first times it worked, however after several times it started failing and did ever since. The usb dvd writer is in perfect condition because mounting the disk on linux also verifies the checksums.

However, if I perform the integrity check booting from the external usb writer it says 1 file failed but doesn't specify which one!!!! what crap is this!!

Bump (bump55) wrote :

When booting from external usb dvd writer:

1) Hit Shift to display grub menu

2) Choose "Check disk for defects"

3) After some seconds it will display:
Check finished: errors found in 1 files!
Press any key to reboot your system

PLEASE UBUNTU tell me what file is corrupt! I hate that you take away from the debug information!

hepabolu (hepabolu) wrote :

I had a similar problem: newly bought USB stick, trying to install Ubuntu 16.04 on a newly bought SSD in my Intel NUC6i3. Failing as soon as the actual installation had to start.

The NUC already runs almost a year with an external HDD. I added the SSD M.2 stick last weekend. Formatting the SSD as a new volume went without errors. I could copy data from the HDD onto the SSD. I was following along a tutorial on how to migrate the data from the HDD onto the SSD. It all went ok until I needed to fix the boot part on the SSD. That process failed and I decided to start fresh with a complete reinstall from a bootable USB drive.

I used a new Sandisk Ultra Flair 16Gb USB3.0 stick. Downloaded iso and created a bootable USB stick while running Ubuntu from the HDD. All went fine, no problems.
Booting from the stick went ok, checking the file system on the stick showed everything is ok. However, installation on the SSD went wrong somewhere in the process with the same errors explained above. Sometimes when starting the actual installation, sometimes when trying to repartition the SSD.
I've tried several iterations creating the bootable stick in Ubuntu or from Unetbootin on my Mac with 14.04 or with 16.04. All proceduced the same error. Different USB stick (same brand and model) same problem. All the time the 'check system' function said everything is ok.

Finally, I upgraded the BIOS firmware to clear out all kinds of settings and I booted an old 4Gb UBS2.0 stick with 14.04 I found. From then on all went smoothly and I have a working Ubuntu (just upgraded to) 16.04 on my SSD.

I doubt the BIOS version was the cause of the problem, since I've had the same problem with the 16Gb stick from the very start.

I wonder if the 16Gb is too big for the bootable image. When trying to reformat the stick with Gparted, I saw a warning something along the lines of 'device descriptor says blocksize 1024, while software says 512'.

Could that be the problem?

Berteun (berteun) wrote :

@hepabolu: I have an extremely similar setup. Intel NUC 6i5SYH ; SanDisk Cruzer Fit Ultra 16 GB USB 3.0 drive.

When booting in UEFI mode from the USB drive, the installation fails, because it reports SQUASHFS errors like earlier in this thread.

When booting in legacy mode everything works.

My workaround was to plug an old USB2 hub in, and put the USB drive in that. It was a bit slower, but it worked. So except for this intermediary USB2 hub, the whole setup was identical: Identical flash drive, identical hardware, and the USB port to which the hub is plugged in is the same port to which the flash drive was plugged in.

So my suspicion there's something going on with the Intel NUC + SanDisk (?) USB 3 drives + UEFI mode that leads to these errors.

ethan.hsieh (ethan.hsieh) wrote :

I have also encountered this issue with a SanDisk USB 3.0 drive.
And, this workaround works for me.

Dario (dariomt) wrote :

Similar problem here. Intel NUC 6i5SYK; SanDisk UltraFit 16GB USB 3.0

When booting in UEFI mode from the USB, and checking the contents from grub it complains about problems in 17 files.

Checking the md5 checksums (in another Windows machine) all the files in the USB have the correct checksum, as per md5sum.txt.

I'll try with a different USB stick.

Gnart (gnart) wrote :

I am not sure what's with this "SQUASHFS error" problem. Here's my experience with it:
I downloaded Ubuntu 17.04 Desktop and installed it. The "SQUASHFS error" appeared on reboot.
I (re)downloaded the ISO and verified the hash, reinstalled and rebooted; same problem appeared.
I downloaded Ubuntu 16.04 LTS Desktop and installed it. There was no issue with the installation.
I rebooted Ubuntu 17.04 and didn't get "SQUASHFS error", they had been fixed by the OS.
Installation for both 16.04 and 17.04:
a. Same Dell Inspiron 5759 Signature, I7-6500U, 16GB RAM, 2TB Seagate ST2000LM003 [not SSD]
b. Running Windows 10
c. Installed as new VMware Workstation Pro 12.5.2 build-4638234 virtual machines, so the virtual disk was raw, initialized and formatted by Ubuntu.

*** I guessed Ubuntu 17.04 would be ok after it fixed those mysterious errors.

midobona (mido2010bona) wrote :

 am using ubuntu server 14.04.1 and i want edit filesystem.squashfs after installed squashfs-tools and unsquashfs and edit filesystem and mksquashfs and build iso i get this error

base-installer: info: Using squashfs support for /cdrom/install/filesystem.squashfs
anna-install: Installing squashfs-modules
anna[21857]: DEBUG: resolver (kernel-image-4.2.0-16-generic-di): package doesn't exist (ignored)
anna[21857]: DEBUG: retrieving squashfs-modules-4.2.0-16-generic-di 4.2.0-16.19
kernel: [44.008353] squashfs: version 4.0 (2009/01/31) Phillip Lougher
main-menu[3537]: (process:21801): getfattr: .: Operation not supported
main-menu[3537]: (process:21801): getfattr: ./bin: Operation not supported
main-menu[3537]: (process:21801): getfattr: ./bin/bunzip2: Operation not supported
main-menu[3537]: (process:21801): getfattr: ./bin/bzcat: Operation not supported
main-menu[3537]: (process:21801): getfattr: ./bin/bzcmp: Operation not supported

i think this error becouse kernel version not equal squashfs-tools

is this right ?

and i want install right package squashfs-tools support kernel ubuntu-server 14.04.1

and sorry if my english is bad

Changed in linux (Fedora):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.