CONFIG_DEBUG_FS is not enabled by "make zfcpdump_defconfig" with Ubuntu 17.10 (kernel 4.13)

Bug #1719290 reported by bugproxy on 2017-09-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
High
Canonical Kernel Team
linux (Ubuntu)
High
Skipper Bug Screeners

Bug Description

Ubuntu 17.10 uses kernel 4.13.

We just found out that on this kernel version CONFIG_DEBUG_FS is not enabled by "make zfcpdump_defconfig".

This makes zfcpdump fail with the following error message:

ERROR: Unable to mount debugfs
No such file or directory

Patch solving this problem is attached

As reference following bugzilla
As reference h
IBM bugzilla for enabling zfcpdump: https://bugzilla.linux.ibm.com/show_bug.cgi?id=139974

or Launchpad
https://bugs.launchpad.net/ubuntu/+source/s390-tools/+bug/1565841

== Comment: #1 - Heinz-Werner Seeck <email address hidden> - 2017-09-25 06:00:23 ==

CVE References

Default Comment by Bridge

tags: added: architecture-s39064 bugnameltc-159188 severity-high targetmilestone-inin1710
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Changed in ubuntu-z-systems:
importance: Undecided → High
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Changed in linux (Ubuntu):
importance: Undecided → High
status: New → Triaged
Joseph Salisbury (jsalisbury) wrote :

CONFIG_DEBUG_FS should be enabled as of Ubuntu-4.13.0-10.11~171. Can you test that version or newer and see if this bug is resolved?

tags: added: kernel-da-key
Frank Heimes (frank-heimes) wrote :

I just did a brief check on an Artful install based on the daily image from the 22nd and it looks like it's indeed already enabled:

ubuntu@s1lp11:/$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Artful Aardvark (development branch)
Release: 17.10
Codename: artful
ubuntu@s1lp11:/$ uname -r
4.13.0-11-generic
ubuntu@s1lp11:/$ grep CONFIG_DEBUG_FS /boot/config-4.13.0-11-generic
CONFIG_DEBUG_FS=y

Changed in ubuntu-z-systems:
status: New → Triaged

------- Comment From <email address hidden> 2017-09-26 07:23 EDT-------
(In reply to comment #7)
> I just did a brief check on an Artful install based on the daily image from
> the 22nd and it looks like it's indeed already enabled:
>
> ubuntu@s1lp11:/$ lsb_release -a
> No LSB modules are available.
> Distributor ID: Ubuntu
> Description: Ubuntu Artful Aardvark (development branch)
> Release: 17.10
> Codename: artful
> ubuntu@s1lp11:/$ uname -r
> 4.13.0-11-generic
> ubuntu@s1lp11:/$ grep CONFIG_DEBUG_FS /boot/config-4.13.0-11-generic
> CONFIG_DEBUG_FS=y

For zfcpdump we have a special kernel package "zfcpdump-kernel".
Have you also checked the config for that kernel?

Dimitri John Ledkov (xnox) wrote :

zfcpdump kernel is escalated to the kernel team.

Changed in zfcpdump-kernel (Ubuntu Artful):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Dimitri John Ledkov (xnox) wrote :

@hws @michael.holzheu @schwidefsky

It seems like schwidefsky updated s390 config upstream in v4.12 to remove -CONFIG_DEBUG_FS=y for the zfcpdump_defconfig. Meaning any Linux on Z systems using v4.12+ default zfcpdump_defconfig from upstream linux source tree will get a bad configuration. It seems counter productive to ask all downstreams to patch for this config issue.

Are you going to get in touch with schwidefsky to re-introduce CONFIG_DEBUG_FS=y in the zfcpdump_defconfig and get it applied in the stable trees too?

Also, i believe zfcpdump-kernel that we currently ship does have debugfs enabled. Are you using zfcpdump-kernel as provided in ubuntu? But we will note and will explicitely enable CONFIG_DEBUG_FS=y when we refress zfcpdump-kernel with v4.13+.

Regards,

Dimitri.

Changed in zfcpdump-kernel (Ubuntu Artful):
status: Triaged → Incomplete
Changed in linux (Ubuntu Artful):
status: Triaged → Incomplete
Changed in ubuntu-z-systems:
status: Triaged → Incomplete
no longer affects: zfcpdump-kernel (Ubuntu Artful)
no longer affects: linux (Ubuntu Artful)
Changed in linux-hwe (Ubuntu):
status: New → Incomplete
Seth Forshee (sforshee) on 2017-10-05
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2017-10-05 12:52 EDT-------
(In reply to comment #11)
> @hws @michael.holzheu @schwidefsky
>
> It seems like schwidefsky updated s390 config upstream in v4.12 to remove
> -CONFIG_DEBUG_FS=y for the zfcpdump_defconfig. Meaning any Linux on Z
> systems using v4.12+ default zfcpdump_defconfig from upstream linux source
> tree will get a bad configuration. It seems counter productive to ask all
> downstreams to patch for this config issue.
>
> Are you going to get in touch with schwidefsky to re-introduce
> CONFIG_DEBUG_FS=y in the zfcpdump_defconfig and get it applied in the stable
> trees too?

I already discussed this with Martin Schwidefsky and we decided *not* to go via stable but instead "warn" Ubuntu explicitly.

AFAIK you are the only official distribution that uses 4.13 for zfcpdump - therefore IMHO this should be sufficient.

> Also, i believe zfcpdump-kernel that we currently ship does have debugfs
> enabled. Are you using zfcpdump-kernel as provided in ubuntu?

I did not check anything - this bugzilla was just a heads-up.

> But we will
> note and will explicitely enable CONFIG_DEBUG_FS=y when we refress
> zfcpdump-kernel with v4.13+.

Thanks.

Launchpad Janitor (janitor) wrote :
Download full text (16.2 KiB)

This bug was fixed in the package linux - 4.13.0-15.16

---------------
linux (4.13.0-15.16) artful; urgency=low

  * linux: 4.13.0-15.16 -proposed tracker (LP: #1721373)

  * Boot regression on POWER9 (LP: #1721391)
    - Revert "crypto/nx: Add P9 NX support for 842 compression engine"
    - Revert "crypto/nx: Add P9 NX specific error codes for 842 engine"
    - Revert "crypto/nx: Use kzalloc for workmem allocation"
    - Revert "crypto/nx: Add nx842_add_coprocs_list function"
    - Revert "crypto/nx: Create nx842_delete_coprocs function"
    - Revert "crypto/nx: Create nx842_configure_crb function"
    - Revert "crypto/nx: Rename nx842_powernv_function as icswx function"
    - Revert "UBUNTU: [Config] CONFIG_PPC_VAS=y"
    - Revert "powerpc/powernv/vas: Define copy/paste interfaces"
    - Revert "powerpc/powernv/vas: Define vas_tx_win_open()"
    - Revert "powerpc/powernv/vas: Define vas_win_close() interface"
    - Revert "powerpc/powernv/vas: Define vas_rx_win_open() interface"
    - Revert "powerpc/powernv/vas: Define helpers to alloc/free windows"
    - Revert "powerpc/powernv/vas: Define helpers to init window context"
    - Revert "powerpc/powernv/vas: Define helpers to access MMIO regions"
    - Revert "powerpc/powernv/vas: Define vas_init() and vas_exit()"
    - Revert "powerpc/powernv: Move GET_FIELD/SET_FIELD to vas.h"
    - Revert "powerpc/powernv/vas: Define macros, register fields and structures"
    - Revert "powerpc/powernv: Enable PCI peer-to-peer"
    - Revert "powerpc/powernv: Add support to set power-shifting-ratio"
    - Revert "powerpc/powernv: Add support for powercap framework"
    - Revert "powerpc/perf: Add nest IMC PMU support"
    - Revert "powerpc/powernv: Detect and create IMC device"
    - Revert "powerpc/powernv: Add IMC OPAL APIs"

  * smartpqi patches for Artful (LP: #1721381)
    - scsi: smartpqi: add pqi reset quiesce support
    - scsi: smartpqi: enhance BMIC cache flush
    - scsi: smartpqi: update pqi passthru ioctl
    - scsi: smartpqi: cleanup doorbell register usage.
    - scsi: smartpqi: update kexec and power down support
    - scsi: smartpqi: add in new controller ids
    - scsi: smartpqi: change driver version to 1.1.2-125

  * CONFIG_DEBUG_FS is not enabled by "make zfcpdump_defconfig" with Ubuntu
    17.10 (kernel 4.13) (LP: #1719290)
    - SAUCE: s390: update zfcpdump_defconfig

  * [Feature] PXE boot with Intel Omni-Path (LP: #1712031)
    - d-i: Add hfi1 to nic-modules

  * [Feature]CNL:New device IDs for CNL (LP: #1685729)
    - pinctrl: intel: Add Intel Cannon Lake PCH-H pin controller support

linux (4.13.0-14.15) artful; urgency=low

  * linux: 4.13.0-14.15 -proposed tracker (LP: #1721122)

  * [Artful] ltp rwtest - Unable to handle kernel paging request at virtual
    address (LP: #1721067)
    - arm64: mm: Use READ_ONCE when dereferencing pointer to pte table

  * linux 4.13.0-13.14 ADT test failure with linux 4.13.0-13.14 (LP: #1720779)
    - SAUCE: LSM stacking: check for invalid zero sized writes

  * Add installer support for Broadcom BCM573xx network drivers. (LP: #1720466)
    - d-i: Add bnxt_en to nic-modules.

  * Miscellaneous Ubuntu changes
    - [Packaging] Include arch/arm6...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Dimitri John Ledkov (xnox) wrote :

> AFAIK you are the only official distribution that uses 4.13 for zfcpdump - therefore IMHO this should be sufficient.
That is not true. We do not use v4.13 kernel for zfcpdump-kernel package. zfcpdump-kernel package is based on v4.9 and upgrading that to v4.10+ fails to perform any dumps at all.

Please see https://bugs.launchpad.net/ubuntu/+source/zfcpdump-kernel/+bug/1722735 which has been requested for reverse-proxy.

Why was debugfs disabled upstream? Especially since s390-tools explicitly tries to mount debugfs.

Changed in ubuntu-z-systems:
status: Incomplete → Confirmed
no longer affects: linux-hwe (Ubuntu)
no longer affects: zfcpdump-kernel (Ubuntu)
Dimitri John Ledkov (xnox) wrote :

That other bug was reverse-proxied as LTC-159968 please see that for further discussion on upgrading Ubuntu's zfcpdump-kernel to 4.13.

Changed in ubuntu-z-systems:
status: Confirmed → Fix Released
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2017-10-11 06:58 EDT-------
IBM Bugzilla Status -> closed, Fix Released within Artful , follow-on problems will be handled by BZ159968 , LP1722735

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2017-10-11 09:01 EDT-------
(In reply to comment #14)
[snip]

>
> Why was debugfs disabled upstream? Especially since s390-tools explicitly
> tries to mount debugfs.

I asked the responsible person: It was just by accident.
Sorry for that.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2017-10-11 10:32 EDT-------
(In reply to comment #14)
> > AFAIK you are the only official distribution that uses 4.13 for zfcpdump - therefore IMHO this should be sufficient.
> That is not true. We do not use v4.13 kernel for zfcpdump-kernel package.
> zfcpdump-kernel package is based on v4.9 and upgrading that to v4.10+ fails
> to perform any dumps at all.
>
> Please see
> https://bugs.launchpad.net/ubuntu/+source/zfcpdump-kernel/+bug/1722735 which
> has been requested for reverse-proxy.

We looked into the report: It looks like the initramfs with the zfcpdump user space is not detected for some reason.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers