Can't boot Artful 17.10 live images on XPS 15 (9560)

Bug #1718936 reported by Anmar Oueja on 2017-09-22
86
This bug affects 16 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

I usually test Ubuntu beta releases. With Artful, I haven't been able to boot the image on my XPS 15 (9560) Dell laptop because the boot process stops half way.

The boot proceeds properly if I pass the "nomodeset" kernel boot option but that won't work because there is no more hiDPI support and dual display doesn't work.

This has been ongoing for several weeks, around the 4.12 kernel. Please fix it. It would be a shame for this product not to boot Artful out of the box.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: linux-image-4.13.0-11-generic 4.13.0-11.12
ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
Uname: Linux 4.13.0-11-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1701 F.... pulseaudio
CasperVersion: 1.384
CurrentDesktop: ubuntu:GNOME
Date: Fri Sep 22 12:38:09 2017
LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170921)
MachineType: Dell Inc. XPS 15 9560
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash --- nomodeset
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-11-generic N/A
 linux-backports-modules-4.13.0-11-generic N/A
 linux-firmware 1.168
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/30/2017
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.5.0
dmi.board.name: 0JHP5H
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.5.0:bd08/30/2017:svnDellInc.:pnXPS159560:pvr:rvnDellInc.:rn0JHP5H:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.family: XPS
dmi.product.name: XPS 15 9560
dmi.sys.vendor: Dell Inc.

Anmar Oueja (anmar) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Anmar Oueja (anmar) wrote :

Here is a photo of the errors I get when I boot off the live CD. This is the live CD from Sep 21, 2017

Bryan Quigley (bryanquigley) wrote :

I'm curious if it works if you just remove the splash line from the command line (press F6 when booting).

Anmar Oueja (anmar) wrote :

I removed the "splash ---" from the boot command option and still didn't boot up. I got more error messages so please attached photon.

Kai-Heng Feng (kaihengfeng) wrote :

Probably a nouveau bug?
Add "blacklist=nouveau modprobe.blacklist=nouveau" to your kernel parameter.

Bryan Quigley (bryanquigley) wrote :

Thanks for trying, not so easy to debug on a live session. Lets see if we can reproduce it locally.

I'm hoping you are running Ubuntu locally (which version?), if so could you try to see if you can reproduce the problem using a mainline kernel build of 4.13 - http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.13.3/ seems like a good first try)
https://wiki.ubuntu.com/Kernel/MainlineBuilds

This would just install the kernel and should make it easier to bisect the issue.

If v4.13.3 doesn't cause the issue, try v4.13-rc7, otherwise we can be relatively sure it's not a kernel issue (or at least not just a kernel issue)

If v4.13.3 doe cause the issue, try v4.14-rc1 to see if it's fixed in a newer release.
Then try v4.12.14 to see if it was present in 4.12, if it wasn't we want to try maybe v4.13-rc3/.
If it is present in v4.12.14 then we want to try maybe v4.12-rc5/.

Ideally we'd work it down to exactly where it was introduced - and then maybe do Git bisects.

garyx (garyx) wrote :
Download full text (9.6 KiB)

I have the exact same laptop and have not been able to start 17.10 here in simple testing with daily images for months. I don't think I have been able to do so with any 17.10 image. I installed the 4.13.3 Kernel and on my 17.04 install on the computer and it started up and is running now as I type this. There were quite some errors when installing regards to missing firmware but it starts at least.

W: Possible missing firmware /lib/firmware/i915/kbl_huc_ver02_00_1810.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_huc_ver01_07_1398.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_huc_ver01_07_1398.bin for module i915
W: Possible missing firmware /lib/firmware/nvidia/gm20b/pmu/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gm20b/pmu/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gm20b/pmu/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/sw_method_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/sw_bundle_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/sw_nonctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/sw_ctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/gpccs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/gpccs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/fecs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/fecs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/acr/ucode_load.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/acr/unload_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/acr/bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/sw_...

Read more...

Joseph Salisbury (jsalisbury) wrote :

Can you see if this issue also happens with the latest daily image? It can be downloaded from:
Desktop:
http://cdimage.ubuntu.com/daily-live/current/
Server:
http://cdimage.ubuntu.com/ubuntu-server/daily/current/

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
tags: added: kernel-da-key

I just tried today's image and I it isn't booting still. Like Joseph, I tried

On Mon, Sep 25, 2017 at 11:18 AM, Joseph Salisbury
<email address hidden> wrote:
> Can you see if this issue also happens with the latest daily image? It can be downloaded from:
> Desktop:
> http://cdimage.ubuntu.com/daily-live/current/
> Server:
> http://cdimage.ubuntu.com/ubuntu-server/daily/current/
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => High
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>
> ** Tags added: kernel-da-key
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1718936
>
> Title:
> Can't boot Artful 17.10 live images on XPS 15 (9560)
>
> Status in linux package in Ubuntu:
> Incomplete
>
> Bug description:
> I usually test Ubuntu beta releases. With Artful, I haven't been able
> to boot the image on my XPS 15 (9560) Dell laptop because the boot
> process stops half way.
>
> The boot proceeds properly if I pass the "nomodeset" kernel boot
> option but that won't work because there is no more hiDPI support and
> dual display doesn't work.
>
> This has been ongoing for several weeks, around the 4.12 kernel.
> Please fix it. It would be a shame for this product not to boot Artful
> out of the box.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.10
> Package: linux-image-4.13.0-11-generic 4.13.0-11.12
> ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
> Uname: Linux 4.13.0-11-generic x86_64
> ApportVersion: 2.20.7-0ubuntu1
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: ubuntu 1701 F.... pulseaudio
> CasperVersion: 1.384
> CurrentDesktop: ubuntu:GNOME
> Date: Fri Sep 22 12:38:09 2017
> LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170921)
> MachineType: Dell Inc. XPS 15 9560
> ProcEnviron:
> TERM=xterm-256color
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 EFI VGA
> ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash --- nomodeset
> RelatedPackageVersions:
> linux-restricted-modules-4.13.0-11-generic N/A
> linux-backports-modules-4.13.0-11-generic N/A
> linux-firmware 1.168
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 08/30/2017
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: 1.5.0
> dmi.board.name: 0JHP5H
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A00
> dmi.chassis.type: 10
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias: dmi:bvnDellInc.:bvr1.5.0:bd08/30/2017:svnDellInc.:pnXPS159560:pvr:rvnDellInc.:rn0JHP5H:rvrA00:cvnDellInc.:ct10:cvr:
> dmi.product.family: XPS
> dmi.product.name: XPS 15 9560
> dmi.sys.vendor: Dell Inc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1718936/+subscriptions

Kai-Heng Feng (kaihengfeng) wrote :

Can you add this to your kernel parameters "blacklist=nouveau modprobe.blacklist=nouveau" and try again.

garyx (garyx) wrote :

I just tried adding "blacklist=nouveau modprobe.blacklist=nouveau" but it will not boot.

Anmar Oueja (anmar) wrote :

I did that with yesterday's Ubuntu 17.10 live image and it did boot.

Q: Does that mean the acceleration is done by the Intel board instead?

On Tue, Sep 26, 2017 at 8:56 AM, Hlini Melsteð Jóngeirsson
<email address hidden> wrote:
> I just tried adding "blacklist=nouveau modprobe.blacklist=nouveau" but
> it will not boot.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1718936
>
> Title:
> Can't boot Artful 17.10 live images on XPS 15 (9560)
>
> Status in linux package in Ubuntu:
> Incomplete
>
> Bug description:
> I usually test Ubuntu beta releases. With Artful, I haven't been able
> to boot the image on my XPS 15 (9560) Dell laptop because the boot
> process stops half way.
>
> The boot proceeds properly if I pass the "nomodeset" kernel boot
> option but that won't work because there is no more hiDPI support and
> dual display doesn't work.
>
> This has been ongoing for several weeks, around the 4.12 kernel.
> Please fix it. It would be a shame for this product not to boot Artful
> out of the box.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.10
> Package: linux-image-4.13.0-11-generic 4.13.0-11.12
> ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
> Uname: Linux 4.13.0-11-generic x86_64
> ApportVersion: 2.20.7-0ubuntu1
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: ubuntu 1701 F.... pulseaudio
> CasperVersion: 1.384
> CurrentDesktop: ubuntu:GNOME
> Date: Fri Sep 22 12:38:09 2017
> LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170921)
> MachineType: Dell Inc. XPS 15 9560
> ProcEnviron:
> TERM=xterm-256color
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 EFI VGA
> ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash --- nomodeset
> RelatedPackageVersions:
> linux-restricted-modules-4.13.0-11-generic N/A
> linux-backports-modules-4.13.0-11-generic N/A
> linux-firmware 1.168
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 08/30/2017
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: 1.5.0
> dmi.board.name: 0JHP5H
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A00
> dmi.chassis.type: 10
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias: dmi:bvnDellInc.:bvr1.5.0:bd08/30/2017:svnDellInc.:pnXPS159560:pvr:rvnDellInc.:rn0JHP5H:rvrA00:cvnDellInc.:ct10:cvr:
> dmi.product.family: XPS
> dmi.product.name: XPS 15 9560
> dmi.sys.vendor: Dell Inc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1718936/+subscriptions

Kai-Heng Feng (kaihengfeng) wrote :

It's driven by intel graphics all the time. Nouveau is the part that has more chance to hang the system.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
garyx (garyx) wrote :

I was going to add that it should run on Intel by default. I updated the image to the latest on the USB and tried again and it still hangs even with the kernel parameters. "blacklist=nouveau modprobe.blacklist=nouveau" It worked for you Anmar?

Cause I cannot get that to work here. Also this issue is set to "Fix Released" What fix is that?

garyx (garyx) wrote :

Someone suggested noveau.modeset=0 however for me that does not boot for me either. The only setting that will is nomodeset as mentioned here in the first entry.

Anmar Oueja (anmar) wrote :

I just tested the "blacklist=nouveau modprobe.blacklist=nouveau" and the "nouveau.modeset=0" separately and both of them the machine booted off the USB stick. I had a live image running 4.12 kernel so I will test today's images (with 4.13 kernel) and report back.

Here is my dmidecode just in case anybody wants to confirm the type of machine I am testing on especially that some of you couldn't boot it with the above modeset mods to the kernel boot prompt.

# dmidecode 3.0
Getting SMBIOS data from sysfs.
SMBIOS 3.0.0 present.
Table at 0x000E0000.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
 Vendor: Dell Inc.
 Version: 1.5.0
 Release Date: 08/30/2017
 Address: 0xF0000
 Runtime Size: 64 kB
 ROM Size: 16384 kB
 Characteristics:
  PCI is supported
  PNP is supported
  BIOS is upgradeable
  BIOS shadowing is allowed
  Boot from CD is supported
  Selectable boot is supported
  EDD is supported
  Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
  5.25"/1.2 MB floppy services are supported (int 13h)

Anmar Oueja (anmar) wrote :

This bug shouldn't be fixed-released. Nothing got fixed. The live image doesn't boot without the nouveau modeset kernel boot option. It shouldn't be fixed until the live image boots without any tinkering.

Changed in linux (Ubuntu):
status: Fix Released → Confirmed

I tried it and it is the same problem as all the previous kernels I tested
(including the latest 4.13 available in Artful)

On Thursday, September 28, 2017, Kai-Heng Feng <email address hidden>
wrote:

> Please try drm-tip kernel [1].
>
> [1] http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/current/
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1718936
>
> Title:
> Can't boot Artful 17.10 live images on XPS 15 (9560)
>
> Status in linux package in Ubuntu:
> Confirmed
>
> Bug description:
> I usually test Ubuntu beta releases. With Artful, I haven't been able
> to boot the image on my XPS 15 (9560) Dell laptop because the boot
> process stops half way.
>
> The boot proceeds properly if I pass the "nomodeset" kernel boot
> option but that won't work because there is no more hiDPI support and
> dual display doesn't work.
>
> This has been ongoing for several weeks, around the 4.12 kernel.
> Please fix it. It would be a shame for this product not to boot Artful
> out of the box.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.10
> Package: linux-image-4.13.0-11-generic 4.13.0-11.12
> ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
> Uname: Linux 4.13.0-11-generic x86_64
> ApportVersion: 2.20.7-0ubuntu1
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: ubuntu 1701 F.... pulseaudio
> CasperVersion: 1.384
> CurrentDesktop: ubuntu:GNOME
> Date: Fri Sep 22 12:38:09 2017
> LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170921)
> MachineType: Dell Inc. XPS 15 9560
> ProcEnviron:
> TERM=xterm-256color
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 EFI VGA
> ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi
> file=/cdrom/preseed/username.seed boot=casper quiet splash --- nomodeset
> RelatedPackageVersions:
> linux-restricted-modules-4.13.0-11-generic N/A
> linux-backports-modules-4.13.0-11-generic N/A
> linux-firmware 1.168
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 08/30/2017
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: 1.5.0
> dmi.board.name: 0JHP5H
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A00
> dmi.chassis.type: 10
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias: dmi:bvnDellInc.:bvr1.5.0:bd08/30/2017:svnDellInc.:
> pnXPS159560:pvr:rvnDellInc.:rn0JHP5H:rvrA00:cvnDellInc.:ct10:cvr:
> dmi.product.family: XPS
> dmi.product.name: XPS 15 9560
> dmi.sys.vendor: Dell Inc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/
> 1718936/+subscriptions
>

Anmar Oueja (anmar) wrote :

I tried it and it is the same problem as all the previous kernels I tested
(including the latest 4.13 available in Artful)

On Thursday, September 28, 2017, Kai-Heng Feng <email address hidden>
wrote:

> Please try drm-tip kernel [1].
>
> [1] http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-tip/current/
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1718936
>
> Title:
> Can't boot Artful 17.10 live images on XPS 15 (9560)
>
> Status in linux package in Ubuntu:
> Confirmed
>
> Bug description:
> I usually test Ubuntu beta releases. With Artful, I haven't been able
> to boot the image on my XPS 15 (9560) Dell laptop because the boot
> process stops half way.
>
> The boot proceeds properly if I pass the "nomodeset" kernel boot
> option but that won't work because there is no more hiDPI support and
> dual display doesn't work.
>
> This has been ongoing for several weeks, around the 4.12 kernel.
> Please fix it. It would be a shame for this product not to boot Artful
> out of the box.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.10
> Package: linux-image-4.13.0-11-generic 4.13.0-11.12
> ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
> Uname: Linux 4.13.0-11-generic x86_64
> ApportVersion: 2.20.7-0ubuntu1
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: ubuntu 1701 F.... pulseaudio
> CasperVersion: 1.384
> CurrentDesktop: ubuntu:GNOME
> Date: Fri Sep 22 12:38:09 2017
> LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170921)
> MachineType: Dell Inc. XPS 15 9560
> ProcEnviron:
> TERM=xterm-256color
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 EFI VGA
> ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi
> file=/cdrom/preseed/username.seed boot=casper quiet splash --- nomodeset
> RelatedPackageVersions:
> linux-restricted-modules-4.13.0-11-generic N/A
> linux-backports-modules-4.13.0-11-generic N/A
> linux-firmware 1.168
> SourcePackage: linux
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 08/30/2017
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: 1.5.0
> dmi.board.name: 0JHP5H
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A00
> dmi.chassis.type: 10
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias: dmi:bvnDellInc.:bvr1.5.0:bd08/
> 30/2017:svnDellInc.:pnXPS159560:pvr:rvnDellInc.:rn0JHP5H:
> rvrA00:cvnDellInc.:ct10:cvr:
> dmi.product.family: XPS
> dmi.product.name: XPS 15 9560
> dmi.sys.vendor: Dell Inc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1718936
> /+subscriptions
>

Kai-Heng Feng (kaihengfeng) wrote :

Please add kernel parameter "drm.debug=0x0e" and boot with the drm-tip kernel. Attach the dmesg here.

If it hangs during boot process, you probably need to remove "quiet splash" in grub.

Anmar Oueja (anmar) wrote :

I have done some more testing and here are my findings:

* 4.12.14 works like a charm with nothing extra added to the command boot option
* 4.13.16 doens't boot and operate normally without nouveau.modeset=0 . The same go for 4.14-rc4

With nouveau.modeset=0, I can use the kernels that ship with 17.10 while booting from USB stick, installing and normal use even if an external monitor was plugged into the XPS 15.

Obviously something regressed but I can't tell what it is.

Kai-Heng Feng (kaihengfeng) wrote :

It's easier to identify the regression on mainline kernel. You only need to from 4.13-rc1, and find which -rcN is the first one that regressed.

Matthew Lewellen (lewellen) wrote :

This issue appears to still be hanging on boot for Dell XPS 15 (9560).

Have we identified any reliable and easy workarounds to get the USB live image booting? I was looking forward to completing my dual boot install this weekend.

Thanks!

Mark Greene (f-mark-s) wrote :

Just received my brand new Dell 9560 and I also cannot boot a Live Image of 17.10 from USB. If I jump out of the splash screen (Alt+F1) I see these kinds of error messages come across:

watchdog: BUG: soft lockup - CPU#2 stuck for 23s! ....

John (sg86sg) wrote :

I also cannot boot 17.10 live USB to be able to install it.

I receive a few USB port errors followed by the same:

BUG: soft lockup - CPU#2 stuck for 23s! ....

Anmar Oueja (anmar) wrote :

Just tested 4.15-rc8 and it boots but the system isn't stable. Gets lockups and screen flicker.

Matthew Lewellen (lewellen) wrote :

Thanks -- keep up the good work. Any known workarounds? as I'd like to get this machine dual-booting.

Anmar Oueja (anmar) wrote :

The fix is easy enough. here is what you need to do.

== Booting a live image
* Enter the boot prompts by presseing Esc
* Edit the boot prompt and append nouveau.modeset=0 to the linux boot command line

== Once installed, you need to do the following:
* Log into the system, assuming it work, if not, do the steps outlined above.
* edit /etc/default/grub file and locate the GRUB_CMDLINE_LINUX= line
* add nouveau.modeset=0 to it
* it should look like this: GRUB_CMDLINE_LINUX="nouveau.modeset=0"
* Save the file
* run sudo update-grub
* Reboot and enjoy

link textThe soln to this is to turn the nouveau driver modesettings and leave things up to the Intel board.

To do that, you need to edit the /etc/default/grub and add nouveau.modeset=0 to the GRUB_CMDLINE_LINUX

so it looks like this: GRUB_CMDLINE_LINUX="nouveau.modeset=0"

Once done, just run update-grub to update and reboot.

Good luck!
Sent from Mailspring (https://link.getmailspring.com/link/local-231e89c4-f332@xps/0?redirect=https%3A%2F%2Fgetmailspring.com%2F&recipient=1718936%40bugs.launchpad.net), the best free email app for work

Matthew Lewellen (lewellen) wrote :

Has anyone tested 4.15 stable to see if it has resolved the issues for XPS 15 9560?

garyx (garyx) wrote :

I just tested upgrading to 18.04 and newest stable 4.15.0-19 does not boot with default parameters.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers