HID 1018:1006 Touchpad does not work

Bug #1685937 reported by Till Grenzdörffer on 2017-04-24
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

The touchpad does not work. hid_multitouch interprets gestures as weird stuff -> opens search, types letters. If I didnt overlook anything the touchpad position does not show in any of the /dev/input files.. Any help would be appreciated.
edit: its on a trekstor surfbook w2.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: linux-image-4.10.0-19-generic 4.10.0-19.21 [modified: boot/vmlinuz-4.10.0-19-generic]
ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
Uname: Linux 4.10.0-19-generic x86_64
ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CurrentDesktop: Unity:Unity7
Date: Mon Apr 24 23:05:18 2017
MachineType: TrekStor SurfBook W2
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-19-generic.efi.signed root=UUID=78342794-9ef5-4a63-9b1e-040a63fd644b ro i8042.nopnp quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.10.0-19-generic N/A
 linux-backports-modules-4.10.0-19-generic N/A
 linux-firmware 1.164
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/22/2016
dmi.bios.version: SB14464-2_BIOS_V2.1.1
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: CherryTrail CR
dmi.board.vendor: TS_I-Net
dmi.board.version: Type2 - Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvn:bvrSB14464-2_BIOS_V2.1.1:bd11/22/2016:svnTrekStor:pnSurfBookW2:pvrType1-TBDbyOEM:rvnTS_I-Net:rnCherryTrailCR:rvrType2-BoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: SurfBook W2
dmi.product.version: Type1 - TBD by OEM
dmi.sys.vendor: TrekStor

Till Grenzdörffer (sefrin) wrote :
description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.11 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.11-rc8

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Till Grenzdörffer (sefrin) wrote :

The bug exists since I installed Ubuntu on that laptop. It still exists in 4.11-rc8.

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Kai-Heng Feng (kaihengfeng) wrote :

I can't find 1008:1016 in hid drivers - it's probably a rebranded touchpad from another vendor. You need to ask the laptop vendor to get this information.

We can match it to the correct driver afterwards.

I recently bought the Voyo Vbook 3 (CherryTrail Edition) which employs the same touchpad.
I have emailed Voyo but didn't receive an answer yet. But judging from some screenshots I found the touchpad might very well be a Synaptics device.

As I am not an experienced developer, especially in regard to the Linux Kernel, I didn't try to assign the synaptics driver. Instead I went for hid-generic which offers basic functionality.

The problem is, that this device gets matched by hid-multitouch. An easy kernel patch is to add the line
#define USB_VENDOR_ID_RIPOFF 0x1018
to drivers/hid/hid-ids.h in the kernel source and then modify drivers/hid/hid-core.c to contain
    case USB_VENDOR_ID_RIPOFF:
 hid->group = HID_GROUP_GENERIC;
        break;
within the function hid_scan_report under vendor specific handlings.

I didn't have the time to recompile the whole kernel (4.13.0, Ubuntu 17.10), so I compiled and installed everything in "drivers/hid" as external modules. After reloading the hid module, the touchpad works.

Curiously, it wouldn't work directly after start up even though the right .ko file had been loaded (as reported by modinfo), so i put the lines
hid
usbhid
hid-generic
in \etc\initramfs-tools\modules and did an "update-initramfs -u"
Now it works on the login screen.

I hope someone with more experience can propose an appropriate kernel patch or something?
In the meantime I plan to soonish publish a more extensive description of my little hack and more tricks to also get other hardware of the voyo (such as wifi) working.

Kai-Heng Feng (kaihengfeng) wrote :

Then it behaves like a mouse - you lose features like scroll/multitouch.

Workaround tested and still scroll/multitouch work. Maybe should be pushed to the upstream?

Kai-Heng Feng (kaihengfeng) wrote :

Sorry for the belated response.

Please send the patch upstream and we can include the patch to Ubuntu's kernel.

I'm sending the patch till the end of the weekend. Is it ok using "USB_VENDOR_ID_RIPOFF" on the upstream, as I can't really find any vendor?

Kai-Heng Feng (kaihengfeng) wrote :

I'll pick USB_VENDOR_ID_1018 as its vendor name.

Ondřej Žára (ondras) wrote :

It looks like I am currently hit by the very same issue: bought a chinese tablet, its keyboard+touchpad is detected as 1018:1006 and the touchpad is not working (only sending garbage on 3-finger gestures).

May I ask about the status of the discussed patch?

tags: added: disco
removed: zesty
Markus Siegert (drmarkus) wrote :

Had the same issue with an Evoo 11.6" tablet (Atom Cherry Trail, sold by Walmart) and fixed it by just removing the hid_multitouch kernel module...
Without it, the touch pad works fine for me with Lubuntu 19.04 (with a 5.0.0 kernel)...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers