Comment 85 for bug 1678184

This is not a Samsung drive

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of John Neffenger
Sent: Tuesday, May 30, 2017 8:50 AM
To: Judy Brock
Subject: [Bug 1678184] Re: APST quirk needed for Samsung 512GB NVMe drive

@kaihengfeng Here you go:

$ sudo nvme id-ctrl /dev/nvme0
NVME Identify Controller:
vid : 0x14a4
ssvid : 0x1b4b
sn : TW0XVRV7LOH006AJ09F1
mn : CX2-8B256-Q11 NVMe LITEON 256GB
fr : 48811QD
rab : 0
ieee : 002303
cmic : 0
mdts : 5
cntlid : 1
ver : 10200
rtd3r : f4240
rtd3e : f4240
oaes : 0
oacs : 0x1f
acl : 3
aerl : 3
frmw : 0x14
lpa : 0x2
elpe : 63
npss : 4
avscc : 0x1
apsta : 0x1
wctemp : 358
cctemp : 368
mtfa : 50
hmpre : 0
hmmin : 0
tnvmcap : 256060514304
unvmcap : 0
rpmbs : 0
sqes : 0x66
cqes : 0x44
nn : 1
oncs : 0x1f
fuses : 0
fna : 0
vwc : 0x1
awun : 255
awupf : 7
nvscc : 1
acwu : 0
sgls : 0
ps 0 : mp:8.00W operational enlat:0 exlat:0 rrt:0 rrl:0
          rwt:0 rwl:0 idle_power:- active_power:-
ps 1 : mp:4.00W operational enlat:5 exlat:5 rrt:1 rrl:1
          rwt:1 rwl:1 idle_power:- active_power:-
ps 2 : mp:2.10W operational enlat:5 exlat:5 rrt:2 rrl:2
          rwt:2 rwl:2 idle_power:- active_power:-
ps 3 : mp:0.1000W non-operational enlat:5000 exlat:5000 rrt:3 rrl:3
          rwt:3 rwl:3 idle_power:- active_power:-
ps 4 : mp:0.0100W non-operational enlat:50000 exlat:100000 rrt:4 rrl:4
          rwt:4 rwl:4 idle_power:- active_power:-

--
You received this bug notification because you are subscribed to the bug report.
https://bugs.launchpad.net/bugs/1678184

Title:
  APST quirk needed for Samsung 512GB NVMe drive

Status in linux package in Ubuntu:
  Confirmed
Status in linux source package in Yakkety:
  Fix Committed
Status in linux source package in Zesty:
  Fix Committed

Bug description:
  APST support just landed in the latest Zesty kernel (4.10.0-14.16) as
  part of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1664602.
  That patch has a quirk for certain 256GB Samsung drives found in Dell
  laptops that do not behave well when APST is enabled. I am
  experiencing the same symptoms with the same model laptop except with
  a 512GB Samsung. Prior to manually disabling APST the drive would die
  and system would go down in flames with I/O errors within 20 to 40
  minutes of boot.

  $ sudo nvme list
  Node SN Model Namespace Usage Format FW Rev
  ---------------- -------------------- ---------------------------------------- --------- -------------------------- ---------------- --------
  /dev/nvme0n1 ************** PM951 NVMe SAMSUNG 512GB 1 500.20 GB / 512.11 GB 512 B + 0 B BXV76D0Q

  ProblemType: Bug
  DistroRelease: Ubuntu 17.04
  Package: linux-image-4.10.0-14-generic 4.10.0-14.16
  ProcVersionSignature: Ubuntu 4.10.0-14.16-generic 4.10.3
  Uname: Linux 4.10.0-14-generic x86_64
  ApportVersion: 2.20.4-0ubuntu2
  Architecture: amd64
  AudioDevicesInUse:
   USER PID ACCESS COMMAND
   /dev/snd/controlC0: ajclayton 3305 F.... pulseaudio
  CurrentDesktop: Unity:Unity7
  Date: Fri Mar 31 09:42:38 2017
  InstallationDate: Installed on 2012-09-08 (1665 days ago)
  InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
  MachineType: Dell Inc. XPS 15 9550
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.10.0-14-generic root=UUID=779e5929-5ffb-49b1-9786-1adcde824b7d ro rootflags=subvol=@ noprompt nouveau.modeset=0 log_buf_len=20M
  RelatedPackageVersions:
   linux-restricted-modules-4.10.0-14-generic N/A
   linux-backports-modules-4.10.0-14-generic N/A
   linux-firmware 1.164
  SourcePackage: linux
  UpgradeStatus: Upgraded to zesty on 2017-03-07 (23 days ago)
  dmi.bios.date: 04/07/2016
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 01.02.00
  dmi.board.name: 0N7TVV
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvr01.02.00:bd04/07/2016:svnDellInc.:pnXPS159550:pvr:rvnDellInc.:rn0N7TVV:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: XPS 15 9550
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1678184/+subscriptions