Comment 100 for bug 1678184

> On 22 Jan 2018, at 9:34 AM, Lucas Zanella <email address hidden> wrote:
>
> I'm having this on my Razer Blade Stealth, 512gb samsung SSD, ubuntu
> 17.10.1, but also had the issue on 17.04 and today at 16.04 after
> updating (possibly related; or not). I installed 17.10.1 today and
> immediately updated and the error ocurred. I then reinstalled without
> updating and I've seen no problems until now.
>
> Could somebody help me? Is this issue fixed for 17.10.1? What should I
> do?

Please file a new bug. This issue is quite specific to different NVMe & motherboard combination.

You can try kernel parameter “nvme_core.default_ps_max_latency_us=1500” to disable PS4.

>
> sudo nvme list
> Node SN Model Namespace Usage Format FW Rev
> ---------------- -------------------- ---------------------------------------- --------- -------------------------- ---------------- --------
> /dev/nvme0n1 S33UNX0J324060 SAMSUNG MZVLW512HMJP-00000 1 25,30 GB / 512,11 GB 512 B + 0 B CXY7501Q
>
>
> NVME Identify Controller:
> vid : 0x144d
> ssvid : 0x144d
> sn : S33UNX0J324060
> mn : SAMSUNG MZVLW512HMJP-00000
> fr : CXY7501Q
> rab : 2
> ieee : 002538
> cmic : 0
> mdts : 0
> cntlid : 2
> ver : 10200
> rtd3r : 186a0
> rtd3e : 4c4b40
> oaes : 0
> oacs : 0x17
> acl : 7
> aerl : 3
> frmw : 0x16
> lpa : 0x3
> elpe : 63
> npss : 4
> avscc : 0x1
> apsta : 0x1
> wctemp : 341
> cctemp : 344
> mtfa : 0
> hmpre : 0
> hmmin : 0
> tnvmcap : 512110190592
> unvmcap : 0
> rpmbs : 0
> sqes : 0x66
> cqes : 0x44
> nn : 1
> oncs : 0x1f
> fuses : 0
> fna : 0
> vwc : 0x1
> awun : 255
> awupf : 0
> nvscc : 1
> acwu : 0
> sgls : 0
> subnqn :
> ps 0 : mp:7.60W operational enlat:0 exlat:0 rrt:0 rrl:0
> rwt:0 rwl:0 idle_power:- active_power:-
> ps 1 : mp:6.00W operational enlat:0 exlat:0 rrt:1 rrl:1
> rwt:1 rwl:1 idle_power:- active_power:-
> ps 2 : mp:5.10W operational enlat:0 exlat:0 rrt:2 rrl:2
> rwt:2 rwl:2 idle_power:- active_power:-
> ps 3 : mp:0.0400W non-operational enlat:210 exlat:1500 rrt:3 rrl:3
> rwt:3 rwl:3 idle_power:- active_power:-
> ps 4 : mp:0.0050W non-operational enlat:2200 exlat:6000 rrt:4 rrl:4
> rwt:4 rwl:4 idle_power:- active_power:-
>
> --
> You received this bug notification because you are subscribed to linux
> in Ubuntu.
> https://bugs.launchpad.net/bugs/1678184
>
> Title:
> APST quirk needed for Samsung 512GB NVMe drive
>
> Status in linux package in Ubuntu:
> Fix Released
> Status in linux source package in Yakkety:
> Fix Released
> Status in linux source package in Zesty:
> Fix Released
>
> Bug description:
> APST support just landed in the latest Zesty kernel (4.10.0-14.16) as
> part of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1664602.
> That patch has a quirk for certain 256GB Samsung drives found in Dell
> laptops that do not behave well when APST is enabled. I am
> experiencing the same symptoms with the same model laptop except with
> a 512GB Samsung. Prior to manually disabling APST the drive would die
> and system would go down in flames with I/O errors within 20 to 40
> minutes of boot.
>
> $ sudo nvme list
> Node SN Model Namespace Usage Format FW Rev
> ---------------- -------------------- ---------------------------------------- --------- -------------------------- ---------------- --------
> /dev/nvme0n1 ************** PM951 NVMe SAMSUNG 512GB 1 500.20 GB / 512.11 GB 512 B + 0 B BXV76D0Q
>
> ProblemType: Bug
> DistroRelease: Ubuntu 17.04
> Package: linux-image-4.10.0-14-generic 4.10.0-14.16
> ProcVersionSignature: Ubuntu 4.10.0-14.16-generic 4.10.3
> Uname: Linux 4.10.0-14-generic x86_64
> ApportVersion: 2.20.4-0ubuntu2
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: ajclayton 3305 F.... pulseaudio
> CurrentDesktop: Unity:Unity7
> Date: Fri Mar 31 09:42:38 2017
> InstallationDate: Installed on 2012-09-08 (1665 days ago)
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
> MachineType: Dell Inc. XPS 15 9550
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.10.0-14-generic root=UUID=779e5929-5ffb-49b1-9786-1adcde824b7d ro rootflags=subvol=@ noprompt nouveau.modeset=0 log_buf_len=20M
> RelatedPackageVersions:
> linux-restricted-modules-4.10.0-14-generic N/A
> linux-backports-modules-4.10.0-14-generic N/A
> linux-firmware 1.164
> SourcePackage: linux
> UpgradeStatus: Upgraded to zesty on 2017-03-07 (23 days ago)
> dmi.bios.date: 04/07/2016
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: 01.02.00
> dmi.board.name: 0N7TVV
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A00
> dmi.chassis.type: 9
> dmi.chassis.vendor: Dell Inc.
> dmi.modalias: dmi:bvnDellInc.:bvr01.02.00:bd04/07/2016:svnDellInc.:pnXPS159550:pvr:rvnDellInc.:rn0N7TVV:rvrA00:cvnDellInc.:ct9:cvr:
> dmi.product.name: XPS 15 9550
> dmi.sys.vendor: Dell Inc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1678184/+subscriptions