[Hyper-V] Rebase Hyper-V in 16.04 and 16.10 to the the upstream 4.9 kernel

Bug #1650059 reported by Joshua R. Poulson on 2016-12-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Xenial
Medium
Tim Gardner
Yakkety
Medium
Tim Gardner
Zesty
Medium
Unassigned

Bug Description

The following files comprise Hyper-V support in the upstream kernel:
arch/x86/kernel/cpu/mshyperv.c
arch/x86/include/asm/mshyperv.h
arch/x86/include/uapi/asm/hyperv.h
include/linux/hyperv.h
drivers/hv/channel.c
drivers/hv/channel_mgmt.c
drivers/hv/connection.c
drivers/hv/hv_balloon.c
drivers/hv/hv.c
drivers/hv/hv_fcopy.c
drivers/hv/hv_kvp.c
drivers/hv/hv_snapshot.c
drivers/hv/hv_util.c
drivers/hv/hv_utils_transport.c
drivers/hv/hv_utils_transport.h
drivers/hv/hyperv_vmbus.h
drivers/hv/ring_buffer.c
drivers/hv/vmbus_drv.c
tools/hv/hv_fcopy_daemon.c
tools/hv/hv_get_dhcp_info.sh
tools/hv/hv_get_dns_info.sh
tools/hv/hv_kvp_daemon.c
tools/hv/hv_set_ifconfig.sh
tools/hv/hv_vss_daemon.c
tools/hv/lsvmbus
drivers/input/serio/hyperv-keyboard.c
drivers/net/hyperv/hyperv_net.h
drivers/net/hyperv/netvsc.c
drivers/net/hyperv/netvsc_drv.c
drivers/net/hyperv/rndis_filter.c
drivers/scsi/storvsc_drv.c
drivers/hid/hid-hyperv.c
drivers/pci/host/pci-hyperv.c
drivers/video/fbdev/hyperv_fb.c

The following commits are upstream in the 4.9 kernel release:

mshyperv.c : commit 186f43608a5c827f8284fe4559225b4dccaa49ef : x86/kernel: Audit and remove any unnecessary uses of module.h
hyperv.h : commit 509879bdb30b8e12bd0b3cb0bc8429f01478df4b : Drivers: hv: Introduce a policy for controlling channel affinity
hyperv.h : commit e7fca5d860aeeb1e606448f5191cea8d925cc7a3 : Drivers: hv: get rid of id in struct vmbus_channel
hyperv.h : commit 0f98829a99850836cf7c2cc9fbf1d7ce0f795780 : Drivers: hv: vmbus: suppress some "hv_vmbus: Unknown GUID" warnings
hyperv.h : commit 8e1d260738ca89bc7c87444f95f04a026d12b496 : Drivers: hv: utils: Support TimeSync version 4.0 protocol samples.
hyperv.h : commit 638fea33aee858cc665297a76f0039e95a28ce0c : Drivers: hv: vmbus: fix the race when querying & updating the percpu list
channel.c : commit 3724287c0ec472815ebe5ae3790f77965c6aa557 : Drivers: hv: vmbus: Implement a mechanism to tag the channel for low latency
channel.c : commit 4d63763296ab7865a98bc29cc7d77145815ef89f : Drivers: hv: get rid of redundant messagecount in create_gpadl_header()
channel.c : commit 638fea33aee858cc665297a76f0039e95a28ce0c : Drivers: hv: vmbus: fix the race when querying & updating the percpu list
channel.c : commit ccef9bcc02ee63ac171ea9f0d51e04b3e55b3a12 : Drivers: hv: vmbus: Enable explicit signaling policy for NIC channels
channel_mgmt.c : commit 638fea33aee858cc665297a76f0039e95a28ce0c : Drivers: hv: vmbus: fix the race when querying & updating the percpu list
channel_mgmt.c : commit e7fca5d860aeeb1e606448f5191cea8d925cc7a3 : Drivers: hv: get rid of id in struct vmbus_channel
connection.c : commit 8de0d7e951826d7592e0ba1da655b175c4aa0923 : Drivers: hv: vmbus: Reduce the delay between retries in vmbus_post_msg()
hv_balloon.c : commit eece30b9f0046cee810a2c7caa2247f3f8dc85e2 : Drivers: hv: balloon: replace ha_region_mutex with spinlock
hv_balloon.c : commit b605c2d913589c448d4a6887262bb8e99da12009 : Drivers: hv: balloon: Use available memory value in pressure report
hv.c : commit a9f61ca793becabdefab03b77568d6c6f8c1bc79 : Drivers: hv: avoid vfree() on crash
mshyperv.c : commit 186f43608a5c827f8284fe4559225b4dccaa49ef : x86/kernel: Audit and remove any unnecessary uses of module.h
hyperv.h : commit 509879bdb30b8e12bd0b3cb0bc8429f01478df4b : Drivers: hv: Introduce a policy for controlling channel affinity
hyperv.h : commit e7fca5d860aeeb1e606448f5191cea8d925cc7a3 : Drivers: hv: get rid of id in struct vmbus_channel
hyperv.h : commit 0f98829a99850836cf7c2cc9fbf1d7ce0f795780 : Drivers: hv: vmbus: suppress some "hv_vmbus: Unknown GUID" warnings
hyperv.h : commit 8e1d260738ca89bc7c87444f95f04a026d12b496 : Drivers: hv: utils: Support TimeSync version 4.0 protocol samples.
hyperv.h : commit 638fea33aee858cc665297a76f0039e95a28ce0c : Drivers: hv: vmbus: fix the race when querying & updating the percpu list
channel.c : commit 3724287c0ec472815ebe5ae3790f77965c6aa557 : Drivers: hv: vmbus: Implement a mechanism to tag the channel for low latency
channel.c : commit 4d63763296ab7865a98bc29cc7d77145815ef89f : Drivers: hv: get rid of redundant messagecount in create_gpadl_header()
channel.c : commit 638fea33aee858cc665297a76f0039e95a28ce0c : Drivers: hv: vmbus: fix the race when querying & updating the percpu list
channel.c : commit ccef9bcc02ee63ac171ea9f0d51e04b3e55b3a12 : Drivers: hv: vmbus: Enable explicit signaling policy for NIC channels
channel_mgmt.c : commit 638fea33aee858cc665297a76f0039e95a28ce0c : Drivers: hv: vmbus: fix the race when querying & updating the percpu list
channel_mgmt.c : commit e7fca5d860aeeb1e606448f5191cea8d925cc7a3 : Drivers: hv: get rid of id in struct vmbus_channel
connection.c : commit 8de0d7e951826d7592e0ba1da655b175c4aa0923 : Drivers: hv: vmbus: Reduce the delay between retries in vmbus_post_msg()
hv_balloon.c : commit eece30b9f0046cee810a2c7caa2247f3f8dc85e2 : Drivers: hv: balloon: replace ha_region_mutex with spinlock
hv_balloon.c : commit b605c2d913589c448d4a6887262bb8e99da12009 : Drivers: hv: balloon: Use available memory value in pressure report
hv.c : commit a9f61ca793becabdefab03b77568d6c6f8c1bc79 : Drivers: hv: avoid vfree() on crash
hv_fcopy.c : commit e0fa3e5e7df61eb2c339c9f0067c202c0cdeec2c : Drivers: hv: utils: fix a race on userspace daemons registration
hv_fcopy.c : commit 7c959127581d420ec692344ee905504fdeecec1a : Drivers: hv: utils: unify driver registration reporting
hv_kvp.c : commit e0fa3e5e7df61eb2c339c9f0067c202c0cdeec2c : Drivers: hv: utils: fix a race on userspace daemons registration
hv_snapshot.c : commit 497af84b81b98b27e9ba7aebb8a373412e328497 : Drivers: hv: utils: Continue to poll VSS channel after handling requests.
hv_snapshot.c : commit e0fa3e5e7df61eb2c339c9f0067c202c0cdeec2c : Drivers: hv: utils: fix a race on userspace daemons registration
hv_snapshot.c : commit db886e4d24c2b3d334be2cc1bd1bd05d547eb4c4 : Drivers: hv: utils: Check VSS daemon is listening before a hot backup
hv_util.c : commit 3ba1eb17b633b419737b65429fa7124ce87c5efc : Drivers: hv: hv_util: Avoid dynamic allocation in time synch
hv_util.c : commit 407a3aee6ee2d2cb46d9ba3fc380bc29f35d020c : hv: do not lose pending heartbeat vmbus packets
hv_utils_transport.c : commit e0fa3e5e7df61eb2c339c9f0067c202c0cdeec2c : Drivers: hv: utils: fix a race on userspace daemons registration
hv_utils_transport.h : commit e0fa3e5e7df61eb2c339c9f0067c202c0cdeec2c : Drivers: hv: utils: fix a race on userspace daemons registration
hyperv_vmbus.h : commit a9f61ca793becabdefab03b77568d6c6f8c1bc79 : Drivers: hv: avoid vfree() on crash
ring_buffer.c : commit 9988ce685676cebe0b14dc128f00e1ae9cd1a4fa : Drivers: hv: ring_buffer: wrap around mappings for ring buffers
ring_buffer.c : commit ccef9bcc02ee63ac171ea9f0d51e04b3e55b3a12 : Drivers: hv: vmbus: Enable explicit signaling policy for NIC channels
ring_buffer.c : commit f24f0b495b17df33c03f3b758b1461385e9f0e50 : Drivers: hv: ring_buffer: use wrap around mappings in hv_copy{from, to}_ringbuffer()
vmbus_drv.c : commit e2e808413425d82c8f162933a30304d10a5df231 : Driver: hv: vmbus: Make mmio resource local
vmbus_drv.c : commit a9f61ca793becabdefab03b77568d6c6f8c1bc79 : Drivers: hv: avoid vfree() on crash
hv_kvp_daemon.c : commit 26840437cbd6d3625ea6ab34e17cd34bb810c861 : Tools: hv: kvp: ensure kvp device fd is closed on exec
hv_vss_daemon.c : commit db886e4d24c2b3d334be2cc1bd1bd05d547eb4c4 : Drivers: hv: utils: Check VSS daemon is listening before a hot backup
hyperv_net.h : commit 9477386687354f2aa8f4843170b7093c6dd1eb37 : hv_netvsc: make RSS hash key static
hyperv_net.h : commit e834da9a40edd3117ef0a9b2a73d845fe6b622a8 : hv_netvsc: pass struct net_device to rndis_filter_set_device_mac()
hyperv_net.h : commit c6a77ff82fb849534748719f37f3f9086d78ed39 : hv_netvsc: fix comments
hyperv_net.h : commit 7f5d5af0b2f859f09b3dcb16a00b800fa48d9288 : hv_netvsc: Add handler for physical link speed change
netvsc.c : commit 796cc88c32c1bd1f833d596448ac785a8736e57c : hv_netvsc: style cleanups
netvsc.c : commit e53a9c2a5a8cd0a3a8b3c0f9b7a3ad9bc6a28867 : hv_netvsc: use kcalloc
netvsc.c : commit 7f5d5af0b2f859f09b3dcb16a00b800fa48d9288 : hv_netvsc: Add handler for physical link speed change
netvsc.c : commit e5a78fad4f1eb49064e4c35d0a4263424b12124c : hv_netvsc: use ARRAY_SIZE() for NDIS versions
netvsc.c : commit e08f3ea586d4145e36c77f0dd1602374b5d7e928 : hv_netvsc: make device_remove void
netvsc.c : commit 6c4c137e5035e0e17fa40c223fa0a3167e0f65fa : hv_netvsc: make variable local
netvsc_drv.c : commit 796cc88c32c1bd1f833d596448ac785a8736e57c : hv_netvsc: style cleanups
netvsc_drv.c : commit a50af86dd49ee1851d1ccf06dd0019c05b95e297 : netvsc: reduce maximum GSO size
netvsc_drv.c : commit 2f5fa6c869e8f8c340dd05a2817eecbcea382c35 : hv_netvsc: pass struct netvsc_device to rndis_filter_{open, close}()
netvsc_drv.c : commit 7f5d5af0b2f859f09b3dcb16a00b800fa48d9288 : hv_netvsc: Add handler for physical link speed change
netvsc_drv.c : commit e52fed7177f74382f742c27de2cc5314790aebb6 : netvsc: fix incorrect receive checksum offloading
netvsc_drv.c : commit e834da9a40edd3117ef0a9b2a73d845fe6b622a8 : hv_netvsc: pass struct net_device to rndis_filter_set_device_mac()
netvsc_drv.c : commit b37879e6ca7079943542048da37f00a386c30cee : hv_netvsc: Add query for initial physical link speed
rndis_filter.c : commit 5362855aba7159aab8f7c6573eb675d9da317914 : netvsc: get rid of completion timeouts
rndis_filter.c : commit 9477386687354f2aa8f4843170b7093c6dd1eb37 : hv_netvsc: make RSS hash key static
rndis_filter.c : commit b37879e6ca7079943542048da37f00a386c30cee : hv_netvsc: Add query for initial physical link speed
storvsc_drv.c : commit 84b342c0f4dc0180ad4ac701b46024761ff4af11 : scsi: storvsc: Filter out storvsc messages CD-ROM medium not present
pci-hyperv.c : commit 0c6045d8c0eff0f7784f310407ccad44f622aa40 : PCI: hv: Use zero-length array in struct pci_packet
pci-hyperv.c : commit 7d0f8eec976ae5a364af84fd8e92f6da9ec05a41 : PCI: hv: Use pci_function_description[0] in struct definitions
pci-hyperv.c : commit 617ceb62eaa1a180e8af1be9903d960c3a0b2ebc : PCI: hv: Remove the unused 'wrk' in struct hv_pcibus_device
pci-hyperv.c : commit a5b45b7b952822aa5fbe842d2ee497c7c9dd7f55 : PCI: hv: Handle hv_pci_generic_compl() error case
pci-hyperv.c : commit 0c6e617f656ec259162a41c0849e3a7557c99d95 : PCI: hv: Fix interrupt cleanup path
pci-hyperv.c : commit 665e2245eb46a217926d45031b83f1212a1bb344 : PCI: hv: Handle vmbus_sendpacket() failure in hv_compose_msi_msg()
pci-hyperv.c : commit 4f1cb01a7892582d18483986fbc268cdef1b1dee : PCI: hv: Use list_move_tail() instead of list_del() + list_add_tail()

In addition 5 patches have been submitted to stable upstream but have not yet appeared in linux-next:

Patchset: Drivers: hv: vmbus: Some miscellaneous fixes (submitted to stable)

K. Y. Srinivasan (1):
  Drivers: hv: vmbus: Prevent sending data on a rescinded channel

Vitaly Kuznetsov (4):
  Drivers: hv: vmbus: Raise retry/wait limits in vmbus_post_msg()
  hv: allocate synic pages for all present CPUs
  hv: init percpu_list in hv_synic_alloc()
  hv: don't reset hv_context.tsc_page on crash

I will post those commits once I see them go through.

These items are needed for the 14.04.5 and 16.04.1 HWE kernels, and 16.10, (and by extension, 16.04.2 HWE).

Joshua R. Poulson (jrp) on 2016-12-14
summary: - Rebase Hyper-V in 16.04 and 16.10 to the the upstream 4.9 kernel
+ [Hyper-V] Rebase Hyper-V in 16.04 and 16.10 to the the upstream 4.9
+ kernel

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1650059

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Joshua R. Poulson (jrp) on 2016-12-15
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in linux (Ubuntu Xenial):
status: New → Triaged
Changed in linux (Ubuntu Yakkety):
status: New → Triaged
Changed in linux (Ubuntu Xenial):
importance: Undecided → Medium
Changed in linux (Ubuntu Yakkety):
importance: Undecided → Medium
tags: added: kernel-da-key kernel-hyper-v xenial yakkety
Tim Gardner (timg-tpi) wrote :

git://kernel.ubuntu.com/rtg/ubuntu-yakkety.git hv

Changed in linux (Ubuntu Yakkety):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Joshua R. Poulson (jrp) wrote :

We'll give them a look.

Joshua R. Poulson (jrp) wrote :

After performance testing, it looks like we need this upstream commit:
"Drivers: hv: vmbus: Base host signaling strictly on the ring state" http://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/commit/?id=74198eb4a42c4a3c4fbef08fa01a291a282f7c2e

Also, we need to add the file for SR-IOV interface bonding:
"tools: hv: Add a script to help bonding synthetic and VF NICs" http://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/commit/?id=178cd55f086629cf0bad9c66c793a7e2bcc3abb6

Can we get these two? We did some testing by adding the script manually so we're sure that will work, and our upstream linux-next testing has the other commit and we're getting the performance we're expecting.

Tim Gardner (timg-tpi) wrote :

I've updated http://kernel.ubuntu.com/~rtg/linux-4.8.0-33-hv/ and http://kernel.ubuntu.com/~rtg/linux-4.4.0-58-hv/ with hv.2 versions that include the two aforementioned commits.

Chris Valean (cvalean) wrote :

Hi Tim,

We've verified the 2 updated test kernels hv.2 from comment #7 and network performance is back to the maximum throughput.
Also, the bond script is present and functional.
Thank you!

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Xenial):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Zesty):
status: Triaged → Fix Released
Luis Henriques (henrix) on 2017-01-20
Changed in linux (Ubuntu Yakkety):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
tags: added: verification-needed-yakkety

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-yakkety' to 'verification-done-yakkety'. If the problem still exists, change the tag 'verification-needed-yakkety' to 'verification-failed-yakkety'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Chris Valean (cvalean) on 2017-02-13
tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :
Download full text (23.0 KiB)

This bug was fixed in the package linux - 4.4.0-63.84

---------------
linux (4.4.0-63.84) xenial; urgency=low

  [ Thadeu Lima de Souza Cascardo ]

  * Release Tracking Bug
    - LP: #1660704

  * Backport Dirty COW patch to prevent wineserver freeze (LP: #1658270)
    - SAUCE: mm: Respect FOLL_FORCE/FOLL_COW for thp

  * Kdump through NMI SMP and single core not working on Ubuntu16.10
    (LP: #1630924)
    - x86/hyperv: Handle unknown NMIs on one CPU when unknown_nmi_panic
    - SAUCE: hv: don't reset hv_context.tsc_page on crash

  * [regression 4.8.0-14 -> 4.8.0-17] keyboard and touchscreen lost on Acer
    Chromebook R11 (LP: #1630238)
    - [Config] CONFIG_PINCTRL_CHERRYVIEW=y

  * Call trace when testing fstat stressor on ppc64el with virtual keyboard and
    mouse present (LP: #1652132)
    - SAUCE: HID: usbhid: Quirk a AMI virtual mouse and keyboard with ALWAYS_POLL

  * VLAN SR-IOV regression for IXGBE driver (LP: #1658491)
    - ixgbe: Force VLNCTRL.VFE to be set in all VMDq paths

  * "Out of memory" errors after upgrade to 4.4.0-59 (LP: #1655842)
    - mm, page_alloc: convert alloc_flags to unsigned
    - mm, compaction: change COMPACT_ constants into enum
    - mm, compaction: distinguish COMPACT_DEFERRED from COMPACT_SKIPPED
    - mm, compaction: simplify __alloc_pages_direct_compact feedback interface
    - mm, compaction: distinguish between full and partial COMPACT_COMPLETE
    - mm, compaction: abstract compaction feedback to helpers
    - mm, oom: protect !costly allocations some more
    - mm: consider compaction feedback also for costly allocation
    - mm, oom, compaction: prevent from should_compact_retry looping for ever for
      costly orders
    - mm, oom: protect !costly allocations some more for !CONFIG_COMPACTION
    - mm, oom: prevent premature OOM killer invocation for high order request

  * Backport 3 patches to fix bugs with AIX clients using IBMVSCSI Target Driver
    (LP: #1657194)
    - SAUCE: ibmvscsis: Fix max transfer length
    - SAUCE: ibmvscsis: fix sleeping in interrupt context
    - SAUCE: ibmvscsis: Fix srp_transfer_data fail return code

  * NVMe: adapter is missing after abnormal shutdown followed by quick reboot,
    quirk needed (LP: #1656913)
    - nvme: apply DELAY_BEFORE_CHK_RDY quirk at probe time too

  * Ubuntu 16.10 KVM SRIOV: if enable sriov while ping flood is running ping
    will stop working (LP: #1625318)
    - PCI: Do any VF BAR updates before enabling the BARs
    - PCI: Ignore BAR updates on virtual functions
    - PCI: Update BARs using property bits appropriate for type
    - PCI: Separate VF BAR updates from standard BAR updates
    - PCI: Don't update VF BARs while VF memory space is enabled
    - PCI: Remove pci_resource_bar() and pci_iov_resource_bar()
    - PCI: Decouple IORESOURCE_ROM_ENABLE and PCI_ROM_ADDRESS_ENABLE
    - PCI: Add comments about ROM BAR updating

  * Linux rtc self test fails in a VM under xenial (LP: #1649718)
    - kvm: x86: Convert ioapic->rtc_status.dest_map to a struct
    - kvm: x86: Track irq vectors in ioapic->rtc_status.dest_map
    - kvm: x86: Check dest_map->vector to match eoi signals for rtc

  * Xenial update to v4.4.44 stable releas...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (20.4 KiB)

This bug was fixed in the package linux - 4.8.0-38.41

---------------
linux (4.8.0-38.41) yakkety; urgency=low

  [ Thadeu Lima de Souza Cascardo ]

  * Release Tracking Bug
    - LP: #1661232

  * Backport Dirty COW patch to prevent wineserver freeze (LP: #1658270)
    - SAUCE: mm: Respect FOLL_FORCE/FOLL_COW for thp

  * Kdump through NMI SMP and single core not working on Ubuntu16.10
    (LP: #1630924)
    - x86/hyperv: Handle unknown NMIs on one CPU when unknown_nmi_panic
    - SAUCE: hv: don't reset hv_context.tsc_page on crash

  * Call trace when testing fstat stressor on ppc64el with virtual keyboard and
    mouse present (LP: #1652132)
    - HID: usbhid: Quirk a AMI virtual mouse and keyboard with ALWAYS_POLL

  * regression in linux-libc-dev in yakkety: C++ style comments are not allowed
    in ISO C90 (LP: #1659654)
    - generic syscalls: kill cruft from removed pkey syscalls

  * [16.04.2] POWER9 patches on top of 4.8 (LP: #1650263)
    - powerpc/book3s: Add a cpu table entry for different POWER9 revs
    - powerpc/mm/radix: Use different RTS encoding for different POWER9 revs
    - powerpc/mm/radix: Use different pte update sequence for different POWER9
      revs
    - powerpc/mm: Update the HID bit when switching from radix to hash
    - powerpc/64/kexec: NULL check "clear_all" in kexec_sequence
    - powerpc/64/kexec: Fix MMU cleanup on radix
    - powerpc/mm: Add radix flush all with IS=3
    - powerpc/64/kexec: Copy image with MMU off when possible
    - powerpc/64: Simplify adaptation to new ISA v3.00 HPTE format
    - powerpc/mm/radix: Invalidate ERAT on tlbiel for POWER9 DD1
    - powerpc/mm: Fix missing update of HID register on secondary CPUs
    - powerpc/64: Add some more SPRs and SPR bits for POWER9
    - powerpc/64: Provide functions for accessing POWER9 partition table
    - powerpc/powernv: Define real-mode versions of OPAL XICS accessors
    - powerpc/64: Define new ISA v3.00 logical PVR value and PCR register value
    - mm: update mmu_gather range correctly
    - mm/hugetlb: add tlb_remove_hugetlb_entry for handling hugetlb pages
    - mm: add tlb_remove_check_page_size_change to track page size change
    - powerpc: Revert Load Monitor Register Support
    - powerpc/mm: Correct process and partition table max size
    - powernv: Clear SPRN_PSSCR when a POWER9 CPU comes online
    - powerpc/mm/radix: Setup AMOR in HV mode to allow key 0
    - powerpc/mm: Detect instruction fetch denied and report
    - powerpc/mm/radix: Prevent kernel execution of user space
    - powerpc/mm: Rename hugetlb-radix.h to hugetlb.h
    - powerpc/mm/hugetlb: Handle hugepage size supported by hash config
    - powerpc/mm: Introduce _PAGE_LARGE software pte bits
    - powerpc/mm: Add radix__tlb_flush_pte_p9_dd1()
    - powerpc/mm: update radix__ptep_set_access_flag to not do full mm tlb flush
    - powerpc/mm: update radix__pte_update to not do full mm tlb flush
    - powerpc/mm: Batch tlb flush when invalidating pte entries
    - powerpc/sparse: Make a bunch of things static
    - powerpc/perf: factor out the event format field
    - powerpc/perf: update attribute_group data structure
    - powerpc/perf: power9 raw event format en...

Changed in linux (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers