sata controller/drive reports exception Emask 0x10 SAct 0x0 SErr 0x40d0002 action 0x2 frozen

Bug #164183 reported by Jerome Haltom on 2007-11-20
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

ata7: exception Emask 0x10 SAct 0x0 SErr 0x40d0002 action 0x2 frozen
[21772.079946] ata7: (irq_stat 0x04400040, connection status changed)
[21772.795175] ata7: soft resetting port
[21772.795183] ata7: softreset failed (port busy but CLO unavailable)
[21772.795214] ata7: reset failed (errno=-95), retrying in 10 secs
[21782.777291] ata7: hard resetting port
[21783.654617] ata7: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[21783.756936] ata7.00: configured for UDMA/100
[21783.756941] ata7: EH complete
[21783.757150] sd 6:0:0:0: [sde] 976773168 512-byte hardware sectors (500108 MB)
[21783.757168] sd 6:0:0:0: [sde] Write Protect is off
[21783.757171] sd 6:0:0:0: [sde] Mode Sense: 00 3a 00 00
[21783.757251] sd 6:0:0:0: [sde] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

These errors repeat and prevent me from accessing two of my disks in on my SATA controller.

00:1f.2 SATA controller: Intel Corporation 631xESB/632xESB SATA AHCI Controller (rev 09)

The problem occurs with any disks in the 4th and 5th SATA slot on the motherboard. I have put different drives in the same slot and experienced the same issues.

Javier Barroso (javibarroso) wrote :

Hi,

I doesn't know if this bug is the same of:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/217920
https://bugs.launchpad.net/linux/+bug/84603
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/112893
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/118646

My kernel is:
Linux noname 2.6.24-16-386 #1 Thu Apr 10 12:50:06 UTC 2008 i686 GNU/Linux

and I using Hardy version of Ubuntu

My partitions stops works 30 seconds (from 149 to 180):
[ 30.391800] ata1: SATA max UDMA/133 abar m1024@0xcfcffc00 port 0xcfcffd00 irq 19
[ 30.866905] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 30.869022] ata1.00: ATA-7: Maxtor 6L200S0, BANC1G10, max UDMA/133
[ 30.869025] ata1.00: 398297088 sectors, multi 0: LBA48 NCQ (not used)
[ 30.872368] ata1.00: configured for UDMA/133
[ 149.933488] ata1.00: exception Emask 0x10 SAct 0x0 SErr 0x280100 action 0x2 frozen
[ 149.933495] ata1.00: irq_stat 0x08000000, interface fatal error
[ 149.933498] ata1: SError: { UnrecovData 10B8B BadCRC }
[ 149.933504] ata1.00: cmd c8/00:08:f7:1a:60/00:00:00:00:00/e0 tag 0 dma 4096 in
[ 149.933507] ata1.00: status: { DRDY }
[ 150.243469] ata1: soft resetting link
[ 150.407400] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 180.395700] ata1.00: qc timeout (cmd 0xec)
[ 180.395710] ata1.00: failed to IDENTIFY (I/O error, err_mask=0x5)
[ 180.395714] ata1.00: revalidation failed (errno=-5)
[ 180.395718] ata1: failed to recover some devices, retrying in 5 secs
[ 185.398056] ata1: hard resetting link
[ 190.911804] ata1: port is slow to respond, please be patient (Status 0x80)
[ 195.445828] ata1: COMRESET failed (errno=-16)
[ 195.445837] ata1: hard resetting link
[ 195.921684] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 195.926786] ata1.00: configured for UDMA/133
[ 195.926805] ata1: EH complete
[ 310.602251] ata1.00: exception Emask 0x10 SAct 0x0 SErr 0x280100 action 0x2 frozen
[ 310.602258] ata1.00: irq_stat 0x08000000, interface fatal error

Any points to SErr codes ?
[ 149.933488] ata1.00: exception Emask 0x10 SAct 0x0 SErr 0x280100 action 0x2 frozen

What does mean Emask 0x10 SAct 0x0 SErr 0x280100 action 0x2 frozen in human language ?

Javier, check http://ata.wiki.kernel.org/index.php/Libata_error_messages

I have almost the same problem:

[ 2502.855519] ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[ 2502.855534] ata1.01: cmd a0/01:00:00:10:00/00:00:00:00:00/b0 tag 0 dma 16 in
[ 2502.855536] cdb 46 00 00 28 00 00 00 00 10 00 00 00 00 00 00 00
[ 2502.855538] res 40/00:02:00:0c:00/00:00:00:00:00/b0 Emask 0x4 (timeout)
[ 2502.855543] ata1.01: status: { DRDY }
[ 2502.855565] ata1: soft resetting link
[ 2503.367728] ata1.01: configured for UDMA/25
[ 2503.367750] ata1: EH complete
[ 2503.367828] sr0: CDROM (ioctl) error, command: Get configuration 46 00 00 28 00 00 00 00 10 00
[ 2503.367840] sr: Sense Key : Aborted Command [current] [descriptor]
[ 2503.367845] sr: Add. Sense: No additional sense information

kiev1 (sys-sys-admin) wrote :

Jerome Haltom, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers