radeon broken with kernel 4.6.0+

Bug #1627496 reported by Valentin Quequet on 2016-09-25
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Hello Guys,

I'm currently running an up-to-date Xenial system on amd64 (PC) platform.

Whenever I launch the OS with stock kernel (4.4.X) all seems good.

Whenever I launch the OS with let's say a mainline-PPA kernel whose version is above 4.6.0 inclusive (4.5.X are functional), or stock yakkety kernel nowadays (4.8.X), kernel fails to setup my graphics card, whose description is appended in a few text files I joined to this message.

In hope this helps,

Sincelely,
Vécu

P.S. : I very suspect this is a mainstream bug ; for any complimentary info. please don't hesitate to post and ask for more.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.8.0-16.17-generic 4.8.0-rc7
Uname: Linux 4.8.0-16-generic x86_64
.tmp.unity_support_test.1:

ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Sun Sep 25 15:23:08 2016
DistUpgraded: 2016-04-23 10:48:41,985 DEBUG enabling apt cron job
DistroCodename: xenial
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] [1002:6840] (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Radeon HD 7670M [1179:fb41]
InstallationDate: Installed on 2015-05-01 (512 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
MachineType: TOSHIBA SATELLITE L875-10G
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.8.0-16-generic root=UUID=fb0648bd-7019-4cb2-b5b3-382141e3716a ro rootflags=subvol=@ quiet splash nomdmonddf nomdmonisw crashkernel=384M-:128M crashkernel=384M-:128M crashkernel=384M-:128M crashkernel=384M-:128M vt.handoff=7
Renderer: Software
SourcePackage: xorg
Symptom: display
UpgradeStatus: Upgraded to xenial on 2016-04-23 (155 days ago)
dmi.bios.date: 3/25/2013
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 6.50
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: Type2 - Board Product Name1
dmi.board.vendor: Type2 - Board Vendor Name1
dmi.board.version: Type2 - Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvr6.50:bd3/25/2013:svnTOSHIBA:pnSATELLITEL875-10G:pvrPSKBLE-003006FR:rvnType2-BoardVendorName1:rnType2-BoardProductName1:rvrType2-BoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: SATELLITE L875-10G
dmi.product.version: PSKBLE-003006FR
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
version.ia32-libs: ia32-libs 1.0
version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.2
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2.2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2.2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Sun Sep 25 15:10:31 2016
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.18.3-1ubuntu2.3

  • Logs Edit (43.5 KiB, application/x-tar)
Download full text (5.2 KiB)

Hi all,

I must have omitted a few pieces of information in fact :
  - The description of the bug
  - Error messages
  - The text files (logs, ...) I mentioned in my previous post

The files are joined as an attachement to this post, and here follow my bug description and error messages extracts.

With Linux 4.5.x or below all is good :
  - Screen resolution of 1600x900 (native screen resolution)
  - Accelerated 3D graphics on AMD TURKS hardware
  - Plymouth shows up and animates well both on OS startup and OS shutdown
  - No scary message in kernel logs (dmesg)

With Linux 4.6.x or above all is bad :
  - Screen resolution of 1152x864 (lower than native)
  - Software rendered 3D graphics on llvmpipe
  - Plymouth neither shows up on OS startup nor on OS shutdown
  - Scary messages in kernel logs (extracts follow) :

[ 5.291603] [drm] Initialized drm 1.1.0 20060810
...
[ 5.353156] [drm] radeon kernel modesetting enabled.
[ 5.353216] call_modprobe: symbol:kgd2kfd_init 2
[ 5.359409] CRAT table not found
[ 5.359410] Finished initializing topology ret=0
[ 5.359425] kfd kfd: Initialized module
[ 5.359614] checking generic (b0000000 3cc000) vs hw (b0000000 10000000)
[ 5.359615] fb: switching to radeondrmfb from simple
[ 5.359644] Console: switching to colour dummy device 80x25
[ 5.359926] [drm] initializing kernel modesetting (TURKS 0x1002:0x6840 0x1179:0xFB41 0x00).
[ 5.359936] [drm] register mmio base: 0xC2000000
[ 5.359937] [drm] register mmio size: 131072
[ 5.359957] ------------[ cut here ]------------
[ 5.359961] WARNING: CPU: 0 PID: 116 at /build/linux-akdJXO/linux-4.8.0/arch/x86/mm/ioremap.c:121 __ioremap_caller+0x1ec/0x370
[ 5.359962] ioremap on RAM at 0x0000000000000000 - 0x000000000001ffff
[ 5.359963] Modules linked in: amdkfd radeon(+) r8169 mii i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops ahci(+) libahci drm wmi ehci_pci xhci_pci fjes ehci_hcd video thermal xhci_hcd usbcore usb_common button
[ 5.359978] CPU: 0 PID: 116 Comm: systemd-udevd Not tainted 4.8.0-16-generic #17-Ubuntu
[ 5.359978] Hardware name: TOSHIBA SATELLITE L875-10G/Type2 - Board Product Name1, BIOS 6.50 3/25/2013
[ 5.359980] 0000000000000286 000000001712e9ce ffffffffbe973f14 ffff8b3f3cebf8c0
[ 5.359982] 0000000000000000 ffffffffbe67f93e 0000000000000000 ffff8b3f3cebf918
[ 5.359985] ffffffffbe9cf198 0000000000020000 0000000000000002 0000000000000000
[ 5.359987] Call Trace:
[ 5.359992] [<ffffffffbe973f14>] ? dump_stack+0x5c/0x78
[ 5.359995] [<ffffffffbe67f93e>] ? __warn+0xbe/0xe0
[ 5.359997] [<ffffffffbe9cf198>] ? pci_map_rom+0x58/0xd0
[ 5.359999] [<ffffffffbe67f9bf>] ? warn_slowpath_fmt+0x5f/0x80
[ 5.360040] [<ffffffffc0536877>] ? igp_read_bios_from_vram+0x57/0xa0 [radeon]
[ 5.360042] [<ffffffffbe66905c>] ? __ioremap_caller+0x1ec/0x370
[ 5.360044] [<ffffffffbe9cf198>] ? pci_map_rom+0x58/0xd0
[ 5.360075] [<ffffffffc05368f5>] ? radeon_read_bios.isra.2+0x35/0xc0 [radeon]
[ 5.360102] [<ffffffffc0536c0c>] ? radeon_get_bios+0x28c/0xfc0 [radeon]
[ 5.360105] [<ffffffffbe6d74ca>] ? vprintk_emit+0x35a/0x520
[ 5.360108] [<ffffffffbe7f1f...

Read more...

Hi all,

After my description and with the logs I joined earlier, can we still blame "xorg" for this bug ?

I very much suggest this be (upstream) "linux" at fault instead.

Another idea ?

Sincerely,
Vécu

Hi,

I reported this bug Upstream as bug #175391 .
( https://bugzilla.kernel.org/show_bug.cgi?id=175391 )

Sincerely,
Vécu

Hello evbd,

Erratum : In the title of this bug report topic I wrote "looked over" instead of "overlooked".

Please pardon me for non being a native english speaker.

Sincerely,
Vécu

Hello,

I improved on this *upstream* bug diagnosis by doing another careful git bisect.

first bad commit: [30b5b8808c12bcd947dd474980482561b69c1bcb] PCI: Restore inclusion of pci/hotplug Kconfig
( https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=30b5b8808c12bcd947dd474980482561b69c1bcb )

You can refer to https://bugzilla.kernel.org/show_bug.cgi?id=175391 for more information.

In hope this helps.

Sincerely,
Vécu

Timo Aaltonen (tjaalton) wrote :

DRM upstream uses bugs.freedesktop.org, not kernel bugzilla

is it broken with yakkety too?

affects: xorg (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
summary: - AMD Radeon hardware features or firmware looked over by Linux 3.6.0+
- kernel.
+ radeon broken with kernel 4.6.0+
Timo Aaltonen (tjaalton) wrote :

you mentioned yakkety already

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
description: updated
Changed in linux (Ubuntu):
importance: Undecided → High

Hi all,

To all the Finnish and other Northern territories people (in fact, to every people from all over the world), I have good news to tell you from France, indeed.

I finally managed to unveil which original bug was hidden by aforementioned botched commit [cfeb8139a1fbbbae3f1e986133f4e9e7833eeac4] ( Merge branch 'pci/host-hv' into next ) .

I stumbled upon git commit [0c0e0736acad4e76e718456c75d78ad95eea0011] ( PCI: Set ROM shadow location in arch code, not in PCI core ) and very much believe this is it at fault.

Obviously, you still can refer to https://bugzilla.kernel.org/show_bug.cgi?id=175391 for more details, as usual.

In hope this helps.

Sincerely,
Vécu

Bjorn Helgaas (bjorn-helgaas) wrote :

There's a test patch at https://bugzilla.kernel.org/show_bug.cgi?id=175391 Any test reports would be welcome.

Hi Folks,

This bug seems to be solved upstream.

Bjorn's patch made it in both mainline (4.9-rc5) and Greg's -stable (4.8.9).

See https://bugzilla.kernel.org/show_bug.cgi?id=175391 for more information.

I'd suggest this bug be closed ; however, if the patch hinders other people experience, it might get reopened.

In hope this helps.

Regards,
Valentin QUEQUET

Nurlan (nurlancik1) on 2016-11-25
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.