10ec:8168 r8169 won't connect

Bug #1547151 reported by Luca Osvaldo Mastromatteo on 2016-02-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

At school when I connect with my Ethernet cable to its network it doesn't see my cable, like it is disconnected. This occurs with a different computer using the same kernel driver with the same LAN chip. The realtek r8168 works flawlessly but it disconnects randomly. I don't have problems in Windows (speed is 100Mbps), or with other computers using the same cable.

WORKAROUND: ethtool -s enp1s0f1 autoneg off speed 100 duplex full

WORKAROUND: Add kernel parameter:
acpi_rev_override

---
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: luky 1556 F.... pulseaudio
 /dev/snd/controlC0: luky 1556 F.... pulseaudio
CurrentDesktop: X-Cinnamon
DistroRelease: Ubuntu 15.10
InstallationDate: Installed on 2016-02-12 (6 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: Acer Aspire E5-571G
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.2.0-29-generic.efi.signed root=UUID=211171d7-1b39-4c4b-8078-7ccbdd97ffdc ro quiet acpi_osi= acpi=force acpi_enforce_resources=lax i915.enable_rc6=1 i915.enable_fbc=1 i915.lvds_downclock=1 i915.semaphores=1 drm.vblankoffdelay=1 acpi_backlight=vendor
ProcVersionSignature: Ubuntu 4.2.0-29.34-generic 4.2.8-ckt3
RelatedPackageVersions:
 linux-restricted-modules-4.2.0-29-generic N/A
 linux-backports-modules-4.2.0-29-generic N/A
 linux-firmware 1.149.3
Tags: wily
UdevLog: Error: [Errno 2] File o directory non esistente: '/var/log/udev'
Uname: Linux 4.2.0-29-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm bumblebee cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 08/03/2015
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V1.31
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: EA50_HB
dmi.board.vendor: Acer
dmi.board.version: V1.31
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.31:bd08/03/2015:svnAcer:pnAspireE5-571G:pvrV1.31:rvnAcer:rnEA50_HB:rvrV1.31:cvnAcer:ct10:cvrChassisVersion:
dmi.product.name: Aspire E5-571G
dmi.product.version: V1.31
dmi.sys.vendor: Acer

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1547151

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected wily
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.5 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-rc4-wily/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

I've tested also the latest kernel, and it also affetcs it.

By the way, the bug happens only with GIGABIT NETWORKS and with MEGABIT CABLE

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

kernel-bug-exists-upstream

tags: added: latest-bios-1.31
description: updated
tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-4.5-rc4
summary: - r8169 kernel module problem
+ 10ec:8168 r8169 won't connect

Luca Mastromatteo, the issue you are reporting is an upstream one. Could you please report this problem following the instructions verbatim at https://wiki.ubuntu.com/Bugs/Upstream/kernel to the appropriate mailing list (TO nic_swsd CC netdev)?

Please provide a direct URL to your post to the mailing list when it becomes available so that it may be tracked.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
AceLan Kao (acelankao) wrote :

Adding "acpi_rev_override" kernel parameter can workaround it.

Changed in linux (Ubuntu):
assignee: nobody → AceLan Kao (acelankao)
tags: added: kittyhawk originate-from-1605487
AceLan Kao (acelankao) wrote :

Luca,
The workaround I mention on comment #24 works on other machine.
I didn't notice the machine you have is not the same as mine, so I'm not sure if the workaround works for you.
Could you help to check that?
Thanks.

AceLan Kao (acelankao) on 2016-12-08
Changed in linux (Ubuntu):
assignee: AceLan Kao (acelankao) → nobody
description: updated

Sorry for the late reply, but I reported the bug to the upstream developers (Hau, from realtek.com) and I helped them to solve the problem. Then, they finally gave me a beta debug driver, after some tests, which seems to solve the problem.
I don't know if those patches are currently committed into the kernel driver. I changed my PC months ago.

Changed in linux (Ubuntu):
status: Triaged → In Progress

Here.
https://github.com/torvalds/linux/commit/f51d4a10ac39ecf06b25e7a79121b06f7ed59928
This may be the commit but I don't know honestly. The date of the commit matches the period which I was in contact with him.

Luca Mastromatteo, to advise, a debug beta driver isn't eligible for inclusion to any production repository (upstream, Ubuntu, etc.). They probably gave it to you to both test some new features/fixes, and capture additional information the production driver doesn't normally output.

Also, when posting attachments, please don't tar/compress them as this makes it inconvenient for folks to review.

Regarding the commit, posting a random commit correlated to time isn't as helpful as either testing the commit specifically, or confirming with the author if it applies to your hardware.

Not Status In Progress as defined in https://wiki.ubuntu.com/Bugs/Status .

Changed in linux (Ubuntu):
status: In Progress → Triaged
Changed in hwe-next:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers