fglrx module fails to build with 3.19.0-26

Bug #1479945 reported by Nicolas Delvaux on 2015-07-30
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

This update broke fglrx here (and so my graphical environment).
I tested with the fglrx from standard repositories and with the latest driver from the amd website. Same error in both cases.

If fails during the DKMS build:

Error! Bad return status for module build on kernel: 3.19.0-26-generic (x86_64)
Consult /var/lib/dkms/fglrx-core/15.200/build/make.log for more information.

$ cat /var/lib/dkms/fglrx-core/15.200/build/make.log
DKMS make.log for fglrx-core-15.200 for kernel 3.19.0-26-generic (x86_64)
jeudi 30 juillet 2015, 21:14:39 (UTC+0200)
/usr/sbin/dkms: ligne 74 : cd: /var/lib/dkms/fglrx/15.200/build: Aucun fichier ou dossier de ce type
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make -C /lib/modules/3.19.0-26-generic/build SUBDIRS=/var/lib/dkms/fglrx-core/15.200/build/2.6.x modules
make[1]: Entering directory '/usr/src/linux-headers-3.19.0-26-generic'
  CC [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/firegl_public.o
/var/lib/dkms/fglrx-core/15.200/build/2.6.x/firegl_public.c:6424:12: warning: ‘KCL_fpu_save_init’ defined but not used [-Wunused-function]
 static int KCL_fpu_save_init(struct task_struct *tsk)
            ^
  CC [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/kcl_acpi.o
/var/lib/dkms/fglrx-core/15.200/build/2.6.x/kcl_acpi.c:832:20: warning: ‘KCL_ACPI_Slot_No_Hotplug’ defined but not used [-Wunused-function]
 static acpi_status KCL_ACPI_Slot_No_Hotplug(KCL_ACPI_DevHandle handle, u32 lvl, void *data, void **rv)
                    ^
  CC [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/kcl_agp.o
  CC [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/kcl_debug.o
  CC [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/kcl_ioctl.o
  CC [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/kcl_io.o
  CC [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/kcl_pci.o
  CC [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/kcl_str.o
  CC [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/kcl_iommu.o
  CC [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/kcl.o
  CC [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/kcl_wait.o
  LD [M] /var/lib/dkms/fglrx-core/15.200/build/2.6.x/fglrx.o
  Building modules, stage 2.
  MODPOST 1 modules
FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol 'pci_ignore_hotplug'
scripts/Makefile.modpost:90: recipe for target '__modpost' failed
make[2]: *** [__modpost] Error 1
Makefile:1397: recipe for target 'modules' failed
make[1]: *** [modules] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-3.19.0-26-generic'
Makefile:88: recipe for target 'kmod_build' failed
make: *** [kmod_build] Error 2
build failed with return value 2

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: linux-image-3.19.0-26-generic 3.19.0-26.27
ProcVersionSignature: Ubuntu 3.19.0-26.27-generic 3.19.8-ckt4
Uname: Linux 3.19.0-26-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: nicolas 1716 F.... pulseaudio
 /dev/snd/controlC1: nicolas 1716 F.... pulseaudio
CurrentDesktop: Unity
Date: Thu Jul 30 21:16:29 2015
HibernationDevice: RESUME=UUID=f723849e-aa39-4a8d-b7f4-87d4f4cbdd95
InstallationDate: Installed on 2015-04-24 (97 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: MSI MS-7752
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-26-generic root=UUID=040f612d-29f0-46e5-961f-dd5deb7df33b ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-26-generic N/A
 linux-backports-modules-3.19.0-26-generic N/A
 linux-firmware 1.143.2
RfKill:

SourcePackage: linux
UdevLog: Error: [Errno 2] Aucun fichier ou dossier de ce type: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/29/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V2.12
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z77A-G45 (MS-7752)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV2.12:bd09/29/2013:svnMSI:pnMS-7752:pvr1.0:rvnMSI:rnZ77A-G45(MS-7752):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.name: MS-7752
dmi.product.version: 1.0
dmi.sys.vendor: MSI

Nicolas Delvaux (malizor) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1479913, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

This is not a duplicated bug. I made a fresh installation last week with 14.04.3 (LTS Enablement Stack On), updated all the system and installed Fglrx succesfully (with Kernel 3.19.0-25). But when updating to 3.19.0-26, Fglrx brokes and the system boots up without Flgrx. When re-installing Flgrx in 3.19.0-26, I obtained same error than Nicolas Delvaux.

There is Nothing the same between this bug and the other bug linked there.

Changed in linux (Ubuntu):
importance: Undecided → High
Rich.T. (rich.t.) wrote :

This kernel has been rolled out now, with the broken, GPL-violating module still present.

I had to roll back to 3.19.0-25 as suggested above.
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1485821

Should this have really been released, if it has been known about for weeks?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers