Ubuntu

Alternate install CD (both x86, AMD64) not booting on HP NX6325

Reported by Christian Wolf on 2007-09-30
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
linux (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Hans Deragon
Nominated for Karmic by Przemysław Kulczycki
Nominated for Lucid by tim__b
Nominated for Maverick by tim__b

Bug Description

The x86 as well as the AMD64 alternate installation CD stops booting immediately after the kernel is being loaded (when switching the screen). So if I remove "quiet" from the kernel parameters, I see all the kernel messages, but immediately after that the screen goes black. The system only responds to Ctrl-Alt-Del works, terminal windows are not active.

I tried several "typical" laptop kernel parameters but that did not help.

The problem exists for the Beta CD set as well the following daily builds. I had no problem with the daily builds before September 24, 2007. Installed systems seem also still to work, also the LiveCD does boot (well at least until Gnome gets started, but this is another bug).

I guess it might be related to a problem with the initrd and/or the framebuffer. Media are ok as I tested them on a different system without this problem.

Funny thing is: When I ask for the CD being tested, that seems to work, there is some HD/CD-activity. However, the screen also remains black.

Overview on the HP NX6325 specs:
https://wiki.ubuntu.com/LaptopTestingTeam/HPNX6325?highlight=%28hpnx6325%29

Details of lshw:
http://vale.homelinux.net/wordpress/wp-content/uploads/2007/02/myhpnx6325.html
--------------
Description modified by Hans Deragon, to reflect current status.

Currently this occurs also with the HP 6510b and HP 2510p using Hardy Heron 08.04 Alpha 6 Alternate install CD. Both of these systems have an Intel GM965/GL960 Integrated Graphic Controller.

There is a workaround. On the main menu, press "F6 Other Options", replace "quiet --" with "fb=false" and try it. The bug seams to be with the framebuffer, thus disabling it get the installer displayed.

description: updated
Christian Wolf (christianwolf) wrote :

The server install CD is also affected by this bug.

As I supposed, it is obviously a problem with the framebuffer device during init phase.

Use the boot parameter "fb=false" (F6 on boot screen of the CD) in order to work around this bug.

The Hardy Heron Alpha2 release will be coming out soon. It will have an updated version of the kernel. It would be great if you could test with this new release and verify if this issue still exists. I'll be sure to update this report when Alpha2 is available. Thanks!

Changed in linux:
status: New → Incomplete

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Christian Wolf (christianwolf) wrote :

Hello Leann,

thank you for working on this issue. I just tested the amd64 - Alternate install CD Hardy Alpha2 two minutes ago, but unfortunately exactly the same issue - it just stops booting after loading the kernel, screen goes black, system is still alive (responds to Ctrl-Alt-Del). With my fb=false workaround, it boots.

The NX6325 comes with a integrated ATI chipset (M200) with an Ati1150 graphics accelerator. Me thinks here is the root for this issue. I will also google around these days as I have some leisure time.

Let me know if I can help you. Thanks again!

Thanks for testing Wolfchri. Per the kernel team's bug policy, can you please attach the following information:

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

Please be sure to attach each file as a separate attachment. It will be most helpful if you can capture the kernel messages (ie dmesg output) up until the screen goes black. Even if you have to take a digital photograph of your screen when you remove the "quiet" kernel parameter and attach the photo to the bug report, that will help. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

I'm opened a new task against the actively developed kernel and am closing the report against linux-source-2.6.22. Thanks!

Changed in linux-source-2.6.22:
status: New → Won't Fix
Christian Wolf (christianwolf) wrote :

Attached come the requested files, additional a lshw output.

dmesg.log

Christian Wolf (christianwolf) wrote :

lspci

Christian Wolf (christianwolf) wrote :

uname

Christian Wolf (christianwolf) wrote :

version

Christian Wolf (christianwolf) wrote :

lshw

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Christian Wolf (christianwolf) wrote :

Movie with boot messages can be downloaded here:

http://rapidshare.de/files/38168563/HardHeron_Alternate.AVI.html

--> if it is not sharp enough, I will do another, better one. Was just a quick&dirrty to get the thing rolling :-)

Hans Deragon (deragon) on 2008-03-12
description: updated

I confirmed that the workaround fb=false as suggested by wolfchri works.

For the alternate install CD, should that not be always the default, to ensure that the display will always work?

Hans Deragon (deragon) on 2008-03-12
description: updated
Christian Wolf (christianwolf) wrote :

For the records:

Problem still exists on Hardy Beta.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

The bug is confirmed. and its work-around (fb=false) on the alternate install Cd of Jaunty beta. Tested on HP Compaq 2510p.

Jorge O. Castro (jorge) wrote :

This is still an issue with Karmic alpha 2 on my 2510p.

tags: added: regression-release
removed: cft-2.6.27
Changed in debian:
status: Unknown → New
Andy Whitcroft (apw) wrote :

@jorge -- the frame buffers generally are all blacklisted by modprobe so I am a little supprised it is loading. Could you get us an lsmod output (from the booting -2 kernel) and the contents of the /etc/modprobe.d/blacklist-frambuffers.conf from the failing machine so we can see whats what. Thanks!

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Przemysław Kulczycki (azrael) wrote :

The problem still exists in Karmic beta alternate cd i386 on HP Compaq nx6325

Przemysław Kulczycki (azrael) wrote :

"Could you get us an lsmod output (from the booting -2 kernel) and the contents of the /etc/modprobe.d/blacklist-frambuffers.conf from the failing machine so we can see whats what."

What do you mean by "booting -2 kernel"?
I tried booting to rescue mode (with fb=false, otherwise it doesn't work) but there was no /etc/modprobe.d/ dir and lsmod didn't show any framebuffer driver.
My HP nx6325 has an integrated ATI Radeon Xpress 1150 RS485M graphics card (AFAIK it uses the r300 part of the ati driver).

Przemysław Kulczycki (azrael) wrote :

Comment from Debian bug:
> As the VESA framebuffer _does_ work (I've tried both vga=788 and vga=791),
> a better option would seem to be to just use the VESA framebuffer for all
> x86 installs by using e.g. vga=788, which is 800x600/16 bits.
> vga=788 is the same setting we use for the graphical installer and I can't
> remember (m)any reports that that setting did not work for users.
>
> We could still keep the vga16fb as a fallback if people explicitly boot
> with VGA=normal.

Przemysław Kulczycki (azrael) wrote :

Debian has a fix committed now:
"I've committed a change that changes the default video mode for normal
installs (using the newt frontend) to vga=788, which forces the VESA
framebuffer. Tested on my own HP 2510p.

The change should take effect in the next daily and weekly builds.

Here's the commit log for the change:
r60979 | fjp | 2009-10-10 14:01:55 +0200 (Sat, 10 Oct 2009) | 15 lines

Change default video mode for i386/amd64 to vga=788 for the "newt" frontend

This forces the framebuffer to VESA and will thereby solve problems
reported on various HP notebooks with the vga16fb driver (#471505).

It also increases the screen size (to 600x800, which is still quite
conservative) and thus allows more information to be displayed. Note that
dialogs should continue to be designed to work with 480x640 as other
architectures may still use that as a default, and for network-console.

vga=788 is the same video mode we use for the gtk frontend and as we've
seen very few reports of that failing the change should be safe, but it is
still somewhat experimental.

Cheers,
FJP"

Changed in debian:
status: New → Fix Committed
tags: added: karmic
Teus Benschop (teusbenschop) wrote :

I tried the released version of Ubuntu 9.10 on a hp elitebook 2710p. This notebook needed the "fb=false" switch when booting from the alternate cd with previous released. However with the newest release of karmic this is no longer needed. This means to me that this bug appears to have been fixed.

Christian Wolf (christianwolf) wrote :

I can NOT confirm that the bug is fixed:

I tested with the 9.10 Karmic i386 Alternate disk (final, official release) and had the same problem as always (black screen after booting the kernel).

The "fb=false" workaround still works (actually, I used fb=off which also seemed to work).

I did not test amd64.

Changed in debian:
status: Fix Committed → Fix Released
Boniek (boniek12p) wrote :

Unfortunately it seems this bug is still an issue. Can you confirm this issue exists with the most recent Lucid Lynx 10.04 release - http://cdimage.ubuntu.com/releases/lucid/alpha-2/. If the issue remains in Lucid, please test the latest 2.6.32 upstream kernel build - https://wiki.ubuntu.com/KernelMainlineBuilds . Let us know your results. Thank

Rico Tzschichholz (ricotz) wrote :

I can still confirm this problem on 2510p with latest lucid-alternate-amd64.iso (2010-02-20)

Boniek (boniek12p) on 2010-03-02
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in debian-installer (Ubuntu):
status: New → Confirmed
Yorick Brunet (yorick-brunet) wrote :

I have exactly the same problem as in the description with :
- xubuntu 10.04 beta 2 alternate CD
- HP Compaq nx8220

tim__b (timb) wrote :

Bug's also present for me with HP Compaq 6710b + 10.04 i386 alternate. Already tried:
 * fb=false as bootoption (worked in jaunty, does not work with lucid)
 * frambuffer=false
 * fb=off
 * debian-installer/framebuffer=false
 * vga=123, tried all of the offered modes
 * vga=771 (get some screwed up output on the screen, which i guess from that the system/machine is not frozen)
 * i915.modeset=1
 * i915.modeset=0
 * xforcevesa etc

Nothing worked. Any Logs needed, as I still hab Jaunty on that machine and the desktop live cd bootes without any trouble.

Teus Benschop (teusbenschop) wrote :

I tried the alternate installer CD for Lucid on a HP 2510p. The bug is present there. I ended up using the standard installer DVD. But we have several older laptops in the department that would not take the standard installer CD because of limited memory. For such laptops the alternate installer CD is the only option to get a modern Ubuntu version installed. For this reason we look forward to the fix for this bug.

4XaBD (4xabd) wrote :

The bug also appears on my old laptop with SIS-Graphic and Ubuntu Lucid. I've tried fb=false and different vga modes as boot parameter. Nothing worked.

Nils Rosehr (rosehr) wrote :

I tried the alternate installer CD kubuntu 10.04.1 for a HP Compaq nx8220 laptop (radeon X600). With the xforcevesa parameter I can see the first few seconds of the boot process, then the screen goes black. fb=false or fb=off does not change that.

With a 9.04 install vga=788 used to work for me, not any more. With vga=311 I can see 16 tiny screens at the top of my displays, nothing is readable, but I can see that a menue bar moves if I use the up and down keys.

Has anybody found a workaround for the bug?

Przemysław Kulczycki (azrael) wrote :

I was able to successfully boot the Maverick RC alternate CD (both i386 and amd64) on my HP Compaq nx6325 laptop. This bug seems to be fixed for me. Can other laptops' owners test them with Ubuntu 10.10 (Maverick Meerkat)?

Christian Wolf, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue with the HP NX6325? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

summary: - Alternate install CD (both x86, AMD64) not booting on HP NX6325, HP
- 6510b and HP 2510p
+ Alternate install CD (both x86, AMD64) not booting on HP NX6325
no longer affects: linux-source-2.6.22 (Ubuntu)
no longer affects: debian-installer (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.