Ubuntu

pcspkr module causes hangup on HP Pavilion dv6391 when system beeps

6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

  On my HP Pavilion dv6391 laptop (runs on an AMD Turion64 X2 processor) the systems sometimes crashes when something causes a beep (like if I press backspace on an empty prompt, or search for an invalid package in aptitude, ... ). Before Tribe5 that used to happen a LOT (even in Feisty) ! After Tribe5 it became less frequent.

Notes:
1. Seems that the laptop uses the same speaker for beeping & for audio card, because when I am playing some audio file, and the systems beeps, the audio gets interrupted.
2. I am not using softbeep.

Please find the attached dmesg, uname -a, lspci -vvnn, lsmod & /proc/version_signature files

Hello,

  I found a couple of temporary solutions:
  1. rmmod pcspkr
  2. Another one is without having to remove pcspkr module: In console I can do : setterm -blength 0. There is some other command for xterms. Anyways, that doesn't solve it for GUI applications that may send beeps I think. Anyways, what I meant is, even if I keep pcspkr, but set the terminal not to beep, then when an application run in the terminal send a '\a' it won't cause a crash. I tested that by writing a program that beeps in a continuous loop. The program is attached with this comment.

The Hardy Heron Alpha2 release will be coming out soon (around Dec 20). It will have an updated version of the kernel. It would be great if you could test with this new release and verify if this issue still exists. I'll be sure to update this report when Alpha2 is available. Thanks!

Changed in linux:
status: New → Incomplete

I'm opened a new task against the actively developed kernel and am closing the report against linux-source-2.6.22. Thanks!

Changed in linux-source-2.6.22:
status: New → Won't Fix

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

Hello,

  I just tried with desktop CD of Hardy Heron Alpha2, I still got the same problem.
  Anyways, I tried something else with my current (Gutsy) installation, I booted with noapic option, and it tested with my beeptest program, and the problem seem to have dissappeared, the problem now is that with 'noapic', the USB is not working !

Can you try booting the Hardy Alpha2 kernel from the LiveCD with the 'noapic' option and verify if it is a possible workaround as well? Also, per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

It would probably be best to capture the dmesg output when not booting with noapic. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Oops, no need to reattach your lspci -vvnn as you already have done so previously. I'm also going to remove the 'hardy-alpha2' tag as we've already opened a new task against the actively developed kernel. Thanks!

Ok I booted the Hardy Alpha2 kernel from the LiveCD with the 'noapic' option and the beeptest worked fine too.

Here are the requested information (in the case that 'noapic' is *NOT* used)

Also here's the output of 'sudo lspci -vvnn' when I booted with 'noapic' option.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged

Hello,

  This problem still exists, I am using Hardy
kernel version: 2.6.24-8.14

Changed in linux-source-2.6.24:
status: New → Invalid

This is /proc/interrupts when I boot without 'noapic' option

dmesg output when I booted with apic=debug

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Hello,

  I just tested alpha6 live CD, and the PC speaker does not work anymore, by examining the kernel configuration I found the following:

CONFIG_PCSPKR_PLATFORM=y
# CONFIG_INPUT_PCSPKR is not set

Hence there is no pcspkr module compiled in the kernel.

Yet in Hardy, I found this in the kernel configuration:
CONFIG_INPUT_PCSPKR=m

and there was a pcspkr module which is loaded.

Of course I cannot test if pcspkr causes hangup or not since it is disabled

Changed in linux:
status: Triaged → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers