Partitions not recognized because of kernel option CONFIG_ACORN_PARTITION_CUMANA

Bug #1453117 reported by Dimos Dimoulis on 2015-05-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Vivid
Undecided
Tim Gardner
Wily
High
Tim Gardner

Bug Description

I am having trouble installing Ubuntu on a newly built system (M/B: Gigabyte B85M-HD3, SSD: Transcend 370 128GB)
The disk was partitioned with Windows installer (Windows 7) with the legacy BIOS (MBR) setting
However the two partitions created by Windows are seen as corrupt by Ubuntu installer disk.
ls /dev/sda* only shows "/dev/sda /dev/sda1" and not /dev/sda2 (sda1 is windows boot partition and sda2 its main partition)
gparted says /dev/sda1 is lacking NTFS signature and /dev/sda2 doesn't exist

This behavior appears in both Ubuntu 15.04 and 14.04.2
However:
Both partitions are correctly recognized and mounted by every other linux distribution I have tried (Arch installer of April 2015, Linux Mint 17.1, Crunchbang). Windows works fine as well.

A relevant fragment from dmesg:
[ 3.326601] sd 0:0:0:0: [sda] 250069680 512-byte logical blocks: (128 GB/119 GiB)
[ 3.326680] sd 0:0:0:0: [sda] Write Protect is off
[ 3.326683] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 3.326705] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 3.327072] sda: [CUMANA/ADFS] sda1 [ADFS] sda1
[ 3.327076] sda: partition table partially beyond EOD, enabling native capacity
[ 3.340753] sda: [CUMANA/ADFS] sda1 [ADFS] sda1
[ 3.340754] sda: partition table partially beyond EOD, truncated
[ 3.340756] sda: p1 size 4067027304 extends beyond EOD, truncated
[ 3.340929] sd 0:0:0:0: [sda] Attached SCSI disk

I compared this to dmesg I get from booting Arch installer and the lines about "partition table partially beyond EOD, truncated" don't appear there. Instead I see something like
[ 3.448351] sda: sda1 sda2
[ 3.448597] sd 0:0:0:0: [sda] Attached SCSI disk
and the partitions are recognized

Output of fdisk -l
Disk /dev/sda: 119.2 GiB, 128035676160 bytes, 250069680 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xe4e835e9

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 206847 204800 100M 7 HPFS/NTFS/exFAT
/dev/sda2 206848 250066943 249860096 119.1G 7 HPFS/NTFS/exFAT

Found this: https://bugzilla.kernel.org/show_bug.cgi?id=4054

"This is a consequence of enabling CONFIG_ACORN_PARTITION_CUMANA:
a 1 in 256 probability of getting any random partition recognized
as CUMANA/ADFS. Solution: do not enable CONFIG_ACORN_PARTITION_CUMANA."

I don't think this option is relevant to Ubuntu installations, would you consider disabling it?

---
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: ubuntu 1882 F.... pulseaudio
 /dev/snd/controlC1: ubuntu 1882 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 1882 F.... pulseaudio
CasperVersion: 1.360
CurrentDesktop: Unity
DistroRelease: Ubuntu 15.04
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
MachineType: Gigabyte Technology Co., Ltd. B85M-HD3
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 nouveaufb
 1 inteldrmfb
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash --- maybe-ubiquity
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-15-generic N/A
 linux-backports-modules-3.19.0-15-generic N/A
 linux-firmware 1.143
RfKill:

Tags: vivid
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
Uname: Linux 3.19.0-15-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 06/19/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: FF
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: B85M-HD3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrFF:bd06/19/2014:svnGigabyteTechnologyCo.,Ltd.:pnB85M-HD3:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnB85M-HD3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: B85M-HD3
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

CVE References

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1453117/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Dimos Dimoulis (dimosd) on 2015-05-08
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1453117

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty vivid

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Dimos Dimoulis (dimosd) on 2015-05-09
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → High
Romain Izard (romain-izard) wrote :

The issue has also been seen in http://askubuntu.com/questions/638291/unable-to-mount-external-usb-ssd

I also reproduced it by chance with a SD card configured with an ARM bootloader located in block 2+. Changing one byte in block #6 restored the normal behaviour, where all partitions are correctly detected.

The issue did not exist in Trusty, it was added in the initial kernel configuration for Utopic and still exists in Vivid.

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Wily):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Vivid):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
tags: added: patch
Brad Figg (brad-figg) on 2015-07-22
Changed in linux (Ubuntu Vivid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.1.0-1.1

---------------
linux (4.1.0-1.1) wily; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: overlay: add backwards compatible overlayfs format support V3
    - LP: #1395877, #1410480
  * SAUCE: overlayfs: when copying up and reading directories ensure
    mounter had permissions V2
    - CVE-2015-1328
  * [Packaging] fix up Vcs-Git: to point to launchpad
  * [Config] correct linux-initramfs-tool virtual linkage
    - LP: #1474810

  [ Chris J Arges ]

  * [Config] Add dm-service-time to multipath-modules
    - LP: #1469240
  * [Config] Add MTD_POWERNV_FLASH and OPAL_PRD
    - LP: #1464560

  [ Jay Vosburgh ]

  * SAUCE: fan: Proof of concept implementation (v2)
    - LP: #1439706
  * SAUCE: fan: tunnel multiple mapping mode (v3)
    - LP: #1470091

  [ Leann Ogasawara ]

  * Revert "SAUCE: ext4: disable ext4_punch_hole for indirect filesystems"
  * Revert "SAUCE: intel_pstate: inform user that thermald is worth
    considering"
  * Revert "SAUCE: Work around broken ACPI backlight on Dell Inspiron 5537"
  * Revert "SAUCE: dm-crypt: never use write same"
  * Release Tracking Bug
    - LP: #1476333

  [ Tim Gardner ]

  * Rebase to v4.1
    - LP: #1443371
  * [Config] Enable Apparmor
  * [Config] CONFIG_OVERLAY_FS_V1=y
  * [Config] DEFAULT_IOSCHED="deadline" for ppc64el
    - LP: #1469829
  * [Config] CONFIG_VM86=n
    - LP: #1473447
  * [Config] ACORN_PARTITION=n
    - LP: #1453117

  [ Timo Aaltonen ]

  * [Config] Disable CONFIG_DRM_I915_PRELIMINARY_HW_SUPPORT
    - LP: #1473319

  [ Upstream Kernel Changes ]

  * efi: efivar_create_sysfs_entry() should return negative error codes
  * efi: Add esrt support
  * x86, doc: Remove cmdline_size from list of fields to be filled in for
    EFI handover
  * efi/esrt: Fix some compiler warnings
  * efi: dmi: List SMBIOS3 table before SMBIOS table
  * efi: Add 'systab' information to Documentation/ABI
  * ALSA: hda - restore the MIC FIXUP for some Dell machines
    - LP: #1473560
  * mtd: powernv: Add powernv flash MTD abstraction driver
    - LP: #1464560
  * powerpc/powernv: Expose OPAL APIs required by PRD interface
    - LP: #1464560
  * powerpc/powernv: Add opal-prd channel
    - LP: #1464560
  * powerpc/powernv: fix construction of opal PRD messages
    - LP: #1464560
  * powerpc/include: Add opal-prd to installed uapi headers
    - LP: #1464560
  * powerpc/powernv: Fix vma page prot flags in opal-prd driver
    - LP: #1464560

 -- Leann Ogasawara <email address hidden> Mon, 20 Jul 2015 10:16:06 -0700

Changed in linux (Ubuntu Wily):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-vivid' to 'verification-done-vivid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-vivid
Tim Gardner (timg-tpi) wrote :

Marking verified:

rtg@m1710:~/tmp$ dpkg -x linux-image-3.19.0-26-generic_3.19.0-26.27_amd64.deb junk
rtg@m1710:~/tmp$ grep ACORN_PARTITION ./junk/boot/config-3.19.0-26-generic
# CONFIG_ACORN_PARTITION is not set

tags: added: verification-done-vivid
removed: verification-needed-vivid
Launchpad Janitor (janitor) wrote :
Download full text (30.6 KiB)

This bug was fixed in the package linux - 3.19.0-26.28

---------------
linux (3.19.0-26.28) vivid; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1483630

  [ Upstream Kernel Changes ]

  * Revert "Bluetooth: ath3k: Add support of 04ca:300d AR3012 device"

linux (3.19.0-26.27) vivid; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1479055
  * [Config] updateconfigs for 3.19.8-ckt4 stable update

  [ Chris J Arges ]

  * [Config] Add MTD_POWERNV_FLASH and OPAL_PRD
    - LP: #1464560

  [ Mika Kuoppala ]

  * SAUCE: i915_bpo: drm/i915: Fix divide by zero on watermark update
    - LP: #1473175

  [ Tim Gardner ]

  * [Config] ACORN_PARTITION=n
    - LP: #1453117
  * [Config] Add i40e[vf] to d-i
    - LP: #1476393

  [ Timo Aaltonen ]

  * SAUCE: i915_bpo: Rebase to v4.2-rc3
    - LP: #1473175
  * SAUCE: i915_bpo: Revert "mm/fault, drm/i915: Use pagefault_disabled()
    to check for disabled pagefaults"
    - LP: #1473175
  * SAUCE: i915_bpo: Revert "drm: i915: Port to new backlight interface
    selection API"
    - LP: #1473175

  [ Upstream Kernel Changes ]

  * Revert "tools/vm: fix page-flags build"
    - LP: #1473547
  * Revert "ALSA: hda - Add mute-LED mode control to Thinkpad"
    - LP: #1473547
  * Revert "drm/radeon: adjust pll when audio is not enabled"
    - LP: #1473547
  * Revert "crypto: talitos - convert to use be16_add_cpu()"
    - LP: #1479048
  * module: Call module notifier on failure after complete_formation()
    - LP: #1473547
  * gpio: gpio-kempld: Fix get_direction return value
    - LP: #1473547
  * ARM: dts: imx27: only map 4 Kbyte for fec registers
    - LP: #1473547
  * ARM: 8356/1: mm: handle non-pmd-aligned end of RAM
    - LP: #1473547
  * x86/mce: Fix MCE severity messages
    - LP: #1473547
  * mac80211: don't use napi_gro_receive() outside NAPI context
    - LP: #1473547
  * iwlwifi: mvm: Free fw_status after use to avoid memory leak
    - LP: #1473547
  * iwlwifi: mvm: clean net-detect info if device was reset during suspend
    - LP: #1473547
  * drm/plane-helper: Adapt cursor hack to transitional helpers
    - LP: #1473547
  * ARM: dts: set display clock correctly for exynos4412-trats2
    - LP: #1473547
  * hwmon: (ntc_thermistor) Ensure iio channel is of type IIO_VOLTAGE
    - LP: #1473547
  * mfd: da9052: Fix broken regulator probe
    - LP: #1473547
  * ALSA: hda - Fix noise on AMD radeon 290x controller
    - LP: #1473547
  * lguest: fix out-by-one error in address checking.
    - LP: #1473547
  * xfs: xfs_attr_inactive leaves inconsistent attr fork state behind
    - LP: #1473547
  * xfs: xfs_iozero can return positive errno
    - LP: #1473547
  * fs, omfs: add NULL terminator in the end up the token list
    - LP: #1473547
  * omfs: fix sign confusion for bitmap loop counter
    - LP: #1473547
  * d_walk() might skip too much
    - LP: #1473547
  * dm: fix casting bug in dm_merge_bvec()
    - LP: #1473547
  * hwmon: (nct6775) Add missing sysfs attribute initialization
    - LP: #1473547
  * hwmon: (nct6683) Add missing sysfs attribute initialization
    - LP: #1473547
  * target/pscsi: Don't leak scsi_host if hba is VIRTUAL_HOST
    - LP: #1473547
  * net...

Changed in linux (Ubuntu Vivid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions