Comment 59 for bug 1447664

Bob Lawrence (pilotbob42) wrote :

Confirmed that this is still an issue on 18.04.1. I have an HP 705 G1 with the Broadcom 5762. In my case it's a Plex server. Whenever I try to stream something the interface goes "NO-CARRIER" and the only way to recover is to reboot. I've tried disabling highdma, tso and gso using ethtool, iommu=soft kernel parameter, and forcing every combo of 1gbps/100mbps & half/full duplex. Nothing seems to workaround the issue.

System: Host: Bobs-HTPC Kernel: 4.15.0-43-generic x86_64 bits: 64 Console: tty 1 Distro: Ubuntu 18.04.1 LTS
Machine: Device: desktop System: Hewlett-Packard product: HP EliteDesk 705 G1 DM serial: N/A
           Mobo: Hewlett-Packard model: 225E serial: N/A BIOS: Hewlett-Packard v: L06 v02.31 date: 08/31/2018
Battery hidpp__0: charge: N/A condition: NA/NA Wh
CPU: Quad core AMD A8-7600 Radeon R7 10 Compute Cores 4C+6G (-MCP-) cache: 8192 KB
           clock speeds: max: 3100 MHz 1: 3094 MHz 2: 3094 MHz 3: 3094 MHz 4: 3094 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Kaveri [Radeon R7 Graphics]
           Display Server: N/A drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           tty size: 120x53 Advanced Data: N/A out of X
Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] Kaveri HDMI/DP Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-43-generic
Network: Card-1: Intel Wireless 7260 driver: iwlwifi
           IF: wlp2s0 state: up mac: cc:3d:82:a7:bf:ed
           Card-2: Broadcom Limited NetXtreme BCM5762 Gigabit Ethernet PCIe driver: tg3
           IF: eno1 state: up speed: 100 Mbps duplex: half mac: ec:b1:d7:4c:2d:8e
Drives: HDD Total Size: 9501.7GB (42.8% used)
           ID-1: /dev/sda model: ST500LM000 size: 500.1GB
           ID-2: USB /dev/sdb model: 5 size: 9001.6GB
Partition: ID-1: / size: 458G used: 23G (6%) fs: ext4 dev: /dev/sda1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 40.8C mobo: N/A gpu: 42.0
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 227 Uptime: 12:49 Memory: 1608.0/5943.7MB Init: systemd runlevel: 5
           Client: Shell (bash) inxi: 2.3.56